Subject: VPWS I/W OAM

From: Giles Heron <[email-masked]>
Date: Fri, 21 Jan 2011 13:15:38 +0000

We're looking at the current list of L2VPN WG milestones, and trying to
clean them up a bit before we add further milestones as part of
re-chartering (hopefully before next IETF).

One item that we have on the list of milestones is "Submit OAM solutions for
VPWS to IESG".  There's an expired WG draft which seems to address this
milestone:

http://tools.ietf.org/html/draft-ietf-l2vpn-vpws-iw-oam-01

Is the consensus of the Working Group that:
A) the milestone is still valid and
B) that this draft is the correct approach?

Nabil & Giles

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 21 Jan 2011 09:09:46 -0500

In a nutshell, the draft is basically the VPWS version of the OAM Message Mapping draft that is in last call 
needed some minor updates:

	http://datatracker.ietf.org/doc/draft-ietf-pwe3-oam-msg-map/

	What I'd suggest we do is go back through the draft to make sure that its still aligned with
the oam-msg-map draft given that it currently references version -04 of oam-msg-map draft and we are up to 
version 14, but I believe that the problems it is trying to solve are still valid, and so the document is 
still useful. I'll be the first to admit that it has been sitting around for too long and needs 
to be wrapped up!

	--Tom

---

From: Giles Heron <[email-masked]>
Date: Fri, 21 Jan 2011 14:49:59 +0000

Isn't the key difference that OAM message mapping is for homogeneous PWEs
and VPWS I/W OAM is for heterogeneous ones?  (that's certainly what section
3 of the VPWS I/W OAM draft seems to say).

But yes, there are likely to be alignment issues given how many revisions
we've had of the OAM message mapping draft.

One key area that will need addressing is Ethernet OAM.  The VPWS I/W OAM
draft pre-dates much of the Ethernet OAM work.  Section 6.3.1 states:

     PE1 enters the AC forward defect state if any of the following
     conditions are met:

     (i)    A physical layer alarm is detected on the Ethernet
       interface.

I'd expect we'd want to expand that list.

Giles

---

From: <[email-masked]>
Date: Fri, 21 Jan 2011 15:31:43 +0000

Hi Giles/Tom,

I have not looked at any of this stuff for while but there should not be any attempt to map OAM Forward Defect Indication messages (DP or otherwise - sometime known as AIS in the co-cs mode):
-	from any client to any server (any client or server mode/technology cases), ie downwards
-	between non-TOS peer clients.....indeed there should not be any peering necessary between any non-TOS layer networks or (ii) different technologies, esp if NOT the same mode, where at least one technology is non-TOS.  So all PWs, Ethernet and MPLS technologies fall into one of these classes.

The worst case example of this I have seen is the one Maarten has been trying to promote wrt Ethernet and MPLS OAM interworking.

The only viable server->client upward FDI case is wrt to a regular time-slice co-cs mode layer network....this is forced because labelling AND resource assignment (==> fixed duration in time ==> fixed no. of bits) are coupled......so a dead timeslot MUST be filled with something.

Doing anything different to this is generating functional coupling between layer networks that should not have it.  Each layer network technology should look after itself wrt OAM.  

regards, Neil

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Giles Heron
> Sent: 21 January 2011 14:50
> To: Thomas Nadeau
> Cc: [email-masked]
> Subject: Re: VPWS I/W OAM
> 
> Isn't the key difference that OAM message mapping is for 
> homogeneous PWEs and VPWS I/W OAM is for heterogeneous ones?  
> (that's certainly what section
> But yes, there are likely to be alignment issues given how 
> many revisions we've had of the OAM message mapping draft.
> 
> One key area that will need addressing is Ethernet OAM.  The 
> VPWS I/W OAM draft pre-dates much of the Ethernet OAM work.  
> Section 6.3.1 states:
> 
> > In a nutshell, the draft is basically the VPWS version of the OAM 
> > Message Mapping draft that is in last call needed some 
> minor updates:
> > 
> > What I'd suggest we do is go back through the draft to make 
> sure that 
> > its still aligned with the oam-msg-map draft given that it 
> currently 
> > references version -04 of oam-msg-map draft and we are up 
> to version 
> > 14, but I believe that the problems it is trying to solve are still 
> > valid, and so the document is still useful. I'll be the 
> first to admit 
> > that it has been sitting around for too long and needs to 
> be wrapped 
> > up!
> > 
> > --Tom
> > 
> > 
> > 
> >> We're looking at the current list of L2VPN WG milestones, 
> and trying 
> >> to clean them up a bit before we add further milestones as part of 
> >> One item that we have on the list of milestones is "Submit OAM 
> >> solutions for VPWS to IESG".  There's an expired WG draft 
> which seems 
> >> to address this
> >> milestone:
> >>

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Fri, 21 Jan 2011 11:05:55 -0600

Dear all,
I agree we need to revisit this draft but I think we can keep it short and refer to the detailed procedures in draft-ietf-pwe3-oam-msg-map-14.txt which has undergone a thourough clean up thanks to the review comments from the PWE3 WG, the AD's and the IESG. 

And yes Ethernet AC should be added for completeness. Again we can refer to detailed procedures in draft-ietf-pwe3-mpls-eth-oam-iwk.

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, January 21, 2011 9:50 AM
To: Thomas Nadeau
Cc: [email-masked]
Subject: Re: VPWS I/W OAM

Isn't the key difference that OAM message mapping is for homogeneous PWEs and VPWS I/W OAM is for heterogeneous ones?  (that's certainly what section
3 of the VPWS I/W OAM draft seems to say).

But yes, there are likely to be alignment issues given how many revisions we've had of the OAM message mapping draft.

One key area that will need addressing is Ethernet OAM.  The VPWS I/W OAM draft pre-dates much of the Ethernet OAM work.  Section 6.3.1 states:

Giles

On 21/01/2011 14:09, "Thomas Nadeau" <[email-masked]> wrote:

> Message Mapping draft that is in last call needed some minor updates:
> 
> What I'd suggest we do is go back through the draft to make sure that 
> its still aligned with the oam-msg-map draft given that it currently 
> references version -04 of oam-msg-map draft and we are up to version 
> valid, and so the document is still useful. I'll be the first to admit 
> that it has been sitting around for too long and needs to be wrapped 
> up!
> 
> --Tom
> 
> 
> 
>> We're looking at the current list of L2VPN WG milestones, and trying 
>> solutions for VPWS to IESG".  There's an expired WG draft which seems 
>> to address this
>> milestone:
>>