Subject: RE: L2vpn Digest, Vol 84, Issue 6

From: "Daniel Cohn" <[email-masked]>
Date: Wed, 1 Jun 2011 17:25:17 +0300

Hi Sam, thanks for the feedback and please see my comments inline with [DC]. Let me know if anything is still not clear.

Regards,

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Cao
Sent: Sunday, May 29, 2011 12:23 PM
To: [email-masked]
Subject: 答复: L2vpn Digest, Vol 84, Issue 6

Daniel,

Today I read your draft and have some questions. 

1) In Figure 2, "VSI Root PW" is used for frames originated from Root ACs.
Is it available for both AC1 on PE1 and AC3 (Root AC) on PE2? For example,
if one unknown unicast originated from AC1, it is carried via VSI root PW
and broadcasted to AC3 and AC4. Is it right? One unknown unicast originated
from AC3 is also carried via VSI Root PW.

[DC] That is correct. Root/leaf PW selection is based solely upon source AC type.

2) AC E-Tree Type. In your draft, it is just locally configured. If so, Root
PW and Leaf PW are always established while VSI has been configured, right?
PE selected the correct PW to send frames upon local configuration, is it
right?

[DC] Right.

3) In 5.2.1, VSI E-Tree encoding. There are two VSI E-Tree types, one is
E-Tree Root VSI, and one is E-Tree Leaf VSI. If so, in figure 2, if one VSI
is attached both Root ACs and Leaf ACs, what is its type? 

[DC] The VSI E-Tree type is a parameter of the PW that interconnects the PEs, not of the entire VSI. So in figure 2, the VSI root PW is signaled with E-Tree Root VSI type, and the VSI leaf PW is signaled with E-Tree Leaf VSI type.

4) Can you tell me the usage of VSI E-Tree identifier? Is it useful to
establish PW? "<VSI E-Tree type, VSI E-Tree identifier> pair", I guess we
have to separate one VSI into two VSIs, one is Root VSI and one is Leaf VSI,
but if so, it is not reasonable to establish just 2 PWs in Figure 2. Root AC
and Leaf AC can not attach to same VSI.

[DC] As explained in the previous comment - there is only one VSI per PE for a VPLS, and this VSI is interconnected to VSIs in other PEs via two PWs.

There are two ways to support E-Tree, I believe, one on data plane and one
on control plane. I also uploaded one draft on this
"http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/". Would you
please share some comments? 

[DC] I reviewed your draft but I need your help in understanding some of the concepts. I will write to you soon with questions.

Yuqun (Sam) Cao
Mobile: +86-18959186587
E-mail: [email-masked] 
 
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表
[email-masked]
发送时间: 2011年5月24日 3:00
收件人: [email-masked]
主题: L2vpn Digest, Vol 84, Issue 6

If you have received this digest without all the individual message
attachments you will need to update your digest options in your list
subscription.  To do so, go to 

https://www.ietf.org/mailman/listinfo/l2vpn

Click the 'Unsubscribe or edit options' button, log in, and set "Get
MIME or Plain Text Digests?" to MIME.  You can set this option
globally for all the list digests you receive at this point.

Send L2vpn mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www.ietf.org/mailman/listinfo/l2vpn
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of L2vpn digest..."

Today's Topics:

   1. Seeking feedback on I-D "Extension to LDP-VPLS for E-Tree
      Using Two	PW" new revision (Daniel Cohn)

----------------------------------------------------------------------

Message: 1
Date: Mon, 23 May 2011 20:28:49 +0300
From: "Daniel Cohn" <[email-masked]>
To: <[email-masked]>
Subject: Seeking feedback on I-D "Extension to LDP-VPLS for E-Tree
	Using Two	PW" new revision
Message-ID: <44F4E579A764584EA9BDFD07D0CA081306C0D78B@tlvmail1>
Content-Type: text/plain;	charset="us-ascii"

Hi L2VPNers,

We (the authors) uploaded a new revision of the "Extension to LDP-VPLS
for E-Tree Using Two PW" at
http://tools.ietf.org/id/draft-ram-l2vpn-ldp-vpls-etree-2pw-02.txt

The main change from the previous revision is the use of new interface
parameters TLVs (VSI E-Tree type and VSI E-Tree identifier) to identify
root and leaf PWs, rather than defining new PW types. This is a result
from feedback we received when we presented the draft at IETF 80.

We are seeking more feedback from the mailing list, and would be
grateful if you could review the document and post comments on the
mailing list or directly to the authors.

Regards,

Daniel

------------------------------

_______________________________________________
L2vpn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2vpn

End of L2vpn Digest, Vol 84, Issue 6
************************************

---

From: "Sam Cao" <[email-masked]>
Date: Fri, 3 Jun 2011 09:57:42 +0800

Hi Daniel,

Thank you very much for your comments. I understood your design, and have 3 more questions,

1) Two PWs are always established and necessary since AC E-Tree Type is locally configured 
   in any case. I agree (Your answer to my Q2). But as you know, most members of one E-Tree 
   instance are Leaf for most E-Tree cases, if so, at least 50% PW is useless. In addtion, 
   if we need to implement Fast ReRouting (PW backup), more uselss PW are established. 
   How to solve this? As you konw, Root-Leaf-Mixed is only a small proportion of E-Tree members. 
2) The VSI E-Tree type is a parameter of the PW that interconnects the PEs, you said. What is 
   the purpose? 
3) The third, I gave one example, it can make myself understood. Suppose two PEs, say PE1 and PE2, belongs
   to one E-Tree instance, where PE1 are bound a Root AC and a Leaf AC, and PE2 are only bound
   a Lead AC.

                   <--------------E-Tree-------------->
                   +---------+              +---------+
                   |   PE1   |              |   PE2   |
   +---+           |  +---+  |              |  +---+  |
   |CE1+----AC1----+--+   |  |              |  |   |  | 
   +---+ (Root AC) |  | V |  |              |  | V |  |
                   |  | S +--+------PW------+--+ S |  |
   +---+           |  | I |  |              |  | I |  |           +---+
   |CE2+----AC2----+--+   |  |              |  |   +--+----AC4----+CE4|
   +---+ (Leaf AC) |  +---+  |              |  +---+  | (Leaf AC) +---+
                   +---------+              +---------+
   
  In this case, 2 PWs are established, I agree that it is reasonable. Any frames are transmitted 
  from AC4 to  PE1 via Spoke PW, then PE1 transmit the frames to AC1 (Root AC), not AC2. If AC1
  goes down, 2 PWs still exist, and now frames from AC4 still are transmitted from AC4 to PE1 via 
  Spoke PW. On PE1 side, PE found that there is no Root AC and dicard the frames. Is this correct? 
  If so, we will have one problem: both PEs are attached to Spoke AC, but garbage frames are 
  ransmitted via Spoke PW. 

  E-Tree needs extension to current standard, and I prefer to extend on control plane since it is 
  clear for user. Sorry for so many questions.

Sam

----- Original Message ----- 
From: "Daniel Cohn" <[email-masked]>
To: "Sam Cao" <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 01, 2011 10:25 PM
Subject: RE: L2vpn Digest, Vol 84, Issue 6

Regards,

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Cao
Sent: Sunday, May 29, 2011 12:23 PM
To: [email-masked]
Subject: 答复: L2vpn Digest, Vol 84, Issue 6

Daniel,

[DC] Right.

Yuqun (Sam) Cao
Mobile: +86-18959186587
 
-----邮件原件-----

Today's Topics:

Message: 1

Hi L2VPNers,

Regards,

Daniel

---

From: "Daniel Cohn" <[email-masked]>
Date: Thu, 9 Jun 2011 09:27:14 +0300

Hi Sam, see answers inline with [DC]

-----Original Message-----
From: Sam Cao [mailto:[email-masked]] 
Sent: Friday, June 03, 2011 4:58 AM
To: Daniel Cohn; [email-masked]
Subject: Re: L2vpn Digest, Vol 84, Issue 6

Hi Daniel,

[DC] Even when all ACs in one PE are leaf type, the root PW is still required. This is because traffic received by this PE which originated in a source AC, gets transmitted in a root PE, no matter what the destination AC is. 

[DC] This is the parameter that identifies root/leaf PW, i.e. by looking at this parameter the PE can tell whether packets coming thru this PW should be treated as originating in source or destination AC.

   

[DC] I don't understand how this is different from a non-etree scenario where the destination AC is down and multicast PDUs are transmitted all the way until the last PE, which discards the frame upon finding that the destination AC is down. Can u explain? 

[DC] As I said I will get back to you soon with questions on your proposal. Sorry for the delay.

Sam

----- Original Message ----- 
From: "Daniel Cohn" <[email-masked]>
To: "Sam Cao" <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 01, 2011 10:25 PM
Subject: RE: L2vpn Digest, Vol 84, Issue 6

Regards,

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Cao
Sent: Sunday, May 29, 2011 12:23 PM
To: [email-masked]
Subject: 答复: L2vpn Digest, Vol 84, Issue 6

Daniel,

[DC] Right.

Yuqun (Sam) Cao
Mobile: +86-18959186587
 
-----邮件原件-----

Today's Topics:

Message: 1

Hi L2VPNers,

Regards,

Daniel

---

From: "Sam Cao" <[email-masked]>
Date: Thu, 9 Jun 2011 15:05:16 +0800

Daniel,

I understood your answer. I asked the first 2 questions in order to fully understand your idea.
Now we can only focus on my last question.

First, for a non-etree scenario, all PEs in VPLS instance are equal, and one PW is enough (Refer 
to RFC 6074). If PW is UP, one PE SHOULD send multicast/broadcast/unknown unicat via the PW, it 
makes sense. But for etree scenario, we SHOULD break communication between Leafs. If we know that 
the peer is bound only Leafs (Root Leaf goes down, that means only one Leaf AC is bound), why we 
still send the packet ans wait the peer discards it? So, maybe we need to find one way to improve 
this solution. Is it clear now? What I mean is, non-etree is a different case.

Daniel, thank you very much for your time. 

Sam

-----Original Message-----
From: Sam Cao [mailto:[email-masked]] 
Sent: Friday, June 03, 2011 4:58 AM
To: Daniel Cohn; [email-masked]
Subject: Re: L2vpn Digest, Vol 84, Issue 6

Hi Daniel,

   

Sam

----- Original Message ----- 
From: "Daniel Cohn" <[email-masked]>
To: "Sam Cao" <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 01, 2011 10:25 PM
Subject: RE: L2vpn Digest, Vol 84, Issue 6

Regards,

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Cao
Sent: Sunday, May 29, 2011 12:23 PM
To: [email-masked]
Subject: 答复: L2vpn Digest, Vol 84, Issue 6

Daniel,

[DC] Right.

Yuqun (Sam) Cao
Mobile: +86-18959186587
 
-----邮件原件-----

Today's Topics:

Message: 1

Hi L2VPNers,

Regards,

Daniel