Subject: RE: WG Last Call on draft-ietf-l2vpn-ipls

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 2 Jan 2013 16:55:27 -0500

IPLS predates EVPN and used many important concepts introduced in this document.
EVPN uses BGP signaling while IPLS uses LDP and provides an alternative to those vendors/networks
that does not want to use BGP for capex/opex  (or any other) reasons.

Thanks for your support.
/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rogers, Josh
Sent: Wednesday, December 19, 2012 11:17 AM
To: Giles Heron; [email-masked]
Subject: Re: WG Last Call on draft-ietf-l2vpn-ipls

I support publication.  This methodology is attractive due to the isolation of the AC, potential isolation and/or mitigation loop on the AC, improved SP visibility into customer traffic benefiting coop troubleshooting and support for multicast customer traffic (to not be treated as broadcast).

I do, however, see some overlap with EVPN, and would like to hear how the authors see the relationship between some of the EVPN work and this?

-Josh

On 12/19/12 9:59 AM, "Giles Heron" <[email-masked]> wrote:

>This email initiates an L2VPN WG Last Call for:
>
>http://tools.ietf.org/html/draft-ietf-l2vpn-ipls-11
>
>please comment to the list as to the suitability of this draft for 
>publication as an Informational RFC from the L2VPN WG.  As always it'd 
>be good to hear some comments over and above the usual "Support!".  
>Well, given the season any comments at all would be good ;)
>
>this last call will close on Friday 4th January.
>
>Nabil & Giles

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Rogers, Josh" <[email-masked]>
Date: Wed, 2 Jan 2013 16:58:23 -0500

Thank you for the clarification.  In an SP role, I would prefer EVPN and
using BGP signaling with a more robust solution, but can also appreciate
the benefit of a non-BGP option to accomplish some of the same goals.

-Josh

On 1/2/13 3:55 PM, "Shah, Himanshu" <[email-masked]> wrote:

>I support publication.  This methodology is attractive due to the
>isolation of the AC, potential isolation and/or mitigation loop on the
>AC, improved SP visibility into customer traffic benefiting coop
>troubleshooting and support for multicast customer traffic (to not be
>treated as broadcast).
>
>I do, however, see some overlap with EVPN, and would like to hear how the
>authors see the relationship between some of the EVPN work and this?
>
>-Josh
>
>
>This E-mail and any of its attachments may contain Time Warner Cable
>proprietary information, which is privileged, confidential, or subject to
>copyright belonging to Time Warner Cable. This E-mail is intended solely
>for the use of the individual or entity to which it is addressed. If you
>are not the intended recipient of this E-mail, you are hereby notified
>that any dissemination, distribution, copying, or action taken in
>relation to the contents of and attachments to this E-mail is strictly
>prohibited and may be unlawful. If you have received this E-mail in
>error, please notify the sender immediately and permanently delete the
>original and any copy of this E-mail and any printout.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 2 Jan 2013 17:05:14 -0500

IPLS introduced to L2VPN WG some of the main concepts that EVPN is using -

- CE MAC address learning  - so that FIB does not have to be created by snooping passing user data frames
- CE MAC address signaling 
- use of mp2p label

Also, the IPLS provides an alternate to BGP based signaling.

Perhaps you may know that L2VPN group has both LDP and BGP based solutions for VPWS and VPLS?
(which included no WG last call for RFC 6624 that I recall - may be you can prove me wrong).

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, December 19, 2012 2:56 PM
To: Giles Heron; [email-masked]
Subject: Re: WG Last Call on draft-ietf-l2vpn-ipls

I would not support this given E_VPN is a superior solution.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 2 Jan 2013 18:33:15 -0500

I am not sure that even WG consensus is required for the "informational" RFC.
The IPLS document has been last called when on standard's track (AFAIK) but IPv6 support was requested
when circulated to other groups. This has been added.

AFAIK, there are a couple of vendors contemplating implementation.
/himanshu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Wednesday, December 19, 2012 6:12 PM
To: Giles Heron; [email-masked]
Subject: RE: WG Last Call on draft-ietf-l2vpn-ipls

Dear All,
would publication of the document fall into the following case (http://www.ietf.org/iesg/informational-vs-experimental.html):
*         ... work that could be practiced, was developed in the IETF, has been dropped for some reason, but is being published for the record. That's Informational, unless the IESG determines that Historic status is more appropriate.
Support if that is the case and Historic status will be suggested to IESG or, even better, selected by the WG itself.
Otherwise - do not support publication.

        Regards,
                Greg

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Wednesday, December 19, 2012 7:59 AM
To: [email-masked]<mailto:[email-masked]>
Subject: WG Last Call on draft-ietf-l2vpn-ipls

please comment to the list as to the suitability of this draft for publication as an Informational RFC from the L2VPN WG.  As always it'd be good to hear some comments over and above the usual "Support!".  Well, given the season any comments at all would be good ;)

Nabil & Giles

---

From: John E Drake <[email-masked]>
Date: Thu, 3 Jan 2013 15:51:07 +0000

I support its publication as 'Informantional'.

Irrespectively Yours,

John

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Shah, Himanshu
> Sent: Wednesday, January 02, 2013 1:55 PM
> To: EXT - [email-masked]; Giles Heron; [email-masked]
> EVPN uses BGP signaling while IPLS uses LDP and provides an alternative
> to those vendors/networks that does not want to use BGP for capex/opex
> (or any other) reasons.
> 
> Thanks for your support.
> /himanshu
> 
> I do, however, see some overlap with EVPN, and would like to hear how
> the authors see the relationship between some of the EVPN work and
> this?
> 
> -Josh
> 
> 
> proprietary information, which is privileged, confidential, or subject
> to copyright belonging to Time Warner Cable. This E-mail is intended
> solely for the use of the individual or entity to which it is
> addressed. If you are not the intended recipient of this E-mail, you
> are hereby notified that any dissemination, distribution, copying, or
> action taken in relation to the contents of and attachments to this E-
> mail is strictly prohibited and may be unlawful. If you have received
> this E-mail in error, please notify the sender immediately and
> permanently delete the original and any copy of this E-mail and any
> printout.