Subject: Regd. ESI Segment Route (Type 4) in evpn

From: Satya Mohanty <[email-masked]>
Date: Thu, 17 Jan 2013 08:05:21 +0000

The information conveyed by the type-4 route Ethernet Segment Route is the esi and as per the description in latest draft, this route (advertised by PE1 lets's say) is to be "imported" by the receiver PE (let's say PE2, to which the CE is dual homed). The "import" is through the new extcom ES-Import Extcom.

I was thinking if  we attach this ES-import extcom to the type 1 (Mandatory) Route; shouldn't it be sufficient?

Then the type 1 route would be "imported" by the PE2 in question, and the ESI is present in the type 1 Route.
[The implementation anyway has to take care of this "import"  filtering via this new ext-com in addition to normal RTs.]
In other words, is type -4 really necessary?

Please do let me know if I am missing anything here.

Thanks,
--Satya

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 17 Jan 2013 08:58:42 +0000

They are imported by a different set of PEs.

The Ether-AD route per segment (type 1) is imported by all
PEs that share an EVI on that segment

The ES route (type 4) is imported by PEs that connect to the same segment,
regardless of which EVIs may exist on the segment.
It is used to inform PEs of other PEs connected to a common segment.
It carries information about the segment that is not necessarily
of interest to PEs that do not share the segment. See
http://tools.ietf.org/html/draft-sajassi-l2vpn-evpn-segment-route-01

--
Jakob Heitz.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Satya Mohanty
Sent: Thursday, January 17, 2013 12:05 AM
To: [email-masked]
Subject: Regd. ESI Segment Route (Type 4) in evpn

Thanks,
--Satya

---

From: Satya Mohanty <[email-masked]>
Date: Thu, 17 Jan 2013 18:14:05 +0000

Jakob,

Thanks for your clarification and the pointer to the draft that you mentioned.

There is use of a BGP attribute (DF Election attribute) which is not mentioned at all in the latest draft http://tools.ietf.org/html/draft-ietf-l2vpn-evpn-02.
[only the ESI-import ext com is mentioned, and the ESI route itself does not contain any more information other than the ESI id]. The latest draft does talk of DF election algorithm, so it is not clear to me whether the "DF Election attribute" in the draft you point out is necessary now.

Keeping this in context, I don't see the extra information that  the ESI segment route is conveying which is already not present in type 1 (mandatory); the "information" is the ESI-id as far as I can tell.

Thanks,
--Satya

From: Jakob Heitz [mailto:[email-masked]]
Sent: Thursday, January 17, 2013 12:59 AM
To: Satya Mohanty; [email-masked]
Subject: RE: Regd. ESI Segment Route (Type 4) in evpn

--
Jakob Heitz.

Thanks,
--Satya