Subject: RE: One question on draft "draft-vgovindan-l2vpn-evpn-bfd-01"

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 27 Mar 2014 03:48:02 +0000

Hi authors, ping your echo.

From: Xialiang (Frank)
Sent: Thursday, March 20, 2014 3:02 PM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]
Subject: One question on draft "draft-vgovindan-l2vpn-evpn-bfd-01"

Hi authors,
I have one question about BFD packet encapsulation: you point out 2 ways: by GAL/G-ACH, or by IP. And you think that the way by IP is not suitable because BFD packets will follow a different path than that of data packets when they use different destination IP address.
Can you clarify the specific reason? And why can the way by GAL/G-ACH avoid this problem of different path?
Thanks!

B.R.
Frank

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Fri, 28 Mar 2014 07:15:16 +0000

Hello Frank,
  Sorry for the delay in my response. The reason why IP encapsulation is not preferred is that the BFD packet may go out-of-band since the DIP of the packet inside the MPLS-BFD is 127/8 (different from the IP a data packet may use). Any node hashing on the DIP may cause it take an out-of-band path especially when the packet does not carry an entropy label in the MPLS label stack. Since this issue is not present in the GAL/ G-Ach case the draft recommends that option.
Thanks
Prasad

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Thursday, March 27, 2014 9:18 AM
To: Vengada Prasad Govindan (venggovi); Samer Salam (ssalam); Ali Sajassi (sajassi)
Cc: [email-masked]
Subject: RE: One question on draft "draft-vgovindan-l2vpn-evpn-bfd-01"

From: Xialiang (Frank)
Sent: Thursday, March 20, 2014 3:02 PM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]<mailto:[email-masked]>
Subject: One question on draft "draft-vgovindan-l2vpn-evpn-bfd-01"

Hi authors,

B.R.
Frank