Subject: Re: [L3sm] Next steps with L3SM

From: <[email-masked]>
Date: Mon, 4 May 2015 12:57:55 +0000

Hi,

Pls find some inline comments.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Fan, Peng
Sent: Thursday, April 30, 2015 05:30
To: [email-masked]
Subject: Re: [L3sm] Next steps with L3SM

Hi,

I looked at draft-l3vpn-service-yang and think it is well written. Here are some comments:

1. How is SVC-MTU related with path MTU? Is such MTU applied to the segment between PE and CE or the segment from one PE to another PE in the operator's backbone?
[SLI] PE-CE. It is related to the service MTU at access. If the service is IP, it refers to an IP MTU.

2. In the schema definition of location, it seems city code is determined after country code, I suggest inserting country-code before city-code.
[SLI] We can fix it, I also added for next version, the postal address of the site.

3. In Sec. 5
"Authorization of traffic exchange is done through what we call a VPN policy or VPn topology defining routing exchange rules between sites. "
s/VPn/VPN

[SLI] Will be fixed

4. In Sec. 8, definition of container attachment "It we would be good to ensure that site-id is template type"
s/It we would be good/It would be good

[SLI] Will be fixed

Best regards,
Peng

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2015年4月21日 17:30
收件人: [email-masked]
抄送: Qin Wu
主题: [L3sm] Next steps with L3SM

Hi working group,

We thought we should give you a plan to work to.

As you know, we have just one deliverable from the working group and plan to complete by the end of the year. 

The charter says we will consider draft-l3vpn-service-yang as our starting point so we have spoken with the authors to find out what state they think the document is in. It looks like they are planning a small revision (mainly concerning operational status) and hope to get to this "soon".

After that we will ask the WG about adopting the document.

In the meantime...

- Please review and comment on the current document
- Please bring your friends to the review party :-)
    - We are particularly interest in service providers who offer L3VPN services
    - Customers (e.g., enterprises) who buy L3VPN services
    - YANG gurus

The planning for IETF-93 in Prague is just starting.

We don't expect that the WG will have a great deal to discuss, but we will provisionally book a 1 hour slot.

Thanks,
Qin and Adrian

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Tue, 5 May 2015 12:05:22 +0000

Forward a few comments from a contributor who has difficult to post his review to the list.

-Qin
发件人: Andy leu [mailto:[email-masked]]
发送时间: 2015年5月5日 16:29
收件人: [email-masked]
主题: Re: [L3sm] Next steps with L3SM

Hi,
I can not send comments from gmail, so I will  try again.
Comments on draft-l3vpn-service-yang as following:

I support this draft but I have two comments:
1. when we use a site as template in VPN A, , can we use the site in VPN B as template?
If yes, How do we use the different path information to represent different site in the same or different VPN?
2. Is there possibility to use service model for customer A as the template to build service model for customer B? If the answer is yes, how to represent this in the YANG model code? Import a module for customer A in the module for customer B?

Andrew

---

From: <[email-masked]>
Date: Tue, 12 May 2015 07:31:27 +0000

Hi,

I think there is a misunderstanding of what a site is here, we consider a site has an access. So Hub#1 will be composed of two sites : one primary and one backup.

Best Regards,

From: 赵婧 [mailto:[email-masked]]
Sent: Tuesday, May 12, 2015 05:14
To: LITKOWSKI Stephane SCE/IBNF
Cc: [email-masked]
Subject: RE: [L3sm] Next steps with L3SM

Hi,
1.  In the schema tree, access-type is within availability. Access-type leaf or access-type leaf list? Can dual home site support both primary access and backup access at the same time
[SLI] I don’t see the use case for this, could you elaborate ?

How about dual homing case where one hub#1 site has two primary-backup accesses (see the first figure in the section 5.2.1.2):
One is CE1- PE1 primary access, the other is CE2-PE2 backup access, then hub#1 site support dual homing
can be represented as follows:
   <site-id>Hub#1Site</site-id>
   <availability>
       <availability-type>
       <service-type>primary-backup</service-type>
       <access-type>primary</access-type>
       <service-type>primary-backup</service-type>
       <access-type>backup</access-type>
   </availability-type>
   </availability>
So I am wondering whether <availability-type> can be defined as list rather than container? What do you think of this?
Also I am not sure the second figure in the section 5.2.1.2 is wrong or not:
                               Hub#2 LAN
              loadsharing        |
              loadsharing-access |
           PE3 --------- CE3 --- |
                                 |
                                 |
           PE4 --------- CE4 --- |
           |   loadsharing       |
           |   loadsharing-access
           |
           | single
           | single-access
           | loadsharing-eibgp
           |
           CE6
           |
       Spoke#2 site

Since it looks to me Spoke# site support single access between PE4 and CE6, but it looks access between PE4 and CE6 also support loadsharing-eibgp, is this intentional?

________________________________
Jingzhao
Shanghai Research Institution of China Telecom