Subject: [L3sm] Proposal for Next Stage of L3SM WG

From: "Aijun Wang" <[email-masked]>
Date: Mon, 26 Oct 2015 18:45:03 +0800

Hi, L3SMer:

As the work for l3vpn service model will be finished soon, we should consider its deployment in real network.  Besides this, the more important is that we should consider the future of the L3SM WG.
Considering there are more services that are deployed within the service provider network, then:
1.Can we consider more service models within this WG? 
2.Can we enlarge the scope this WG, strip the character of "L3" from the name "L3SM", change it to "SM(Service Model) WG", then we can do more work step by step?  
3.Can we considering also the relationship/deployment scenario among the Service Model and Network Model, with other system in service provide?

We can see that there are already several new drafts covering the above consideration, for example:
1.  http://datatracker.ietf.org/doc/draft-gu-l3sm-vas-service-model/ discusses the VAS service model that used in NFV environment.
2.  http://datatracker.ietf.org/doc/draft-wang-l3sm-service-automation-architecture/ discusses the relationship between Service Model and Network Model, and their deployment scenarios.
3.  http://datatracker.ietf.org/doc/draft-xie-l3sm-l2vpn-service-model/ discusses the yang model for L2VPN
4.  http://datatracker.ietf.org/doc/draft-zha-l3sm-l3vpn-onos-deployment/?include_text=1 give one example of how to define one l3vpn network model that has relation with the defined l3vpn service model.

Then I think it is the time to discuss the above proposals in order to make the standard works more synchronization and more fruitful.
And your opinions?

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute 
Intelligent Network Product Line

---

From: "Bragg, Nigel" <[email-masked]>
Date: Tue, 27 Oct 2015 08:24:40 -0400

Hello Aijun Wang,
	In considering possible enlargement of the scope of the L3SM WG, the group should be aware that there is 
               work in progress on YANG modelling of Layer 2 Services taking place under the auspices of the MEF Forum.

	A liaison drawing attention to this work was sent to IETF on 29 Jan 2015 : 
https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-02-04-mef-the-ietf-liaison-about-new-project-on-yang-modules-for-mef-services-attachment-1.pdf  

	Regards,
Nigel Bragg

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: 26 October 2015 10:45
To: [email-masked]
Subject: [L3sm] Proposal for Next Stage of L3SM WG

Hi, L3SMer:

We can see that there are already several new drafts covering the above consideration, for example:
1.  http://datatracker.ietf.org/doc/draft-gu-l3sm-vas-service-model/ discusses the VAS service model that used in NFV environment.
2.  http://datatracker.ietf.org/doc/draft-wang-l3sm-service-automation-architecture/ discusses the relationship between Service Model and Network Model, and their deployment scenarios.
3.  http://datatracker.ietf.org/doc/draft-xie-l3sm-l2vpn-service-model/ discusses the yang model for L2VPN 4.  http://datatracker.ietf.org/doc/draft-zha-l3sm-l3vpn-onos-deployment/?include_text=1 give one example of how to define one l3vpn network model that has relation with the defined l3vpn service model.

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Intelligent Network Product Line

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 30 Oct 2015 11:07:53 +0800

Hi, Bragg:

Would you like to give more information or reference link about the scope
and current progress of Layer 2 service model? Will these models be
discussed within IETF?

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Bragg, Nigel
Sent: Tuesday, October 27, 2015 8:25 PM
To: Aijun Wang; [email-masked]
Cc: Ranganathan, Raghu
Subject: Re: [L3sm] Proposal for Next Stage of L3SM WG

Hello Aijun Wang,
	In considering possible enlargement of the scope of the L3SM WG, the
group should be aware that there is 
               work in progress on YANG modelling of Layer 2 Services taking
place under the auspices of the MEF Forum.

	A liaison drawing attention to this work was sent to IETF on 29 Jan
2015 : 
https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-02-04-mef-the-iet
f-liaison-about-new-project-on-yang-modules-for-mef-services-attachment-1.pd
f  

	Regards,
Nigel Bragg

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: 26 October 2015 10:45
To: [email-masked]
Subject: [L3sm] Proposal for Next Stage of L3SM WG

Hi, L3SMer:

As the work for l3vpn service model will be finished soon, we should
consider its deployment in real network.  Besides this, the more important
is that we should consider the future of the L3SM WG.
Considering there are more services that are deployed within the service
provider network, then:
1.Can we consider more service models within this WG? 
2.Can we enlarge the scope this WG, strip the character of "L3" from the
name "L3SM", change it to "SM(Service Model) WG", then we can do more work
step by step?  
3.Can we considering also the relationship/deployment scenario among the
Service Model and Network Model, with other system in service provide?

We can see that there are already several new drafts covering the above
consideration, for example:
1.  http://datatracker.ietf.org/doc/draft-gu-l3sm-vas-service-model/
discusses the VAS service model that used in NFV environment.
2.
http://datatracker.ietf.org/doc/draft-wang-l3sm-service-automation-architect
ure/ discusses the relationship between Service Model and Network Model, and
their deployment scenarios.
3.  http://datatracker.ietf.org/doc/draft-xie-l3sm-l2vpn-service-model/
discusses the yang model for L2VPN 4.
http://datatracker.ietf.org/doc/draft-zha-l3sm-l3vpn-onos-deployment/?includ
e_text=1 give one example of how to define one l3vpn network model that has
relation with the defined l3vpn service model.

Then I think it is the time to discuss the above proposals in order to make
the standard works more synchronization and more fruitful.
And your opinions?

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Intelligent
Network Product Line

---

From: 顾戎 <[email-masked]>
Date: Fri, 30 Oct 2015 03:52:03 +0000

Hi, Aijun.I think your proposal is valuable. Some work is still on discussion without standardization relavant to the service model and the L3 vpn scenario. While they are out of the charter of L3SM, and there is no other home for these work, so the proposal of considering on the charter enlargement of L3SM is in time. Thanks for pointing out my draft of vas service model. Indeed, when we provide the value added service in our cloud datacenter, we meet the problems that the service models are not standardized and the NFV architecture remains unclear. http://datatracker.ietf.org/doc/draft-gu-l3sm-vas-service-model
L3SMers, if you are also interested in the vas service model, feel free to connect me.
Best regards.
Gu [email-masked]@chinamobile.com