Subject: Re: Route distribution among VRF's in a single PE

From: John Smith <[email-masked]>
Date: Thu, 18 Sep 2003 09:39:26 +0100 (BST)

Sakthivadivu,

This is applicable when a PE router has two VRFs A and B defined as:

VRF A:
Import RT - 100:100
Export RT - 100:100 200:200

VRF B:
Import RT - 200:200
Export RT - 200:200

Now when VRF A learns a route from its CE peer (either through redistribution/static/etc)
then the route is redistributed to VRF B also.

This happens as the export RTs of VRF A match with that of VRF B's import RT.

Regards,
John
----- Original Message ----- 
From: "Sakthivadivu.S.S" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 17, 2003 3:57 PM
Subject: Route distribution among VRF's in a single PE

> Hi,
> 
>    BGP/MPLS VPN draft talks about route distribution among VRF's in a single
> PE in section 4.3.6.
>    Can you please tell when will this situation occur.?
> 
> Thanks,
> Sakthi

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk

---

From: "Sakthivadivu.S.S" <[email-masked]>
Date: Thu, 18 Sep 2003 16:51:34 +0530

Hi John,
  Thanks for your inputs.

Consider the following scenario.

  CE1 -----------PE1----------CE2

  CE1 is associated with VRF-A and CE2 is associated with VRF-B.
  Site1 is connected to CE1 and site2 is connected to CE2.
   VRF A:
     Import RT - 100:100
     Export RT - 100:100 200:200

   VRF B:
     Import RT - 200:200
     Export RT - 200:200

  If CE1 learns route 10.10/8, it will be installed in VRF-A. Since export
policy of VRF-A and
  import policy of VRF-B are same, 10.10/8 will be installed in VRF-B
also.My doubt is what will be
  the nexthop for 10.10/8 in VRF-B. How will be the IP packet forwarded from
CE2 to CE1.
  Is it through IP or MPLS.If it through MPLS what will be the bottom label
and top label.
   If it is through IP, what will be the nexthop for 10.10/8.

 Thanks in advance,
  Sakthi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
John Smith
Sent: Thursday, 18 September 2003 2:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Route distribution among VRF's in a single PE

Sakthivadivu,

VRF A:
Import RT - 100:100

VRF B:
Import RT - 200:200
Export RT - 200:200

Now when VRF A learns a route from its CE peer (either through
redistribution/static/etc)
then the route is redistributed to VRF B also.

This happens as the export RTs of VRF A match with that of VRF B's import
RT.

Regards,
John
----- Original Message -----
From: "Sakthivadivu.S.S" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 17, 2003 3:57 PM
Subject: Route distribution among VRF's in a single PE

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************