Subject: RE: RRs

From: [email-masked]
Date: Wed, 16 Mar 2005 10:43:19 +0530

Answers Inline...

________________________________

From: [email-masked] on behalf of John Smith
Sent: Tue 3/15/2005 8:28 PM
To: [email-masked]
Subject: RRs

Hi,

Are the following statements true about BGP Route Reflectors in BGP/MPLS VPNs:

[1] We are not required to configure any RDs since most of the times there would not be
any customers attached to the RRs.

This is not always TRUE.

 BGP RR can have customers attached when it is acting as a PE router. 

[2] The RR would be peered up with a couple of BGP PE routers. It would reflect
(following the rules laid out for RRs) all the BGP VPN routes it learns from one PE
router to the other PE router without modifying the NEXT_HOP. It does not even need to
look at the extended communities for doing that, unless some ORF has been advertised by a
PE router.

It is true. 

[3] If the RR does not have any VRFs then it will not insert any routes in its FIB and
will not program the MPLS labels. How would then the forwarding take place? Does the RR
need to do something special for that?

RR may not come in the forwarding path of the packet. Even if it come in the forwarding path it would be part of MPLS or any other tunnel between the PEs based on the internal routing.

I would really appreciate if somebody could help me with these questions.

Thanks and Regards,
John Smith

Send instant messages to your online friends http://uk.messenger.yahoo.com

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 21 Mar 2005 07:18:23 -0800

Venkat,

> Answers Inline...

see in-line...

> Are the following statements true about BGP Route Reflectors in BGP/MPLS > VPNs:
> 
> [1] We are not required to configure any RDs since most of the times > there would not be
> [2] The RR would be peered up with a couple of BGP PE routers. 

The RR is likely to peer with more than just "a couple of BGP PE routers".

> It would reflect (following the rules laid out for RRs) all the BGP 
> VPN routes it learns from one PE router to the other PE router without 
> modifying the NEXT_HOP. It does not even need to
> look at the extended communities for doing that, unless some ORF has 
> been advertised by a PE router.
> 
> It is true.

RR may use Route Target Constrain (draft-ietf-l3vpn-rt-constrain-01.txt)
instead of ORF.

Yakov.