Subject: RE: draft-ycai-mvpn-experience-00

From: "Leymann, Nicolai" <[email-masked]>
Date: Fri, 18 Nov 2005 13:11:53 +0100

Hi,

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von Mike McBride
> Gesendet: Mittwoch, 19. Oktober 2005 22:03
> An: [email-masked]
> Betreff: draft-ycai-mvpn-experience-00
> 
> Please review draft-ycai-mvpn-experience-00. We'd like you to 
> consider it becoming a l3vpn wg doc. We'll ask for time 
> during the wg meeting in Vancouver to discuss.
> 
> http://www.ietf.org/internet-drafts/draft-ycai-mvpn-experience-00.txt
> 
> thanks,
> mike
> 
I've a few comments regarding the draft:

- Interoperability (Problems)
We did some quite extensive interop tests (using default and data MDTs) and experienced some quite interesting "issues". I'm happy to share this experiences but I'm not sure how to handle this kind of information because it also includes critical implementation-bugs which were found during the tests.

- Scalability
>From my point of view there should be a difference between the general scalability of mVPN (based on the drafts) and the scalability of existing solutions. From the drafts point of view (number of PIM neighours) our scenarios scales but if you look on the existing implementations there are some limitations.

  Regards

     Nic

--
Nicolai Leymann
T-Systems International GmbH
Senior Expert, IP-Technologies
E-Mail: [email-masked]
Internet: http://www.t-systems.com

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 22 Nov 2005 07:09:21 -0800

Nic,

> We did some quite extensive interop tests (using default and data
> MDTs) and experienced some quite interesting "issues". I'm happy
> to share this experiences but I'm not sure how to handle this kind
> of information because it also includes critical implementation-bugs
> which were found during the tests.
> 
> - Scalability
> From my point of view there should be a difference between the
> general scalability of mVPN (based on the drafts) and the scalability
> of existing solutions.  From the drafts point of view (number of
> PIM neighours) our scenarios scales but if you look on the existing
> implementations there are some limitations.

Since the draft is about "experience gained from implementation
and deployment" the draft should describe the limitations of the
implementations.

Yakov.

---

From: Yiqun Cai <[email-masked]>
Date: Tue, 22 Nov 2005 11:27:31 -0800

Nic,

Your comments are definitely welcome as one of the objectives of the  
draft
is to help implementors and service providers avoid making the same
mistakes made before.

As an implementor,  I understand your concern.  If you don't mind,   
please
unicast to me the information and we will discuss the most appropriate
means to share the information with the community.

> and deployment" the draft should describe the limitations of the

While I agree with Yakov in general,  I think there is a fine line  
with any
specific implementation with regard to what kind of information can be
made public.   So we will review it on a case by case basis.

Thanks.

(And sorry for the late reply)

--
Yiqun