Subject: RE: Review of draft-ietf-l3vpn-ppvpn-mcast-reqts-03

From: [email-masked]
Date: Tue, 17 Jan 2006 10:04:28 -0000

Thomas,
 
See in-line.  My comments are marked [BPN].
 
Ben

________________________________

	From: Thomas Morin [mailto:[email-masked]] 
	Sent: Tuesday, January 17, 2006 9:48 AM
	To: Niven-jenkins,B,Ben,XDE73 R
	Cc: [email-masked]
	Subject: RE: Review of draft-ietf-l3vpn-ppvpn-mcast-reqts-03

	Hi Benjamin,
	
	[email-masked]: 

				1st paragraph: "VPN services satisfying
the requirement defined in" 

			In fact, a plural was missing.

			[BPN] Then it should be "VPN services satifying
the requirements defined in" 

	Ok.

				Section 4.1:

			[...]

				2nd paragraph: "to impact most of the
design" 

			The goal is to talk about things thay have a
greater impact on the design.
			Would that be better english: "scenarios that
are expected to impact the most the design of a multicast VPN solution".

			[BPN] I believe my original proposal is the best
English and is in line with your goal to talk about things that have a
large impact on the design. 

	I'm not sure. 
	Maybe "scenarios are expected to have a greater impact on the
design of a solution" ?
	 
	[BPN] Greater impact than what?  How about "scenarios that are
expected to have a large impact on the design of a solution"? 

				Section 5.1.2:
				
				1st paragraph: "Consequently to Section
3.1, the CEs and PEs CE-PE protocol SHOULD employ existing multicast
protocols." These edits also need to be made to the copy of the
requirement in Appendix A.  

			Misunderstanding here: we can't reduce to one
"CE-PE protocol"; there can be many, e.g IGMP or PIM; and we don't want
either to invent a new CE-PE protocol that would reuse an exisiting
mcast protocol.

			[BPN] OK.  My concern is that by saying "CEs and
PEs SHOULD employ existing multicast protocols" implies that it is more
than the CE-PE protocol that you are referring to - i.e. that you are
implying that the PE-PE and MDT tunnel establishment protocols SHOULD
also use existing protocols.  How about something like "the CEs and PEs
SHOULD employ existing multicast protocols for communication with each
other"?

	I see your point now.
	Maybe "[..] multicast-related protocol exchanges between a CE
and its directly connected PE should happen via existing multicast
protocols:"  ?
	 
	[BPN] OK.  That's fine.
	 
	Thanks,
	
	-Thomas

---

From: Thomas Morin <[email-masked]>
Date: Tue, 17 Jan 2006 11:33:19 +0100

Hi Benjamin,

[email-masked]:
>         >         > Section 4.1:
>         >         [...]
>         >         > 2nd paragraph: "to impact most of the design" 
>         >         
>         >         The goal is to talk about things thay have a greater
>         >         impact on the design.
>         >         Would that be better english: "scenarios that are
>         >         expected to impact the most the design of a
>         >         multicast VPN solution".
>         >           
>         >         English and is in line with your goal to talk about
>         >         things that have a large impact on the design. 
>         
>         I'm not sure. 

Yes, fine.
Thank you again for your careful review.

-Thomas