Subject: draft-ietf-l3vpn-2547bis-mcast-bgp-05.txt does not say anithing about how to include PMSI tunnel attribute

From: Subinoy Das <[email-masked]>
Date: Fri, 21 Nov 2008 12:21:55 +0530 (IST)

draft-ietf-l3vpn-2547bis-mcast-bgp-05.txt says 
 
5. PMSI Tunnel attribute
 This document defines and uses a new BGP attribute, called PMulticast
Service Interface Tunnel (PMSI Tunnel) attribute. This is
an optional transitive BGP attribute.
 
Here it is not clear what is Type Code of PMSI Tunnel Attribute. If it is to be included under BGP Path attributes then there should be 1 octate Type Code for PMSI Tunnel Attribute [as ORIGIN(1), AS_PATH(2), MP_REACH_NLRI(14) etc].
 
Regards,
Subinoy

      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

---

From: Thomas Morin <[email-masked]>
Date: Mon, 24 Nov 2008 17:42:50 +0100

Hi,

Subinoy Das :
> Here it is not clear what is Type Code of PMSI Tunnel Attribute. If it
> is to be included under BGP Path attributes then there should be 1
> octate Type Code for PMSI Tunnel Attribute [as ORIGIN(1), AS_PATH(2),
> MP_REACH_NLRI(14) etc].

Such values are attributed by IANA
( http://www.iana.org/assignments/bgp-parameters/ ).

The PMSI Tunnel Attribute has a temporary value of 22.

Similarly, the MVPN SAFI has a temporary value of 5 defined in
http://www.iana.org/assignments/safi-namespace .

-Thomas

---

From: Subinoy Das <[email-masked]>
Date: Tue, 25 Nov 2008 10:00:44 +0530 (IST)

Thanks
- Subinoy

________________________________
From: Thomas Morin <[email-masked]>
To: Subinoy Das <[email-masked]>
Cc: L3VPN <[email-masked]>
Sent: Monday, 24 November, 2008 10:12:50 PM
Subject: Re: draft-ietf-l3vpn-2547bis-mcast-bgp-05.txt does not say anithing abouthow to include PMSI tunnel attribute

Hi,

-Thomas

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 26 Nov 2008 08:01:34 -0500

On Mon, Nov 24, 2008 at 11:42 AM, Thomas Morin <
[email-masked]> wrote:

> http://www.iana.org/as <http://www.iana.org/assignments/safi-namespace>

Note that these are temporary values, and that IANA can and may assign
different ones once the
draft is published.

Regards
Marshall

> signments/safi-namespace <http://www.iana.org/assignments/safi-namespace>.
>
> -Thomas
>
>