Subject: Query about upstrean assigned label from draft-ietf-l3vpn-2547bis-mcast-07.txt

From: Subinoy Das <[email-masked]>
Date: Thu, 20 Nov 2008 15:02:48 +0530 (IST)

Hi,

Section Point 5 in 7.4.1.1. Advertising C-flow Binding to P-Tunnel in draft-ietf-l3vpn-2547bis-mcast-07.txt says 

"If at least some of the S-PMSIs aggregated onto the same
P-tunnel belong to different MVPNs, then all these routes MUST
carry an MPLS upstream assigned label [MPLS-UPSTREAM-LABEL,
section 6.3.4]. If all these aggregated S-PMSIs belong to the
same MVPN, then the routes MAY carry an MPLS upstream assigned
label [MPLS-UPSTREAM-LABEL]. The labels MUST be distinct on a
per MVPN basis, and MAY be distinct on a per route basis."

I do not understand where 1 label per MVPN solves everything then what is the need to use 1 label per route. What is the need to keep multiple label for a single MVPN per PE router?

Regards,
Subinoy

      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

---

From: Subinoy Das <[email-masked]>
Date: Thu, 20 Nov 2008 20:12:29 +0530 (IST)

Each PE have (C-S,C-G) state for each C-flow per MVPN. Then what is the need of different label for different C-flow?

Regards,
Subinoy

________________________________
From: Raveendra Torvi <[email-masked]>
To: Subinoy Das <[email-masked]>
Sent: Thursday, 20 November, 2008 6:50:52 PM
Subject: Re: Query about upstrean assigned label from draft-ietf-l3vpn-2547bis-mcast-07.txt

You need route label to distinguish c-flows of a mvpn.
-R

On Thu, Nov 20, 2008 at 4:32 AM, Subinoy Das <[email-masked]> wrote:

Hi,

Regards,
Subinoy

________________________________
 Add more friends to your messenger and enjoy! Invite them now.

      Get perfect Email ID for your Resume. Grab now http://in.promos.yahoo.com/address

---

From: Eric Rosen <[email-masked]>
Date: Mon, 24 Nov 2008 10:09:35 -0500

Subinoy> Section Point 5 in 7.4.1.1. Advertising C-flow Binding to P-Tunnel
Subinoy> in draft-ietf-l3vpn-2547bis-mcast-07.txt says

Subinoy> I do not understand where 1 label per MVPN solves everything then
Subinoy> what is the need to use 1 label per route. What is the need to keep
Subinoy> multiple label for a single MVPN per PE router?

The text you've  quoted does not require that a label  be assigned for every
route.  

If you're  asking why that's even allowed  as an option, the  reason is that
some implementers may prefer to assign  a different label to each c-flow, so
as to avoid the need to do an <S,G> lookup.

Subinoy> Suppose Customer is running PIM as multicast protocol, Provider
Subinoy> network support l3vpn with BGP, RSVP P2MP.  Then how customer
Subinoy> Register packet destined to C-RP is forwarded through provider
Subinoy> network?

Register packets are unicast packets.

Subinoy> From draft-ietf-l3vpn-2547bis-mcast-07.txt I could not understand
Subinoy> exactly when Source Active A-D route is sent and when send Source
Subinoy> Active A-D route?  Ingress PE or Egress PE?  To whom Source Active
Subinoy> A-D route is sent?

Did you look at section 9.2?  Also section 13 of draft-ietf-l3vpn-2547bis-
mcast-bgp-05.txt.  Could you  say more about which bit  of text is confusing
you?

---

From: Subinoy Das <[email-masked]>
Date: Tue, 25 Nov 2008 10:18:50 +0530 (IST)

In Section 9.2 says 
"Whenever a PE creates an <C-S, C-G> state as a result of receiving a 
C-multicast route for <C-S, C-G> from some other PE, and the C-G
group is an ASM group, the PE that creates the state MUST originate a
Source Active auto-discovery route (see [MVPN-BGP] section 4.5) as
specified below."
I am not sure which PE originates Source Active A-D route? Ingress PE for that Source or any Egress PE?

- Subinoy

________________________________
From: Eric Rosen <[email-masked]>
To: Subinoy Das <[email-masked]>
Cc: [email-masked]
Sent: Monday, 24 November, 2008 8:39:35 PM
Subject: Re: Query about upstrean assigned label from draft-ietf-l3vpn-2547bis-mcast-07.txt

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 25 Nov 2008 06:00:43 -0800

Subinoy,

> PE for that Source or any Egress PE?

The ingress PE for that sources.

Yakov.