Subject: [Editorial Errata Reported] RFC4364 (3647)

From: RFC Errata System <[email-masked]>
Date: Wed, 12 Jun 2013 01:56:58 -0700 (PDT)

The following errata report has been submitted for RFC4364,
"BGP/MPLS IP Virtual Private Networks (VPNs)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4364&eid=3647

--------------------------------------
Type: Editorial
Reported by: Bharat Joshi <[email-masked]>

Section: 3.2

Original Text
-------------
If it is desired to have a particular host be in multiple virtual sites, then that host must determine, for each packet, which virtual site the packet is associated with. 

Corrected Text
--------------
If it is desired to have a particular host to be in multiple virtual sites, then that host must determine, for each packet, which virtual site the packet is associated with.

Notes
-----
'host be' should be 'host to be'

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4364 (draft-ietf-l3vpn-rfc2547bis-03)
--------------------------------------
Title               : BGP/MPLS IP Virtual Private Networks (VPNs)
Publication Date    : February 2006
Author(s)           : E. Rosen, Y. Rekhter
Category            : PROPOSED STANDARD
Source              : Layer 3 Virtual Private Networks INT
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 12 Jun 2013 13:48:01 +0000

This is not necessary. The original is correct grammar.
"be" is being used in the subjunctive form.

A more modern alternative might be "If a particular host is desired to be in multiple virtual sites,", but the original is correct, so why bother?

--
Jakob Heitz.

---

From: Acee Lindem <[email-masked]>
Date: Wed, 12 Jun 2013 14:00:04 +0000

I think one problem with the errata process is that the you have to be an AD in order to validate or reject them. The WG chairs should also have the authority to summarily reject errata - especially the nuisance errata that are being submitted these days. 
Thanks,
Acee

---

From: Ted Lemon <[email-masked]>
Date: Wed, 12 Jun 2013 14:10:32 +0000

> I think one problem with the errata process is that the you have to be an AD in order to validate or reject them. The WG chairs should also have the authority to summarily reject errata - especiall…

That sounds great in theory, but I think it would be difficult to write the code that decided which working group chairs got to modify which errata.   We recently got a typo erratum on RFC 917.

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 12 Jun 2013 15:06:40 +0000

Thanks for your reply.

While reading, I felt that adding a 'to' here make things more clearer.

As you mentioned that the existing one is correct, so its ok.

Regards,
Bharat
________________________________________
From: Jakob Heitz [[email-masked]]
Sent: Wednesday, June 12, 2013 7:18 PM
To: RFC Errata System
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Bharat Joshi; [email-masked]
Subject: Re: [Editorial Errata Reported] RFC4364 (3647)

--
Jakob Heitz.

> "BGP/MPLS IP Virtual Private Networks (VPNs)".

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Brian Haberman <[email-masked]>
Date: Wed, 12 Jun 2013 11:32:14 -0400

Hi Bharat,

> While reading, I felt that adding a 'to' here make things more clearer.

It does make things clearer, but the original wording is correct.

> As you mentioned that the existing one is correct, so its ok.

I believe that holds for all three errata opened on this document. 
Unless someone objects, I will mark all three (3647, 3648, & 3649) as 
"Rejected".

Regards,
Brian

---

From: <[email-masked]>
Date: Wed, 12 Jun 2013 15:38:45 +0000

Hi Brian,

> Unless someone objects, I will mark all three (3647, 3648, & 3649) as

3649 is actually correcting a real typo.

-Thomas

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Joe Touch <[email-masked]>
Date: Wed, 12 Jun 2013 09:56:27 -0700

> It does make things clearer, but the original wording is correct.

FWIW, I disagree.

Original:

If it is desired to have a particular host be in multiple virtual sites, 
then that host must determine, for each packet, which virtual site the 
packet is associated with.

"to have it be X" != "to have it to be X"

The latter could be misinterpreted as:

	to have it become in a state of X

The former means:

	to have it in a state of X

However, the original form is something we should avoid in the future 
(though I doubt it's worth rewriting).

It would have been preferable to say:

	If a host is a member of multiple virtual sites, then
	that host must determine which site corresponds to
	each packet transmitted or received.

Joe

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 12 Jun 2013 17:45:12 +0000

> 	each packet transmitted or received.

The subjunctive is explained well in http://en.wikipedia.org/wiki/Subjunctive_mood

-- 
Jakob Heitz.

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 12 Jun 2013 15:42:55 +0000

Hi Brain,

>Unless someone objects, I will mark all three (3647, 3648, & 3649) as

I think Errata 3647 and 3648 are making things more readable so if you think that the current text is ok then may be you can reject them. Errata 3649 is more of a typo which I think should be fixed.

Regards,
Bharat