Subject: [Editorial Errata Reported] RFC4364 (3648)

From: RFC Errata System <[email-masked]>
Date: Wed, 12 Jun 2013 01:58:07 -0700 (PDT)

The following errata report has been submitted for RFC4364,
"BGP/MPLS IP Virtual Private Networks (VPNs)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4364&eid=3648

--------------------------------------
Type: Editorial
Reported by: Bharat Joshi <[email-masked]>

Section: 4

Original Text
-------------
If two routes to the same IP address prefix are actually routes to different systems, it is important to ensure that BGP not treat them as comparable.

Corrected Text
--------------
If two routes to the same IP address prefix are actually routes to two different systems, it is important to ensure that BGP not treat them as comparable.

Notes
-----
'routes to different system' should be 'routes to two different system'

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4364 (draft-ietf-l3vpn-rfc2547bis-03)
--------------------------------------
Title               : BGP/MPLS IP Virtual Private Networks (VPNs)
Publication Date    : February 2006
Author(s)           : E. Rosen, Y. Rekhter
Category            : PROPOSED STANDARD
Source              : Layer 3 Virtual Private Networks INT
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Joe Touch <[email-masked]>
Date: Wed, 12 Jun 2013 09:58:50 -0700

FWIW, this should be rejected.

The original text is correct and more than sufficient.

Bharat - you might want to check these with others in advance of issuing 
them as errata.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Wed, 12 Jun 2013 17:31:34 +0000

On Jun 12, 2013, at 1:13 PM, Bharat Joshi <[email-masked]> wrote:
>      I think I made a mistake by submitting them as Errata without checking with others. I completely agree that I should have first send out a mail on the mailing list to ask the wider audience about this.

As a general rule, I think (this is my personal opinion, not any kind of official statement) that it's pretty useless to submit errata for typos or spelling errors unless the typo or spelling error changes the meaning of the document in a way that would actually cause the reader to read something other than what the author(s) intended.   Someone has to look at these errata; before spending someone's time, it's worth asking yourself if there is some benefit to doing so.   I think errata can be really useful, and even typos sometimes do change the meaning of documents, but definitely do a little mental cost-benefit analysis before submitting one!

Also, verb tenses are hard. :)

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 12 Jun 2013 17:49:03 +0000

> Also, verb tenses are hard. :)

You wish that they be easy.

-- 
Jakob Heitz.

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 13 Jun 2013 05:08:21 +0000

Ted, and all,
I tend to agree with your statement that errata on typos should be rejected unless the typo changes the meaning of the document.

I remember an erratum filed on RFC where FEC has been erroneously exploded (presumably by the RFC Editor) as "Forward Error Correction" instead of "Forwarding Equivalence Class".

The general feeling has been that an reader with minimal basic background knowledge required for understanding the document would not run to learn about Reed-Solomon codes based on this error.

My 2c,
     Sasha

________________________________________
From: [email-masked] [[email-masked]] on behalf of Ted Lemon [[email-masked]]
Sent: Wednesday, June 12, 2013 7:31 PM
To: Bharat Joshi
Cc: [email-masked]; [email-masked]; Joe Touch; [email-masked]; [email-masked]; [email-masked]; RFC Errata System
Subject: Re: [Editorial Errata Reported] RFC4364 (3648)

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 12 Jun 2013 17:13:14 +0000

Joe,

      I will surely not skip this step in future.

      Thanks for your kind reply.

Regards,
Bharat
________________________________________
From: Joe Touch [[email-masked]]
Sent: Wednesday, June 12, 2013 10:28 PM
To: RFC Errata System
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Bharat Joshi
Subject: Re: [Editorial Errata Reported] RFC4364 (3648)

Joe

> "BGP/MPLS IP Virtual Private Networks (VPNs)".

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***