Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

From: Kireeti Kompella <[email-masked]>
Date: Fri, 2 Aug 2013 19:22:41 +0200

Hi Aldrin,

On Aug 2, 2013, at 15:24, Aldrin Isaac <[email-masked]> wrote:

> Local ID is useful to key into any action or context versus only into context that represents a flat tenant network.  

Great point!  Hadn't thought of it this way ...

> This can be leveraged by an SDN controller or via distributed provisioning.  If standards produce a one trick pony than proprietary complexity will creep in.

I hope folks get this!!!

Cheers,
Kireeti

---

From: Aldrin Isaac <[email-masked]>
Date: Fri, 2 Aug 2013 09:24:37 -0400

Local ID is useful to key into any action or context versus
only into context that represents a flat tenant network.   This can be
leveraged by an SDN controller or via distributed provisioning.  If
standards produce a one trick pony than proprietary complexity will creep
in.

On Friday, July 26, 2013, Lucy yong wrote:

> (change back to the original subject title)
>
> For this context, the global VN ID means that the label is used as the VN
> identifier in the data plane and is allocated per VN basis (maybe by NVA);
> the local (VN) ID means that the label is allocated by individual NVEs and
> only has the significance for the NVE that creates it. Thus, each NVE has
> to distribute the local (VN) ID to all the other NVEs that are the members
> of the same VN, which requires some distributed control plane capability.
> The NVE may create one local ID for a VN or several local IDs associated to
> a VN.
>
> Local ID mechanism provides some flexibility to NVE in egress forwarding
> process. However, if the major application of NVO3 is for the case that NVE
> resides on server, i.e. NVE and end-points resides on a same device, is
> this flexibility necessary? Sometimes "flexibility" also means
> "complexity". When using separated NVE forwarder and NVE controller, and
> having SDN based NVE controller, will local ID distribution make this
> solution more complex than using global VN ID?
>
> NVO3 requires supporting both NVE local and NVE remote. Can one solution
> fit both applications well? or we need more than one solution and let
> providers to choose?
>
> Lucy
>
> > -----Original Message-----
> > From: [email-masked] <javascript:;> [mailto:[email-masked]<javascript:;>]
> On Behalf Of
> > Pat Thaler
> > Sent: Thursday, July 25, 2013 7:59 AM
> > To: Richard Li; Kireeti Kompella; Lucy yong
> > Cc: L3VPN; Yakov Rekhter; [email-masked] <javascript:;>; Aldrin Isaac;
> > [email-masked] <javascript:;>; UTTARO, JAMES
> > Subject: [nvo3] The meaning of "global"
> >
> > "Global" seems to be used in this discussion and the data plane
> > requirements to mean "unique in the administrative domain" as
> > contrasted to a "local" identifier that is mapped to another value at
> > some points in the domain.
> >
> > On the other hand, when discussing VN Name in the hyperviser - NVE
> > control plane, global is used in the sense that I understand global -
> > i.e. unique in the world - e.g. a UUID. 24-bit identifiers aren't large
> > enough to be global in that sense.
> >
> > It would be better to use another term when we mean unique in the
> > administrative domain.
> >
> > Pat
> >
> > -----Original Message-----
> > From: [email-masked] <javascript:;> [mailto:[email-masked]<javascript:;>]
> On Behalf Of
> > Richard Li
> > Sent: Tuesday, July 23, 2013 5:12 PM
> > To: Kireeti Kompella; Lucy yong
> > Cc: L3VPN; Yakov Rekhter; [email-masked] <javascript:;>; Aldrin Isaac;
> > [email-masked] <javascript:;>; UTTARO, JAMES
> > Subject: Re: [nvo3] The possibility of using global MPLS labels as
> > VNIs ... for l3vpn
> >
> > We may be able to get some wisdom from VLAN where both local and global
> > ids are used.
> >
> > The global vlan id is used to build a whole "subnet" across different
> > and multi-hop Ethernet segments.
> >
> >
> >
> > -----Original Message-----
> > From: [email-masked] <javascript:;> [mailto:
> [email-masked] <javascript:;>] On Behalf
> > Of Kireeti Kompella
> > Sent: Wednesday, July 24, 2013 12:46 AM
> > To: Lucy yong
> > Cc: [email-masked] <javascript:;>; L3VPN; Yakov Rekhter;
> [email-masked] <javascript:;>;
> > Aldrin Isaac; UTTARO, JAMES
> > Subject: Re: [nvo3] The possibility of using global MPLS labels as
> > VNIs ... for l3vpn
> >
> > On Jul 23, 2013, at 19:28, Lucy yong <[email-masked]<javascript:;>>
> wrote:
> >
> > > Like to hear more the people opinions about: in SDN approach, will
> > global ID and local ID are equally good (just mater choice) or one is
> > better than other?
> >
> > The SDN (centralized) approach makes allocation of global IDs easier.
> > However, Xiaohu asked a data plane question. Local IDs are much easier
> > for the data plane.
> >
> > BTW, I am not in favor of centralizing everything.
> >
> > Kireeti
> > _______________________________________________
> > nvo3 mailing list
> > [email-masked] <javascript:;>
> > https://www.ietf.org/mailman/listinfo/nvo3
> >
> >
> > _______________________________________________
> > nvo3 mailing list
> > [email-masked] <javascript:;>
> > https://www.ietf.org/mailman/listinfo/nvo3
>