Subject: [Lager] [Editorial Errata Reported] RFC7940 (6102)

From: RFC Errata System <[email-masked]>
Date: Tue, 14 Apr 2020 00:37:52 -0700 (PDT)

The following errata report has been submitted for RFC7940,
"Representing Label Generation Rulesets Using XML".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6102

--------------------------------------
Type: Editorial
Reported by: Michael Bauland <[email-masked]>

Section: 5.4.2.

Original Text
-------------
Any "char", "range", or "variant" element in the "data" section may contain an OPTIONAL "comment" attribute.

Corrected Text
--------------
Any "char", "range", or "var" element in the "data" section may contain an OPTIONAL "comment" attribute.

Notes
-----
The variant element is <var> not <variant>.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7940 (draft-ietf-lager-specification-13)
--------------------------------------
Title               : Representing Label Generation Rulesets Using XML
Publication Date    : August 2016
Author(s)           : K. Davies, A. Freytag
Category            : PROPOSED STANDARD
Source              : Label Generation Rules
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 14 Apr 2020 12:13:54 +0000

> -----Original Message-----
> From: RFC Errata System <[email-masked]>
> Sent: Tuesday, April 14, 2020 3:38 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Hollenbeck, Scott <[email-masked]>;
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [EXTERNAL] [Editorial Errata Reported] RFC7940 (6102)
>
> The following errata report has been submitted for RFC7940, "Representing
> Label Generation Rulesets Using XML".
>
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party can log in to change the status and
> edit the report, if necessary.
>

This should be verified. The RELAX NG Schema in Appendix D describes the name of the element as "var".

Scott