Subject: [Lager] [Editorial Errata Reported] RFC7940 (6105)

From: RFC Errata System <[email-masked]>
Date: Tue, 14 Apr 2020 05:48:02 -0700 (PDT)

The following errata report has been submitted for RFC7940,
"Representing Label Generation Rulesets Using XML".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6105

--------------------------------------
Type: Editorial
Reported by: Michael Bauland <[email-masked]>

Section: 7.2.1.

Original Text
-------------
A label "yy" would have the variants "xy", "yx", and "xx".  Because the variant mapping from "y" to "x" is of type "allocatable" and a mapping from "y" to "y" is not defined, the labels "xy" and "yx" trigger the "any-variant" condition on the third label.

Corrected Text
--------------
A label "yy" would have the variants "xy", "yx", and "xx".  Because the variant mapping from "y" to "x" is of type "allocatable" and a mapping from "y" to "y" is not defined, the labels "xy" and "yx" trigger the "any-variant" condition on the third action.

Notes
-----
The "third label" at the end of the sentence makes no sense in this context, instead it should read that the condition of the "third action" is triggered.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7940 (draft-ietf-lager-specification-13)
--------------------------------------
Title               : Representing Label Generation Rulesets Using XML
Publication Date    : August 2016
Author(s)           : K. Davies, A. Freytag
Category            : PROPOSED STANDARD
Source              : Label Generation Rules
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Asmus Freytag <[email-masked]>
Date: Tue, 14 Apr 2020 12:54:47 -0700

> "Representing Label Generation Rulesets Using XML".

This should be verified.

A./

> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager

---

From: Asmus Freytag <[email-masked]>
Date: Tue, 14 Apr 2020 12:55:22 -0700

This should be verified.

A./