Subject: Teletex Terminal Identifier in draft-ietf-ldapbis-syntaxes-01

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 28 Feb 2002 09:13:23 -0700

This syntax has the encoding:
teletex-id = ttx-term  0*("$" ttx-param)
where ttx-param ends in an octetstring.

Some escapment policy must be noted regarding the occurance of %0x24 in
the octetstring (due to the $ delimiter). It probably would have been
easier if ttx-param was defined as:
ttx-param  = ttx-key ":" ttx-value-len ":" ttx-value

but I think we're beyond going back and changing it.

Jim

---

From: "Steven Legg" <[email-masked]>
Date: Fri, 1 Mar 2002 15:10:00 +1100

Jim,

> but I think we're beyond going back and changing it.

The <octetstring> rule isn't actually defined anywhere so we're
free to define it to be something sensible. I suggest we make
it a hexadecimal string.

Note that the 4th edition of X.500 has deprecated this syntax.
The X.500 working group has even gone to the extent of removing
the teletexTerminalIdentifier attribute from every object class
that used to reference it. An option for us is to throw it out too.

Regards,
Steven