Subject: length of octetstring

From: Kathy Dally <[email-masked]>
Date: Thu, 14 Feb 2002 19:56:51 -0500

Hi All!

In the syntaxes draft (2252bis), a definition is needed for
"octetstring".  My proposal is below.  The question is whether
octetstring can be empty (that is, *OCTET)?

   The definition of OCTET, from [RFC 2234], is:

      OCTET          =  %x00-FF
                        ; 8 bits of data

      octetstring = 1*OCTET

Thanks,
Kathy Dally

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 14 Feb 2002 17:07:35 -0800

>octetstring can be empty (that is, *OCTET)?

Yes.

Kurt

---

From: "Steven Legg" <[email-masked]>
Date: Fri, 15 Feb 2002 12:21:06 +1100

Kathy,

> octetstring can be empty (that is, *OCTET)?

In all the cases where the Octet String syntax is used in RFC 2256,
the corresponding X.500 definition allows zero-length OCTET STRINGs,
so *OCTET is appropriate.

Regards,
Steven