Subject: RE: ;binary and userCertificate (Was: Private email ...)

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 21 Feb 2002 13:58:30 +1100

Kurt,

Once certificates are removed for the base spec, these arguments are moot.

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Thursday, 21 February 2002 13:36
To: Christopher Oliva
Cc: Christopher Oliva; Ramsay, Ron; David Chadwick; Mark C Smith;
Christopher Oliva; Sharon Boeyen; LDAP BIS
Subject: RE: ;binary and userCertificate (Was: Private email ...)

Let me boil this down...

The specification says certificates are to be requested and
transferred using ;binary.  There are multiple independently
developed interoperable implementations of this specification.

You state that the specification should be changed because
some other implementors have produced implementations which
don't interoperate with the above implementations.

If these other implementors' interpretation of the specification
was reasonable, that is, a result of ambiguity in the
specification, then it could be argued that specification
should be clarified to one of the two (or more) reasonable
interpretations.

If on the other hand, these implementors simply did not
adhere to the specification, they are broken.  They should
be fixed.

It's my belief that this is a case of the latter.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 20 Feb 2002 21:09:18 -0800

>Once certificates are removed for the base spec, these arguments are moot.

Yes, but they are not moot for an I-D replacing portions of
an Proposed Standard.

Kurt