Subject: Re: [Models] including root DSE in subtree search

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 22 Sep 2004 17:23:23 -0600

Talk about semantics!

You say a control specification can "impact" the semantics of an
operation, but they cannot "alter" those semantics (if I read that
right). If it turned out (for example) that we did decide that
ManageDsaIT should cause the rootDSE to be returned in a subtree search,
would this be an impact or alteration?

Or are you instead saying that there's no need to update the base spec
because the control spec in effect defines a sort of 'new' form of the
operation, which may or may not follow some or all of the semantics of
the base operation? Hopefully this is what you're saying.

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 9/22/04 4:55:25 PM >>>
At 03:21 PM 9/22/2004, Jim Sermersheim wrote:
>[Models} says: "The root DSE SHALL NOT be included if the client
>performs a subtree search starting from the root."
>
>I know ldapbis sort of puts blinders on in terms of the distributed
>directory data model and the use of the ManageDsaIT control, but I
>believe when the ManageDsaIT control is used, the root *is*
considered
>when performing a subtree search from the root.

I disagree, but that's a discussion I think
we should leave for a future rfc3298bis effort
(or take to ldapext).

>Do we want to relax the 'SHALL NOT' or just know that the definition
of
>ManageDsaIT will update this document?

Neither.

The specification of any control should state how
the semantics of base semantics of the requested
operation are impacted by attachment of the control
to the request.  As such statements do not alter the
semantics of the base operation itself, there
is no need for the control specification to
'update' the base specification.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 22 Sep 2004 17:20:19 -0700

To clarify,

A message which has been adorned with a control
as a different semantic than a message which has
not been adorned by a control.  The adorned
message can be said to be extended by the control.

The control's technical specification does not
alter the semantics of an unadorned message, it
specifies the semantics of a messages adorned by
the control (which are generally based upon the
semantics that apply to an unadorned message).

Nothing in any control's technical specification
should be viewed as 'updating' the technical
specification of the unadorned message.

(Nor should any control technical specification
attempt to 'update' the technical specification of an
unadorned message, to do so would make the
control specification truly non-optional.  I
discuss this in my (expired?) extension guide I-D.)

Kurt