Subject: Re: [Syntaxes] += RFC 3698?

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 27 Sep 2004 08:26:04 -0600

People are puzzled as to why the RFC 3698 rules are missing from
[Syntaxes] (I saw this happen just last week). I vote (unless there are
problems with doing so) to add them.

Jim

>>> Hallvard B Furuseth <[email-masked]> 9/27/04 2:24:54 AM
>>>
Will the matching rules from RFC 3698 be included in [Syntaxes]?
It was discussed in thread 'Protocol: Rolling in recent updates'
in December; Kurt had a list of suggested 'SHOULD/MAY implement'.

-- 
Hallvard

---

From: Steven Legg <[email-masked]>
Date: Tue, 28 Sep 2004 13:31:59 +1000

I don't have a strong opinion either way. It should be noted that the
storedPrefixMatch is not defined in X.520:1993 so it can't be rolled
into [Syntaxes]. If the Chairs want to declare that there is consensus
on including all the rules from RFC 3698, except for storedPrefixMatch,
then I'll take care of it.

Regards,
Steven

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 27 Sep 2004 21:32:46 -0700

>then I'll take care of it.

Are there any objections to adding these rules?

Any objection to adding octetStringSubstringsMatch as well?

I couldn't include it in RFC 3698 due to how substrings
assertions were defined in RFC 2251/2252.  Now that we've
fixed substrings assertions, octetStringSubstringsMatch
can now properly be specified for use in LDAP.  Given that
LDAP matching rule specification does little more than
incorporate the X.500 rule, I don't have a problem with
including it (even though it is not presently specified
in a standard track RFC).

-- Kurt

---

From: Steven Legg <[email-masked]>
Date: Tue, 28 Sep 2004 14:54:40 +1000

Kurt,

> Any objection to adding octetStringSubstringsMatch as well?

I don't object, but there is the problem that there isn't a syntax OID
or LDAP-specific encoding for the assertion syntax of the matching rule,
i.e. OctetSubstringAssertion.

Regards,
Steven