Subject: [Models] including root DSE in subtree search

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 22 Sep 2004 16:21:40 -0600

[Models} says: "The root DSE SHALL NOT be included if the client
performs a subtree search starting from the root."

I know ldapbis sort of puts blinders on in terms of the distributed
directory data model and the use of the ManageDsaIT control, but I
believe when the ManageDsaIT control is used, the root *is* considered
when performing a subtree search from the root.

Do we want to relax the 'SHALL NOT' or just know that the definition of
ManageDsaIT will update this document?

Jim

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 22 Sep 2004 15:55:25 -0700

>when performing a subtree search from the root.

I disagree, but that's a discussion I think
we should leave for a future rfc3298bis effort
(or take to ldapext).

>ManageDsaIT will update this document?

Neither.

The specification of any control should state how
the semantics of base semantics of the requested
operation are impacted by attachment of the control
to the request.  As such statements do not alter the
semantics of the base operation itself, there
is no need for the control specification to
'update' the base specification.

Kurt