Subject: Authmeth

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 21 Sep 2004 06:51:01 -0700

Please review the latest revision of ldapbis-authmeth I-D.
Thanks, Kurt

---

From: Andrew Sciberras <[email-masked]>
Date: Tue, 28 Sep 2004 12:53:46 +1000

Hi,

Just one comment from me; I find this confusing:

> 8. Simple Authentication Mechanism of Simple Bind 
<SNIP>
>    If the DN is not valid, or the password is not valid for the DN, or
>    the server otherwise considers the credentials to be invalid, the
>    server is to return the invalidCredentials result code. 

The wording 'If the DN is not valid' automatically makes me think about 
an invalid DN (syntactically) - in which case I would return 
invalidDNSyntax.
I'm guessing that by not valid you mean that the directory can't map the 
DN to an entry. Is this the case?

I think a change in wording to make this sentence more precise would be 
helpful.

Thanks,
_________________________________________
Andrew Sciberras
eB2Bcom - Software Engineer

EMail:	[email-masked]
Web	http://www.eb2bcom.com