Subject: Re: Second last WG call on the Java API

From: "Steve Sonntag" <[email-masked]>
Date: Wed, 09 May 2001 15:58:21 -0600

Rob,

The following statement was added in version 14

3.4 Level of compatibility 
   Implementations of the API are to be binary compatible. Any 
   implementation MUST behave as defined above with any application 
   written to the API specification. 

The sample programs were changed to import the package:

import org.ietf.ldap.*;

Binary compatibility implies that all implementations use the
same Java package structure.  Is this included in your definition
of binary compatibility?

Is it a MUST that implementations use the package org.ietf.ldap?

-Steve

------------------------
Steve Sonntag
Novell, Inc., the leading provider of Net services software

---

From: Rob Weltman <[email-masked]>
Date: Wed, 09 May 2001 15:39:09 -0700

> Is it a MUST that implementations use the package org.ietf.ldap?

  I think that does follow from the binary compatibility requirement.

Rob