Subject: Subentries decision - internet draft withdrawn

From: "Ed Reed" <[email-masked]>
Date: Mon, 13 Aug 2001 08:04:38 -0600

Hello, all -

At the IETF in London the working group chairs of the LDUP and (late) LDUPEXT working groups considered the issues raised surrounding the LDAP Subentries draft I've been working on.  Their decision, as related to me, was to ask that the LDUP information model be revised so that object classes defined there for ReplicaSubentry and ReplicaAgreementSubentry no longer are treated as subentries, and that the work on the LDAP Subentries as a standards track document be ended.

So, the draft is hereby withdrawn from work group consideration.

The basis of the decision was that since the Access Control editors have decided not to use LDAP Subentries in their document, and since they were the only other charter-item document in the works that might have referenced the document, there appears to be insufficient interest in generalizing a variant from the X.500 version  of Subentries to be worth continuing in the working group.  There is a strongly felt (and forcefully expressed) feeling among several folks in the working group that there is no reason to "dummy down" the X.500 Subentry specification.  So we won't.

Thank you all for your patience in this matter...

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065
http://www.Reed-Matthews.COM

---

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 13 Aug 2001 10:42:25 -0600

Hmm, I wonder how many other drafts refer to it. I know the password policy draft does.

I forsee a whole bunch of 'special' auxilliary objectclasses being defined that carry subtree policy semantics.

>>> "Ed Reed" <[email-masked]> 08/13/01 08:04AM >>>

Hello, all -

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065

---

From: "Timothy Hahn" <[email-masked]>
Date: Mon, 13 Aug 2001 13:17:09 -0400

Jim,

I know that the current individual submission:

draft-hahn-schemapart-00.txt: 
http://search.ietf.org/internet-drafts/draft-hahn-schemapart-00.txt

in section 7.3, refers to/uses the ldapSubEntry object class as a base to 
defining a ldapSubSchemaSubEntry object class.  I will have to re-align 
this in one of two ways:
a) to inherit from a subentry object class for which an LDAP definition 
that is derived from the X.500 subentry object class (assuming that 
someone writes up something describing how the X.500 subentry object class 
is used/exhibited in a LDAP environment).
or
b) to inherit from 'top' and define the subschema entry (subschema is an 
AUXILIARY object class) as something that is a "special case" of entries 
NOT returned on searches.

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681

"Jim Sermersheim" <[email-masked]>
08/13/2001 12:42 PM

        To:     <[email-masked]>, <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        Re: Subentries decision - internet draft withdrawn

Hmm, I wonder how many other drafts refer to it. I know the password 
policy draft does.

I forsee a whole bunch of 'special' auxilliary objectclasses being defined 
that carry subtree policy semantics.

Hello, all -

At the IETF in London the working group chairs of the LDUP and (late) 
LDUPEXT working groups considered the issues raised surrounding the LDAP 
Subentries draft I've been working on.  Their decision, as related to me, 
was to ask that the LDUP information model be revised so that object 
classes defined there for ReplicaSubentry and ReplicaAgreementSubentry no 
longer are treated as subentries, and that the work on the LDAP Subentries 
as a standards track document be ended.

The basis of the decision was that since the Access Control editors have 
decided not to use LDAP Subentries in their document, and since they were 
the only other charter-item document in the works that might have 
referenced the document, there appears to be insufficient interest in 
generalizing a variant from the X.500 version  of Subentries to be worth 
continuing in the working group.  There is a strongly felt (and forcefully 
expressed) feeling among several folks in the working group that there is 
no reason to "dummy down" the X.500 Subentry specification.  So we won't.

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065

---

From: Christopher Apple <[email-masked]>
Date: Mon, 13 Aug 2001 13:24:26 -0400

Comments below....

Chris Apple
Program Manager - Directory Services
United Messaging Inc.
<http://www.unitedmessaging.com>
<mailto:[email-masked]> 
(V) 610-425-2860

   >-----Original Message-----
   >From: Jim Sermersheim [mailto:[email-masked]]
   >Sent: Monday, August 13, 2001 12:42 PM
   >To: [email-masked]; [email-masked]; [email-masked]

Here's the list I've found, please post any missing I-D URLs to
the list if you know of them:

http://search.ietf.org/internet-drafts/draft-reed-ldup-inheritance-00.tx
t (indirectly) 

http://search.ietf.org/internet-drafts/draft-ietf-ldup-infomod-03.txt

http://search.ietf.org/internet-drafts/draft-behera-ldap-password-policy
-04.txt

http://www.ietf.org/internet-drafts/draft-ietf-ldapext-acl-model-08.txt

   >
   >I forsee a whole bunch of 'special' auxilliary 
   >objectclasses being defined that carry subtree policy semantics.

That's the idea...

Chris.

   >At the IETF in London the working group chairs of the LDUP 
   >and (late) LDUPEXT working groups considered the issues 
   >raised surrounding the LDAP Subentries draft I've been 
   >working on.  Their decision, as related to me, was to ask 
   >that the LDUP information model be revised so that object 
   >classes defined there for ReplicaSubentry and 
   >ReplicaAgreementSubentry no longer are treated as 
   >subentries, and that the work on the LDAP Subentries as a 
   >standards track document be ended.
   >
   >The basis of the decision was that since the Access Control 
   >editors have decided not to use LDAP Subentries in their 
   >document, and since they were the only other charter-item 
   >document in the works that might have referenced the 
   >document, there appears to be insufficient interest in 
   >generalizing a variant from the X.500 version  of 
   >Subentries to be worth continuing in the working group.  
   >There is a strongly felt (and forcefully expressed) feeling 
   >among several folks in the working group that there is no 
   >reason to "dummy down" the X.500 Subentry specification.  
   >So we won't.
   >