Subject: [ldapext] Clarification of draft-behera-ldap-password-policy-07.txt

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 Feb 2004 11:48:59 +1100

Hi Ludovic,

I am seeking clarification regarding when the password-policy control response is returned. The -06 draft Section 5.1 says it is returned "when appropriate" and Section 5.2 says it is returned with "the following operation responses...."

Is it expected that the response control is
a. always returned if the request control was present
b. only returned if a status needs to be signalled
c. returned if the operation is one of bind, modify, add, compare, or
d. only returned if the operation is one of bind, modify, add, compare and a status needs to be signalled?

When can we expect draft -07 to be published>

Thanks,

Ron

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Ludovic Poitou <[email-masked]>
Date: Fri, 20 Feb 2004 12:03:13 +0100

-07 has been published.
-08 intends to be published in April or May.

As for the clarification, my quick answer would be: always return when 
the request control is present. But I need to put some more thoughts on 
this.

Regards,

Ludovic.

-- 
Ludovic Poitou
Directory Architect.
Directory Server Group, Grenoble, France
Sun Microsystems Inc.

Sun Microsystems requires the following notice:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NOTICE:  This email message is for the sole use of the intended
recipient(s) and may contain confidential and privileged
information.  Any unauthorized review, use, disclosure or
distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy
all copies of the original message.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~