Subject: RE: [ldapext] draft-pauzies-ldap-schema-nonascii-mr-00.txt

From: "Ramsay, Ron" <[email-masked]>
Date: Mon, 17 May 2004 19:43:19 +1000

Why isn't this covered by the old matching rules? The X.500 standard caseIgnoreMatch applies to UTF-8 and matches case (though they may not have defined the meaning of space?).

Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Alexandre PAUZIES
Sent: Friday, 14 May 2004 19:48
To: [email-masked]
Subject: [ldapext] draft-pauzies-ldap-schema-nonascii-mr-00.txt

Hi,

I made a draft to propose new LDAP matching rules :
http://www.ietf.org/internet-drafts/draft-pauzies-ldap-schema-nonascii-mr-00.txt
and I hope you could send me comments on this.

I also made patchs to add thoses matching rules implementation in OpenLDAP.

Alexandre

-- 
Alexandre Pauziès <[email-masked]>
LINAGORA - Société de services en Logiciels Libres
http://www.linagora.com/ - Tél: 01.58.18.68.28

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Steven Legg <[email-masked]>
Date: Tue, 18 May 2004 15:18:33 +1000

Ramsay, Ron wrote:
> Why isn't this covered by the old matching rules? The X.500 standard
 > caseIgnoreMatch applies to UTF-8 and matches case (though they may not
 > have defined the meaning of space?).

These matching rules strip out diacriticals before performing the case
ignore match, which is something the existing case ignore matching rules
don't do.

The names of these matching rules are clearly causing confusion. A better
name for caseIgnoreNonasciiMatch, for example, would be something like
caseIgnoreCanonicalLatinMatch or caseIgnoreBasicLatinMatch.

Regards,
Steven