Subject: Re: LDAPsubentry

From: Helmut Volpers <[email-masked]>
Date: Fri, 19 Nov 1999 13:44:31 +0100

Ed Reed wrote:
> 
> Hmmm...I made it structural, because that's how the X.500 subentry
> is defined...I can see doing it either way.
> 
> Any reaction from the X.500 community?  Does it matter to you,
> one way or the other?  To be clear, the draft specifies ldapSubEntry
> to be STRUCTURAL, and Kurt's proposal is to make it ABSTRACT,
> instead.

The reason why it should be structural is because ObjectClasses
like subSchema, collectiveAttributeSubentry or AccessControlSubentry
are auxiliary and every entry should have a structural ObjectClass,
that means if the Subentry ObjectClass is abstract I need another
structural ObjClass for the subentries.
I also didn't understand the real reason why it should be abstract ?

Helmut

> 
> Ed
> 
> =================
> Ed Reed
> Reed-Matthews, Inc.
> +1 801 785 0315
> http://www.OnCallDBA.COM
> 
> >>> "Kurt D. Zeilenga" <[email-masked]> 11/18/99 10:42AM >>>
> Forwarded to owning WG...
> 
> >To: [email-masked]
> >From: "Kurt D. Zeilenga" <[email-masked]>
> >Cc: [email-masked]
> >
> >I would like to see LDAP subentry be an abstract object class
> >to which is then subclassed as necessary to provide structure
> >(including naming attributes).
> >
> >As defined, LDAP subentry requires cn.  This may not be appropriate
> >for LDAP subentries.   I suggest:
> >
> >( ldapSubEntryOID NAME 'ldapSubEntry'
> >   DESC 'LDAP Subentry abstract class, version 1'
> >     SUP top ABSTRACT )
> >
> >( cnSubEntryOID NAME 'cnSubEntry'
> >   DESC 'CN LDAP Subentry class, version 1'
> >     SUP ldapSubEntry STRUCTURAL
> >     MUST ( cn ) )
> >
> >Your schema definition would then be split as appropriate between
> >the abstract class and the structural class.
> >
> >Regards, Kurt
> >
> >
> >
> 
>   ------------------------------------------------------------------------
> 
>    TEXT.htmName: TEXT.htm
>            Type: Plain Text (text/plain)

---

From: Erik Skovgaard <[email-masked]>
Date: Fri, 19 Nov 1999 10:11:25 -0800

Ed,

STRUCTURAL sounds good to me.  In fact, it has to be. An ABSTRACT Object
Class cannot be instantiated.  It is merely used to create other Object
Classes through inheritance.

Cheers,                  ....Erik.
--------------------------------------
Erik Skovgaard
GeoTrain/Global Knowledge Network
Enterprise Directory Engineering
http://www.geotrain.com
Telephone: +1 604 244-9131

At 21:13 99/11/18 -0700, Ed Reed wrote:
>Attachment Converted: "d:\Program Files\Eudora\Attach\TEXT2.htm"
>