Subject: [ledbat] Review - draft-shalunov-ledbat-congestion-00.txt

From: Murari Sridharan <[email-masked]>
Date: Mon, 23 Mar 2009 08:23:52 -0700

I like the simplicity, this also conforms to the general intuition I had of adapting a delay based CC algorithm and making it a ledbat one; which is to cap the delay and if you are worried about reverse path congestion, use one way delay, when things go crazy fall back to TCP level aggressiveness. It did make it easy to review, I do have several questions/comments.

1.       The controller is simple and I can see how it will work well in a stable environment, however if I have a wireless hop on the path and there is delay variance what kind of oscillations do we get?

2.       OWD is typically error prone and I am pretty sure that since you got it implemented you have a very good sense of how to remove clock skew. I am a bit worried that if somebody does a Greenfield implementation based on this draft they may struggle with one way measurement and the devil may be in the implementation details. May be we can provide more guidance here?

3.       TCP responds to RTT but ledbat uses OWD. Are we assuming that if TCP is congested on the reverse path and cannot grow the residual bw is up for grabs? This is fine, I just wanted to clarify since we are trying to be as aggressive as TCP and there may be cases where we may get more and those are by design.

4.       I think the pseudocode should be modified to talk in terms of bytes (ABC) as opposed to acknowledgement to make things more explicit. If nothing else if the receiver is acking faster than TCP then the cwnd may grow faster which may end up violating the claim in Sec 4.7.

5.       It would be good to state the value for GAIN in the draft since you are already fixing TARGET to 25ms.

6.       Initialization values should be specified for all relevant variables

7.       If there is some notion of timeout at the app level or even at the protocol level then it would be good to dump base delay during those points. This would be inline with other delay based algorithms and when they dump the base delay. We can add it as a recommendation in 4.12 if it is possible to detect a timeout of some sorts

8.       Off_target can be negative and that's the one way cwnd reduces right (other than packet loss)?

9.       Sec 4.2 talks about the fact that when delay is zero queue is empty and no data is transmitted. This is not the case and in fact you do say that it simply means link is not saturated. I think the "no data is transmitted" part should be reworded.

Based on what I read I have the following concerns and it would be good to get the draft to talk about some of these. We'll also see what others in the WG think.

-          I have is the effect of multiple ledbat flows flowing through a bottleneck. If each of them tries to maintain a 25ms delay this can add up.

-          I think we should also talk about intraflow fairness

-          It would be good to understand how this behaves in difficult/range of environments as specified by guidelines 2 & 3 in http://www.ietf.org/rfc/rfc5033.txt

-

Thanks
Murari

---

From: Murari Sridharan <[email-masked]>
Date: Mon, 23 Mar 2009 15:59:54 -0700

One more question in addition to below which is "what really is worst case for ledbat". Somebody raised this today at the meeting as well. One is the safety net of not hurting TCP, second is some guarantee on throughput, some form of acceptable performance. Should we define some metrics around it to evaluate different ledbat proposals?

Based on Stas' response to below we'll continue further discussion.

Thanks

From: Murari Sridharan
Sent: Monday, March 23, 2009 8:24 AM
To: [email-masked]
Cc: Murari Sridharan
Subject: Review - draft-shalunov-ledbat-congestion-00.txt

-

Thanks
Murari

---

From: Murari Sridharan <[email-masked]>
Date: Fri, 27 Mar 2009 14:44:52 -0700

+Jitu who is now on the ledbat mailing list and helped review the initial draft.

Thanks

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murari Sridharan
Sent: Monday, March 23, 2009 4:00 PM
To: [email-masked]
Subject: Re: [ledbat] Review - draft-shalunov-ledbat-congestion-00.txt

Thanks

From: Murari Sridharan

-

Thanks
Murari