Subject: Re: [ledbat] open issues, applicability statement

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 8 Jul 2010 18:02:43 +0200

Hi,

> 3. Applicability
> I myself had a few comments on clarifications in the document during the
> last meeting. There maybe are a few applicability statements we could add
> to the draft. E.g. today there are still a lot of rural areas served by DSL
> with really low uplink capacities. LEDBAT will not be able to achieve the
> delay target here if full-sized segments are sent. A single segment will
> violate the 25 ms. This could be added, with a comment that adaptive
> segment sizing is not in scope of the document but is not precluded by the
> document either. Another hint could be given to home gateway manufactures
> which like to classify P2P traffic into low priority class queues. Which is
> fine when they run over TCP, but LEDBAT deals with the "problem" already so
> there is no need to put it into a different queue. In fact we did some
> measurements that show that in certain circumstances LEDBAT will not fulfil
> its design goals in such a low priority queue anymore. But that is home
> gateway implementation-specific. There were arguments against this. Please
> discuss.
I think those points are important to be documented somewhere. That might go 
in-line with having a description of the scenarios ledbat is supposed to be 
used in.

What actually happens in the case with low priority queues: Will ledbat get a 
static share of the bandwidth?

Mirja

---

From: "Rolf Winter" <[email-masked]>
Date: Fri, 9 Jul 2010 11:19:47 +0200

Hi,

> static share of the bandwidth?

That seems to depend on the queuing discipline implemented. Have a look at the bottom plot of the figure that I have sent around earlier to see one possible behavior of a quite recent home gateway that does some interesting traffic shaping. Actually, running standard TCP through this home gateway and a TCP background flow achieves what LEDBAT achieves, just slightly more efficient. 

Best,

	Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mirja Kuehlewind
> Sent: Donnerstag, 8. Juli 2010 18:03
> To: [email-masked]
> Subject: Re: [ledbat] open issues, applicability statement
> 
> Hi,
> 
> > 3. Applicability
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat