Subject: RE: [lemonade] Recommended timeouts for BDAT/BURL?

From: "Burger, Eric" <[email-masked]>
Date: Mon, 10 Jul 2006 10:24:03 -0400

Having written draft-burger-smtp-rdlv-00 back in August 2004, I think
it's about time to get this done :-)

Alexey - you're now writing more than me :-))

Randy, want the XML source?

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: Sunday, July 09, 2006 12:11 PM
To: Alexey Melnikov
Cc: Lemonade WG
Subject: Re: [lemonade] Recommended timeouts for BDAT/BURL?

At 4:22 PM +0100 7/9/06, Alexey Melnikov wrote:

>  Randall Gellens wrote:
>
>>  At 9:18 PM +0100 7/6/06, Alexey Melnikov wrote:
>>
>>>   So I guess the timeout for BDAT/BURL "LAST"  should be 10 
>>> minutes as well. What about non-last BDAT/BURL?
>>
>>  We had some discussion of this a while back (maybe a year or 
>> two?). As I recall, there seemed to be some agreement that the 
>> current SMTP timeouts were too large for mobile clients and could 
>> be reduced for lemonade.
>
>  Ok. Is this something we want to cover in Lemonade Profile bis?

I think we need to, yes.

>>  Also, there was some discussion of adding intermediate "command in 
>> progress" responses to let the client know that the server hadn't 
>> vanished.
>
>  You reminded me that I actually volunteered to co-edit it :-).

I'm happy to help with that.

We should probably try and get rough consensus in the group that it 
is something we still want to do.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Lottery: A tax on people who are bad at math.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Tony Finch <[email-masked]>
Date: Mon, 10 Jul 2006 17:00:55 +0100

> it's about time to get this done :-)

I don't think RDLV is robust against connection lossage: it only reduces
the window. It isn't compatible with pipelining.

I intend to produce a revised version of REPLAY which is more compatible
with RFC 1845 and has less irrelevant verbiage. It should provide similar
functionality to RDLV+DETA, plus it avoids the race between sending data
and getting the first response from the server.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
FAIR ISLE: SOUTH VEERING WEST 5 TO 7. OCCASIONAL RAIN. MODERATE OR GOOD
OCCASIONALLY POOR.