Subject: [lemonade] I-D ACTION:draft-ietf-lemonade-compress-02.txt

From: [email-masked]
Date: Mon, 17 Jul 2006 15:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Enhancements to Internet email to support diverse service environments Working Group of the IETF.

	Title		: The IMAP COMPRESS=DEFLATE Extension
	Author(s)	: A. Gulbrandsen
	Filename	: draft-ietf-lemonade-compress-02.txt
	Pages		: 8
	Date		: 2006-7-17
	
The COMPRESS=DEFLATE extension allows an IMAP connection to be
    compressed using the DEFLATE algorithm, such that effective
    compression is available even when TLS is used.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-lemonade-compress-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-lemonade-compress-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-lemonade-compress-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: <[email-masked]>
Date: Wed, 26 Jul 2006 13:57:11 +0300

Hi all,
Here are my comments on this draft:
Section 2:
"but a careful IMAP implementation can do much better"  What makes and IMAP implementation 'careful'? I know what You mean, but I think we should find a better word here.
"Hopefully it will not be necessary to define additional algorithms." Suggest removal.

Section 3:
"The client MUST NOT send any commands until it has seen the result of COMPRESS." This is fine, but can the server send anything else in the meantime? I mean I can turn it on at any time during the session.

Section 3 and section 5:
How can it be turned off?

Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]] 
Sent: 17 July, 2006 22:50
To: [email-masked]
Cc: [email-masked]
Subject: [lemonade] I-D ACTION:draft-ietf-lemonade-compress-02.txt 

	

To remove yourself from the I-D Announcement list, send a message to [email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username "anonymous" and a password of your e-mail address. After logging in, type "cd internet-drafts" and then
	"get draft-ietf-lemonade-compress-02.txt".

A list of Internet-Drafts directories can be found in http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Send a message to:
	[email-masked].
In the body type:

---

From: Randall Gellens <[email-masked]>
Date: Fri, 28 Jul 2006 15:27:37 -0700

(1) I think the Introduction should discuss the trade-offs in having 
an IMAP command for compression versus using TLS; specifically, using 
TLS has a major advantage in that all applications immediately 
benefit with no changes (for us, that's at least IMAP and message 
submission).  However, TLS compression is not yet widely supported 
(this was mentioned in -00 but dropped in -01).  Separately, as Dave 
points out, the compressing side has more control over the level of 
compression applied to a specific block of data, because of the APIs 
commonly used.

(2) In the discussion in Section 3 on ordering of compression and 
encryption, should there be advice on ordering with regard to 
authentication?  There was some discussion of this point at the 
Montreal meeting, and at a previous meeting (perhaps the interim?).

(3) The text in Section 4 says "clients which send many APPEND 
commands may want to take special care of literals, in the same way 
that servers do."  I think more specific advice would be helpful. 
What should a client do?  (Sending many APPENDs is, I think, fairly 
common for IMAP clients. )  Perhaps the text should say "in the same 
way that servers do, by sending Z_FULL_FLUSH as discussed later in 
this section".

(4) Typo in Section 4: "resembling a 6-bit bytes" -- "bytes" should 
be singular.

(5) Typo in Section 4: "change the level 0" should be "change the level to 0".
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
I hope we shall...crush in its birth the aristocracy of our moneyed
corporations, which dare already to challenge our government to a
trial of strength, and bid defiance to the laws of our country.
         --Thomas Jefferson, letter to George Logan. November 12, 1816

---

From: Randall Gellens <[email-masked]>
Date: Fri, 28 Jul 2006 16:01:54 -0700

At 1:57 PM +0300 7/26/06, <[email-masked]> wrote:

>  "but a careful IMAP implementation can do much better"  What makes 
> and IMAP implementation 'careful'? I know what You mean, but I 
> think we should find a better word here.

This is Dave's point about APIs.  I've suggested some improvements to 
the section.

> algorithms." Suggest removal.

I sent suggested text on the issue.

>  Section 3:
>  "The client MUST NOT send any commands until it has seen the result 
> of COMPRESS." This is fine, but can the server send anything else 
> in the meantime? I mean I can turn it on at any time during the 
> session.

The server can't send anything else (such as an unsolicited response) 
in the meantime .  This seems obvious but could be explicitly stated.

>  How can it be turned off?

By logging out and back in.  The added complexity of allowing it to 
be turned off doesn't seem to be justified by the low utility.

-------------- Randomly-selected tag: ---------------
There will be no lasting peace on our earth as long as politicians and
dictators continue to lead masses of people who are endemically
neurotic and sexually sick.                            --Wilhelm Reich

---

From: <[email-masked]>
Date: Mon, 31 Jul 2006 11:14:29 +0300

Hi Randall,
Thank You for Your asnwers.
I added questions/comments to the last two issues tagged with [ZÖr].
Thank you.

-----Original Message-----
From: ext Randall Gellens [mailto:[email-masked]] 
Sent: 29 July, 2006 02:02
To: [email-masked]
Subject: Re: [lemonade] WGLC compress-02

At 1:57 PM +0300 7/26/06, <[email-masked]> wrote:

> and IMAP implementation 'careful'? I know what You mean, but I think 
> we should find a better word here.

This is Dave's point about APIs.  I've suggested some improvements to the section.

> of COMPRESS." This is fine, but can the server send anything else in 
> the meantime? I mean I can turn it on at any time during the session.

The server can't send anything else (such as an unsolicited response) in the meantime .  This seems obvious but could be explicitly stated.
[ZÖr] This is true only if You issue the command during login I guess - if You issue it during some other time during the session, You might get other responses as well.
>From Your response below to my question below it seems that this command can be used only once - but the draft does not say that it is the login phase during which it has to be used when compression is desired.
Thank you.

>  How can it be turned off?

By logging out and back in.  The added complexity of allowing it to be turned off doesn't seem to be justified by the low utility.
[ZÖr] Question: if I do a quick reconnect, will the compression state be restored? (in which case disconnect will not help me much).
Another thing is that when I store an email that contains an uncompressable (JPG, ZIP) file, I might want to switch compression off before uploading it, and turn it back on afterwards. I am sure that this has been discussed, but I do not seem to be able to find the related emails - so I ask it again to get the right answers.
Thank you.

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: --------------- There will be no lasting peace on our earth as long as politicians and dictators continue to lead masses of people who are endemically
neurotic and sexually sick.                            --Wilhelm Reich