Subject: [lemonade] Compress result code

From: "Burger, Eric" <[email-masked]>
Date: Tue, 11 Jul 2006 13:50:22 -0400

Why "NO" if the connection is already compressed?  Wouldn't "OK" be ok?
Otherwise, if the connection is already compressed, and I see a "NO", I
might think that the connection is now no longer compressed.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 11 Jul 2006 23:43:31 +0100

>might think that the connection is now no longer compressed.
The client must know if application level compression is already running 
or not. The client must not attempt to do something which is guaranteed 
to fail.
The server should actually return BAD in this case, IMHO.

---

From: Dave Cridland <[email-masked]>
Date: Wed, 12 Jul 2006 00:06:47 +0100

> might think that the connection is now no longer compressed.

In my code, a successful result to a COMPRESS command inserts a new 
compression layer.

NO is fine.

BAD is arguably better, except that there are times when you don't 
know if the TLS layer has already done compression for you, as a 
client, so it's a good faith error - a NO - rather than a bug - a BAD.

I'd be happy with a second COMPRESS command causing a BAD, though.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Randall Gellens <[email-masked]>
Date: Tue, 11 Jul 2006 16:10:18 -0700

At 11:43 PM +0100 7/11/06, Alexey Melnikov wrote:

>  The client must know if application level compression is already 
> running or not. The client must not attempt to do something which 
> is guaranteed to fail.

This seems to be an order of command (state) error.  RFC 3501 says:

    It is a protocol error for the
    client to attempt a command while the connection is in an
    inappropriate state, and the server will respond with a BAD or
    NO (depending upon server implementation) command completion
    result.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
How does a project get to be a year behind schedule?
One day at a time.   --Fred Brooks in _The Mythical Man Month_