Subject: RE: [lemonade] Profile Bis -03

From: Randall Gellens <[email-masked]>
Date: Fri, 7 Jul 2006 17:10:36 -0700

At 1:35 PM +0300 6/27/06, <[email-masked]> wrote:

>  3.4.1 "This command can be omitted, being for metadata only." 
> Suggest wording change to: "This command is only metadata, thus it 
> can be omitted."
>  3.4.2 "This command can be omitted." Suggest same wording as 
> previous: "This command is only metadata, thus it can be omitted."

I'd prefer the current wording, as your suggestion may imply too low 
a value for the command.  Alternatively, what about saying "Clients 
that do not use or set the $Forwarded flag may omit this command"?

>  4.3 One question on this: should we mention that the size declared 
> is supposed to be "before compression, encyption, transfer 
> encoding, etc".

I don't think we need to go into that detail, but if you think there 
is a potential for confusion, I'd suggest including it in parenthesis.

>   Another question: if I do forward without download, what size do I 
> declare here? I might not have fetched the attachment, so I might 
> have no idea how big it is - does the "size of the message after 
> expansion of all BURL parts" statement take care of this?

The client knows the sizes of the attachments from the BODYSTRUCTURE response.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Algol was a great improvement on most of its successors.
                                          --C.A.R Hoare

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Fri, 7 Jul 2006 17:26:55 -0700

At 10:33 PM +0100 6/29/06, Dave Cridland wrote:

>  On Tue Jun 27 11:35:42 2006, [email-masked] wrote:
>>  Thank You Dave for the update.
>>  Goog progress.
>>  Here are some comments/questions I came across while reading it:
>>  General: shouldn't the cover page say dated June, expires in December?
>
>  Yes, I'd slightly messed up the boilerplate, which meant it was rejected.
>
>  The good news is that not only has that been put right, but it gave 
> me the opportunity to address your comments in part. It's almost 
> like I planned it all along.

Sorry, my earlier comments were based on the version you mailed to the list.

>  I looked at what the RFC Editor did to the original ("This command 
> can be omitted" in both), and I don't actually like it much, 
> because it fails to explain why it can be omitted. I've tried out a 
> new variant.

Perhaps this new variant goes too far in making the command sound 
useless and worthy of omission?

-------------- Randomly-selected tag: ---------------
"SFPD Homicide: Our Day Begins when Yours End" --Slogan seen on back of
San Francisco Police Jacket, as reported by Herb Cain in SF Chronicle

---

From: <[email-masked]>
Date: Wed, 26 Jul 2006 13:28:45 +0300

Hi all,
Just catching up with my email backlog. 

-----Original Message-----
From: ext Randall Gellens [mailto:[email-masked]] 
Sent: 08 July, 2006 03:11
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]; [email-masked]
Subject: RE: [lemonade] Profile Bis -03

At 1:35 PM +0300 6/27/06, <[email-masked]> wrote:

> Suggest wording change to: "This command is only metadata, thus it can 
> be omitted."

I'd prefer the current wording, as your suggestion may imply too low a value for the command.  Alternatively, what about saying "Clients that do not use or set the $Forwarded flag may omit this command"?

[ZÖr] Yes, this is the best so far. Needs the touch of an expert :-)