Subject: [lemonade] more on CONVERTERROR response

From: Peter Coates <[email-masked]>
Date: Fri, 21 Sep 2007 05:13:39 -0700

IF we agree that the CONVERTERROR untagged response is the place to put the
descriptive text that in -11 of the CONVERT draft goes on the tagged NO, the the
syntax of the CONVERTERROR response has to be better defined.
 
At the moment it I have it always start
* msgno CONVERTERROR (tag "tag") 
This is followed either by 
MISSINGPARAMETER from-type to-type ("missingparameter") descriptive text
or
BADPARAMETER from-type to-type descriptive text
or
BADPARAMETER from-type to-type ("parameter" "badvalue") descriptive text
 
This is going to be hard to parse.  Can I suggest that the structured part of
the response goes inside [...] thus:
 
* msgno CONVERTERROR (tag "tag") [MISSINGPARAMETER from-type to-type
("missingparameter")] descriptive text
* msgno CONVERTERROR (tag "tag") [BADPARAMETER from-type to-type] descriptive
text
* msgno CONVERTERROR (tag "tag") [BADPARAMETER from-type to-type ("parameter"
"badvalue")] descriptive text
 
Also, note that I'm assuming that no parameters should be passed back in the
BADPARAMETER part unless that parameter was in error.
 
And I'm ignoring PARAMETERS I don't need/recognise.  I suspect that is wrong...
 
Peter
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 22 Sep 2007 23:25:39 +0100

Peter Coates wrote:

> Also, note that I'm assuming that no parameters should be passed back 
> in the BADPARAMETER part unless that parameter was in error.

Yes, this needs to be clarified in the draft.

> And I'm ignoring PARAMETERS I don't need/recognise.  I suspect that is 

Yes, it is. You should be returning BADPARAMETER instead.

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 22 Sep 2007 23:25:39 +0100

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 23 Sep 2007 11:27:20 +0100

Peter Coates wrote:

> IF we agree that the CONVERTERROR untagged response is the place to 
> put the descriptive text

I think so.

> that in -11 of the CONVERT draft goes on the tagged NO,

CONVERTERROR is an untagged response, not a response code anymore. So it 
is not returned in the tagged NO.

> the the syntax of the CONVERTERROR response has to be better defined.
>  
> This is going to be hard to parse.  Can I suggest that the structured 
> part of the response goes inside [...] thus:
>  
> * msgno CONVERTERROR (tag "tag") [BADPARAMETER from-type to-type] 
> descriptive text
> * msgno CONVERTERROR (tag "tag") [BADPARAMETER from-type to-type 
> ("parameter" "badvalue")] descriptive text

IMAP usually uses () for grouping, so I've used () instead of [].

Note that I've also changed syntax of from-type and to-type to be quoted 
strings, for consistency with the CONVERT request itself.

Example:

      C: b001 CONVERT 2 ("text/plain" ("charset" "us-ascii")) BINARY[3]
      S: * 2 CONVERTERROR (TAG "b001") (BADPARAMETERS "text/html" 
"text/plain" ("charset" "us-ascii")) "Source text has non us-ascii"
      S: b001 NO Conversion request failed

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 23 Sep 2007 11:27:20 +0100

I think so.

Example: