Subject: Re: [lemonade] Multiple Scripts for IMAP-Sieve

From: Eric Burger <[email-masked]>
Date: Sun, 25 Nov 2007 14:50:41 -0800

So here it is, November, and I have not heard boo on this subject.

Any thoughts?  Does Zoltan's client identifier draft help or is it
orthogonal to this problem?

On 10/15/07 7:54 AM, "Eric Burger" <[email-masked]> wrote:

> While on the subject of "Don't Add Anything," we seemed to have had rough
> consensus on Randy's text for supporting multiple scripts for IMAP Sieve.
> However, it appears that consensus is eroding.
> 
> Normally, the Chairs would offer to drop the text supporting per-client
> sieve scripts.  However, we would like to visit Zoltan's request:
> 
>    My worry here is that we might release a genie from the bottle.
>    I mean if Lemonade bis was released/deployed as is (with a single
>    script setup), we might not be able to change that in the future -
>    well, at least not easily and quickly because we are going to have
>    to provide backwards compatibility until the old services are
>    phase out.
>    Would it be possible to build in some sort of safeguard so that we
>    can change this later on without making it incompatible with
>    existing Lemonade deployment? Some sort of future-proof-ish
>    solution?
> 
> We would like to hear people's observations on this ASAP, preferably before
> 19 October.
> 
> 
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and have
> received this message in error, please immediately return this by email and
> then delete it.
> 
> 
> _______________________________________________
> lemonade mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/lemonade
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/lemonade

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Dan Karp <[email-masked]>
Date: Sun, 25 Nov 2007 23:03:16 -0800 (PST)

> orthogonal to this problem?

Personal opinion?  No way should Sieve scripts for anything but SMTP message receipt be a mandatory part of Lemonade.  And definitely no multiple script support -- "future proofing" is almost always code for "this adds significant complexity and I have no idea how it could be useful"...

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 26 Nov 2007 10:53:03 +0100

Dan Karp writes:
> Personal opinion? No way should Sieve scripts for anything but SMTP 
> message receipt be a mandatory part of Lemonade. And definitely no 
> multiple script support -- "future proofing" is almost always code 
> for "this adds significant complexity and I have no idea how it could 
> be useful"...

+1 and a boldfaced, 80-point +1.

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 26 Nov 2007 10:36:17 +0000

> +1 and a boldfaced, 80-point +1.

I have to agree with this. I want IMAP Sieve work to be finished, but I 
don't think it should be included into Lemonade Profile Bis.

I think this is something we should discuss in Vancouver.