Subject: [lemonade] List of open issues with draft-gulbrandsen-imap-enable-03

From: Alexey Melnikov <[email-masked]>
Date: Mon, 12 Nov 2007 13:44:26 +0000

I will try to summarize the list of open issues so far (some of them are 
related):

1). In which states the ENABLE command should be allowed: all, only 
after authentication, ...
2). Handling of ENABLE for unrecognized extensions: send error or ignore
3). Handling of ENABLE for extensions that should not be enablable (e.g. 
IDLE): send error or ignore
4). How the client can learn if a particular extension was enabled or 
not? Does it need to know?
5). Does ENABLE affect CAPABILITY response/response code?

Does this look like a full list of issues?

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 12 Nov 2007 13:46:58 +0000

Alexey Melnikov wrote:

> I will try to summarize the list of open issues so far (some of them 
> are related):

> after authentication, ...

All states.

> 2). Handling of ENABLE for unrecognized extensions: send error or ignore

Ignore.

> 3). Handling of ENABLE for extensions that should not be enablable 
> (e.g. IDLE): send error or ignore

Ignore.

> not? Does it need to know?

Clients should only rely on CAPABILITY responses/response codes.

> 5). Does ENABLE affect CAPABILITY response/response code?

It shouldn't affect the CAPABILITY command issued in the same state, but 
it might change after authentication.