Subject: [lemonade] Second WGLC: BINARY

From: Eric Burger <[email-masked]>
Date: Tue, 22 Apr 2008 17:32:52 -0400

Although this is a short document, only 6 pages of text, it did grow by two
pages and the ABNF was revamped and the example was corrected.  Thus we are
holding a second call for final comments.

The period for getting your comments in expires 2 May 2008.

http://tools.ietf.org/html/draft-cridland-urlfetch-binary-02

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: "Vaudreuil, Greg M \(Greg\)" <[email-masked]>
Date: Tue, 22 Apr 2008 22:37:02 -0500

I have given this document a once-over and see no issues.

It would be an improvement to see this document and RFC 4467 (URLAUTH)
merged into a single document, a single standard that supersedes
URLAUTH.  I don't anticipate future implementers will code the base
URLAUTH without these extensions.

Greg V.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Eric Burger
Sent: Tuesday, April 22, 2008 5:33 PM
To: [email-masked]
Subject: [lemonade] Second WGLC: BINARY

Although this is a short document, only 6 pages of text, it did grow by
two
pages and the ABNF was revamped and the example was corrected.  Thus we
are
holding a second call for final comments.

Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 23 Apr 2008 13:17:30 +0200

Vaudreuil, Greg M (Greg) writes:
> URLAUTH.

Yes, agreed. Just importing the text and superseding 4467 would be okay.

I feel a little overwhelmed by the number of RFCs, so I imagine other 
people will be, too.

Arnt

---

From: Eric Burger <[email-masked]>
Date: Thu, 24 Apr 2008 13:06:31 -0400

Yes, and...

They do not have to go together; one could envision one without the other.
Thus, rather than combining the two documents, creating the need for a full
WGLC, and further delaying other, dependent documents, let us leave it as
two documents for now.

When we want to go for DS on either URLAUTH or BINARY, we can consolidate
them as experience merits.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 24 Apr 2008 18:10:26 +0100

>them as experience merits.
While agree with the desire on not merging the two documents now, this 
brings a question of whether both documents should be in Profile Bis, or 
just URLAUTH.

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 24 Apr 2008 13:48:44 -0700

<chair-hat off>
Sensible to be in Profile-bis. 

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Thursday, April 24, 2008 1:10 PM
To: Eric Burger
Cc: Arnt Gulbrandsen; [email-masked]
Subject: Re: [lemonade] Second WGLC: BINARY

Eric Burger wrote:

>Thus, rather than combining the two documents, creating the need for a 
>full WGLC, and further delaying other, dependent documents, let us 
>leave it as two documents for now.
>
>When we want to go for DS on either URLAUTH or BINARY, we can 
>consolidate them as experience merits.
>  
>

>>>It would be an improvement to see this document and RFC 4467 
>>>(URLAUTH) merged into a single document, a single standard that 
>>>supersedes URLAUTH.
>>>      
>>>

---

From: "Vaudreuil, Greg M \(Greg\)" <[email-masked]>
Date: Thu, 24 Apr 2008 17:50:47 -0500

Just BINARY.

Greg V.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Alexey Melnikov
Sent: Thursday, April 24, 2008 1:10 PM
To: Eric Burger
Cc: [email-masked]
Subject: Re: [lemonade] Second WGLC: BINARY

>Thus, rather than combining the two documents, creating the need for a
full
>When we want to go for DS on either URLAUTH or BINARY, we can
consolidate

just URLAUTH.

>>>It would be an improvement to see this document and RFC 4467
(URLAUTH)

---

From: Dave Cridland <[email-masked]>
Date: Fri, 25 Apr 2008 13:37:21 +0100

> Sensible to be in Profile-bis.
But streaming isn't, and this is only needed for (and mandated by)  
streaming.

So in a sense, draft-ietf-lemonade-streaming is a "Streaming  
Profile", and the two can be kept distinct. (Although the OMA can  
mandate both if they want).

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Ken Murchison <[email-masked]>
Date: Fri, 25 Apr 2008 11:57:50 -0400

The doc looks good to me.  It appears the only change from -01 is the 
decoupling of the BINARY and BODYPARTSTRUCTURE options (as requested by 
Alexey), correct?  I gave the ABNF a quick pass and it looks correct.

-- 
Kenneth Murchison
Systems Programmer
Project Cyrus Developer/Maintainer
Carnegie Mellon University
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade