Subject: Re: [lp-wan] LPWAN Architecture names

From: Ana Minaburo <[email-masked]>
Date: Wed, 5 Oct 2016 14:15:50 +0200

Hello,

Just for continue the discussion. How about the Security Server, do we call it Service Server or AAA or Registar? and How about the Application Server, is ti ok for you Application Server or something else? 

Thanks
Ana
> On 21 Sep 2016, at 18:08, Laurent Toutain <[email-masked]> wrote:
> 
> Hi,
> 
> Why not put LPWAN in front of each name:
> - LPWAN-Host (LH)
> - LPWAN-Radio-GW (LR)
> - LPWAN-Gateway (LG)
> 
>  
> 
> I think that the IETF ‘node’ in the first row is really a ‘host’, since it is an end point.
> 
> [JCZ] This is true. I’m just wondering if host is a fair definition for all types of LPWAN devices, since some of them may be running a full IP stack, but some others may be extremely simple (like a sensor with just a microcontroller and a radio). End Device seems to be generic enough.
> 
> 
> For me it is optimization to say that some sensor (LH) will be extremely simple. The IETF model must be preserved. A node should be have the capability to forward packets.
> 
> Laurent
> 
>  
> 
> The classical name for the router is a (network) gateway, so I’m happy with what Ana placed there, but I’d add ‘router’ to that entry.
> 
>  
> 
> Juan Carlos
> 
>  
> 
> Then again I’m happy with the terminology.
> 
>  
> 
> What do others think?
> 
>  
> 
> Pascal
> 
>  
> 
>  
> 
>  
> 
> From: lp-wan [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Thomas Watteyne
> Sent: mercredi 21 septembre 2016 10:26
> To: Ana Minaburo <[email-masked] <mailto:[email-masked]>>
> Cc: lp-wan <[email-masked] <mailto:[email-masked]>>
> Subject: Re: [lp-wan] LPWAN Architecture names
> 
>  
> 
> I don't undertsand the different between radio GW and network GW. Maybe "non-routing node" (intead of node), "routing node" (instead of node) and "gateway" (instead of newtwork GW)?
> 
> PLease point out if I'm missing something
> 
>  
> 
> On Wed, Sep 21, 2016 at 10:22 AM, Ana Minaburo <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hello everybody,
> 
>  
> 
> I hope you are fine!, Here I’m again after some weeks off.
> 
>  
> 
> I started working on the architecture for the LPWAN. Based on the presentation made during the Berlin BoF, We need to agree on how we name each device on the LPWAN architecture. As you can see in the following table, each technology gives a different name to the same functionality device.  Which could be the best name at IETF for these devices, are you agree in my proposition?
> 
>  
> 
> Thanks
> 
> Ana
> 
>  
> 
> ⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮      Function⧹ Technology     ⎮       LORAWAN       ⎮            NB-IOT                         ⎮            SIGFOX             ⎮           IETF                     ⎮ 
> 
> ⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮     Sensor, Actuator, object   ⎮       End Device       ⎮           User Equipment            ⎮          End Point             ⎮            NODE                 ⎮ 
> 
> ⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮    Transceiver, Antenna        ⎮          Gateway        ⎮            Evolved Node B           ⎮         Base Station          ⎮  RADIO GATEWAY       ⎮   
> 
> ⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮          Network  Server         ⎮   Network Server    ⎮            Serving-Gateway          ⎮       Service Center         ⎮ NETWORK GATEWAY ⎮ 
> 
> ⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮  Registar, Security Server   ⎮       Join Server       ⎮     Home Subscriber Server     ⎮   Registration Authority  ⎮ REGISTRAR (As in SIP) ⎮ 
> 
> ⎮                                              ⎮                                ⎮                                                  ⎮                                       ⎮   or AAA (as Mobile-IP)   ⎮ 
> 
> ⎮ ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
> ⎮      Application Server          ⎮  Application Server ⎮  Packet Data Node Gateway  ⎮   Network Application     ⎮   APPLICATION SERVER ⎮ 
> 
> ⎮ ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮ 
> 
>  
> 
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
> 
>  
> 
> -- 
> 
> _______________________________________
> 
>  
> 
> Thomas Watteyne, PhD
> 
> Research Scientist & Innovator, Inria
> 
> Sr Networking Design Eng, Linear Tech
> 
> Founder & co-lead, UC Berkeley OpenWSN
> 
> Co-chair, IETF 6TiSCH
> 
>  
> 
> www.thomaswatteyne.com <http://www.thomaswatteyne.com/>
> _______________________________________
> 
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
> 
> 
> 
> -- 
> Laurent Toutain 
> +--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
> | Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit :
> | Mob: +33 6 800 75 900    |                                        |
> | Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |  http://class.touta.in <http://class.touta.in/>
> | [email-masked] <mailto:[email-masked]>         | [email-masked] <mailto:[email-masked]>    |
> +--------------------------+----------------------------------------+
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 6 Oct 2016 00:11:32 +0200

Hi Ana,

It seems to me that it would be nice to use terms and names that are already well understood and known. Security Server could mean many things to many different people. Registrar has a different connotation for me (it does not always perform authentication) - it registers.

AAA is well understood and its core functionalities are known. I’d stick with this one.

On the Application Server.. I suppose here you may have more ambiguity, but for me it seems OK.

So, to recap on the architecture naming, we’ll have:

THING <-> RADIO-GW <-> NETWORK-GW <-> APPLICATION SERVER

Where the NETWORK-GW also interacts with AAA

We’d probably need to consider having shorter names for these things, or our documents will get pretty verbose…
A possible way would be:
THING: T (or simply Node)
RADIO-GW: R-GW
NETWORK-GW: N-GW
APPLICATION SERVER: AS
AAA: AAA (here it’s explicit enough)

0.2€
Alexander

> Le 5 oct. 2016 à 14:15, Ana Minaburo <[email-masked]> a écrit :
> 
> Hello,
> 
>> On 21 Sep 2016, at 18:08, Laurent Toutain <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Yeoh Chun-Yeow <[email-masked]>
Date: Thu, 6 Oct 2016 15:22:36 +0800

Hi, Ana

For NB-IoT, I would assume that S-GW/P-GW is the network server and
application server is after the SGi interface and not part of EPC
core.

Thanks

----
Chun-Yeow

⎮      Function⧹ Technology     ⎮       LORAWAN       ⎮
NB-IOT                         ⎮            SIGFOX             ⎮
    IETF                     ⎮

⎮     Sensor, Actuator, object   ⎮       End Device       ⎮
User Equipment            ⎮          End Point             ⎮
 NODE                 ⎮

⎮    Transceiver, Antenna        ⎮          Gateway        ⎮
 Evolved Node B           ⎮         Base Station          ⎮  RADIO
GATEWAY       ⎮

⎮          Network  Server         ⎮   Network Server    ⎮
Serving-Gateway /         ⎮       Service Center         ⎮ NETWORK
GATEWAY ⎮

                 Packet Data Node Gateway

⎮  Registar, Security Server   ⎮       Join Server       ⎮     Home
Subscriber Server     ⎮   Registration Authority  ⎮ REGISTRAR (As in
SIP) ⎮

⎮                                              ⎮
         ⎮                                                  ⎮
                             ⎮   or AAA (as Mobile-IP)   ⎮

⎮      Application Server          ⎮  Application Server ⎮
Application Server                  ⎮   Network Application     ⎮
APPLICATION SERVER ⎮

On Thu, Oct 6, 2016 at 6:11 AM, Alexander Pelov <[email-masked]> wrote:
> Hi Ana,
>
> It seems to me that it would be nice to use terms and names that are already
> well understood and known. Security Server could mean many things to many
> different people. Registrar has a different connotation for me (it does not
> always perform authentication) - it registers.
>
> Just for continue the discussion. How about the Security Server, do we call
> it Service Server or AAA or Registar? and How about the Application Server,
> is ti ok for you Application Server or something else?
>
> Thanks
> Ana
>
> On 21 Sep 2016, at 18:08, Laurent Toutain
> <[email-masked]> wrote:
>
> Hi,
>
>> [JCZ] This is true. I’m just wondering if host is a fair definition for
>> all types of LPWAN devices, since some of them may be running a full IP
>> stack, but some others may be extremely simple (like a sensor with just a
>> microcontroller and a radio). End Device seems to be generic enough.
>
>
> For me it is optimization to say that some sensor (LH) will be extremely
> simple. The IETF model must be preserved. A node should be have the
> capability to forward packets.
>
> Laurent
>
>
>>
>> The classical name for the router is a (network) gateway, so I’m happy
>> with what Ana placed there, but I’d add ‘router’ to that entry.
>>
>>
>>
>> Juan Carlos
>>
>>
>>
>> From: lp-wan [mailto:[email-masked]] On Behalf Of Thomas Watteyne
>> To: Ana Minaburo <[email-masked]>
>> Cc: lp-wan <[email-masked]>
>> I don't undertsand the different between radio GW and network GW. Maybe
>> "non-routing node" (intead of node), "routing node" (instead of node) and
>> "gateway" (instead of newtwork GW)?
>>
>> On Wed, Sep 21, 2016 at 10:22 AM, Ana Minaburo <[email-masked]> wrote:
>>
>> Hello everybody,
>>
>>
>>
>> I started working on the architecture for the LPWAN. Based on the
>> presentation made during the Berlin BoF, We need to agree on how we name
>> each device on the LPWAN architecture. As you can see in the following
>> table, each technology gives a different name to the same functionality
>> device.  Which could be the best name at IETF for these devices, are you
>> agree in my proposition?
>>
>>
>>
>> Thanks
>>
>> Ana
>>
>>
>>
>> ⎮
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮     Sensor, Actuator, object   ⎮       End Device       ⎮           User
>> Equipment            ⎮          End Point             ⎮            NODE
>> ⎮
>>
>> ⎮
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮    Transceiver, Antenna        ⎮          Gateway        ⎮
>> Evolved Node B           ⎮         Base Station          ⎮  RADIO GATEWAY
>> ⎮
>>
>> ⎮
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮          Network  Server         ⎮   Network Server    ⎮
>> Serving-Gateway          ⎮       Service Center         ⎮ NETWORK GATEWAY ⎮
>>
>> ⎮
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮  Registar, Security Server   ⎮       Join Server       ⎮     Home
>> Subscriber Server     ⎮   Registration Authority  ⎮ REGISTRAR (As in SIP) ⎮
>>
>> ⎮                                              ⎮
>> ⎮                                                  ⎮
>> ⎮   or AAA (as Mobile-IP)   ⎮
>>
>> ⎮
>> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>> ⎮      Application Server          ⎮  Application Server ⎮  Packet Data
>> Node Gateway  ⎮   Network Application     ⎮   APPLICATION SERVER ⎮
>>
>> ⎮
>> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮
>>
>>
>>
>>
>> www.thomaswatteyne.com
> | Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
> http://class.touta.in
> | [email-masked]         | [email-masked]    |