Subject: [lp-wan] kicking off the work

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Oct 2016 14:17:01 +0000

Dear all :

Thanks to Suresh' deep involvement and support, we now have a working group, and an entry in the agenda for Seoul for IETF 97; this means that we have very little time before we meet again in person. And as it goes, we have only 2 weeks left to publish work before the IETF cut off  (from http://ietf.org/meeting/important-dates-2016.html#ietf97):
*  2016-10-31 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59, upload using IETF ID Submission Tool<https://datatracker.ietf.org/submit/>.

Compared with the discussions at the BoF, the charter final is limiting our scope to 2 main activities:

"
1. Produce an Informational document describing and relating some selected LPWA technologies. This work will document the common characteristics and highlight actual needs that the IETF could serve; but it is not intended to provide a competitive analysis. It is expected that the information contained therein originates from and is reviewed by people who work on the respective LPWA technologies.

2. Produce a Standards Track document to enable the compression and fragmentation of a CoAP/UDP/IPv6 packet over LPWA networks. This will be achieved through stateful mechanisms, specifically designed for star topology and severely constrained links. The work will include the definition of generic data models to describe the compression and fragmentation contexts. This work may also include to define technology- specific adaptations of the generic compression/fragmentation mechanism wherever necessary.
"

This reduced charter comes with aggressive milestones, in particular on the first item for which we do not have proposed text yet.:
"
Milestones:
  Nov 2016 - Adopt LPWAN specifications as WG item
  Dec 2016 - Adopt IP/UDP compression and fragmentation mechanism as a WG item
...
"

In order to meet the deadlines for item 1, we need to produce the informational draft 00 on LPWAN technologies within 2 weeks. We already have material from the Berlin BoF that can be turned into text, with one section per technology. The chairs will ask the BoF presenters to either contribute their section or propose an alternate author for that contribution. We'd need that text within 10 days to achieve the deadline. From there we will need an editor to put it all together and are looking for candidates.

Also:

For those new to the IETF, you'll find that the following page is quite useful, with links to jabber, etherpad, I-drafts, etc...
https://datatracker.ietf.org/meeting/97/agenda.html

In that page, you'll find that we'll meet 15:50-17:50 on Monday Afternoon in Grand Ballroom III<https://datatracker.ietf.org/meeting/97/floor-plan?room=grand-ballroom-iii>. This is according to the draft agenda; the final agenda is to be posted next Friday (10/21).

Take care,

The chairs

---

From: Jiazi Yi <[email-masked]>
Date: Mon, 17 Oct 2016 17:01:37 +0200

Hi Pascal, 

We had also some text in our recent publication 

A Study of LoRa: Long Range & Low Power Networks for the Internet of Things
	Aloÿs Augustin, Jiazi Yi, Thomas Clausen and William Mark Townsley
	http://www.mdpi.com/1424-8220/16/9/1466/htm

which provides an analysis of LoRa (and very high-level overview of related technologies). If you found it interesting, we are glad to contribute some text for the informational document. 

regards

Jiazi

Ecole Polytechnique, France

> On 17 Oct 2016, at 16:17, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Dear all :
>  
> Thanks to Suresh’ deep involvement and support, we now have a working group, and an entry in the agenda for Seoul for IETF 97; this means that we have very little time before we meet again in person. And as it goes, we have only 2 weeks left to publish work before the IETF cut off  (from http://ietf.org/meeting/important-dates-2016.html#ietf97 <http://ietf.org/meeting/important-dates-2016.html#ietf97>): 
> ·  2016-10-31 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59, upload using IETF ID Submission Tool <https://datatracker.ietf.org/submit/>.
>  
> “
> “
> “
> …
> “
> In order to meet the deadlines for item 1, we need to produce the informational draft 00 on LPWAN technologies within 2 weeks. We already have material from the Berlin BoF that can be turned into text, with one section per technology. The chairs will ask the BoF presenters to either contribute their section or propose an alternate author for that contribution. We’d need that text within 10 days to achieve the deadline. From there we will need an editor to put it all together and are looking for candidates.
>  
> Also:
>  
> For those new to the IETF, you’ll find that the following page is quite useful, with links to jabber, etherpad, I-drafts, etc…
> https://datatracker.ietf.org/meeting/97/agenda.html <https://datatracker.ietf.org/meeting/97/agenda.html>
>  
> In that page, you’ll find that we’ll meet 15:50-17:50 on Monday Afternoon in Grand Ballroom III <https://datatracker.ietf.org/meeting/97/floor-plan?room=grand-ballroom-iii>. This is according to the draft agenda; the final agenda is to be posted next Friday (10/21).
>  
> Take care,
>  
> The chairs
>  
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: Alper Yegin <[email-masked]>
Date: Mon, 17 Oct 2016 18:09:52 +0300

Hello Pascal,

Wouldn't it be better to have each technology produce its own I-D, and
maintain it as necessary (considering evolutions, etc.)? Two of the techs
already have their I-D from last meeting as you remember, and we in the
LoRa Alliance are already working on our LoRa I-D as well (to be submitted
soon).

Alper

On Mon, Oct 17, 2016 at 5:17 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Dear all :
>
>
>
> Thanks to Suresh’ deep involvement and support, we now have a working
> group, and an entry in the agenda for Seoul for IETF 97; this means that we
> have very little time before we meet again in person. And as it goes, we
> have only 2 weeks left to publish work before the IETF cut off  (from
> http://ietf.org/meeting/important-dates-2016.html#ietf97):
>
> ·  * 2016-10-31 (Monday):* Internet Draft submission cut-off (for all
> drafts, including -00) by UTC 23:59, upload using IETF ID Submission Tool
> <https://datatracker.ietf.org/submit/>.
>
>
>
> 1. Produce an Informational document describing and relating some
> selected LPWA technologies. This work will document the common
> characteristics and highlight actual needs that the IETF could serve; but
> it is not intended to provide a competitive analysis. It is expected that
> the information contained therein originates from and is reviewed by people
> who work on the respective LPWA technologies.
>
>
>
> 2. Produce a Standards Track document to enable the compression and
> fragmentation of a CoAP/UDP/IPv6 packet over LPWA networks. This will be
> achieved through stateful mechanisms, specifically designed for star
> topology and severely constrained links. The work will include the
> definition of generic data models to describe the compression and
> fragmentation contexts. This work may also include to define technology-
> specific adaptations of the generic compression/fragmentation mechanism
> wherever necessary.
>
> “
>
>
>
> This reduced charter comes with aggressive milestones, in particular on
> the first item for which we do not have proposed text yet.:
>
> “
>
> Milestones:
>
> In order to meet the deadlines for item 1, we need to produce the
> informational draft 00 on LPWAN technologies within 2 weeks. We already
> have material from the Berlin BoF that can be turned into text, with one
> section per technology. The chairs will ask the BoF presenters to either
> contribute their section or propose an alternate author for that
> contribution. We’d need that text within 10 days to achieve the deadline.
> From there we will need an editor to put it all together and are looking
> for candidates.
>
>
>
> Also:
>
>
>
> For those new to the IETF, you’ll find that the following page is quite
> useful, with links to jabber, etherpad, I-drafts, etc…
>
> In that page, you’ll find that we’ll meet 15:50-17:50 on Monday Afternoon
> in Grand Ballroom III
> <https://datatracker.ietf.org/meeting/97/floor-plan?room=grand-ballroom-iii>.
> This is according to the draft agenda; the final agenda is to be posted
> next Friday (10/21).
>
>
>
> Take care,
>
>
>
> The chairs
>
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

---

From: Jiazi Yi <[email-masked]>
Date: Tue, 18 Oct 2016 00:27:09 +0200

Hi, 

I think it depends on what’s the purpose of this informational document.

If it’s for describing common characteristics and needs of IETF, a single document would be better. It won’t hinder documenting the evolutions of different technologies. For people as lazy as me, I would be scared if I had a long reading list to go through just to understand what LPWAN looks like. 

If it’s for having in-depth understanding of different technologies, having independent IDs would be a better choice. 

regards

Jiazi

> On 17 Oct 2016, at 17:09, Alper Yegin <[email-masked]> wrote:
> 
> Hello Pascal,
> 
> Wouldn't it be better to have each technology produce its own I-D, and maintain it as necessary (considering evolutions, etc.)? Two of the techs already have their I-D from last meeting as you remember, and we in the LoRa Alliance are already working on our LoRa I-D as well (to be submitted soon).
> 
> Alper
> 
> 
> On Mon, Oct 17, 2016 at 5:17 PM, Pascal Thubert (pthubert) <[email-masked] <mailto:[email-masked]>> wrote:
> Dear all :
> 
>  
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 Oct 2016 06:33:55 +0000

Agreed Jiazi;

I think that the reference section should point on many more documents. But this one must be a rather homogeneous and short document positioning things, and pointing at existing docs and specs when they are available. My take is to roughly follow the script that the chairs suggested for the presentation at IETF 96 as a reference point. This is what the presenters did at the BoF, so words along the existing slides would be perfect if you ask me.

Take care,

Pascal

From: Jiazi Yi [mailto:[email-masked]]
Sent: mardi 18 octobre 2016 00:27
To: Alper Yegin <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; lp-wan <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [lp-wan] kicking off the work

Hi,

regards

Jiazi

On 17 Oct 2016, at 17:09, Alper Yegin <[email-masked]<mailto:[email-masked]>> wrote:

Hello Pascal,

Alper

On Mon, Oct 17, 2016 at 5:17 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all :

Thanks to Suresh’ deep involvement and support, we now have a working group, and an entry in the agenda for Seoul for IETF 97; this means that we have very little time before we meet again in person. And as it goes, we have only 2 weeks left to publish work before the IETF cut off  (from http://ietf.org/meeting/important-dates-2016.html#ietf97):
•  2016-10-31 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59, upload using IETF ID Submission Tool<https://datatracker.ietf.org/submit/>.

“

Also:

In that page, you’ll find that we’ll meet 15:50-17:50 on Monday Afternoon in Grand Ballroom III<https://datatracker.ietf.org/meeting/97/floor-plan?room=grand-ballroom-iii>. This is according to the draft agenda; the final agenda is to be posted next Friday (10/21).

Take care,

The chairs

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Ana Minaburo <[email-masked]>
Date: Tue, 18 Oct 2016 15:01:25 +0200

Hello Pascal, and all

I was wondering, how the drafts gap analysis and IPv6-analysis ( that we are merging after the comments of Berlin meeting, and that will be published in the next days) will be reused to complete this item number 1. I think we have already work on the  "common characteristics and highlight actual needs that the IETF could serve” on this two drafts and they can be part of the work on this item.

Thanks
Ana

> On 18 Oct 2016, at 08:33, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Agreed Jiazi;
>  
> On 17 Oct 2016, at 17:09, Alper Yegin <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hello Pascal,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 Oct 2016 13:15:31 +0000

Good point Ana:

We are gathering the potential authors and the editor. This makes you a potential author for non-specific sections, to be worked out with the editor.

Take care,

Pascal

From: Ana Minaburo [mailto:[email-masked]]
Sent: mardi 18 octobre 2016 15:01
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Jiazi Yi <[email-masked]>; Alper Yegin <[email-masked]>; lp-wan <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [lp-wan] kicking off the work

Hello Pascal, and all

Thanks
Ana

On 18 Oct 2016, at 08:33, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Agreed Jiazi;

Take care,

Pascal

From: Jiazi Yi [mailto:[email-masked]]
Sent: mardi 18 octobre 2016 00:27
To: Alper Yegin <[email-masked]<mailto:[email-masked]>>
Cc: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; lp-wan <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [lp-wan] kicking off the work

Hi,

regards

Jiazi

Hello Pascal,

Alper

“

Also:

Take care,

The chairs