Subject: [lp-wan] LoRa Wireshark dissector ? Re: LoRa Simulator

From: <[email-masked]>
Date: Thu, 20 Oct 2016 07:26:13 +0000

Hello all,

Regarding tools for LoRa, do you know of a publicly available Wireshark dissector for LoRa?
Eventually, one will have to develop one, let's avoid two or more developing it.
We at Orange Labs are willing to contribute/review, with limited resources.
Thanks

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Diego Dujovne <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 19 October 2016 22:36
À : Alexander Pelov <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : Re: [lp-wan] LoRa Simulator

Alexander,
                 I answer inline.
Regards,

                     Diego

2016-10-19 17:24 GMT-03:00 Alexander Pelov <[email-masked]<mailto:[email-masked]>>:
Dear Diego,

Thanks for sharing this with the community! It sure is a great step in the right direction!

What would be the next steps in the development of the simulator?

The next steps, would be to continue adding the LoRa phases and to enable IPv6

-->Transmission Phase

-->Adaptative Rate Phase

-->Configuration Deployment

-->LoRaWAN/IPv6 transition Module

Do you need any feedback on the propagation models or mostly focusing on the MAC layer?

Though we are currently focusing on the MAC layer, we need real traffic logs to validate
the simulator and test the propagation model.

A more long-term question - do you think parts of your simulator could be reused for other technologies, or would you consider that it would be too much of an effort, and therefore separate simulators should be developed?

Since other technologies are based on similar principles, I believe new modules can be
derived from the LoRa-Sim implementation, but developed as different entities with
the same API.

Thanks again for starting your work,
Alexander

Le 19 oct. 2016 à 22:02, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> a écrit :

Dear all,
             At the IoT group at Universidad Diego Portales
we have started a new project to develop a LoRa Simulator,
called LoRa-Sim.
             Our first aim is to develop a module for the simulation
of the LoRa stack and the second, to add IPv6 support. The
simulator is built on top of OMNET++ v5.0.
             The simulator is currently on the early stages of development
and I would like to invite any interested volunteer to collaborate
on this effort.
             The github link is:

https://github.com/z1gm4/LoRa-Sim

              Thank you.
              Regards,

                                 Diego Dujovne

--
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl/>
(56 2) 676 8125
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

--
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 20 Oct 2016 14:28:31 +0000 (UTC)

Hello all,
>Regarding tools for LoRa, do you know of a publicly available Wireshark dissector for LoRa?>Eventually, one will have to develop one, let's avoid two or more developing it.>We at Orange Labs are willing to contribute/review, with limited resources.
Guys, I am on the Wireshark Developers email list & know quite a few of them well.  I was involved in doing the initial work for the Wireshark dissector for TLS1.3.
I am too busy to actually do any of the work for LoRa (although it sounds fascinating!).  I can certainly put you in touch with the core Wireshark developers and see if there is any interest from them or others in the Wireshark community.
Nalini ElkinsInside Products, Inc. De : lp-wan <[email-masked]> on behalf of Diego Dujovne <[email-masked]>
Date : Wednesday 19 October 2016 22:36
À : Alexander Pelov <[email-masked]>
Cc : "[email-masked]" <[email-masked]>
Objet : Re: [lp-wan] LoRa Simulator

Alexander,
                 I answer inline.
Regards,

                     Diego

2016-10-19 17:24 GMT-03:00 Alexander Pelov <[email-masked]>:

Dear Diego,

-->Transmission Phase-->Adaptative Rate Phase-->Configuration Deployment-->LoRaWAN/IPv6 transition Module

Thanks again for starting your work,Alexander

Le 19 oct. 2016 à 22:02, Prof. Diego Dujovne <[email-masked]> a écrit :
Dear all,

https://github.com/z1gm4/LoRa- Sim

              Thank you.
              Regards,

                                 Diego Dujovne  

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125
______________________________ _________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/ listinfo/lp-wan

www.ingenieria.udp.cl

[email-masked]

---

From: Yeoh Chun-Yeow <[email-masked]>
Date: Thu, 20 Oct 2016 23:39:31 +0800

You mean that wireshark to decode the RF packet payload sent by GW to
network server?

----
Chun-Yeow

On Thu, Oct 20, 2016 at 10:28 PM,  <[email-masked]> wrote:
> Guys, I am on the Wireshark Developers email list & know quite a few of them
> well.  I was involved in doing the initial work for the Wireshark dissector
> for TLS1.3.
>
> I am too busy to actually do any of the work for LoRa (although it sounds
> fascinating!).  I can certainly put you in touch with the core Wireshark
> developers and see if there is any interest from them or others in the
> Wireshark community.
>
> Nalini Elkins
> Inside Products, Inc.
>
> De : lp-wan <[email-masked]> on behalf of Diego Dujovne
> <[email-masked]>
> A more long-term question - do you think parts of your simulator could be
> reused for other technologies, or would you consider that it would be too
> much of an effort, and therefore separate simulators should be developed?
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: <[email-masked]>
Date: Thu, 20 Oct 2016 16:15:49 +0000 (UTC)

Wireshark will, of course, decode standard L2 / L3, etc.
But, if you have payload and any other information that is unique to your protocol, then you have to do a dissector for that.  Probably easiest to start with a dissector that is close and then modify that.
I hope I am answering the question you asked.
Nalini

      From: Yeoh Chun-Yeow <[email-masked]>
 To: [email-masked] 
Cc: "[email-masked]" <[email-masked]>; Prof. Diego Dujovne <[email-masked]>; Alexander Pelov <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Thursday, October 20, 2016 8:39 AM
 Subject: Re: [lp-wan] LoRa Wireshark dissector ? Re: LoRa Simulator

----
Chun-Yeow

---

From: Lorenzo Vangelista <[email-masked]>
Date: Thu, 20 Oct 2016 18:26:58 +0200

Hello Nalini,

Lo-Ra protocol design started with the IEEE 802.15.4 as a basis. So we could take
that as a starting point.

Lorenzo
> On 20 Oct 2016, at 18:15, <[email-masked]> <[email-masked]> wrote:
> 
> 
> On Thu, Oct 20, 2016 at 10:28 PM,  <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >
> >
> > Hello all,
> >
> > De : lp-wan <[email-masked] <mailto:[email-masked]>> on behalf of Diego Dujovne
> > <[email-masked] <mailto:[email-masked]>>
> > À : Alexander Pelov <[email-masked] <mailto:[email-masked]>>
> > Cc : "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> > 2016-10-19 17:24 GMT-03:00 Alexander Pelov <[email-masked] <mailto:[email-masked]>>:
> >
> > Dear Diego,
> >
> > Le 19 oct. 2016 à 22:02, Prof. Diego Dujovne <[email-masked] <mailto:[email-masked]>> a
> > écrit :
> >
> > Dear all,
> > https://github.com/z1gm4/LoRa-  <https://github.com/z1gm4/LoRa->Sim
> >
> >              Thank you.
> >              Regards,
> >
> >                                  Diego Dujovne
> >
> >
> > --
> > DIEGO DUJOVNE
> > Profesor Asociado
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/  <https://www.ietf.org/mailman/>listinfo/lp-wan
> >
> >
> >
> >
> >
> > --
> > DIEGO DUJOVNE
> > Profesor Asociado
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >
> >
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
>

---

From: ""Pieter De Mil (allóra Factory)"" <[email-masked]>
Date: Thu, 20 Oct 2016 18:28:46 +0200

Decoding the RF packet when it arrives at the GW, and decoding downlink messages sent by the network server seems to be the way to go.

I’ll ask Semtech if they already have such a LoRaWAN wireshark decoder.

Best
Pieter
allora Factory

> On 20 Oct 2016, at 17:39, Yeoh Chun-Yeow <[email-masked]> wrote:
>

---

From: <[email-masked]>
Date: Thu, 20 Oct 2016 17:04:19 +0000 (UTC)

Lorenzo,
Sure.  Let's wait until we see if a dissector already exists.  I believe someone on list is checking.
Then, we can move forward. Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

      From: Lorenzo Vangelista <[email-masked]>
 To: [email-masked] 
Cc: Yeoh Chun-Yeow <[email-masked]>; "[email-masked]" <[email-masked]>; Prof. Diego Dujovne <[email-masked]>; "[email-masked]" <[email-masked]>; Alexander Pelov <[email-masked]>
 Sent: Thursday, October 20, 2016 9:26 AM
 Subject: Re: [lp-wan] LoRa Wireshark dissector ? Re: LoRa Simulator
   
Hello Nalini,
Lo-Ra protocol design started with the IEEE 802.15.4 as a basis. So we could take that as a starting point.
Lorenzo 

  

----
Chun-Yeow

---

From: Mathieu Goessens <[email-masked]>
Date: Mon, 24 Oct 2016 16:56:28 +0200

Hi,

> that as a starting point.

LoRaWan [1] evolved a bit far away of IEEE 802.15.4, so I am not sure
how much IEEE 802.15.4 can be use as basics.

One who want to decode LoRaWan would also have to decode Semtech
protocol used for GW (Antenna) to LoRa Network Server, that encapsulate
packets (and add metadatas, like frequency, txpower, rssi...):

https://github.com/Lora-net/packet_forwarder/blob/master/PROTOCOL.TXT

While I won't have time to implement this decoder by myself, I will be
pleased to give a try and an hand if needed.

[1]
https://www.lora-alliance.org/portals/0/specs/LoRaWAN%20Specification%201R0.pdf

-- 
Mathieu Goessens
Research Engineer
Telecom-Bretagne

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 24 Oct 2016 13:18:04 -0300

You can also publish your requirement
on the new IETF tool named "CodeStand" which matches
requests and developers for I-Ds and projects.

https://codestand.ietf.org/codestand/

Regards,

                               Diego