Subject: [lp-wan] LoRa Simulator

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 19 Oct 2016 17:02:14 -0300

Dear all,
             At the IoT group at Universidad Diego Portales
we have started a new project to develop a LoRa Simulator,
called LoRa-Sim.
             Our first aim is to develop a module for the simulation
of the LoRa stack and the second, to add IPv6 support. The
simulator is built on top of OMNET++ v5.0.
             The simulator is currently on the early stages of development
and I would like to invite any interested volunteer to collaborate
on this effort.
             The github link is:

https://github.com/z1gm4/LoRa-Sim

              Thank you.
              Regards,

                                 Diego Dujovne

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 19 Oct 2016 22:25:57 +0200

Dear Diego,

Thanks for sharing this with the community! It sure is a great step in the right direction!

What would be the next steps in the development of the simulator? Do you need any feedback on the propagation models or mostly focusing on the MAC layer?

A more long-term question - do you think parts of your simulator could be reused for other technologies, or would you consider that it would be too much of an effort, and therefore separate simulators should be developed?

Thanks again for starting your work,
Alexander

> Le 19 oct. 2016 à 22:02, Prof. Diego Dujovne <[email-masked]> a écrit :
> 
> Dear all,
> https://github.com/z1gm4/LoRa-Sim <https://github.com/z1gm4/LoRa-Sim>
> 
>               Thank you.
>               Regards,
> 
>                                  Diego Dujovne  
>              
> 
> -- 
> DIEGO DUJOVNE
> Profesor Asociado
> www.ingenieria.udp.cl <http://www.ingenieria.udp.cl/>
> (56 2) 676 8125
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 19 Oct 2016 17:36:21 -0300

Alexander,
                 I answer inline.
Regards,

                     Diego

2016-10-19 17:24 GMT-03:00 Alexander Pelov <[email-masked]>:

> What would be the next steps in the development of the simulator?
>

The next steps, would be to continue adding the LoRa phases and to enable
IPv6

-->Transmission Phase

-->Adaptative Rate Phase

-->Configuration Deployment

-->LoRaWAN/IPv6 transition Module

Do you need any feedback on the propagation models or mostly focusing on
the MAC layer?

Though we are currently focusing on the MAC layer, we need real traffic
logs to validate
the simulator and test the propagation model.

> A more long-term question - do you think parts of your simulator could be
> reused for other technologies, or would you consider that it would be too
> much of an effort, and therefore separate simulators should be developed?
>

Since other technologies are based on similar principles, I believe new
modules can be
derived from the LoRa-Sim implementation, but developed as different
entities with
the same API.