Subject: [lp-wan] a window and tiles

From: Shoichi Sakane <[email-masked]>
Date: Thu, 6 Dec 2018 13:27:55 +0900

Hi,

When I look at the figure 28 in draft-ietf-lpwan-ipv6-static-context-hc-17, the number of tiles are changed from W=2, FCN=19. And, I believe the behavior of the figure for Ack-on-error is expected.

> 8.2.2.2.  Windows
>
>   o  all the windows of a SCHC Packet, except the last one, MUST
>      contain the same number of tiles.  This number is WINDOW_SIZE.

Is the definition of Windows in the 8.2.2.2 section still correct ?

The next version going to be 18 looks same.

Thanks,
Shoichi

---

From: <[email-masked]>
Date: Fri, 7 Dec 2018 09:44:23 +0000

Hello Shoichi,

Thanks for your thorough reading of the SCHC draft, this is appreciated!
Regarding your question:
Indeed, Figure 28 in -17 shows a MTU change from (including) Fragment W=2
FCN=19. And yes, this illustres the ACK-on-Error mode.
It turns out that window number 2 is the last window of the packet. It has
17 tiles (numbered from 27 downto 11).
Windows number 0 and 1 have 28 tiles.
How does this contradict the definition in 8.2.2.2?

Best regards

Dominique

Le 06/12/18 05:27, « lp-wan on behalf of Shoichi Sakane »
<[email-masked] on behalf of [email-masked]> a écrit :

>Hi,
>
>When I look at the figure 28 in
>draft-ietf-lpwan-ipv6-static-context-hc-17, the number of tiles are
>changed from W=2, FCN=19. And, I believe the behavior of the figure for
>Ack-on-error is expected.
>
>> 8.2.2.2.  Windows
>>
>_______________________________________________
>lp-wan mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lp-wan

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Shoichi Sakane <[email-masked]>
Date: Sat, 8 Dec 2018 21:24:47 +0900

Hi Dominique,

>From 8.2.2.2, I misread that the number of tiles in each SCHC packet are to be equal.

Now, I understand what 8.2.2. means.  All the windows MUST contain the same number of tiles except the last one, and each SCHC packet may contain different numbers of tiles.

Thanks,
Shoichi

---

From: Shoichi Sakane <[email-masked]>
Date: Sat, 8 Dec 2018 23:29:57 +0900

I mixed SCHC fragment and packet.  That's the reason.  Sorry for my mess.

My word must be: All the windows of a SCHC packet MUST contain the same number of tiles except the last one, and each SCHC *fragment* may contain different numbers of tiles.

Thanks,
Shoichi