Subject: [lp-wan] The bitmap for the last window

From: Shoichi Sakane <[email-masked]>
Date: Mon, 10 Dec 2018 16:07:06 +0900

> 8.2.2.3.  Bitmaps

>   tile numbered 0.  In the Bitmap for the last window, the bit at the
>   right-most position corresponds either to the tile numbered 0 or to a
>   tile that is sent/received as "the last one of the SCHC Packet"
>   without explicitely stating its number (see Section 8.3.1.2).

Because when Receiver sends ACK with the bitmap to Sender, it is clear that Receiver has received the last tile in the All-1 fragment.  I don't see any reason why the right-most position of the bitmap in the last window may represent to the last one tile.

If this assumption is correct, the bit is always corresponded to the tile numbered 0.

Then, from 8.3.1.2, it looks that only one tile can be put in the ALL-1 fragment.  However, if we relax the above limitation, we can put more than one tiles there.

Thanks,
Shoichi

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 10 Dec 2018 09:31:13 +0100

Hi Shoichi,

> Because when Receiver sends ACK with the bitmap to Sender, it is clear
> that Receiver has received the last tile in the All-1 fragment.  I don't
> see any reason why the right-most position of the bitmap in the last
> window may represent to the last one tile.

If the All-1 SCHC Fragment is lost, the sender will send a SCHC ACK
request upon Retransmission Timer expiration. In that case, the bitmap
sent by the receiver will indicate that the last tile was not received.

Cheers,

Carles

> Then, from 8.3.1.2, it looks that only one tile can be put in the ALL-1
> fragment.  However, if we relax the above limitation, we can put more than
> one tiles there.
>
> Thanks,
> Shoichi

---

From: Shoichi Sakane <[email-masked]>
Date: Tue, 11 Dec 2018 12:54:22 +0900

Hi Carles,

> sent by the receiver will indicate that the last tile was not received.

In this scenario, and if the receiver received the tile numbered 0, how will the right-most bit become ?

Thanks,
Shoichi

> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: <[email-masked]>
Date: Tue, 11 Dec 2018 08:28:15 +0000

Hello Shoichi,

If the last tile of a SCHC Packet happens to have tile index 0, you can
always send it with FCN All-1, and everything works.
If the  mode and Profile allows for it, you could also send it as part of
a multi-tile Fragment, then send a MIC-only All-1 Fragment message.
In both situations, the bit 0 in the Bitmap will be set to indicate that
this tile was received.
To say the same thing in a different way: it doesn't matter that there is
an ambiguity about the meaning of bit 0 in the bitmap of the last window
(i.e., does bit position 0 means "tile index 0" or "last tile"?). Because
this is the last window, then tile index 0, if it exists, can only be the
last tile.
Does this make sense?

Best regards

Dominique
 
Le 11/12/18 04:54, « lp-wan on behalf of Shoichi Sakane »
<[email-masked] on behalf of [email-masked]> a écrit :

>>> If this assumption is correct, the bit is always corresponded to the
>>>tile
>>> numbered 0.
>>>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Shoichi Sakane <[email-masked]>
Date: Thu, 13 Dec 2018 00:02:01 +0900

Hi Dominique,

I have noticed that the All-1 fragment and the FCN=0 (All-0) fragment will not happen in same window.

If there was a FCN=0 fragment, it means that at least, more than one tile was remained.  In this case, the right most bit always represents the tile of FCN=0.
If there was the All-1 fragment with a tile, the right most bit represents the tile and it doesn't matter whether the FCN is zero or not.

About processing the last tile, I want to confirm one thing.

If the size of the last tile of a SCHC packet is less than L2 word, AND the last tile number is zero, AND it doesn't fit into the All-1 fragment, then, the last tile is carried by the next window and the All-1 fragment (MIC only) sent after that.  Is it correct ?

> 8.3.1.1.  Regular SCHC Fragment
> 
>    The Fragment Payload of a SCHC Fragment with FCN == 0 (called an
>    All-0 SCHC Fragment) MUST be at least the size of an L2 Word.  The
>    rationale is that, even in the presence of padding, an All-0 SCHC
>    Fragment needs to be distinguishable from the SCHC ACK REQ message,
>    which has the same header but has no payload (see Section 8.3.3).

Thanks,
Shoichi