Subject: Re: [lp-wan] charter v2

From: <[email-masked]>
Date: Fri, 18 Jan 2019 17:16:05 +0000

Hello all,

Sorry I missed the call yesterday.
The proposed charter quoted below sounds good to me.
Thanks for putting together!

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Date : Thursday 17 January 2019 15:35
À : lp-wan <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] charter v2

Dear all ;

We discussed the new proposed charter in IETF 103 and again yesterday during our interim (see
https://datatracker.ietf.org/meeting/interim-2019-lpwan-02/materials/minutes-interim-2019-lpwan-02-201901161700).

The bottom line is that we delivered SCHC are are now willing to recharter to continue the work.
Based on our discussions, the new charter would be as follows. Please feed back!

The chairs

Charter LPWAN 2.0

        A new generation of wireless technologies has emerged under the generic
        name of Low-Power Wide-Area (LPWA), with a number of common
        characteristics, which make these technologies unique and disruptive for
        Internet of Things applications.

        Those common traits include an optimized radio modulation, a star
        topology, frame sizes in the order of tens of bytes transmitted
        a few times per day at ultra-low speeds and sometimes variable MTUs,
        and, though downstream may be supported, a mostly upstream transmission
        pattern that allows the devices to spend most of their time in low-
        energy deep-sleep mode.

        This enables a range of several kilometers and a long battery lifetime,
        possibly ten years operating on a single coin-cell. This also enables
        simple and scalable deployments with low-cost devices and thin
        infrastructures.

        Those benefits come at a price: the layer 2 frame formats are optimized
        and specific to each individual technology. There is no network layer
        and the application is often hard wired to the layer 2 frame format,
        leading to siloed deployments that must be managed, secured and operated
        individually. Migrating from one LPWA technology to another implies
        rebuilding the whole chain.

        To unleash the full power of LPWA technologies and their ecosystems,
        there is a need to couple them with other ecosystems that will guarantee
        the inter-working by introducing a network layer, and enable common
        components for management and security, as well as shared application
        profiles. The IETF can contribute by providing IPv6 connectivity, and
        propose technologies to secure the operations and manage the devices and
        their gateways.

        The Working Group will focus on enabling IPv6 connectivity over the
        following selection of Low-Power Wide-Area technologies: SIGFOX, LoRa,
        IEEE 802.15.4w (WIP) and NB-IOT. WI-SUN is still considered but there is
        no chartered item that is specific to that technology.

        These technologies present similar characteristics of rare and widely
        unbalanced over-the-air transmissions, with little capability to alter
        the frame formats to accommodate this work, which makes it so that
        existing IETF work (6lo) cannot be trivially applied.

        The Working Group will leverage cross-participation with the associated
        set of stakeholders to ensure that the work taking place corresponds to
        real demands and that the proposed solutions are indeed applicable.

        The group will produce informational work describing LPWA
        technologies and their needs as well as new standard work to optimize
        IPv6-based communications to the end device

        The group will:

        1) Produce a Standards Track document to enable the compression and
        fragmentation of a CoAP messages over LPWA networks. This will be
        achieved through stateful mechanisms, for a relevant subset of the
        possible CoAP interactions (TBD as part of the work).

        2) Produce Standard Track documents to apply SCHC IPv6/UDP over baseline
        technologies including LoRa, SIGFOX, NBIOT and 802.15.4w.

        3) Produce a Standards Track document to define the generic data models
        to formalize the compression and fragmentation contexts.

        4) Produce a Standards Track document to enable some operations,
        administration and maintenance (OAM) to the LPWAN device, including but
        not limited to support for delayed or proxyed liveliness verification
        (Ping) and path discovery (Traceroute).

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 18 Jan 2019 14:21:53 -0300

Dear all,
             Same for me, I missed the call but I do
agree with the charter.
Thank you.
Regards,

                           Diego

Le ven. 18 janv. 2019 à 14:16, <[email-masked]> a écrit :

> De : lp-wan <[email-masked]> on behalf of Pascal Thubert <
> [email-masked]>
> À : lp-wan <[email-masked]>, "
> [email-masked]" <
> [email-masked]>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Laurent Toutain <[email-masked]>
Date: Thu, 24 Jan 2019 16:26:39 +0100

OAM uses specific messages sent into the data plane to measure some
parameters of a network. Most of the time no explicit values are sent is
these messages. Network parameters are obtained from the analysis of these
specific messages.

This can be used:

-       To detect if a host id up or down.

-       Measure the RTT and its variation other the time.

-       Path used by packets to reach a destination.

OAM in LPWAN is a little bit trickier since the bandwidth is limited and
extra traffic added by OAM can introduce perturbation on regular
transmission.

Two scenarios can be investigated:

-       OAM coming from internet. In that case, the NGW should act as a
proxy and handle specifically the OAM traffic.

-       OAM coming from LPWAN devices: This can be included into regular
devices but some specific devices may be installed in the LPWAN network to
measure its quality.

Anyway, in some cases, the AOM should be sent

On Fri, Jan 18, 2019 at 6:22 PM Prof. Diego Dujovne <
[email-masked]> wrote:

>>         technologies including LoRa, SIGFOX, NBIOT and 802.15.4w..
>>
>>
>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 30 Jan 2019 13:38:59 +0000

Dear all

I’d like to discuss the scope of the ICMP work at the interim today. We will have Dominique presenting on his new draft, and beyond that I wonder what are the KPI that are specific to LPWAN and need observing.

Talking with Laurent in the context of CoAP Con messages, it appears that the queue at the NGW towards the device is one critical resource to observe in particular in asymmetric operations similar to LoRa class A.

I have in mind that the OAM should be able to return the current latency of the queue. This could be done by pinging the device with a long time out. This could also be done by having the NGW respond to the ping on behalf of the device with an indication of the latency (time spent in that queue) of the most recent message to the device.

Regards

Pascal

From: Laurent Toutain <[email-masked]>
Sent: jeudi 24 janvier 2019 16:27
To: Prof. Diego Dujovne <[email-masked]>
Cc: BARTHEL Dominique IMT/OLPS <[email-masked]>; lp-wan <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>
Subject: Re: [lp-wan] charter v2

OAM uses specific messages sent into the data plane to measure some parameters of a network. Most of the time no explicit values are sent is these messages. Network parameters are obtained from the analysis of these specific messages.

This can be used:

OAM in LPWAN is a little bit trickier since the bandwidth is limited and extra traffic added by OAM can introduce perturbation on regular transmission.

-       OAM coming from internet. In that case, the NGW should act as a proxy and handle specifically the OAM traffic.

-       OAM coming from LPWAN devices: This can be included into regular devices but some specific devices may be installed in the LPWAN network to measure its quality.

On Fri, Jan 18, 2019 at 6:22 PM Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,
             Same for me, I missed the call but I do
agree with the charter.
Thank you.
Regards,

                           Diego

Le ven. 18 janv. 2019 à 14:16, <[email-masked]<mailto:[email-masked]>> a écrit :
Hello all,

Dominique

Dear all ;

The chairs

Charter LPWAN 2.0

        The group will:

Thank you.
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

--
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan