Subject: [lp-wan] SCHC C library

From: Bart Moons <[email-masked]>
Date: Wed, 18 Dec 2019 13:33:43 +0100

Dear all,

Last few months we worked hard on the implementation of the SCHC standard and now I'm pleased to share the library with you, available here: https://github.com/imec-idlab/libschc .
The implementation is based on draft-18, but provides a good starting point for experimenting and future implementations.
Feel free to comment and contribute!

Best regards,
Bart

Bart Moons
Ghent University - imec
IDLab

iGent Tower - Department of Information Technology
Technologiepark-Zwijnaarde 15, B-9052 Ghent, Belgium (https://maps.google.com/?q=Technologiepark-Zwijnaarde%2015%2C%20B-9052%20Ghent%2C%20Belgium)

[email-masked] (mailto:[email-masked]) +32 472 42 23 91 (tel:%20+32%20472%2042%2023%2091)
http://IDLab.UGent.be
http://idlab.technology

---

From: <[email-masked]>
Date: Wed, 18 Dec 2019 13:03:04 +0000

Hello Bart,

This is great news, thanks a lot for your work and for letting us know!
We are currently discussing an interop at Hackathon107 (Vancouver).
Do you plan on attending physically? Otherwise, would you be willing to participate remotely?
Best regards

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Bart Moons <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 18 December 2019 13:33
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] SCHC C library

Dear all,

Best regards,
Bart

Bart Moons
Ghent University - imec
IDLab

iGent Tower - Department of Information Technology
Technologiepark-Zwijnaarde 15, B-9052 Ghent, Belgium<https://maps.google.com/?q=Technologiepark-Zwijnaarde%2015%2C%20B-9052%20Ghent%2C%20Belgium>
[email-masked]<mailto:[email-masked]> +32 472 42 23 91<tel:%20+32%20472%2042%2023%2091>
http://IDLab.UGent.be
http://idlab.technology

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 18 Dec 2019 13:03:08 +0000

Thanks, Bart. That’s quite timely.

From: lp-wan <[email-masked]> On Behalf Of Bart Moons
Sent: Wednesday, December 18, 2019 1:34 PM
To: [email-masked]
Subject: [lp-wan] SCHC C library

Dear all,

Best regards,
Bart

Bart Moons
Ghent University - imec
IDLab
iGent Tower - Department of Information Technology
Technologiepark-Zwijnaarde 15, B-9052 Ghent, Belgium<https://maps.google.com/?q=Technologiepark-Zwijnaarde%2015%2C%20B-9052%20Ghent%2C%20Belgium>
[email-masked]<mailto:[email-masked]> +32 472 42 23 91<tel:%20+32%20472%2042%2023%2091>
http://IDLab.UGent.be
http://idlab.technology
[Sent from Mailspring]
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 18 Dec 2019 16:08:14 +0100

Yes, excellent news !

Hope to see you in Vancouver (or remotely) and during the interim meetings!

Cheers,
Alexander

On Wed, Dec 18, 2019, 14:03 Hannes Tschofenig <[email-masked]>
wrote:

> *From:* lp-wan <[email-masked]> *On Behalf Of *Bart Moons
> *Sent:* Wednesday, December 18, 2019 1:34 PM
> *To:* [email-masked]
> *Subject:* [lp-wan] SCHC C library
>
>
>
> Dear all,
>
>
>
> Last few months we worked hard on the implementation of the SCHC standard
> and now I'm pleased to share the library with you, available here:
> https://github.com/imec-idlab/libschc .
>
> The implementation is based on draft-18, but provides a good starting
> point for experimenting and future implementations.
>
> *Bart Moons*
> Technologiepark-Zwijnaarde 15, B-9052 Ghent, Belgium
> <https://maps.google.com/?q=Technologiepark-Zwijnaarde%2015%2C%20B-9052%20Ghent%2C%20Belgium>
>
> [email-masked] +32 472 42 23 91 <%20+32%20472%2042%2023%2091>
>
> http://IDLab.UGent.be
>
> http://idlab.technology
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Bart Moons <[email-masked]>
Date: Wed, 18 Dec 2019 16:11:30 +0100

Hi Dominique,

I might travel to Vancouver, but Madrid (108) seems more feasible. I will for sure try to participate remotely!
Regards,
Bart

Bart Moons
Ghent University - imec
IDLab

On Dec 18 2019, at 2:03 pm, [email-masked] wrote:
> De : lp-wan <[email-masked] (mailto:[email-masked])> on behalf of Bart Moons <[email-masked] (mailto:[email-masked])>
> À : "[email-masked] (mailto:[email-masked])" <[email-masked] (mailto:[email-masked])>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 18 Dec 2019 12:18:59 -0300

Great news!
I have checked the implementation and it is pretty complete.
It is nice to have a C-version for embedded systems. I hope
to try it next month.
Regards,

                        Diego Dujovne

Le mer. 18 déc. 2019 à 12:11, Bart Moons <[email-masked]> a écrit :

> De : lp-wan <[email-masked]> on behalf of Bart Moons <
> [email-masked]>
> À : "[email-masked]" <[email-masked]>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Khaled Q. Abdelfadeel" <[email-masked]>
Date: Wed, 18 Dec 2019 15:43:22 +0000

Thanks, Bart for the good work. I was wondering if you have some numbers
for the ROM and RAM requirements?

Best,
Khaled

On Wed, Dec 18, 2019 at 3:19 PM Prof. Diego Dujovne <
[email-masked]> wrote:

> Le mer. 18 déc. 2019 à 12:11, Bart Moons <[email-masked]
> <[email-masked]>> a écrit :
>
>> Hi Dominique,
>>
>> I might travel to Vancouver, but Madrid (108) seems more feasible.. I
>> will for sure try to participate remotely!
>>
>> Regards,
>> Bart
>>
>> *Bart Moons*
>> Ghent University - imec
>> IDLab

---

From: Bart Moons <[email-masked]>
Date: Wed, 18 Dec 2019 16:49:18 +0100

Hi Khaled,

You can find ROM and RAM usage in a paper we published ( http://hdl.handle.net/1854/LU-8613162 ).
These numbers depend on the configuration of the library and also the rules have a large impact on the ROM usage.

Regards,
Bart

Bart Moons
Ghent University - imec
IDLab

On Dec 18 2019, at 4:43 pm, Khaled Q. Abdelfadeel <[email-masked]> wrote:
> Thanks, Bart for the good work. I was wondering if you have some numbers for the ROM and RAM requirements?
>
> Best,
> Khaled
>
>
> On Wed, Dec 18, 2019 at 3:19 PM Prof. Diego Dujovne <[email-masked] (mailto:[email-masked])> wrote:
> > Great news!
> > Le mer. 18 déc. 2019 à 12:11, Bart Moons <[email-masked] (mailto:[email-masked])> a écrit :
> > > Hi Dominique,
> > >
> > > I might travel to Vancouver, but Madrid (108) seems more feasible.. I will for sure try to participate remotely!
> > > Regards,
> > > Bart
> > >
> > > Bart Moons
> > > Ghent University - imec
> > > IDLab
> > >
> > >
> > > On Dec 18 2019, at 2:03 pm, [email-masked] (mailto:[email-masked]) wrote:
> > > >
> > > > Hello Bart,
> > > >
> > > [email-masked] (mailto:[email-masked])
> > www.ingenieria.udp.cl (http://www.ingenieria.udp.cl)
> > (56 2) 676 8125
> >
> >
> >
> >
> >
> > [email-masked] (mailto:[email-masked])