Subject: [lp-wan] Doub about sending missing tiles

From: Rodrigo Muñoz Lara <[email-masked]>
Date: Fri, 27 Dec 2019 10:33:58 -0300

Dear Author,

I have a question about draft "draft-ietf-lpwan-ipv6-static-context-hc-24".
In section 8.3.1.2 say:

"*On receiving a SCHC ACK, if the W field in the SCHC ACK not corresponds
to the last window of the SCHC Packet:*

   -

   *MUST send SCHC Fragment messages containing the tiles that
reported missing in the SCHC ACK*"

What happened if the missing tiles do not fit in a SCHC fragment?

Regards

---

From: <[email-masked]>
Date: Mon, 30 Dec 2019 17:29:53 +0000

Hello Rodrigo,

Thanks for you mail.
I'm unsure about what part of the text you actually refer to.
Section 8.3.1.2 is about the All-1 Fragment SCHC format
https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-24#section-8.3.1.2

From the text you quote, I think you are talking about the Sender Behavior of Ack-on-Error mode (section (8.4.3.1).
In this section, we are simply saying that the Sender must resend the missing tiles. It may use several Fragments for this.
It does not matter that the tiles are re-send packed the same way in SCHC Fragments as they were packed in the initial transmission.
Typically, if the MTU has changed to a lower value since the initial transmission, the retransmitted tiles will have to be packed in a different way (less tiles per SCHC Fragment).
Does this answer your question?
Best regards, and happy end of year

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Rodrigo Muñoz Lara <[email-masked]<mailto:[email-masked]>>
Date : Friday 27 December 2019 14:33
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Sandra Cespedes <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] Doub about sending missing tiles

Dear Author,

I have a question about draft "draft-ietf-lpwan-ipv6-static-context-hc-24". In section 8.3.1.2 say:

"On receiving a SCHC ACK, if the W field in the SCHC ACK not corresponds to the last window of the SCHC Packet:

  *

MUST send SCHC Fragment messages containing the tiles that reported missing in the SCHC ACK"

Regards

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.