Subject: [Lsr] RtgDir review: draft-ietf-isis-segment-routing-extensions-20

From: <[email-masked]>
Date: Sat, 10 Nov 2018 10:50:34 -0500

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-isis-segment-routing-extensions-20
Reviewer: Russ White
Review Date: 10 November 2018
IETF LC End Date: 12 December 2018
Intended Status: Standards Track

Summary: 

This document is basically ready for publication, but has nits that should be considered prior to publication.

Overall, this document is well written, and the mechanisms described are well thought out. 

Major Issues:

No major issues found.

Minor Issues:

No minor issues found.

Nits:

Section 2.1

Algorithms identifiers are defined in Section 3.2.

"Algorithm" rather than "Algorithms."

Sections 2.1 and 2.2

"Length" is listed as "variable," but not further definition is provided. From the text it seems like valid values here would be 3 or 20, in octets, as this is explicit in section 2.3, but it might be good to clarify (ie, just copy the text for "Length" in section 2.3 to these sections as well).

😊 /r

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 10 Nov 2018 23:24:31 +0000

Hi Russ, 

Thanks much for the fast turnaround on the review!

Les, et al,

Go ahead and publish a -21 version to address these comments. I would guess it is going to be awhile until Alvaro gets to this document as he said he was back traveling in next week - better him than me __

Thanks,
Acee

On 11/10/18, 10:50 AM, "[email-masked]" <[email-masked]> wrote:

    Hello,

    
    
    Summary: 

    
    Major Issues:
    
    No major issues found.
    
    Minor Issues:
    
    No minor issues found.
    
    Nits:
    
    Section 2.1

    
    Sections 2.1 and 2.2

    😊 /r

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 11 Nov 2018 04:10:03 +0000

Russ -

Thanx for the review.
Responses inline.

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Saturday, November 10, 2018 7:51 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: RtgDir review: draft-ietf-isis-segment-routing-extensions-20
> 
> Hello,
> 
> I have been selected as the Routing Directorate reviewer for this draft. The
> Routing Directorate seeks to review all routing or routing-related drafts as
> they pass through IETF last call and IESG review, and sometimes on special
> request. The purpose of the review is to provide assistance to the Routing
> ADs. For more information about the Routing Directorate, please see 
> http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
> 
> Although these comments are primarily for the use of the Routing ADs, it
> would be helpful if you could consider them along with any other IETF Last
> Call comments that you receive, and strive to resolve them through
> discussion or by updating the draft.
> 

[Les:] Ack - thanx.

> Sections 2.1 and 2.2
> 
> "Length" is listed as "variable," but not further definition is provided. From
> the text it seems like valid values here would be 3 or 20, in octets, as this is
> explicit in section 2.3, but it might be good to clarify (ie, just copy the text for
> "Length" in section 2.3 to these sections as well).
> 
[Les:] The length of the sub-TLV  is variable because the length of the SID itself is variable.

Both sections have the text:

<snip>
SID/Index/Label: according to the V and L flags, it contains
      either:

      *  A 4 octet index defining the offset in the SID/Label space
         advertised by this router using the encodings defined in
         Section 3.1.  In this case the V and L flags MUST be unset.

      *  A 3 octet local label where the 20 rightmost bits are used for
         encoding the label value.  In this case the V and L flags MUST
         be set.
<end snip>

The text for Section 2.3 is necessarily different because there is no flags field in the SID/Label sub-TLV and there also are no additional fields in the sub-TLV other than the SID itself.

I therefore think the text as is should be fine - but I am open to suggestion.
Russ - could you review this one more time in light of the above and let me know what you think?

   Les