Subject: [Lsr] draft-ietf-ospf-ospfv3-segment-routing-extensions - small change

From: Peter Psenak <[email-masked]>
Date: Thu, 15 Nov 2018 15:48:10 +0100

Hi,

as a part of the RtgDir review we got a comment about the usage of the 
IA bit in the OSPFv3 Extended Prefix Range TLV (Section 5).

We defined this bit for OSPFv2 originally. In OSPFv2 Extended Prefix 
Range TLV is carried as a top level TLV of the Extended Prefix Opaque 
LSA, which is not specific to any route-type, so we needed a mechanism 
to prevent redundant flooding of Prefix Range TLVs between areas.

In OSPFv3 however, we are advertising the Extended Prefix Range TLV in 
the type specific LSAs, so we can use standard rules to prevent the 
"looping" of advertisements.

So we want to remove the IA bit from the flags field in OSPFv3 Extended 
Prefix Range TLV.

I would like to know whether anyone has any objection.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 15 Nov 2018 15:25:20 +0000

Hi Peter, 
I agree - it is not needed in OSPFv3 Extended LSAs.

Hi Dirk, Mahendra, 

How will this impact your implementations?

Thanks,
Acee

On 11/15/18, 9:48 AM, "Lsr on behalf of Peter Psenak (ppsenak)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    

    
    thanks,
    Peter
    
    _______________________________________________
    Lsr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lsr

---

From: Mahendra Singh Negi <[email-masked]>
Date: Fri, 16 Nov 2018 06:19:50 +0000

Hi Acee/Peter,

This change doesn't impact our implementation.

Thanks,
Mahendra

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: 15 November 2018 20:55
To: Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Cc: Goethals, Dirk (Nokia - BE/Antwerp) <[email-masked]>; Mahendra Singh Negi <[email-masked]>
Subject: Re: [Lsr] draft-ietf-ospf-ospfv3-segment-routing-extensions - small change

Hi Peter, 

Hi Dirk, Mahendra, 

Thanks,
Acee

    Hi,

    

    
    thanks,
    Peter

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 16 Nov 2018 16:39:47 -0500

Peter:

Hi!

-18 still has one reference to the IA-flag in §8.1.  Please remove it.

Thanks!

Alvaro.

On November 16, 2018 at 1:20:18 AM, Mahendra Singh Negi (
[email-masked]) wrote:

Hi Acee/Peter,

Thanks,
Mahendra

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: 15 November 2018 20:55
To: Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Cc: Goethals, Dirk (Nokia - BE/Antwerp) <[email-masked]>; Mahendra
Singh Negi <[email-masked]>
Subject: Re: [Lsr] draft-ietf-ospf-ospfv3-segment-routing-extensions -
small change

Hi Peter,

Hi Dirk, Mahendra,

Thanks,
Acee

On 11/15/18, 9:48 AM, "Lsr on behalf of Peter Psenak (ppsenak)" <
[email-masked] on behalf of [email-masked]> wrote:

Hi,

thanks,
Peter