Subject: [Lsr] Alissa Cooper's No Objection on draft-ietf-ospf-mpls-elc-13: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Wed, 20 May 2020 12:57:44 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-ospf-mpls-elc-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I wasn't clear on where the  thread ended up from the Gen-ART review, but I'm
nevertheless suggesting some text below to resolve the main sticking point.

OLD
If the router supports ELs on all of its interfaces, it SHOULD advertise the
ELC with every local host prefix it advertises in OSPF.

NEW
If the router supports ELs on all of its interfaces, it SHOULD advertise the
ELC with every local host prefix it advertises in OSPF. The absence of these
advertisements implies that advertisement of the ELC is not supported.

Not sure if that matches the intent though.

---

From: Peter Psenak <[email-masked]>
Date: Thu, 21 May 2020 09:51:13 +0200

Hi Alissa,

> https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

I added the suggested text, plus I added "OSPF" at the end. So the text is:

"If the router supports ELs on all of its interfaces, it SHOULD 
advertise the ELC with every local host prefix it advertises in OSPF. 
The absence of these advertisements implies that advertisement of the 
ELC is not supported in OSPF."

I added similar text to ISIS ELC draft.

thanks,
Peter

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 21 May 2020 09:09:13 -0400

Thanks!
Alissa

> On May 21, 2020, at 3:51 AM, Peter Psenak <[email-masked]> wrote:
> 
> Hi Alissa,
> 
> "If the router supports ELs on all of its interfaces, it SHOULD advertise the ELC with every local host prefix it advertises in OSPF. The absence of these advertisements implies that advertisement of the ELC is not supported in OSPF."
>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 21 May 2020 18:55:13 +0200

Alissa,

as Les correctly pointed out privately to me, this updated text is not 
entirely correct. Not advertising the ELC bit can be result of:

a) router not supporting this extension
b) router supporting this extension, but not supporting ELC

So I would rather keep the original text unchanged.

This is not anything new. This ambiguity is common for any new protocol 
extension that signals a boolean type of information.

thanks,
Peter

On 21/05/2020 15:09, Alissa Cooper wrote:
> Thanks!
> Alissa
> 
>> On May 21, 2020, at 3:51 AM, Peter Psenak <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Alissa,
>>