Subject: [Lsr] Warren Kumari's No Objection on draft-ietf-ospf-mpls-elc-13: (with COMMENT)

From: Warren Kumari via Datatracker <[email-masked]>
Date: Thu, 14 May 2020 18:25:50 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-ospf-mpls-elc-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Nit: “ When an OSPF Autonomous System Boundary Router (ASBR) redistributes a  
prefix from another instance of the OSPF or from some other protocol,   it
SHOULD preserve the ELC signaling for the prefix.“

S/the /OSPF/OSPF/.

S/for the prefix/for the prefix (if it exists)/ — some protocols will not have
/ carry the ELC.

Apologies if I missed it, but I didn’t see discussion on *exporting* ELC into
other protocols...

---

From: Peter Psenak <[email-masked]>
Date: Fri, 15 May 2020 13:28:11 +0200

Hi Warren,

> https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

fixed.

> S/for the prefix/for the prefix (if it exists)/ — some protocols will not have

fixed.

> Apologies if I missed it, but I didn’t see discussion on *exporting* ELC into

what do you mean by "exporting"?

thanks,
Peter

---

From: Warren Kumari <[email-masked]>
Date: Fri, 15 May 2020 13:25:06 -0400

On Fri, May 15, 2020 at 7:28 AM Peter Psenak <[email-masked]> wrote:

> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html

thanks!

> > S/for the prefix/for the prefix (if it exists)/ — some protocols will

thanks!

> what do you mean by "exporting"?

Sorry -- the above discusses : "When an OSPF Autonomous System Boundary
Router (ASBR) redistributes a prefix ... FROM some other protocol,  "
(imports), but presumably you would also like to be able to do "When an
OSPF Autonomous System Boundary Router (ASBR) redistributes a prefix
**INTO** some other protocol,  ..." (exports). Yes, the "other protocol"
document should describe this in detail, but I think that it is worth
mentioning the topic here -- we may be helpful for implementers to keep in
mind that this may occur, and so the data should be reachable
(likely through the RIB).

W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 15 May 2020 17:34:50 +0000

Hi Warren,

From: Warren Kumari <[email-masked]>
Date: Friday, May 15, 2020 at 1:25 PM
To: "Peter Psenak (ppsenak)" <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Acee Lindem <[email-masked]>, Alvaro Retana <[email-masked]>
Subject: Re: Warren Kumari's No Objection on draft-ietf-ospf-mpls-elc-13: (with COMMENT)
Resent-From: <[email-masked]>
Resent-To: Acee Lindem <[email-masked]>, Yingzhen Qu <[email-masked]>, Christian Hopps <[email-masked]>
Resent-Date: Friday, May 15, 2020 at 1:25 PM

On Fri, May 15, 2020 at 7:28 AM Peter Psenak <[email-masked]<mailto:[email-masked]>> wrote:
Hi Warren,

fixed.

thanks!

fixed.

thanks!

Sorry -- the above discusses : "When an OSPF Autonomous System Boundary Router (ASBR) redistributes a prefix ... FROM some other protocol,  " (imports), but presumably you would also like to be able to do "When an OSPF Autonomous System Boundary Router (ASBR) redistributes a prefix **INTO** some other protocol,  ..." (exports). Yes, the "other protocol" document should describe this in detail, but I think that it is worth mentioning the topic here -- we may be helpful for implementers to keep in mind that this may occur, and so the data should be reachable (likely through the RIB).

Can you suggest some text? Do you realize that in the Routing Area, route redistribution (aka, route import/export) has always been considered an implementation matter and is not formally specified. It would hard to standardize this now (other than Routing Policy YANG model) due to differences between implementations.

Thanks,
Acee

W

thanks,
Peter

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

---

From: Warren Kumari <[email-masked]>
Date: Fri, 15 May 2020 17:08:18 -0400

On Fri, May 15, 2020 at 1:34 PM Acee Lindem (acee) <[email-masked]> wrote:

> Hi Warren,
>
>
>
> *From: *Warren Kumari <[email-masked]>
> *Date: *Friday, May 15, 2020 at 1:25 PM
> *To: *"Peter Psenak (ppsenak)" <[email-masked]>
> *Cc: *The IESG <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>, Acee Lindem <
> [email-masked]>, Alvaro Retana <[email-masked]>
> *Subject: *Re: Warren Kumari's No Objection on
> draft-ietf-ospf-mpls-elc-13: (with COMMENT)
> *Resent-From: *<[email-masked]>
> *Resent-To: *Acee Lindem <[email-masked]>, Yingzhen Qu <
> [email-masked]>, Christian Hopps <[email-masked]>
> *Resent-Date: *Friday, May 15, 2020 at 1:25 PM
>
>
>
>
>
>
>
> Can you suggest some text? Do you realize that in the Routing Area, route
> redistribution (aka, route import/export) has always been considered an
> implementation matter and is not formally specified. It would hard to
> standardize this now (other than Routing Policy YANG model) due to
> differences between implementations.
>

Sure -- how about something like:
   When an OSPF Autonomous System Boundary Router (ASBR) redistributes a
   prefix from another instance of the OSPF or from some other protocol,
   it SHOULD preserve the ELC signaling for the prefix.
  **In addition ASBRs should allow the
  ELC signaling for the prefix to be preserved when redistributing
to another instance of OSPF or to some other protocol**

(Addition in asterisks).
Note that this is just a suggestion / not a hill I care to die on -- as an
ops person, when I read "you should be able to preserve X when importing
into Y", I automatically start wondering how / if I can preserve X when
exporting from Y.

But, 'm also fine if y'all don't want to address this,
W

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sat, 16 May 2020 00:06:57 +0000

Warren –

The problem I have with your suggestion is that we do not know whether the destination protocol for redistribution even supports the signaling.

I am very supportive of Acee’s characterization of redistribution as outside the scope of specification.

I think we can say what happens intra-protocol – but we should stay away from inter-protocol statements.

   Les

From: Lsr <[email-masked]> On Behalf Of Warren Kumari
Sent: Friday, May 15, 2020 2:08 PM
To: Acee Lindem (acee) <[email-masked]>
Cc: [email-masked]; Alvaro Retana <[email-masked]>; [email-masked]; The IESG <[email-masked]>; [email-masked]; Peter Psenak (ppsenak) <[email-masked]>
Subject: Re: [Lsr] Warren Kumari's No Objection on draft-ietf-ospf-mpls-elc-13: (with COMMENT)

On Fri, May 15, 2020 at 1:34 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Warren,

From: Warren Kumari <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 15, 2020 at 1:25 PM
To: "Peter Psenak (ppsenak)" <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Subject: Re: Warren Kumari's No Objection on draft-ietf-ospf-mpls-elc-13: (with COMMENT)
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Yingzhen Qu <[email-masked]<mailto:[email-masked]>>, Christian Hopps <[email-masked]<mailto:[email-masked]>>
Resent-Date: Friday, May 15, 2020 at 1:25 PM

fixed.

thanks!

fixed.

thanks!

  ELC signaling for the prefix to be preserved when redistributing to another instance of OSPF or to some other protocol**

(Addition in asterisks).
Note that this is just a suggestion / not a hill I care to die on -- as an ops person, when I read "you should be able to preserve X when importing into Y", I automatically start wondering how / if I can preserve X when exporting from Y.

Thanks,
Acee

W

thanks,
Peter

---

From: Warren Kumari <[email-masked]>
Date: Fri, 15 May 2020 21:41:18 -0400

On Fri, May 15, 2020 at 8:07 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Warren –
>
>
>
> The problem I have with your suggestion is that we do not know whether the
> destination protocol for redistribution even supports the signaling.
>
>
>
Okey dokey, I’m convinced...

Thanks, w

> *From:* Lsr <[email-masked]> *On Behalf Of * Warren Kumari
> *Sent:* Friday, May 15, 2020 2:08 PM
> *To:* Acee Lindem (acee) <[email-masked]>
> *Cc:* [email-masked]; Alvaro Retana <
> [email-masked]>; [email-masked]; The IESG <[email-masked]>;
> [email-masked]; Peter Psenak (ppsenak) <[email-masked]>
> *Subject:* Re: [Lsr] Warren Kumari's No Objection on
>  it