Subject: [Lsr] draft-ietf-lsr-flex-algo

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Fri, 8 May 2020 13:37:27 +0000

Hi authors:

After reading through this draft lsr-flex-algo, I want to know whether there is a potential goal of this draft to reduce the SRH size with enabling flex-algo with admin group in SRv6 deployment, because without flex-algo we have to have a big SRH size when the SRH include more SRv6 SIDs, if we enable flex-algo under special topology and link constraint condition, in theory we can even construct  a end to end SR path/tunnel without SRH, but it still meet TE requirement. So my question is whether the flex-algo can be used as tool to reduce SRH size?

Cheers !

WANG Weibin

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sat, 9 May 2020 06:51:40 +0000

Hi Wang,

You are correct. Though I wouldn't call it a goal but rather a benefit/advantage - same applies to SR-MPLS where the label stack can be reduced.

Thanks,
Ketan

From: Lsr <[email-masked]> On Behalf Of Wang, Weibin (NSB - CN/Shanghai)
Sent: 08 May 2020 19:07
To: [email-masked]
Subject: [Lsr] draft-ietf-lsr-flex-algo

Hi authors:

Cheers !

WANG Weibin

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Sat, 9 May 2020 08:27:10 +0000

Ketan, thank you for clarification.

Cheers!

Wang Weibin

From: Ketan Talaulikar (ketant) <[email-masked]>
Sent: 2020年5月9日 14:52
To: Wang, Weibin (NSB - CN/Shanghai) <[email-masked]>; [email-masked]
Subject: RE: draft-ietf-lsr-flex-algo

Hi Wang,

You are correct. Though I wouldn’t call it a goal but rather a benefit/advantage – same applies to SR-MPLS where the label stack can be reduced.

Thanks,
Ketan

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Wang, Weibin (NSB - CN/Shanghai)
Sent: 08 May 2020 19:07
To: [email-masked]<mailto:[email-masked]>
Subject: [Lsr] draft-ietf-lsr-flex-algo

Hi authors:

Cheers !

WANG Weibin

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 9 May 2020 12:23:33 -0700

Weibin,

One could have an algo with MSD/ERLD as optimizations constrains, would be quite similar to colored links. Note - ERLD has implemented node capabilities only, so all links on a node will have to be pruned.
The tradeoffs are - having centralized controller with global view computing a path that meets the constraints(classical BGP-LS + PCEP scenario) vs building a dynamic topology of connected nodes that meet a set of constrains, in first case, change in topology/capabilities would cause path recalculation/reoptimization on the PCE while in the second - IGP would recompute the topology locally.

Regards,
Jeff

> On May 9, 2020, at 01:27, Wang, Weibin (NSB - CN/Shanghai) <[email-masked]> wrote:
> 
> 
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Sun, 10 May 2020 01:25:02 +0000

Jeff, I see what you said, thank you for sharing information;

Cheers!

Wang Weibin

From: Jeff Tantsura <[email-masked]>
Sent: 2020年5月10日 3:24
To: Wang, Weibin (NSB - CN/Shanghai) <[email-masked]>
Cc: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]
Subject: Re: [Lsr] draft-ietf-lsr-flex-algo

Weibin,

Regards,
Jeff

On May 9, 2020, at 01:27, Wang, Weibin (NSB - CN/Shanghai) <[email-masked]<mailto:[email-masked]>> wrote:

Cheers!

Wang Weibin

From: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Sent: 2020年5月9日 14:52
To: Wang, Weibin (NSB - CN/Shanghai) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-ietf-lsr-flex-algo

Hi Wang,

Thanks,
Ketan

Hi authors:

Cheers !

WANG Weibin
_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 18 May 2020 21:52:02 -0400

Flex algo is usually mentioned in the context of SR-TE to help reduced SRH
size to circumvent MSD issues for both SRV6 and SR-MPLS, however can the
0-127 flex algo extensions since it’s an IGP extension used in any pure IP
network independent of SR flavors SR-MPLS or SRv6.

Also can flex algo be used in conjunction with RSVP-TE or PPR(preferred
path routing).

Kind regards

Gyan

On Sat, May 9, 2020 at 9:25 PM Wang, Weibin (NSB - CN/Shanghai) <
[email-masked]> wrote:

> *From:* Jeff Tantsura <[email-masked]>
> *Sent:* 2020年5月10日 3:24
> *To:* Wang, Weibin (NSB - CN/Shanghai) <[email-masked]>
> *Cc:* Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]
> *Subject:* Re: [Lsr] draft-ietf-lsr-flex-algo
>
>
>
> Weibin,
>
>
>
> One could have an algo with MSD/ERLD as optimizations constrains, would be
> quite similar to colored links. Note - ERLD has implemented node
> capabilities only, so all links on a node will have to be pruned.
>
> The tradeoffs are - having centralized controller with global view
> computing a path that meets the constraints(classical BGP-LS + PCEP
> scenario) vs building a dynamic topology of connected nodes that meet a set
> of constrains, in first case, change in topology/capabilities would cause
> path recalculation/reoptimization on the PCE while in the second - IGP
> would recompute the topology locally.
>
>
>
> Regards,
>
> Jeff
>
>
>
> *From:* Ketan Talaulikar (ketant) <[email-masked]>
> *Sent:* 2020年5月9日 14:52
> *To:* Wang, Weibin (NSB - CN/Shanghai) <[email-masked]>;
> [email-masked]
> *Subject:* RE: draft-ietf-lsr-flex-algo
>
>
>
> Hi Wang,
>
>
>
> You are correct. Though I wouldn’t call it a goal but rather a
> benefit/advantage – same applies to SR-MPLS where the label stack can be
> reduced.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* Lsr <[email-masked]> *On Behalf Of *Wang, Weibin (NSB -
> CN/Shanghai)
> *Sent:* 08 May 2020 19:07
> *To:* [email-masked]
> *Subject:* [Lsr] draft-ietf-lsr-flex-algo
>
>
>
> Hi authors:
>
>
>
> After reading through this draft lsr-flex-algo, I want to know whether
> there is a potential goal of this draft to reduce the SRH size with
> enabling flex-algo with admin group in SRv6 deployment, because without
> flex-algo we have to have a big SRH size when the SRH include more SRv6
> SIDs, if we enable flex-algo under special topology and link constraint
> condition, in theory we can even construct  a end to end SR path/tunnel
> without SRH, but it still meet TE requirement. So my question is whether
> the flex-algo can be used as tool to reduce SRH size?
>
>
>
>
>
>
>
> *Cheers !*
>
>
>
> *WANG Weibin*
>
-- 

Gyan  Mishra

Network Engineering & Technology

Verizon

Silver Spring, MD 20904

Phone: 301 502-1347

Email: [email-masked]

---

From: Peter Psenak <[email-masked]>
Date: Tue, 19 May 2020 09:38:08 +0200

Gyan,

On 19/05/2020 03:52, Gyan Mishra wrote:
> 
> Flex algo is usually mentioned in the context of SR-TE to help reduced 
> SRH size to circumvent MSD issues for both SRV6 and SR-MPLS, 

though segment list reduction may be seen as one of the benefits of the 
flex-algo, it is certainly not the primary motivation behind it. The 
primary motivation of flex-algo is to provide dynamic any to any 
constrained based routing.

> however can 
> the 0-127 flex algo extensions since it’s an IGP extension used in any 
> pure IP network independent of SR flavors SR-MPLS or SRv6.

SR/SRv6 is used as a dataplane. Any data plane can be used, if it 
provides a way to route an algo specific traffic.

> Also can flex algo be used in conjunction with RSVP-TE or PPR(preferred 

same answer as above.

thanks,
Peter

> 
> Kind regards
> 
> Gyan
> 
> On Sat, May 9, 2020 at 9:25 PM Wang, Weibin (NSB - CN/Shanghai) 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Jeff, I see what you said, thank you for sharing information;____
> 
>     __ __
> 
>     __ __
> 
>     __ __
> 
>     Cheers!
> 
>     ____
> 
>     __ __
> 
>     Wang Weibin____
> 
>     __ __
> 
>     *From:* Jeff Tantsura <[email-masked]
>     <mailto:[email-masked]>>
>     *Sent:* 2020年5月10日 3:24
>     *To:* Wang, Weibin (NSB - CN/Shanghai) <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Ketan Talaulikar (ketant) <[email-masked]
>     <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Lsr] draft-ietf-lsr-flex-algo____
> 
>     __ __
> 
>     Weibin,____
> 
>     __ __
> 
>     One could have an algo with MSD/ERLD as optimizations constrains,
>     would be quite similar to colored links. Note - ERLD has implemented
>     node capabilities only, so all links on a node will have to be
>     pruned.____
> 
>     scenario) vs building a dynamic topology of connected nodes that
>     meet a set of constrains, in first case, change in
>     topology/capabilities would cause path recalculation/reoptimization
>     on the PCE while in the second - IGP would recompute the topology
>     locally.____
> 
>     __ __
> 
>     Regards,____
> 
>     Jeff____
> 
> 
> 
>     ____
> 
>         On May 9, 2020, at 01:27, Wang, Weibin (NSB - CN/Shanghai)
>         <[email-masked]
>         <mailto:[email-masked]>> wrote:____
> 
>         ____
> 
>         Ketan, thank you for clarification.____
> 
>         ____
> 
>         ____
> 
>         ____
> 
>         Cheers!____
> 
>         ____
> 
>         Wang Weibin____
> 
>         ____
> 
>         *From:* Ketan Talaulikar (ketant) <[email-masked]
>         <mailto:[email-masked]>>
>         *Sent:* 2020年5月9日 14:52
>         *To:* Wang, Weibin (NSB - CN/Shanghai)
>         <[email-masked]
>         <mailto:[email-masked]>>; [email-masked]
>         <mailto:[email-masked]>
>         *Subject:* RE: draft-ietf-lsr-flex-algo____
> 
>         ____
> 
>         Hi Wang,____
> 
>         ____
> 
>         benefit/advantage – same applies to SR-MPLS where the label
>         stack can be reduced.____
> 
>         ____
> 
>         Thanks,____
> 
>         Ketan____
> 
>         ____
> 
>         *From:* Lsr <[email-masked] <mailto:[email-masked]>>
>         *On Behalf Of *Wang, Weibin (NSB - CN/Shanghai)
>         *To:* [email-masked] <mailto:[email-masked]>
>         *Subject:* [Lsr] draft-ietf-lsr-flex-algo____
> 
>         ____
> 
>         Hi authors:____
> 
>         ____
> 
>         After reading through this draft lsr-flex-algo, I want to know
>         whether there is a potential goal of this draft to reduce the
>         SRH size with enabling flex-algo with admin group in SRv6
>         deployment, because without flex-algo we have to have a big SRH
>         size when the SRH include more SRv6 SIDs, if we enable flex-algo
>         under special topology and link constraint condition, in theory
>         we can even construct  a end to end SR path/tunnel without SRH,
>         but it still meet TE requirement. So my question is whether the
>         flex-algo can be used as tool to reduce SRH size?____
> 
>         ____
> 
>         ____
> 
>         ____
> 
>         /Cheers !/____
> 
>         **____
> 
>         *WANG Weibin*____
> 
>         [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mailman/listinfo/lsr____
> 
>     [email-masked] <mailto:[email-masked]>
> Email: [email-masked] <mailto:[email-masked]>
> 
> 
>

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 19 May 2020 18:37:14 -0400

> provides a way to route an algo specific traffic.

    Gyan> Please clarify.  I would think that since the flex algo
capability is part of the IGP independent of the data plane is what you are
saying, so any data plane can use the feature.

So you are saying even if it can that their maybe a data plane specific
algo awareness to be able to use or route the algo specific traffic.  So
for example can native IPv4 or IPv6 date plane can it without any specific
algo awareness can it utilitize flex algo constraint based steering.  Also
others mentioned is their special hooks or programming required to make it
work with RSVP-TE or PPR.

> >         flex-algo can be used as tool to reduce SRH size?____

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Peter Psenak <[email-masked]>
Date: Wed, 20 May 2020 10:16:00 +0200

On 20/05/2020 00:37, Gyan Mishra wrote:
> 
> 
> 
> On Tue, May 19, 2020 at 3:38 AM Peter Psenak <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Gyan,
> 
> capability is part of the IGP independent of the data plane is what you 
> are saying, so any data plane can use the feature.

not really. You need to have a way to forward traffic for different 
algos over different paths.

> for example can native IPv4 or IPv6 date plane can it without any 
> specific algo awareness can it utilitize flex algo constraint based 
> steering.  

if you have IP prefix P1 and you want to be able to send the traffic to 
it via 3 different paths via native IPv4 network how would you do that?

> Also others mentioned is their special hooks or programming 
> required to make it work with RSVP-TE or PPR.
> 

I let RSVP experts to find a way how to use the flex-algo paths. I'm 
sure there are ways to do so :)

thanks,
Peter

>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>      >     *Sent:* 2020年5月10日 3:24
>     <[email-masked] <mailto:[email-masked]>
>      >     <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>>>;
>     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     <mailto:[email-masked]>
>      >         <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:____
>      >
>      >         ____
>      >
>     <mailto:[email-masked]>
>      >         <mailto:[email-masked] <mailto:[email-masked]>>>
>      >         *Sent:* 2020年5月9日 14:52
>     <mailto:[email-masked]>
>      >         <mailto:[email-masked]
>     <mailto:[email-masked]>>>; [email-masked]
>     <mailto:[email-masked]>
>      >         <mailto:[email-masked] <mailto:lsr@ietf..org>>
>      >         *From:* Lsr <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >
>      >
>      >
> 
> -- 
> 
> /Network Solutions A//rchitect /
> 
> /M 301 502-1347
> 13101 Columbia Pike
> /Silver Spring, MD
> 
>

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 20 May 2020 11:44:16 -0400

> algos over different paths.

   Gyan> That is what I was expecting. So the flex algo draft talks in the
context of SR-MPLS and SRV6 as those are the two data planes currently
supported.  Any other data planes would require development of a
specification to use flex algo, but more so an industry business need or
gap that is being filled with the development.  SRv6 has more ubiquitous
use cases then SR-MPLS, so both together cover most every use case
requiring steering.  So then is their a need to steer with native IPV4 or
IPV6.

*Gyan Mishra*