Subject: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 15 May 2020 19:39:46 +0000

This begins a 3 week (due to holidays) WG adoption call for the “Flooding Topology Computation Algorithm” draft. Please issue your support or objection to this list by 11:59 PM, UTC on June 5th, 2020. Here is a URL for your convenience.

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/

Thanks,
Acee

---

From: Huaimo Chen <[email-masked]>
Date: Sat, 16 May 2020 00:53:17 +0000

Support.

Best Regards,
Huaimo as co-author
________________________________
From: Lsr <[email-masked]> on behalf of Acee Lindem (acee) <acee=[email-masked]>
Sent: Friday, May 15, 2020 3:39 PM
To: [email-masked] <[email-masked]>
Subject: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C85d75c098f3e415eda0508d7f907c4fc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637251684079273956&sdata=9JPE4sYiSzUvjpQKav7k3nSjvFYcjG6Y4ZWRIb1pNe8%3D&reserved=0>

Thanks,
Acee

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 18 May 2020 15:50:59 +0800

Yes, support as co-author.

The algorithm is needed for the flooding reduction deployment and should be standardized especially in distributed mode.

Best Regards.

Aijun Wang

China Telecom

发件人: [email-masked] [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2020年5月16日 3:40
收件人: [email-masked]
主题: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks,
Acee

---

From: Yanhe Fan <[email-masked]>
Date: Mon, 18 May 2020 19:37:23 +0000

Support it as a co-author.

Thanks,
Yanhe

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Friday, May 15, 2020 3:40 PM
To: [email-masked]
Subject: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks,
Acee

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 19 May 2020 02:39:45 -0400

I support WG adoption and have a few questions related to the draft.

Does this flooding algorithm use the dynamic flooding algorithm used in
data center clos dense meshed topologies with many ECMP paths where the
flood is decoupled from the physical topology.  In the dynamic flooding
algorithm mentioned in centralized mode the flooding is computed by the
area leader and distributed to all nodes.  In distributed mode each mode
the area leader determines the algorithm and then each node computes the
flooding topology based on the algorithm.

This dynamic algorithm for optimized flood reduction would reduce the
amount of redundant flooding in highly densely meshed ospf or Isis
topologies.  So this optimization of flooding would improving overall link
state routing protocol convergence.

Gyan

On Mon, May 18, 2020 at 3:37 PM Yanhe Fan <[email-masked]> wrote:

> *From:* Lsr <[email-masked]> *On Behalf Of *Acee Lindem (acee)
> *Sent:* Friday, May 15, 2020 3:40 PM
> *To:* [email-masked]
> *Subject:* [Lsr] Flooding Topology Computation Algorithm -
> draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call
>
>
>
> This begins a 3 week (due to holidays) WG adoption call for the “Flooding
> Topology Computation Algorithm” draft. Please issue your support or
> objection to this list by 11:59 PM, UTC on June 5th, 2020. Here is a URL
> for your convenience.
>
>
>
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 19 May 2020 14:57:58 +0000

Support the WG Adoption.

Linda Dunbar

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Acee Lindem (acee)
Sent: Friday, May 15, 2020 3:40 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C5734ce330848415ad72108d7fb62ec30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637254274611408698&sdata=rOiq%2FeRJv6O8Jy2KKHsnj6DMZLFxQUpyP8qopwYCxjI%3D&reserved=0>

Thanks,
Acee

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 20 May 2020 03:52:22 +0000

Hi Gyan,

    Thank you very much for your questions and support.

    This Flooding Topology Computation algorithm can be used in the Dynamic Flooding on Dense Graphs to compute the flooding topologies for the data center clos dense meshed topologies with many ECMP paths. It can be used by the area leader in the centralized mode to compute the flooding topology.

Best Regards,
Huaimo
________________________________
From: Lsr <[email-masked]> on behalf of Gyan Mishra <[email-masked]>
Sent: Tuesday, May 19, 2020 2:39 AM
To: Yanhe Fan <[email-masked]>
Cc: [email-masked] <[email-masked]>; Acee Lindem (acee) <acee=[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Does this flooding algorithm use the dynamic flooding algorithm used in data center clos dense meshed topologies with many ECMP paths where the flood is decoupled from the physical topology.  In the dynamic flooding algorithm mentioned in centralized mode the flooding is computed by the area leader and distributed to all nodes.  In distributed mode each mode the area leader determines the algorithm and then each node computes the flooding topology based on the algorithm.

This dynamic algorithm for optimized flood reduction would reduce the amount of redundant flooding in highly densely meshed ospf or Isis topologies.  So this optimization of flooding would improving overall link state routing protocol convergence.

Gyan

On Mon, May 18, 2020 at 3:37 PM Yanhe Fan <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267311232&sdata=yBEjECqdVgodmO5T3C%2FRQE21bFKOWX6lpJA0CMdJ18A%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267311232&sdata=hTQLnO1j3UqxcJP2hEs9DpYQiSOZpw00SF2LNrwgtKc%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267321230&sdata=mYvXS9UFr523Pxr9%2B3Il52dsAEPsTWglyYsCtUDUdo0%3D&reserved=0>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: LEI LIU <[email-masked]>
Date: Wed, 20 May 2020 07:58:13 -0700

Thanks,

Best regards,

Lei

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 20 May 2020 11:14:39 -0400

Huaimo

This is a much needed feature that operators have been needing for densely
meshed topologies that commonly exist in data centers to accommodate very
high bandwidth E-W traffic.

Below is link from Cisco which has introduced feature for dynamic flooding
in clos high density ECMP data center topologies.

Please look at the feature description and it does seem to be exactly the
same as this draft.  Please confirm.

There maybe other vendors due to industry demand have to get the feature
deployed before it reaches standards vendor consensus with the IETF.

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html

We are testing this feature and planning to deploy but wanted to ensure
that this is the same as the draft on the standards track.

Kind regards

Gyan

On Tue, May 19, 2020 at 11:52 PM Huaimo Chen <[email-masked]>
wrote:

>     This Flooding Topology Computation algorithm can be used in the Dynamic
> Flooding on Dense Graphs to compute the flooding topologies for the data
> center clos dense meshed topologies with many ECMP paths. It can be used by
> the area leader in the centralized mode to compute the flooding topology.
>
> Best Regards,
> Huaimo
> ------------------------------
> *From:* Lsr <[email-masked]> on behalf of Gyan Mishra <
> [email-masked]>
> *Sent:* Tuesday, May 19, 2020 2:39 AM
> *To:* Yanhe Fan <[email-masked]>
> *Cc:* [email-masked] <[email-masked]>; Acee Lindem (acee) <acee=
> [email-masked]>
> *Subject:* Re: [Lsr] Flooding Topology Computation Algorithm -
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267311232&sdata=yBEjECqdVgodmO5T3C%2FRQE21bFKOWX6lpJA0CMdJ18A%3D&reserved=0>
>
>
>
> Thanks,
> Acee
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267311232&sdata=hTQLnO1j3UqxcJP2hEs9DpYQiSOZpw00SF2LNrwgtKc%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C67789a4ab2b84b08385508d7fbbf82c1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637254672267321230&sdata=mYvXS9UFr523Pxr9%2B3Il52dsAEPsTWglyYsCtUDUdo0%3D&reserved=0>
>
> <https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>
> *Gyan Mishra*
>
> *M 301 502-1347 13101 Columbia Pike
> <https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
> *Silver Spring, MD
> <https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>
> --

*Gyan Mishra*

---

From: [email-masked]
Date: Wed, 20 May 2020 08:48:27 -0700

Hi Gyan,

> This is a much needed feature that operators have been needing for densely meshed topologies that commonly exist in data centers to accommodate very high bandwidth E-W traffic.

Thank you.

> Please look at the feature description and it does seem to be exactly the same as this draft.  Please confirm. 

It would appear to be a different, proprietary, and unpublished algorithm.  

This will give us three different implementations, using three different algorithms, none of which will inter-operate.  Whee!!! :-(

> There maybe other vendors due to industry demand have to get the feature deployed before it reaches standards vendor consensus with the IETF.

Our implementation shipped last year.

> We are testing this feature and planning to deploy but wanted to ensure that this is the same as the draft on the standards track.

It does not appear to be, but someone from Cisco should confirm.

Tony

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 21 May 2020 03:59:09 +0000

Hi Gyan,

    Thanks much for your questions. My answers are inline below with [HC].

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]>
Sent: Wednesday, May 20, 2020 11:14 AM
To: Huaimo Chen <[email-masked]>
Cc: Acee Lindem (acee) <acee=[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Huaimo

This is a much needed feature that operators have been needing for densely meshed topologies that commonly exist in data centers to accommodate very high bandwidth E-W traffic.
[HC]: Thank you very much.

Below is link from Cisco which has introduced feature for dynamic flooding in clos high density ECMP data center topologies.

Please look at the feature description and it does seem to be exactly the same as this draft.  Please confirm.
[HC]: It seems different.

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949669307&sdata=9nLFlmBSFxBQayL0fCiq864Ylvzyksk3U0GmZPbhPts%3D&reserved=0>

We are testing this feature and planning to deploy but wanted to ensure that this is the same as the draft on the standards track.
[HC]: The feature appears implemented draft "Dynamic Flooding on Dense Graphs", which does not include any flooding topology computation algorithm.

Kind regards

Gyan

On Tue, May 19, 2020 at 11:52 PM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

Best Regards,
Huaimo
________________________________
From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, May 19, 2020 2:39 AM
To: Yanhe Fan <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <acee=[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Gyan

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949679298&sdata=08cwC5X8u06cotUPxaWyOq3euYKGK9Pfh0pieb7Tqf0%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949679298&sdata=tyTKAAIC3DyLtli74eDEYNscLfuULnvGwGUu25BeuBA%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949689289&sdata=PPAEeVtUFf4l1J46AvbBRXWE6zymmTpZls6wSTCY5bI%3D&reserved=0>
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949689289&sdata=0lc7p9qzWy1VsJxX2ig1%2BHJWNHMfqWeyBBLf7wUCsV4%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=eZ%2BBnU124L7SGnc%2BQURZRhNmbMYvBMNTGG0to0%2BiuR8%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=eZ%2BBnU124L7SGnc%2BQURZRhNmbMYvBMNTGG0to0%2BiuR8%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=%2FoV6iULRSggdYhbq%2FJosVJeUYYufjIKeQ3hTIjEzRfk%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Xufeng Liu <[email-masked]>
Date: Thu, 21 May 2020 09:46:51 -0400

Support as a co-author.
Thanks,
- Xufeng

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 10:36:58 -0400

On Wed, May 20, 2020 at 11:59 PM Huaimo Chen <[email-masked]>
wrote:

> *From:* Gyan Mishra <[email-masked]>
> *Sent:* Wednesday, May 20, 2020 11:14 AM
> *To:* Huaimo Chen <[email-masked]>
> *Cc:* Acee Lindem (acee) <acee=[email-masked]>; [email-masked] <
> [email-masked]>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949669307&sdata=9nLFlmBSFxBQayL0fCiq864Ylvzyksk3U0GmZPbhPts%3D&reserved=0>
>
> [HC]: The feature appears implemented draft "Dynamic Flooding on Dense
> Graphs", which does not include any flooding topology computation
> algorithm.
>

    Gyan> How does this draft compare to the WG LC draft for flood
reduction.  Would they be two eventual standard options in the operators
toolbox  or competing features for optimized flood reduction. Would having
two flood reduction features standardized versus one default IGP flood
reduction feature be confusing for operators.  Just as it was confusing to
me.

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/

> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949679298&sdata=08cwC5X8u06cotUPxaWyOq3euYKGK9Pfh0pieb7Tqf0%3D&reserved=0>
>
>
>
> Thanks,
> Acee
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949679298&sdata=tyTKAAIC3DyLtli74eDEYNscLfuULnvGwGUu25BeuBA%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949689289&sdata=PPAEeVtUFf4l1J46AvbBRXWE6zymmTpZls6wSTCY5bI%3D&reserved=0>
>
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>*Gyan
> Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=eZ%2BBnU124L7SGnc%2BQURZRhNmbMYvBMNTGG0to0%2BiuR8%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=eZ%2BBnU124L7SGnc%2BQURZRhNmbMYvBMNTGG0to0%2BiuR8%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Caf6069f07e9c4b9b881508d7fcd08b26%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255844949699284&sdata=%2FoV6iULRSggdYhbq%2FJosVJeUYYufjIKeQ3hTIjEzRfk%3D&reserved=0>
>
> *Gyan Mishra*
>

*Gyan Mishra*

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 21 May 2020 15:01:48 +0000

Hi Gyan,

    Thanks much for your questions.

 Gyan> How does this draft compare to the WG LC draft for flood reduction.  Would they be two eventual standard options in the operators toolbox  or competing features for optimized flood reduction. Would having two flood reduction features standardized versus one default IGP flood reduction feature be confusing for operators.  Just as it was confusing to me.
https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=TGrkecn6m9liviazX7qqPglGqYEWu5Ekg2FRIaDpBZ8%3D&reserved=0>

    [HC]: This draft plus the draft for flooding reduction can provide two modes of flooding reductions (i.e., centralized mode and distributed mode). The latter describes the two modes, but does not include any flooding topology computation algorithm for the distributed mode. The former proposes a flooding topology computation algorithm to be used in the distributed mode.

Best Regards,
Huaimo
Sent: Thursday, May 21, 2020 10:36 AM

On Wed, May 20, 2020 at 11:59 PM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, May 20, 2020 11:14 AM
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Cc: Acee Lindem (acee) <acee=[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Huaimo

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=CPEu2451qkfD9440Ihj1bKPWl%2BzH%2BiuYUwuWpfzR%2B0Q%3D&reserved=0>

    Gyan> How does this draft compare to the WG LC draft for flood reduction.  Would they be two eventual standard options in the operators toolbox  or competing features for optimized flood reduction. Would having two flood reduction features standardized versus one default IGP flood reduction feature be confusing for operators.  Just as it was confusing to me.

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=TGrkecn6m9liviazX7qqPglGqYEWu5Ekg2FRIaDpBZ8%3D&reserved=0>

Kind regards

Gyan

Best Regards,
Huaimo

Gyan

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327614000&sdata=FkKUWXneiQIUtjkGB6RITfo0vAt2qhkwDWB%2BghP7%2FLg%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327623992&sdata=tyEhpdkwdbAVJqAlvbfzNxb7n1qLGrrEZ%2FBjEKa9rVs%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327633988&sdata=ii1nTDHCkuMU0AfaMkLjY6N2ww2STRdJBbhHozWSL9I%3D&reserved=0>
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327633988&sdata=ynmYABCZrGN%2F8N64BptBEbnBHxMR7S3b%2FkVz5uO0EZI%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327643983&sdata=ma%2Bv7qm1pab2bjLQ5szL4wCjOCOc5WuYoFHmxd9BOy8%3D&reserved=0>Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327653980&sdata=TYHrbd1wDXt4p2yDXi%2Fqm3XEmjK4V7zu3caXeNJFthU%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327663981&sdata=5b0tVVJLdEO9%2FuAksAsc0BAqy%2F%2F%2BE7EBPjRlkKvvOH4%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327673971&sdata=Bbk8qEHi1RU7J1x%2FNP11v8CYcnDLszZQiNRLmklSDOY%3D&reserved=0>

Gyan Mishra

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327673971&sdata=YcMh3o%2F2a%2FNmVBFKcj4c8MsQn8GfQS41843hjMi3hrs%3D&reserved=0>

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327683966&sdata=2sVGWVhM3Sbk84D2ZyaCYUGfp5wDLt8U8uLpgMJuwSU%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=OQccpoFntfT0LMaEVNaWmGhkqFbTKJLWu4PIlTuKFoA%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=zKzhCcHJbUpzdvulN4y1N92e6KJKAEqHvdF5KDKJKH8%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 13:51:07 -0400

On Thu, May 21, 2020 at 11:01 AM Huaimo Chen <[email-masked]>
wrote:

> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=TGrkecn6m9liviazX7qqPglGqYEWu5Ekg2FRIaDpBZ8%3D&reserved=0>
>
>
>     [HC]: This draft plus the draft for flooding reduction can provide two
> modes of flooding reductions (i.e., centralized mode and distributed mode).
> The latter describes the two modes, but does not include any flooding
> topology computation algorithm for the distributed mode. The former
> proposes a flooding topology computation algorithm to be used in the
> distributed mode.
>

   Gyan> It maybe a good idea for both documents to reference each other as
to how they play together or  in some respects if any provide a homogeneous
complete holistic solution for flooding problem being solved.

In my opinion it may not be a bad idea even to combine both drafts so the
solution is complete and holistic.  This will also make the overall
specification flow nicely.

I know that efforts were made by LSR to have a common IGP solution, however
there are many inherent differences between ISIS and OSPF that from IGP
Link state protocol perspective you can treat like apples to apples but
really it’s apples and oranges.  Maybe it might we wise to have separate
draft for both and have references linking together as the same algorithm
concept and mathematically however the actual code implementation would
vary as the LSDB link state data structures are completely different.

Later = Dynamic flooding = 2 modes Centralized leader based and distributed

This later draft per section excerpt provides both centralized and
distributed algorithm see below

6.4 <https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.4>.
Area Leader Responsibilities

   If the Area Leader operates in centralized mode, it MUST advertise
   algorithm 0 in its Area Leader Sub-TLV.  In order for Dynamic
   Flooding to be enabled it also MUST compute and advertise a flooding
   topology for the area.  The Area Leader may update the flooding
   topology at any time, however, it should not destabilize the network
   with undue or overly frequent topology changes.  If the Area Leader
   operates in centralized mode and needs to advertise a new flooding
   topology, it floods the new flooding topology on both the new and old
   flooding topologies.

   If the Area Leader operates in distributed mode, it MUST advertise a
   non-zero algorithm in its Area Leader Sub-TLV.

   When the Area Leader advertises algorithm 0 in its Area Leader Sub-
   TLV and does not advertise a flooding topology, Dynamic Flooding is
   disabled for the area.  Note this applies whether the Area Leader
   intends to operate in centralized mode or in distributed mode.

   Note that once Dynamic Flooding is enabled, disabling it risks
   destabilizing the network.
6.5 <https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.5>.
Distributed Flooding Topology Calculation

   If the Area Leader advertises a non-zero algorithm in its Area Leader
   Sub-TLV, all nodes in the area that support Dynamic Flooding and the
   value of algorithm advertised by the Area Leader MUST compute the
   flooding topology based on the Area Leader's advertised algorithm.

   Nodes that do not support the value of algorithm advertised by the
   Area Leader MUST continue to use standard flooding mechanism as
   defined by the protocol.

   Nodes that do not support the value of algorithm advertised by the
   Area Leader MUST be considered as Dynamic Flooding incapable nodes by
   the Area Leader.

   If the value of the algorithm advertised by the Area Leader is from
   the range 128-254 (private distributed algorithms), it is the
responsibility of the

network operator to guarantee that all nodes in the area have a common
understanding of what the given algorithm value represents.

Former = WG LC
https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08

Provides algorithm for distributed mode for this draft as well as the
algorithm to be used for distributed mode later dynamic flooding draft

Separate question-

In light of the flooding algorithm and seeing that at the bottom of section
6.5 mentions flooding algorithm are the IANA codepoints reserved for
flooding unique and non overlapping with the flex algo codepoints I believe
0-127.  I would think the flooding algorithm range of values is completely
separate since a different function then flex algo values.

https://datatracker.ietf.org/doc/html/draft-ietf-lsr-flex-algo-07

> *Sent:* Thursday, May 21, 2020 10:36 AM
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=CPEu2451qkfD9440Ihj1bKPWl%2BzH%2BiuYUwuWpfzR%2B0Q%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327604003&sdata=TGrkecn6m9liviazX7qqPglGqYEWu5Ekg2FRIaDpBZ8%3D&reserved=0>
>
>
> Kind regards
>
> Gyan
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327614000&sdata=FkKUWXneiQIUtjkGB6RITfo0vAt2qhkwDWB%2BghP7%2FLg%3D&reserved=0>
>
>
>
> Thanks,
> Acee
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327623992&sdata=tyEhpdkwdbAVJqAlvbfzNxb7n1qLGrrEZ%2FBjEKa9rVs%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327633988&sdata=ii1nTDHCkuMU0AfaMkLjY6N2ww2STRdJBbhHozWSL9I%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327643983&sdata=ma%2Bv7qm1pab2bjLQ5szL4wCjOCOc5WuYoFHmxd9BOy8%3D&reserved=0>*Gyan
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
> Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327653980&sdata=TYHrbd1wDXt4p2yDXi%2Fqm3XEmjK4V7zu3caXeNJFthU%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327663981&sdata=5b0tVVJLdEO9%2FuAksAsc0BAqy%2F%2F%2BE7EBPjRlkKvvOH4%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327673971&sdata=Bbk8qEHi1RU7J1x%2FNP11v8CYcnDLszZQiNRLmklSDOY%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327683966&sdata=2sVGWVhM3Sbk84D2ZyaCYUGfp5wDLt8U8uLpgMJuwSU%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=OQccpoFntfT0LMaEVNaWmGhkqFbTKJLWu4PIlTuKFoA%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=zKzhCcHJbUpzdvulN4y1N92e6KJKAEqHvdF5KDKJKH8%3D&reserved=0>
>
> *Gyan Mishra*
>
> *M 301 502-1347
> <https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>13101
> Columbia Pike

*Gyan Mishra*

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 21 May 2020 20:07:43 +0000

Speaking as WG Co-chair:

Hi Gyan,

I guess you’ve joined this discussion late. It might be a good idea to review the LSR mailing list archives.

From: Gyan Mishra <[email-masked]>
Date: Thursday, May 21, 2020 at 1:51 PM
To: Huaimo Chen <[email-masked]>
Cc: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

On Thu, May 21, 2020 at 11:01 AM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

   Gyan> It maybe a good idea for both documents to reference each other as to how they play together or  in some respects if any provide a homogeneous complete holistic solution for flooding problem being solved.

It is a good idea to have this new draft reference the dynamic-flooding but not vice-versa. The existing dynamic flooding draft provides a framework for any dynamic flooding algorithm that provides a separate flooding topology. This algorithm is just the first to be formally proposed in a draft. Note that another algorithm was presented during the LSR virtual interim which replaced IETF 107.

In my opinion it may not be a bad idea even to combine both drafts so the solution is complete and holistic.  This will also make the overall specification flow nicely.

No – we’re not going to do this.

Thanks,
Acee

I know that efforts were made by LSR to have a common IGP solution, however there are many inherent differences between ISIS and OSPF that from IGP Link state protocol perspective you can treat like apples to apples but really it’s apples and oranges.  Maybe it might we wise to have separate draft for both and have references linking together as the same algorithm concept and mathematically however the actual code implementation would vary as the LSDB link state data structures are completely different.

This later draft per section excerpt provides both centralized and distributed algorithm see below

6.4<https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.4>.  Area Leader Responsibilities

   flooding topologies.

6.5<https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.5>.  Distributed Flooding Topology Calculation

   defined by the protocol.

   the Area Leader.

   the range 128-254 (private distributed algorithms), it is the responsibility of the

network operator to guarantee that all nodes in the area have a common understanding of what the given algorithm value represents.

Former = WG LC

Provides algorithm for distributed mode for this draft as well as the algorithm to be used for distributed mode later dynamic flooding draft

Separate question-

In light of the flooding algorithm and seeing that at the bottom of section 6.5 mentions flooding algorithm are the IANA codepoints reserved for flooding unique and non overlapping with the flex algo codepoints I believe 0-127.  I would think the flooding algorithm range of values is completely separate since a different function then flex algo values.

Best Regards,
Huaimo

Best Regards,
Huaimo

Huaimo

We are testing this feature and planning to deploy but wanted to ensure that this is the same as the draft on the standards track.
[HC]: The feature appears implemented draft "Dynamic Flooding on Dense Graphs", which does not include any flooding topology computation algorithm..

Kind regards

Gyan

Best Regards,
Huaimo

Gyan

Thanks,

Yanhe

Thanks,
Acee

[Image removed by sender.]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327633988&sdata=ii1nTDHCkuMU0AfaMkLjY6N2ww2STRdJBbhHozWSL9I%3D&reserved=0>

Gyan <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g> Mishra

M 301 502-1347

--

[Image removed by sender.]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327673971&sdata=Bbk8qEHi1RU7J1x%2FNP11v8CYcnDLszZQiNRLmklSDOY%3D&reserved=0>

Gyan Mishra

M 301 502-1347

--

[Image removed by sender.]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=zKzhCcHJbUpzdvulN4y1N92e6KJKAEqHvdF5KDKJKH8%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
Silver Spring, MD<https://www.google.com/maps/search/13101+Columbia+Pike+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>

--

[Image removed by sender.]<http://www.verizon.com/>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 16:20:07 -0400

Yes and I have started reviewing the LSR mail archives as I am late in the
discussion for this.

If you have link to any particular dates in the archives would be helpful.

That sums up all the questions I have so if all answered in the archives
then I am all set.

I support the draft moving forward as flood reduction is a much needed
feature.

I think overall both drafts will really help large data centers with any
overlay underlay vxlan spine leaf meshed CLOS highly meshed topology that
scales out horizontally with a large spine footprint - this is a much much
needed feature.  This also helps eliminate complexity of the workaround of
using BGP in the underlay which to me adds tremendous complexity.

Kind regards

Gyan

On Thu, May 21, 2020 at 4:07 PM Acee Lindem (acee) <[email-masked]> wrote:

> *From: *Gyan Mishra <[email-masked]>
> *Date: *Thursday, May 21, 2020 at 1:51 PM
> *To: *Huaimo Chen <[email-masked]>
> *Cc: *Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: [Lsr] Flooding Topology Computation Algorithm -
>    Gyan> It maybe a good idea for both documents to reference each other
> as to how they play together or  in some respects if any provide a
> homogeneous complete holistic solution for flooding problem being solved.
>
>
>
> It is a good idea to have this new draft reference the dynamic-flooding
> but not vice-versa. The existing dynamic flooding draft provides a
> framework for any dynamic flooding algorithm that provides a separate
> flooding topology. This algorithm is just the first to be formally proposed
> in a draft. Note that another algorithm was presented during the LSR
> virtual interim which replaced IETF 107.
>
>
>
> I know that efforts were made by LSR to have a common IGP solution,
> however there are many inherent differences between ISIS and OSPF that from
> IGP Link state protocol perspective you can treat like apples to apples but
> *6.4 <https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.4>.  Area Leader Responsibilities*
>
>
>
> *6.5 <https://datatracker.ietf.org/doc/html/draft-ietf-lsr-dynamic-flooding-05#section-6.5>.  Distributed Flooding Topology Calculation*
>
>
>
> In light of the flooding algorithm and seeing that at the bottom of
> section 6.5 mentions flooding algorithm are the IANA codepoints reserved
> for flooding unique and non overlapping with the flex algo codepoints I
> believe 0-127.  I would think the flooding algorithm range of values is
> completely separate since a different function then flex algo values.
>
>
>
> algorithm..
>     This Flooding Topology Computation algorithm can be used in the
> Dynamic Flooding on Dense Graphs to compute the flooding topologies for
> the data center clos dense meshed topologies with many ECMP paths. It can
> be used by the area leader in the centralized mode to compute the flooding
> topology.
>
>
>
> Best Regards,
>
> Huaimo
> *Gyan
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>Mishra*
>
> *Network Solutions Architect *
>
>
>
> *Network Solutions Architect *
>
> *Network Solutions Architect *
>
>
> *Network Solutions Architect *
>
>
-- 

*Gyan Mishra*

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 21 May 2020 23:01:43 +0000

Hi Gyan,

From: Gyan Mishra <[email-masked]>
Date: Thursday, May 21, 2020 at 4:20 PM
To: Acee Lindem <[email-masked]>
Cc: Huaimo Chen <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Yes and I have started reviewing the LSR mail archives as I am late in the discussion for this.

No – it was more an “evolution” than an “epiphany”.

That sums up all the questions I have so if all answered in the archives then I am all set.

I support the draft moving forward as flood reduction is a much needed feature.

I think overall both drafts will really help large data centers with any overlay underlay vxlan spine leaf meshed CLOS highly meshed topology that scales out horizontally with a large spine footprint - this is a much much needed feature.  This also helps eliminate complexity of the workaround of using BGP in the underlay which to me adds tremendous complexity.

Here is the other recently presented dynamic flooding draft.

https://datatracker.ietf.org/doc/draft-chen-lsr-dynamic-flooding-algorithm/

You can see they both make use of the dynamic flooding infra in https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/

Thanks,
Acee

Kind regards

Gyan

On Thu, May 21, 2020 at 4:07 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Speaking as WG Co-chair:

Hi Gyan,

Cc: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Thanks,
Acee

   flooding topologies.

   defined by the protocol.

   the Area Leader.

Former = WG LC

Separate question-

Best Regards,
Huaimo

Best Regards,
Huaimo

Huaimo

Kind regards

Gyan

Best Regards,
Huaimo

Gyan

Thanks,

Yanhe

Thanks,
Acee

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327633988&sdata=ii1nTDHCkuMU0AfaMkLjY6N2ww2STRdJBbhHozWSL9I%3D&reserved=0>

M 301 502-1347

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327673971&sdata=Bbk8qEHi1RU7J1x%2FNP11v8CYcnDLszZQiNRLmklSDOY%3D&reserved=0>

Gyan Mishra

M 301 502-1347

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C60df274544ba4b75447f08d7fd947201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256686327693961&sdata=zKzhCcHJbUpzdvulN4y1N92e6KJKAEqHvdF5KDKJKH8%3D&reserved=0>

Gyan Mishra

M 301 502-1347

--

Error! Filename not specified.<http://www.verizon.com/>

Gyan Mishra

M 301 502-1347

--

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 22:13:49 -0400

I think for both drafts it would be good to have a stick diagram at a
minimum.

I majored in EE with math  minor and both drafts are hard to follow without
a diagram with labels showing the exact topology examples.

Four main topologies - full mesh, partial mesh and leaf spine ( 2 tier) and
CLOS ( 3 tier) - real world scenario’s.

>From the interim meeting was their a slide deck visual topology shared?

That would help.

4.1

Step 1 - Build Cq candidate queue

For each node B on FT whose D is one (from minimum to maximum
       node ID), find a link L attached to B such that L's remote node R
       has minimum D and ID, add link L between B and R into FT and
       increase B's D and R's D by one.  Return FT.

My interpretation is the algorithm an iterative loop and starts with any
node in the candidate list so could start from edge and work left to right
or vice versa.  For loop to build FT from Cq = with each node B with
directly attached node R via link L.  Increment node B from Cq until the FT
is build for all nodes.  Instead of starting with a wide diameter FT
matching physical topology we start micro topology with D=1 and go node by
node.

4.2

1.  Finding and removing the first element with node A in Cq that is
       not on FT and one PH's D in PHs < MaxD and PH's D < PH's ConMaxD.

       If A is root R0, then add the element into FT

       otherwise  (i.e., A != R0 with one PH's D in PHs < MaxD and PH's
          D < PH's ConMaxD.  Assume that PH is the first one in PHs
          whose D < MaxD and PH's D < PH's ConMaxD), PH's D++, and add A
          with D = 1 and PHs = {PH} into FT.

       Note:  if there is no element with a node in Cq satisfying the
          conditions, then algorithm may be restarted from R0, ++MaxD,
          Cq = {(R0,D=0,PHs = { })}, FT = { };

This is similar to 4.1 with micro topology with 2 directly connected nodes

https://www.ietf.org/id/draft-chen-lsr-dynamic-flooding-algorithm-00.html

My interpretation of the algorithm from the verbiage.

So this draft starts in the middle of the topology and is geared towards
leaf spine 2 or 3 tier clos topology.

For this one we build the bi graph so that could be leaf connected to two
spines or spine connected to two leafs and iteratively build out the FT
topology 3 node arch  spine leaf spine or leaf spine leaf.

Kind regards

Gyan

On Thu, May 21, 2020 at 7:01 PM Acee Lindem (acee) <[email-masked]> wrote:

> *Date: *Thursday, May 21, 2020 at 4:20 PM
> *To: *Acee Lindem <[email-masked]>
> *Cc: *Huaimo Chen <[email-masked]>, "[email-masked]" <
> [email-masked]>
> You can see they both make use of the dynamic flooding infra in
> *Error! Filename not specified.*
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>*Network
> Solutions Architect *
>
>
>
> *Error! Filename not specified.*
> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>13101
> Columbia Pike
> *Error! Filename not specified.*
> *Error! Filename not specified.* <http://www.verizon.com/>
>
> *Gyan Mishra*
>
-- 

*Gyan Mishra*

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 22:32:13 -0400

I see the diagrams Appendix A -  reviewing

Thanks

Gyan

On Thu, May 21, 2020 at 10:13 PM Gyan Mishra <[email-masked]> wrote:

> I majored in EE with math  minor and both drafts are hard to follow
> without a diagram with labels showing the exact topology examples.
>
> Four main topologies - full mesh, partial mesh and leaf spine ( 2 tier)
> and CLOS ( 3 tier) - real world scenario’s.
>
>>     [HC]: This draft plus the draft for flooding reduction can provide
>> two modes of flooding reductions (i.e., centralized mode and distributed
>> mode). The latter describes the two modes, but does not include any
>> flooding topology computation algorithm for the distributed mode. The
>> former proposes a flooding topology computation algorithm to be used in
>> the distributed mode.
>>
>>
>>
>> *Cc:* Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
>> <[email-masked]>
>> *Cc:* Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
>> <[email-masked]>
>> This is a much needed feature that operators have been needing for
>> densely meshed topologies that commonly exist in data centers to
>> accommodate very high bandwidth E-W traffic.
>>
>> Below is link from Cisco which has introduced feature for dynamic
>> flooding in clos high density ECMP data center topologies.
>>
>>
>>

*Gyan Mishra*

---

From: Sarah Chen <[email-masked]>
Date: Thu, 21 May 2020 19:59:37 -0700

Hi, Gyan,

I presented
https://www.ietf.org/id/draft-chen-lsr-dynamic-flooding-algorithm-00.html in
the last IETF. You may find the slides below helpful in understanding the
algorithm:

https://datatracker.ietf.org/meeting/interim-2020-lsr-01/materials/slides-interim-2020-lsr-01-sessa-2-dynamic-flooding-algo-sarah.pdf

Thanks,
Sarah

On Thu, May 21, 2020 at 7:32 PM Gyan Mishra <[email-masked]> wrote:

>>> me..
>>> In my opinion it may not be a bad idea even to combine both drafts so
>>> the solution is complete and holistic.  This will also make the overall
>>>    algorithm 0 in its Area Leader Sub-TLV..  In order for Dynamic
>>>
>>> This begins a 3 week (due to holidays) WG adoption call for the
>>> “Flooding Topology Computation Algorithm” draft. Please issue your support
>>> or objection to this list by 11:59 PM, UTC on June 5th, 2020. Here is a
>>> URL for your convenience.
>>>
>>>
>>>
>>> https://www..ietf.org/mailman/listinfo/lsr

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 21 May 2020 23:36:32 -0400

Great Thanks Sarah!!

Gyan

On Thu, May 21, 2020 at 10:59 PM Sarah Chen <[email-masked]> wrote:

>>> For this one we build the bi graph so that could be leaf connected to
>>> two spines or spine connected to two leafs and iteratively build out the FT
>>>> I think overall both drafts will really help large data centers with
>>>> any overlay underlay vxlan spine leaf meshed CLOS highly meshed topology
>>>> that scales out horizontally with a large spine footprint - this is a much
>>>> much needed feature.  This also helps eliminate complexity of the
>>>> workaround of using BGP in the underlay which to me adds tremendous
>>>> complexity.
>>>>
>>>>
>>>>
>>>> former proposes a flooding topology computation algorithm to be used
>>>> in the distributed mode.
>>>>
>>>>
>>>>
>>>>    Gyan> It maybe a good idea for both documents to reference each
>>>> other as to how they play together or  in some respects if any provide a
>>>> *Cc:* Acee Lindem (acee) <acee=[email-masked]>;
>>>> [email-masked] <[email-masked]>
>>>> *Cc:* Acee Lindem (acee) <acee=[email-masked]>;
>>>> [email-masked] <[email-masked]>
>>>> There maybe other vendors due to industry demand have to get the
>>>> feature deployed before it reaches standards vendor consensus with the IETF.
>>>>
>>>>
>>>>
>>>>
>>>> or objection to this list by 11:59 PM, UTC on June 5th, 2020. Here is
>>>> a URL for your convenience.
>>>>
>>>>
>>>>
>>>> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%C2%A0+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
>>>> *Silver Spring, MD
>>>> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%C2%A0+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
>>>>
>>>>
>>>> --
>>>>
>>>> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%C2%A0+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
>>>> *Silver Spring, MD
>>>> <https://www.google.com/maps/search/13101%0D%0A+Columbia+Pike+%C2%A0+%0D%0A+Silver%0D%0A+Spring,+MD?entry=gmail&source=g>
>>>>
>>>> --
>>>>
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>> *Silver Spring, MD
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>>
>>>> --
>>>>
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>> *Silver Spring, MD
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>>
>>>> --
>>>>
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>> *Silver Spring, MD
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>>
>>> --
>>>
>>> *M 301 502-134713101 Columbia Pike
>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g> *Silver
>>> Spring, MD
>>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>>
>>> --
>>
>> *M 301 502-134713101 Columbia Pike
>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g> *Silver
>> Spring, MD
>> <https://www.google.com/maps/search/13101+Columbia+Pike+%C2%A0+%0D%0A+Silver+Spring,+MD?entry=gmail&source=g>
>>

*Gyan Mishra*

---

From: Huaimo Chen <[email-masked]>
Date: Fri, 22 May 2020 13:27:59 +0000

Hi Gyan,

    Thanks much for your suggestion.

[HC]: I will add the reference in the draft.

Best Regards,
Huaimo
Sent: Thursday, May 21, 2020 1:51 PM

 Gyan> How does this draft compare to the WG LC draft for flood reduction.  Would they be two eventual standard options in the operators toolbox  or competing features for optimized flood reduction. Would having two flood reduction features standardized versus one default IGP flood reduction feature be confusing for operators.  Just as it was confusing to me.
https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824693892&sdata=4vWmUdR%2BbXWXgjyBAw62Ig%2BxUyKPuq6uucKbrfbNv5w%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824693892&sdata=4vWmUdR%2BbXWXgjyBAw62Ig%2BxUyKPuq6uucKbrfbNv5w%3D&reserved=0>

6.4<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.4&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824703852&sdata=FvMPjTxl622QWR0mgEZFUlnwM5rGlRKKdTWSTjPXcBs%3D&reserved=0>.  Area Leader Responsibilities

6.5<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.5&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824703852&sdata=9IDNZX2%2F5FTACbaHZd4faYuNVCx5LXaSjlJUc409ocU%3D&reserved=0>.  Distributed Flooding Topology Calculation

Former = WG LC
https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824713798&sdata=Zqopm1yqpqM1ZD7ObT0BFMIUSJd0iT6Ri2b6vStCJCo%3D&reserved=0>

Separate question-

https://datatracker.ietf.org/doc/html/draft-ietf-lsr-flex-algo-07<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-flex-algo-07&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824713798&sdata=MOIfltBuiViPgsuRYDxQ5lDQjIRjP%2BojrhcVN8hwOPI%3D&reserved=0>

Best Regards,
Huaimo

Best Regards,
Huaimo

Huaimo

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824713798&sdata=Pm51EVp6O2zpw30mvKMJPh6HsoYQbwVzSYOubRRBVq0%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824723756&sdata=RyLoLJDPfL16ZPZF5qzbHZjMTdmemUWu468jtQh9l2k%3D&reserved=0>

Kind regards

Gyan

Best Regards,
Huaimo

Gyan

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824723756&sdata=8fExZMtHNTeVuZkWgp25GiSyInqOm8M3OAcmG%2B8cWtc%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824733714&sdata=tsa4Ojxc3ylgeUecgkmfh2om5Yiff1PBuskEcI06zwg%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824733714&sdata=LPKmRl3s46m6fMUiITzRUTXpyUXJPWRHWWDpPH8GxmA%3D&reserved=0>
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824743667&sdata=h47l%2FQYNnH%2FtPDN7zR9BiXr2GivvcuIvSpnUz%2Bz%2B9b8%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824743667&sdata=LgS%2BTDgbDLHHihGm8CDP9%2F5kj2sfR9XHFAZWbh6zW2Q%3D&reserved=0>Gyan <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824753624&sdata=3IMpHFXLe3o2uWZUkGsx6qBNZVwojdx24VuAGlZHSB0%3D&reserved=0> Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824753624&sdata=gT67YHrFxcyFOuAJJN7TNy4r6b95MwEhzRL5yAeqa%2FY%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824753624&sdata=gT67YHrFxcyFOuAJJN7TNy4r6b95MwEhzRL5yAeqa%2FY%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824763585&sdata=Xq02x0vLv3g%2FAjnuEuBJcMdEYxsBRo%2BDwn%2FPwxMv%2FGI%3D&reserved=0>

Gyan Mishra

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824763585&sdata=09iR61WVYxs72aR6p6Kk6Nae%2BzJquOkg6ZdB2KflOa4%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824773542&sdata=R%2FgBETIY57llywOkt%2FPq014B2SQ3Ym7kN2%2F9ubP3%2FWI%3D&reserved=0>

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824773542&sdata=MNku9GCzbL4NpaxOXqb3%2FwAHf9TE2ASteqrPkozrNcE%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824783499&sdata=Y2Q%2BDoEFuib0A1y8%2FrvsdIj5bDKBJ40TOBmBd%2BbZQng%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824783499&sdata=Iztk7Zc0CuV3%2Fm4iWBGLoKwJaobqcgMX8SGRnulguSM%3D&reserved=0>

Gyan Mishra

M 301 502-1347
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824793457&sdata=pkvGEPEKRF6LGk%2FMjeVySLwnDyAdC0MiCM2MIfsxLY0%3D&reserved=0>13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824793457&sdata=pkvGEPEKRF6LGk%2FMjeVySLwnDyAdC0MiCM2MIfsxLY0%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824803410&sdata=t4Vd9hSZ9iq6rD%2BaAz4IglQFcyb3NymrrMMGBVRNaAU%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce0f4766963da47bb3ba608d7fdaf9134%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256802824803410&sdata=X%2B7ErL%2BFWEjLMUTOfGa2BlEM2zz1eJ0u9qc0NaDhJNE%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Huaimo Chen <[email-masked]>
Date: Fri, 22 May 2020 14:05:25 +0000

Hi Gyan,

    Thanks much for your questions. My answers/explanations are inline below.

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]>
Sent: Thursday, May 21, 2020 10:13 PM
To: Acee Lindem (acee) <[email-masked]>
Cc: Huaimo Chen <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

I think for both drafts it would be good to have a stick diagram at a minimum.
[HC]: A diagram for illustrating the steps of the algorithm is in Appendix.
I majored in EE with math  minor and both drafts are hard to follow without a diagram with labels showing the exact topology examples.

Four main topologies - full mesh, partial mesh and leaf spine ( 2 tier) and CLOS ( 3 tier) - real world scenario’s.

>From the interim meeting was their a slide deck visual topology shared?
[HC]: The set of slides presented in IETF 105 is attached.

That would help.

https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446371900&sdata=glKNEHI0pmavkJwY%2BykW0%2BArX10F74JP0WMEvG6FY88%3D&reserved=0>

4.1

My interpretation is the algorithm an iterative loop and starts with any node in the candidate list so could start from edge and work left to right or vice versa.  For loop to build FT from Cq = with each node B with directly attached node R via link L.  Increment node B from Cq until the FT is build for all nodes.  Instead of starting with a wide diameter FT matching physical topology we start micro topology with D=1 and go node by node.
[HC]: This (For each node B on FT .... Return FT.) is an iterative loop after every node is added to FT. This loop connects each node whose D = 1 (i.e., there is only one link attached to it on FT) to a node through a link on FT (i.e., add the link to FT) to make every node on FT to have its D > 1. Page 5 of the attached slides shows some details for this loop.

4.2

This is similar to 4.1 with micro topology with 2 directly connected nodes
[HC]: It is similar to 1. in section 4.1.

https://www.ietf.org/id/draft-chen-lsr-dynamic-flooding-algorithm-00.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-chen-lsr-dynamic-flooding-algorithm-00.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446371900&sdata=0%2B33ORq8CFVJuZjTNSQwvI1UjK6W8xdcz%2FlOXsYMTxc%3D&reserved=0>

So this draft starts in the middle of the topology and is geared towards leaf spine 2 or 3 tier clos topology.

For this one we build the bi graph so that could be leaf connected to two spines or spine connected to two leafs and iteratively build out the FT topology 3 node arch  spine leaf spine or leaf spine leaf.

Kind regards

Gyan

On Thu, May 21, 2020 at 7:01 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gyan,

From: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 21, 2020 at 4:20 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: Huaimo Chen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

https://datatracker.ietf.org/doc/draft-chen-lsr-dynamic-flooding-algorithm/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-lsr-dynamic-flooding-algorithm%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446381892&sdata=iCY2RDNVQtNcoWRomiMNfyyVhtAf7DossHwlhuHdsM0%3D&reserved=0>

You can see they both make use of the dynamic flooding infra in https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446381892&sdata=m%2FyOgcPdrBoA2ZPOs0jhC%2BT%2B4sxDes%2BooNO9hqQ1CIA%3D&reserved=0>

Thanks,

Acee

Kind regards

Gyan

Speaking as WG Co-chair:

Hi Gyan,

Hi Gyan,

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446391897&sdata=myU2K8Y9ZPNxUZ6LhjTbIJDT5gZo0HBZGCMEwsad6CE%3D&reserved=0>

Thanks,

Acee

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446401884&sdata=A0He%2BkbFrye6L7vgdHjLIY50hzWE%2Bty0reMCMbE1QF0%3D&reserved=0>

6.4<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.4&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446401884&sdata=K%2BSin3SGk78gUaBME9B5UjYUncvtprSkvLZOF1UWxQE%3D&reserved=0>.  Area Leader Responsibilities

   flooding topologies.

6.5<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.5&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446411879&sdata=eqK0e8YFYfRgXo%2F6K%2BSPT3mCdFXDoME6gMLUp%2BcVjB4%3D&reserved=0>.  Distributed Flooding Topology Calculation

   defined by the protocol.

   the Area Leader.

Former = WG LC

https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446411879&sdata=kIqZH1iGc%2BVFx3SyBaja8Nedu2m7G4OlzHRKxp5Et4o%3D&reserved=0>

Separate question-

https://datatracker.ietf.org/doc/html/draft-ietf-lsr-flex-algo-07<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-flex-algo-07&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446421873&sdata=s6y04UJjyUATTDuUvKgFl9AtQzuNbV6vgkbeuQw1UNM%3D&reserved=0>

Best Regards,

Huaimo

Hi Gyan,

Best Regards,

Huaimo

Huaimo

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446431887&sdata=WiNe%2B5vVFxheyMEmT92pdJRtoA%2F2WGYtA7HT%2FlJs1J0%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446441864&sdata=RirosOO%2BSH8U3Fyb9Ejxjv%2B%2BeeMwW8%2FHpOLkZGO8FN4%3D&reserved=0>

Kind regards

Gyan

Hi Gyan,

Best Regards,

Huaimo

Gyan

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446441864&sdata=fqmSXecEZOQbkD0lpbQ8BfAjXZvOZ8bzCWeEsfQojw4%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446451864&sdata=xg2AvQQfqPS228FUYFhK1ueJJeUuuMZsI3yTdsVkji8%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446451864&sdata=h%2BrHjI5NY37uHQIjPKYv5GW6J6chceH6U3dbj3xwb7A%3D&reserved=0>

Gyan <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446461859&sdata=b%2FrOXTZ8ayq5rzEPxpOlLuMfEvsw3FPbOVkqQUcnieQ%3D&reserved=0> Mishra

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446471858&sdata=GLW4e%2BMcjf8oIZmuUXtgcfmzrB%2BBWqXsvDquWI492EU%3D&reserved=0>Network Solutions Architect

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446471858&sdata=psm7wBWSK%2BEtFkhnb9B3soi0S6%2FrAXm%2FEXMoo6dnGKM%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446481860&sdata=p0ttOIduJDiC0qR91gpSHhFnYJ6uVzJUJdV5qfOCPlw%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446491855&sdata=ik1xhwQyDjOvNfMg%2BQMAIIiMPkWlUER3K5q99T43c%2Fo%3D&reserved=0>

Gyan Mishra

M 301 502-1347
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446491855&sdata=2U%2B3C5vUgVYU0GgNHfX2GRpsPVMm43GWWqzxm%2BOdOKQ%3D&reserved=0>13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446501852&sdata=eCAT1E6b8XpInRH0rt3JhcsRLGIoq32a5UOw84kqLQw%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446511843&sdata=e6tNSbiepHHR7EJywi46nnEh2sD7JNdlKBF%2Bj%2B2WV8w%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446511843&sdata=mlfQG0sJIh5NUKLahCziTmtrCWqimi13RAze0SXZ2cE%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446521838&sdata=9u8%2Fhg6zqPW4BNxxuyEQd%2Fky69FmzGY7bwz7uZW%2FC14%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446521838&sdata=9u8%2Fhg6zqPW4BNxxuyEQd%2Fky69FmzGY7bwz7uZW%2FC14%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446531830&sdata=j7qLXVJD4j8%2FviHXL9MOvkB3MB5k2jEh%2BnprB5sh%2FvA%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446541830&sdata=sTN2HQO64Um1VqZkhLZMa8Mi7S8WykmI%2BsqVNa921uI%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446541830&sdata=kvKt%2FhIAtw0TihRjOw2QUQwsciGPZsEvA7Ajyd8nu0Y%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446551824&sdata=w5mciZkFOfsgol2MPiv%2BtS3bfa7xI5KZj7WHYnxBFYM%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446551824&sdata=w5mciZkFOfsgol2MPiv%2BtS3bfa7xI5KZj7WHYnxBFYM%3D&reserved=0>

--

[Image removed by sender.]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446561816&sdata=faawTrV7ADwTXxvf%2BKE9WX64z1r5ro%2B7bmfhRMbW2Xg%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446571816&sdata=dvcFR%2BGQMsm6kW0RSiWOhNdIFc8ntpHrhdAFFYqWi%2Fc%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446571816&sdata=dvcFR%2BGQMsm6kW0RSiWOhNdIFc8ntpHrhdAFFYqWi%2Fc%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446581809&sdata=uYQI13rtEKidJMaMnowsjiSAqbN3Ygeu4X2eQL7LCts%3D&reserved=0>

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446581809&sdata=D7sb4GOCEOeHEvKNjVxo0Sy004BHtfqiE4k65sSuxiY%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 22 May 2020 20:41:37 -0400

Hi Huaimo

Thank you for the slide deck.  That really helps understand the algorithm.

I will let you know if I have any questions.

The goal of the algorithm is to speed up convergence by limiting the
convergence scope and expanding out 1 link at a time until all nodes and
links are part of the flood scope.  From the examples in the slide deck I
did not see mentioned what is done with the dynamic flooding algorithm
where when you have a meshed network in the slide 5 examples, how do you
limit the flooding on redundant links duplicate flooding with the many
meshed paths as you iteratively grow the FT nodes scope Cq().  I believe
with the dynamic flooding it does a degree of 2 so 2 links between nodes.

I think with clos spine leaf the mesh is much more intensive and
problematic with ECMP then a circular topology nodal mesh that results in
duplicate redundant flooding that slows down convergence.  With spine leaf
it’s like an X horizontal width axis and then depth is spine to leaf
links.  With spine leaf as you grow sideways and the spine expand the
redundant ECMP grows and redundant flooding grows exponentially and is much
worse then circular nodal mesh.

Thank you

Gyan

On Fri, May 22, 2020 at 10:05 AM Huaimo Chen <[email-masked]>
wrote:

> *Sent:* Thursday, May 21, 2020 10:13 PM
> *To:* Acee Lindem (acee) <[email-masked]>
> *Cc:* Huaimo Chen <[email-masked]>; [email-masked] <[email-masked]>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446371900&sdata=glKNEHI0pmavkJwY%2BykW0%2BArX10F74JP0WMEvG6FY88%3D&reserved=0>
>
> 4.1
>
> [HC]: This (For each node B on FT .... Return FT.) is an iterative loop
> after every node is added to FT. This loop connects each node whose D = 1
> (i.e., there is only one link attached to it on FT) to a node through a
> link on FT (i.e., add the link to FT) to make every node on FT to have its
> D > 1. Page 5 of the attached slides shows some details for this loop.
>
> 4.2
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-chen-lsr-dynamic-flooding-algorithm-00.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446371900&sdata=0%2B33ORq8CFVJuZjTNSQwvI1UjK6W8xdcz%2FlOXsYMTxc%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-lsr-dynamic-flooding-algorithm%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446381892&sdata=iCY2RDNVQtNcoWRomiMNfyyVhtAf7DossHwlhuHdsM0%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446381892&sdata=m%2FyOgcPdrBoA2ZPOs0jhC%2BT%2B4sxDes%2BooNO9hqQ1CIA%3D&reserved=0>
>
>
>
> Thanks,
>
> Acee
>
>
>
>
>
>
>
>
>
> Kind regards
>
>
>
> Gyan
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446391897&sdata=myU2K8Y9ZPNxUZ6LhjTbIJDT5gZo0HBZGCMEwsad6CE%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446401884&sdata=A0He%2BkbFrye6L7vgdHjLIY50hzWE%2Bty0reMCMbE1QF0%3D&reserved=0>
>
>
>
> *6.4 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.4&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446401884&sdata=K%2BSin3SGk78gUaBME9B5UjYUncvtprSkvLZOF1UWxQE%3D&reserved=0>.  Area Leader Responsibilities*
>
>
>
> *6.5 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.5&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446411879&sdata=eqK0e8YFYfRgXo%2F6K%2BSPT3mCdFXDoME6gMLUp%2BcVjB4%3D&reserved=0>.  Distributed Flooding Topology Calculation*
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446411879&sdata=kIqZH1iGc%2BVFx3SyBaja8Nedu2m7G4OlzHRKxp5Et4o%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-flex-algo-07&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446421873&sdata=s6y04UJjyUATTDuUvKgFl9AtQzuNbV6vgkbeuQw1UNM%3D&reserved=0>
>
>
>
>
>
> Best Regards,
>
> Huaimo
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446431887&sdata=WiNe%2B5vVFxheyMEmT92pdJRtoA%2F2WGYtA7HT%2FlJs1J0%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446441864&sdata=RirosOO%2BSH8U3Fyb9Ejxjv%2B%2BeeMwW8%2FHpOLkZGO8FN4%3D&reserved=0>
>
>
>
> Kind regards
>
>
>
> Gyan
>
>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446441864&sdata=fqmSXecEZOQbkD0lpbQ8BfAjXZvOZ8bzCWeEsfQojw4%3D&reserved=0>
>
>
>
> Thanks,
> Acee
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446451864&sdata=xg2AvQQfqPS228FUYFhK1ueJJeUuuMZsI3yTdsVkji8%3D&reserved=0>
>
> --
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446451864&sdata=h%2BrHjI5NY37uHQIjPKYv5GW6J6chceH6U3dbj3xwb7A%3D&reserved=0>
>
> *Gyan
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446461859&sdata=b%2FrOXTZ8ayq5rzEPxpOlLuMfEvsw3FPbOVkqQUcnieQ%3D&reserved=0>Mishra*
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446471858&sdata=GLW4e%2BMcjf8oIZmuUXtgcfmzrB%2BBWqXsvDquWI492EU%3D&reserved=0>*Network
> Solutions Architect *
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446471858&sdata=psm7wBWSK%2BEtFkhnb9B3soi0S6%2FrAXm%2FEXMoo6dnGKM%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446481860&sdata=p0ttOIduJDiC0qR91gpSHhFnYJ6uVzJUJdV5qfOCPlw%3D&reserved=0>
>
>
>
> --
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446491855&sdata=ik1xhwQyDjOvNfMg%2BQMAIIiMPkWlUER3K5q99T43c%2Fo%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446491855&sdata=2U%2B3C5vUgVYU0GgNHfX2GRpsPVMm43GWWqzxm%2BOdOKQ%3D&reserved=0>13101
> Columbia Pike
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446501852&sdata=eCAT1E6b8XpInRH0rt3JhcsRLGIoq32a5UOw84kqLQw%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446511843&sdata=e6tNSbiepHHR7EJywi46nnEh2sD7JNdlKBF%2Bj%2B2WV8w%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446511843&sdata=mlfQG0sJIh5NUKLahCziTmtrCWqimi13RAze0SXZ2cE%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446521838&sdata=9u8%2Fhg6zqPW4BNxxuyEQd%2Fky69FmzGY7bwz7uZW%2FC14%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446521838&sdata=9u8%2Fhg6zqPW4BNxxuyEQd%2Fky69FmzGY7bwz7uZW%2FC14%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446541830&sdata=sTN2HQO64Um1VqZkhLZMa8Mi7S8WykmI%2BsqVNa921uI%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446541830&sdata=kvKt%2FhIAtw0TihRjOw2QUQwsciGPZsEvA7Ajyd8nu0Y%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446561816&sdata=faawTrV7ADwTXxvf%2BKE9WX64z1r5ro%2B7bmfhRMbW2Xg%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446571816&sdata=dvcFR%2BGQMsm6kW0RSiWOhNdIFc8ntpHrhdAFFYqWi%2Fc%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446571816&sdata=dvcFR%2BGQMsm6kW0RSiWOhNdIFc8ntpHrhdAFFYqWi%2Fc%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7Cc9f9e8ddb76b406057d208d7fdf5cb4e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257104446581809&sdata=D7sb4GOCEOeHEvKNjVxo0Sy004BHtfqiE4k65sSuxiY%3D&reserved=0>
>
> *Gyan Mishra*
>
-- 

*Gyan Mishra*

---

From: [email-masked]
Date: Fri, 22 May 2020 18:02:13 -0700

Hi Gyan,

> I think with clos spine leaf the mesh is much more intensive and problematic with ECMP then a circular topology nodal mesh that results in duplicate redundant flooding that slows down convergence.  With spine leaf it’s like an X horizontal width axis and then depth is spine to leaf links.  With spine leaf as you grow sideways and the spine expand the redundant ECMP grows and redundant flooding grows exponentially and is much worse then circular nodal mesh.  

One very nice thing about dynamic flooding is that it computes a flooding topology at the node level.  If the adjacency between A and B is on the flooding topology, then any single link between them may be used for flooding.  If you have 128 way parallel links, this is an immediate 128x improvement in flooding overhead.  What’s more, A and B do not need to agree on which link they are using and can use different links, resulting in an asymmetric situation, without any loss of correctness or performance. 

Regards,
Tony

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 22 May 2020 21:11:44 -0400

Hi Huaimo

Thinking about physical topology a little further as with the FT algorithm
it makes sense to decouple the FT from the physical however the overall
coverage is based on those basic parameters of degree number of links and
nodes as well as width and depth of the topology.

Thinking about it further the clos leaf spine DC style topology is much
worse in terms of flooding due to physical topology that leafs don’t
physical connection and are interconnected via the spine creating massive
ECMP and overload of the spine super spine.  So the physical DC leaf spine
topology really exacerbates the flooding due to the non full mesh nature of
the topology.

With a service provider core which is typically a mesh style multi tier
multiple concentric circles mix of full and partial mesh and hub spoke type
physical topologies.

So with flooding with full mesh every node connects with every node so you
don’t have an overload of flooding being funneled through a super spine as
you do with a leaf spine DC architecture.  So in a full mesh which is the
best case scenario for flooding perspective from my point of view which
each node as root connects to all nodes and then you can iteratively grow
the flooding scope and it’s pretty controlled and you can limit the
redundant flooding.  When the physical topology changes to a much more
partially meshed the ECMP paths grow astronomically as does the flooding
and longer convergence time.

So I think in the slide deck and draft look at scenario where their is
tremendous ECMP from partial meshing and how the flood reduction algorithm
improves the flooding and convergence.

Kind regards

Gyan

On Fri, May 22, 2020 at 8:41 PM Gyan Mishra <[email-masked]> wrote:

>> *Cc:* Huaimo Chen <[email-masked]>; [email-masked] <[email-masked]
>> >

*Gyan Mishra*

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 23 May 2020 16:43:49 -0400

On Fri, May 22, 2020 at 9:02 PM <[email-masked]> wrote:

> One very nice thing about dynamic flooding is that it computes a flooding
> topology at the node level.  If the adjacency between A and B is on the
> flooding topology, then any single link between them may be used for
> flooding.  If you have 128 way parallel links, this is an immediate 128x
> improvement in flooding overhead.  What’s more, A and B do not need to
> agree on which link they are using and can use different links, resulting
> in an asymmetric situation, without any loss of correctness or performance.
>

   Gyan>. Agreed.  The dynamic flooding really helps with X way ECMP
prevalent in high density data center clos multi tier leaf spine parial
mesh topologies that scale massive bandwidth breadth wise horizontally for
E-W flows.

*Gyan Mishra*

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 24 May 2020 18:29:39 -0400

Hi Acee

Do you know if the dynamic flooding algorithm discussed during interim ietf
by Sarah and Toni is the same as the one implemented by Cisco on Nexus
platform or is Cisco’s Dynamic flooding a proprietary implementation?

Cisco’s flooding algorithm does seem almost identical to dynamic flooding.

Cisco Dynamic flooding - Nexus 9k

Dynamic Flooding - Arista - Sarah & Toni

Flood reduction- H Chen - WG adoption pending

I know we are trying to adopt an flooding algorithm
and from my reading up on all proposed algorithms, the dynamic flooding
seems to be geared towards Data Center  partial mesh high x ECMP leaf spine
architecture, where redundant flooding is problematic using either
centralized area leader or distributed flooding using same dynamic
algorithm,  versus the call for adoption flood reduction algorithm seems to
geared towards full mesh but from what I can tell would not be the
preferred for clos multi tier DC leaf spine topology with high x ECMP paths.

Why would we not want to adopt the best algorithm that is best for both
full mesh and non full mesh leaf spine topology algorithm that works for
all physical topologies and adopt that draft.

Unless a one size fits all won’t work I would like to understand why one
best solution draft we come up with for an FT algorithm for all possible
physical topologies cannot be picked for WG adoption.

Why would we want to adopt multiple flooding algorithms?

Gyan

*Gyan Mishra*

---

From: [email-masked]
Date: Sun, 24 May 2020 15:41:21 -0700

Hi Gyan,

> Do you know if the dynamic flooding algorithm discussed during interim ietf by Sarah and Toni is the same as the one implemented by Cisco on Nexus platform or is Cisco’s Dynamic flooding a proprietary implementation?

It appears not to be.  Our algorithm is not limited to leaf-spine topologies and has been tested against numerous other dense and sparse topologies.

> Why would we not want to adopt the best algorithm that is best for both full mesh and non full mesh leaf spine topology algorithm that works for all physical topologies and adopt that draft.  

Proving that an algorithm is ‘optimal’ is going to be very difficult, both from a theoretical and market standpoint. As is frequently the case with IETF, we are proposing many ideas and trying to sort through them.

> Unless a one size fits all won’t work I would like to understand why one best solution draft we come up with for an FT algorithm for all possible physical topologies cannot be picked for WG adoption.
> 

Adoption does not imply that it will be standardized.  It merely means that it’s part of the working group’s effort.  It is up to the WG and the market to decide which algorithms we should pursue.  Some may be enhanced, some may be revised, and some may be discarded. We can also adopt all of them and let the market sort it out.  That’s probably not the optimal approach from a technological perspective, but making real decisions in the modern IETF is very hard.

Tony

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 May 2020 01:28:18 +0000

Hi Gyan,

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]>
Sent: Friday, May 22, 2020 8:41 PM
To: Huaimo Chen <[email-masked]>
Cc: Acee Lindem (acee) <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Hi Huaimo

The goal of the algorithm is to speed up convergence by limiting the convergence scope and expanding out 1 link at a time until all nodes and links are part of the flood scope.  From the examples in the slide deck I did not see mentioned what is done with the dynamic flooding algorithm where when you have a meshed network in the slide 5 examples, how do you limit the flooding on redundant links duplicate flooding with the many meshed paths as you iteratively grow the FT nodes scope Cq().  I believe with the dynamic flooding it does a degree of 2 so 2 links between nodes.
[HC]: The slide 5 example illustrates step 4 of the algorithm in section 4.1. When the algorithm reaches this step, all the nodes are  on the FT, but some of them may have degree of 1 (i.e., one link on the FT connected to the node). This step makes sure that every node on the FT has degree of at least 2.  It seems that the dynamic flooding expects the FT having its every node with degree of at least 2 for redundancy. In the Dynamic Flooding on Dense Graphs, link states will be flooded over the links on the FT. For example, for a node with degree of N (e.g., 3), when the node receives a link state from one link on the FT, it will flood the link state to the other N-1 (e.g., 3-1=2) links on the FT.

I think with clos spine leaf the mesh is much more intensive and problematic with ECMP then a circular topology nodal mesh that results in duplicate redundant flooding that slows down convergence.  With spine leaf it’s like an X horizontal width axis and then depth is spine to leaf links.  With spine leaf as you grow sideways and the spine expand the redundant ECMP grows and redundant flooding grows exponentially and is much worse then circular nodal mesh.
[HC]: In the slides, a full mess topology is used to illustrate the algorithm in some details. The algorithm can be used to compute FT for any other topology such as clos spine leaf. For topology with M (e.g., 100) parallel links between any pair of nodes X and Y, the algorithm will just add one link to the FT between X and Y, the other M - 1 (e.g., 100-1 = 99) links will not be added to the FT. Thus the link states will flood over only this one link between X and Y on the FT and will not flood over the other M - 1 (e.g., 100 - 1 = 99) links, which are not on the FT.

Thank you

Gyan

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 May 2020 02:25:41 +0000

Hi Gyan,

    Thanks much for your comments and suggestions. My answers/explanations are inline below.

Best Regards,
Huaimo
Sent: Friday, May 22, 2020 9:11 PM

Hi Huaimo

Thinking about physical topology a little further as with the FT algorithm it makes sense to decouple the FT from the physical however the overall coverage is based on those basic parameters of degree number of links and nodes as well as width and depth of the topology.
[HC]: We may add/think more about physical topology and reduce/simplify the description about parameters in the draft.

Thinking about it further the clos leaf spine DC style topology is much worse in terms of flooding due to physical topology that leafs don’t physical connection and are interconnected via the spine creating massive ECMP and overload of the spine super spine.  So the physical DC leaf spine topology really exacerbates the flooding due to the non full mesh nature of the topology.
[HC]: You are right. The clos leaf spine topology is much worse. The algorithm in the draft can be used to compute FT for the clos leaf spine topology and reduce the number of links used for flooding significantly.

With a service provider core which is typically a mesh style multi tier multiple concentric circles mix of full and partial mesh and hub spoke type physical topologies.

So with flooding with full mesh every node connects with every node so you don’t have an overload of flooding being funneled through a super spine as you do with a leaf spine DC architecture.  So in a full mesh which is the best case scenario for flooding perspective from my point of view which each node as root connects to all nodes and then you can iteratively grow the flooding scope and it’s pretty controlled and you can limit the redundant flooding.  When the physical topology changes to a much more partially meshed the ECMP paths grow astronomically as does the flooding and longer convergence time.

So I think in the slide deck and draft look at scenario where their is tremendous ECMP from partial meshing and how the flood reduction algorithm improves the flooding and convergence.
[HC]: They should have more scenarios including clos spine leafs. The reason for not having them in the draft is that "drawing" topology of clos spine leaf to illustrate the algorithm in details is very hard.

Kind regards

Gyan

On Fri, May 22, 2020 at 8:41 PM Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:
Hi Huaimo

Thank you

Gyan

On Fri, May 22, 2020 at 10:05 AM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, May 21, 2020 10:13 PM
To: Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>
Cc: Huaimo Chen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

That would help.

https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306983861&sdata=IFYiJFuxf4UAMRmjxDf%2BTICOWslqJxCWjWwYYJM%2F6uQ%3D&reserved=0>

4.1

4.2

https://www.ietf.org/id/draft-chen-lsr-dynamic-flooding-algorithm-00.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-chen-lsr-dynamic-flooding-algorithm-00.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306988838&sdata=DlhahSNtm%2Ft406GcNtbGGq7uhFKfAqHO72Cm0vQdIo8%3D&reserved=0>

Kind regards

Gyan

Hi Gyan,

https://datatracker.ietf.org/doc/draft-chen-lsr-dynamic-flooding-algorithm/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-lsr-dynamic-flooding-algorithm%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306993818&sdata=f93gTdRXOpDko4jB0G%2B1Ixebs%2FrDHfmJ7WCWExPD5EI%3D&reserved=0>

You can see they both make use of the dynamic flooding infra in https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306998798&sdata=y7jC5eotw%2BebdD4dDfvO7pSlh8JUYurUyAC4kFJDpfY%3D&reserved=0>

Thanks,

Acee

Kind regards

Gyan

Speaking as WG Co-chair:

Hi Gyan,

Hi Gyan,

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306998798&sdata=y7jC5eotw%2BebdD4dDfvO7pSlh8JUYurUyAC4kFJDpfY%3D&reserved=0>

Thanks,

Acee

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307003777&sdata=b5DAj1yMUCRnkNtCjslcw8%2BhFQvZDFS%2FQZ1j9eRX5ts%3D&reserved=0>

6.4<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.4&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307008751&sdata=jKC3VcXH%2Bo64b4sgsoce8QmETmJm4vLNdCucfrLyCAg%3D&reserved=0>.  Area Leader Responsibilities

   flooding topologies.

6.5<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.5&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307013733&sdata=1XXbBG%2Fo%2Ft6zGyxqPQdbMZQLET3%2FaxrKj516zl1Ayn8%3D&reserved=0>.  Distributed Flooding Topology Calculation

   defined by the protocol.

   the Area Leader.

Former = WG LC

https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307018706&sdata=zf%2FK80oG8tz90g15eVrkGeyGc5fhBym5PJezCFfSi9A%3D&reserved=0>

Separate question-

https://datatracker.ietf.org/doc/html/draft-ietf-lsr-flex-algo-07<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-flex-algo-07&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307023687&sdata=MkDKud9pIJUwwoN%2F7w71fnOXfwu38sk4qwkGmDspUKI%3D&reserved=0>

Best Regards,

Huaimo

Hi Gyan,

Best Regards,

Huaimo

Huaimo

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307028662&sdata=NM0O3bq44tQ5GxZWm08rVjOh34mJjI1QsQ8DKFMgrAI%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-ietf-lsr-dynamic-flooding/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307033643&sdata=tk5GwzA0o%2Bheui0Hl3nIpNwmNXM0QW%2FEXRbDQav8y54%3D&reserved=0>

Kind regards

Gyan

Hi Gyan,

Best Regards,

Huaimo

Gyan

Thanks,

Yanhe

https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307038619&sdata=Rg7ZsHHsYJnJS7SpYUCLRsrDZ86Gi0iyKD2vMcjbboM%3D&reserved=0>

Thanks,
Acee

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307043598&sdata=JDfLRjkZ4PI%2BwVcV0Mm0LXqq4Pzl3wz7BWWpv0zTtq0%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307048576&sdata=gHSFT4GR6ZWS2MoTOPOVT%2BtTnF3wtTfRi5r1u6nzmcI%3D&reserved=0>

Gyan <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307053548&sdata=5RCW%2FwKABspmTndYt2yddKU2cGmYRpylfBQrM44LVZ0%3D&reserved=0> Mishra

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307058534&sdata=6kQPY2lr7kCb1D8TK8FyEcLUhEw%2BXbGo5wq25P1%2BCN8%3D&reserved=0>Network Solutions Architect

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307063514&sdata=KYMkolhI78NOupCfu2t4loUYoqPOz4DhWyVE5B6YefI%3D&reserved=0>

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307068486&sdata=efWfnCnZLIuib%2FkjHpXFoRTG%2FtueVoh5yTltBhLr4y4%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307073469&sdata=DU1ttb6xRduWgtpsBD6WNSWjma%2BtmtQdS%2FfOkth%2FwYc%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307078448&sdata=0Oy2TQby8nTywn4XD8Zlsf8pbX34m0xOcwFcPdDl6u0%3D&reserved=0>

Gyan Mishra

M 301 502-1347
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307083424&sdata=DDxMBzfPAQ4XWIlzTfnZSp%2Fn5Q2Q1eAqZffx%2BHM4aig%3D&reserved=0>13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307083424&sdata=KSSlepfFHvtyqtOAbwIAdqkXy9RF%2FdOfo7%2FDz5RHp7k%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307088401&sdata=8N6QAF6sCbXNbIhQQDT%2B7LbdWxWK5PX5kcfqeSA8PW0%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307093381&sdata=gM%2FzFPLLYGGKVIywDfe1VLMFtva0uGeYVwqjk4as53g%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307098359&sdata=RFI30Fh8pkVGzCIo0t%2FuhBIYcu6cFYMQnfAKH9TCXXM%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307103340&sdata=JJvVXt2V%2B4qdM6D8hsCCltvguXzAGUPqzJAF2cSurVo%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307108314&sdata=zZ9exHtpFs%2B7d%2BTLGDwewg8ogHEksDYKQ%2FlHoXfS5R4%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307113289&sdata=%2FvTes4sdQnRrA93lMZPAu%2BJeOuSZS%2BHN2NDIol5vkYU%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307118270&sdata=CClF2UDqnAIwJ%2FfohMZudsssA%2FOMvzcgQfNPGQaPFqk%3D&reserved=0>

--

Error! Filename not specified.<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307123246&sdata=hspNepcNSicG01BlQPInlTrzCEDP7PrhsN5l0U9Qps4%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307128228&sdata=Zb1%2FHn2R9VxjacjDLBnZIb97XOKZvEMRn7QJS2LUN0s%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307133207&sdata=6ggk25pVaku9AIy6JyzPcXFYp9HxBqyxJUCsS2O7cOk%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307133207&sdata=6ggk25pVaku9AIy6JyzPcXFYp9HxBqyxJUCsS2O7cOk%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307138181&sdata=UYVHVeDZVxKw00dHyJFAM%2Ft4RrHG1Q5xsnfU2%2FQh89E%3D&reserved=0>

--

[Image removed by sender.]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307143161&sdata=X%2FWFBYrgiaP3mP0VBmEbu9FmwKXpEBlXX%2F7N6IlbQMM%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307148138&sdata=9KuBH1b%2FrqYPVPz1x0oh6WOhHTgJwGYW4oTqijSBVns%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307153117&sdata=A%2F3aTskhdp8bYtLKDT9VQLCNNifuZm%2F3F2YRciVyH5E%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307158095&sdata=iW%2F09yn2PMwEzUAIXaBwVId9QrSNXbS1z7s8Vl9Ts78%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307163074&sdata=o6fgwcMsNL9oCFlB%2BUx%2FmtsvLiz%2BcUS5njwbbChsjlg%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307168050&sdata=mixHFVEqF4qQ4i%2B6JbES5OP1g%2FSb%2FrxDgIv9Rww4jf4%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307173031&sdata=zguxTuADiqiiAZ22lAVWQD8f6JNBQwU9hgD1QktRULs%3D&reserved=0>
Silver Spring, MD<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307173031&sdata=zguxTuADiqiiAZ22lAVWQD8f6JNBQwU9hgD1QktRULs%3D&reserved=0>

<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307178009&sdata=37qV2uXfgIRo455Ws84yQpkIjpQxU6VM6O8mSCRJjVc%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307182993&sdata=nHxpOihZ9RJbYVyIpCHoF22OEPNqU2vfUUlGkIY5wIA%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307187963&sdata=i9TTvZIGnP2LjLgUmMY013K5JYHVlHSoDmhMSfI8cbc%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 May 2020 02:50:02 +0000

Hi Gyan,

Gyan> I know we are trying to adopt an flooding algorithm
and from my reading up on all proposed algorithms, the dynamic flooding seems to be geared towards Data Center  partial mesh high x ECMP leaf spine architecture, where redundant flooding is problematic using either centralized area leader or distributed flooding using same dynamic algorithm,  versus the call for adoption flood reduction algorithm seems to geared towards full mesh but from what I can tell would not be the preferred for clos multi tier DC leaf spine topology with high x ECMP paths.

[HC]: The algorithm in the call for adoption is also for (or say, gear towards) clos multi tier DC leaf spine topology with high x ECMP paths. In the Appendix of the draft, a full mess example topology of 5 nodes is used to illustrate the steps of the algorithm in some details. Using this topology is for easily "drawing" it and illustrating the steps of the algorithm. "Drawing" a clos multi tier DC leaf spine topology high x ECMP paths to illustrate the algorithm in details is very hard in the draft.

Best Regards,
Huaimo
________________________________
From: Gyan Mishra <[email-masked]>
Sent: Sunday, May 24, 2020 6:29 PM
To: Sarah Chen <[email-masked]>; [email-masked] <[email-masked]>
Cc: Acee Lindem (acee) <[email-masked]>; Huaimo Chen <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Hi Acee

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-9000-series-switches/white-paper-c11-743015.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C427cee154ea74148fc8f08d80031f917%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637259561920543212&sdata=qVG4uwYPelL1syGzMViZSvOodKoWy2dlL1AyZ%2BljmB0%3D&reserved=0>

https://www.ietf.org/id/draft-chen-lsr-dynamic-flooding-algorithm-00.html<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-chen-lsr-dynamic-flooding-algorithm-00.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C427cee154ea74148fc8f08d80031f917%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637259561920553208&sdata=v400uLAa%2Fu3RwJlHfYhplTzR4sXVwMpCZA%2B%2BSM6adgI%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-cc-lsr-flooding-reduction-08<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C427cee154ea74148fc8f08d80031f917%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637259561920553208&sdata=ZA%2F1DXQYGsbJHynkM5V8bj6Y5VnuwM%2FHftO02nlmzLk%3D&reserved=0>

I know we are trying to adopt an flooding algorithm
and from my reading up on all proposed algorithms, the dynamic flooding seems to be geared towards Data Center  partial mesh high x ECMP leaf spine architecture, where redundant flooding is problematic using either centralized area leader or distributed flooding using same dynamic algorithm,  versus the call for adoption flood reduction algorithm seems to geared towards full mesh but from what I can tell would not be the preferred for clos multi tier DC leaf spine topology with high x ECMP paths.

Gyan

On Sat, May 23, 2020 at 4:43 PM Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, May 22, 2020 at 9:02 PM <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gyan,

   Gyan>. Agreed.  The dynamic flooding really helps with X way ECMP prevalent in high density data center clos multi tier leaf spine parial mesh topologies that scale massive bandwidth breadth wise horizontally for E-W flows.

Regards,
Tony

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C427cee154ea74148fc8f08d80031f917%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637259561920563199&sdata=hZ4%2BnucAFIcZGAaq3Tx%2FnmLMuEP63mHgoIPhvNTjW6s%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C427cee154ea74148fc8f08d80031f917%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637259561920573196&sdata=oxuHfFd0YTOLZPTeLYMIEAuHzJhzNsjkPyjO8DqgFkA%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 27 May 2020 17:49:25 +0000

Tony/Gyan -

Please find my replies inline.

From: Lsr <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, May 20, 2020 8:48 AM
To: Gyan Mishra <[email-masked]>
Cc: [email-masked]; Huaimo Chen <[email-masked]>; Acee Lindem (acee) <acee=[email-masked]>
Subject: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Hi Gyan,

Thank you.

[Les:] Yes, this is a different algorithm than either https://datatracker.ietf.org/doc/draft-chen-lsr-dynamic-flooding-algorithm/ or  https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/

We are contemplating submitting a draft for this algorithm to the WG.

[Les:] As I understand it, draft-chen only supports centralized mode - which is why it is Informational track and does not have interoperability concerns.
Sarah/Tony - do you have plans to extend this to support distributed mode and then standardize it?

At present there are no standard algorithm candidates which have achieved WG status - though that likely will change very soon.
And the point of allowing multiple standardized algorithms to be defined was in the expectation that more than one might be proven useful.

[Les:] As did Cisco's.

[Les:] Confirmed.

   Les

Tony

---

From: [email-masked]
Date: Wed, 27 May 2020 11:40:42 -0700

Les,

> We are contemplating submitting a draft for this algorithm to the WG.

We would welcome that.  

Does your algorithm have any relationship to https://tools.ietf.org/html/draft-allan-lsr-flooding-algorithm-00? <https://tools.ietf.org/html/draft-allan-lsr-flooding-algorithm-00?>

> [Les:] As I understand it, draft-chen only supports centralized mode – which is why it is Informational track and does not have interoperability concerns.

Not at this time.  As we said during our presentation, we found debugging this already ‘challenging’ and morphing it to be distributed and deterministic in distributed mode doesn’t pass our sense of a beneficial cost/benefit ratio.

We have no objections if others want to take this on.  Centralized mode Just Works.

> And the point of allowing multiple standardized algorithms to be defined was in the expectation that more than one might be proven useful.

Interoperability might also prove useful. :-)

Tony

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 28 May 2020 23:14:44 -0400

Les & Tony

Please see my replies inline

On Wed, May 27, 2020 at 1:49 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Tony/Gyan –
> *From:* Lsr <[email-masked]> *On Behalf Of * [email-masked]
> *Sent:* Wednesday, May 20, 2020 8:48 AM
> *To:* Gyan Mishra <[email-masked]>
> *Cc:* [email-masked]; Huaimo Chen <[email-masked]>; Acee Lindem
> (acee) <acee=[email-masked]>
> *[Les:] Yes, this is a different algorithm than either
> <https://datatracker.ietf.org/doc/draft-chen-lsr-dynamic-flooding-algorithm/>
> or  https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/
> <https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/>*
>
* <https://datatracker.ietf.org/doc/draft-cc-lsr-flooding-reduction/>*
>
> *We are contemplating submitting a draft for this algorithm to the WG.*
>
> * Gyan> I think that would  be good for your customers so it’s not
> proprietary.*
>
>
>
>
>
> This will give us three different implementations, using three different
> algorithms, none of which will inter-operate.  Whee!!! :-(
>
>
>
>
>
> *[Les:] As I understand it, draft-chen only supports centralized mode –
> which is why it is Informational track and does not have interoperability
> concerns.*
>
> *Sarah/Tony - do you have plans to extend this to support distributed mode
> and then standardize it?*
>
>
>
> *At present there are no standard algorithm candidates which have achieved
> WG status – though that likely will change very soon.*
>
> *And the point of allowing multiple standardized algorithms to be defined
> was in the expectation that more than one might be proven useful.*
>
> * Gyan> So along those same lines in theory we could have hypothetically 3
> algorithms and all three on standards track which would give operators like
> Verizon and 3 options to pick from based on the physical topology use case.*
>
*Caveat would be - would vendors really want to develop other vendors
> options at a cost especially if there are more then two or rather keep
> their own option proprietary.  I think *
>
There maybe other features that you could get away with interoperability
> not being a concern but I think the flooding algorithm I would think would
> have to be the same for 2 vendors to be interoperable.
>
> *[Les:] As did Cisco’s.*
> *[Les:] Confirmed.*
> *   Les*
-- 

*Gyan Mishra*

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 28 May 2020 23:24:07 -0400

Hi Huaimo

Thank you for answering my questions.

Replies in-line

On Sun, May 24, 2020 at 10:25 PM Huaimo Chen <[email-masked]>
wrote:

> *Sent:* Friday, May 22, 2020 9:11 PM
> *Cc:* Acee Lindem (acee) <[email-masked]>; [email-masked] <[email-masked]>
> [HC]: We may add/think more about physical topology and reduce/simplify
> the description about parameters in the draft.
>

    Gyan>. Thank you I think that would be really helpful adding other
physical topologies other then full mesh and if you can do clos 3 tier and
leaf/spine would be great. Simplify parameter descriptions would be very
helpful.

> [HC]: You are right. The clos leaf spine topology is much worse. The
> algorithm in the draft can be used to compute FT for the clos leaf spine
> topology and reduce the number of links used for flooding significantly.
>

    Gyan> Adding the other physical would help visualize how the algorithm
works with all topologies.  In reading the draft I did not get that the
algorithm would work for clos or leaf/spine so maybe need to add verbiage
to clarify.

> [HC]: They should have more scenarios including clos spine leafs. The
> reason for not having them in the draft is that "drawing" topology of clos
> spine leaf to illustrate the algorithm in details is very hard.
>
> Kind regards
>
> Gyan
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306983861&sdata=IFYiJFuxf4UAMRmjxDf%2BTICOWslqJxCWjWwYYJM%2F6uQ%3D&reserved=0>
>
> 4.1
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-chen-lsr-dynamic-flooding-algorithm-00.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306988838&sdata=DlhahSNtm%2Ft406GcNtbGGq7uhFKfAqHO72Cm0vQdIo8%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-lsr-dynamic-flooding-algorithm%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306993818&sdata=f93gTdRXOpDko4jB0G%2B1Ixebs%2FrDHfmJ7WCWExPD5EI%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306998798&sdata=y7jC5eotw%2BebdD4dDfvO7pSlh8JUYurUyAC4kFJDpfY%3D&reserved=0>
>
>
>
> Thanks,
>
> Acee
>
>
>
>
>
>
>
>
>
> Kind regards
>
>
>
> Gyan
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931306998798&sdata=y7jC5eotw%2BebdD4dDfvO7pSlh8JUYurUyAC4kFJDpfY%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307003777&sdata=b5DAj1yMUCRnkNtCjslcw8%2BhFQvZDFS%2FQZ1j9eRX5ts%3D&reserved=0>
>
>
>
> *6.4 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.4&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307008751&sdata=jKC3VcXH%2Bo64b4sgsoce8QmETmJm4vLNdCucfrLyCAg%3D&reserved=0>.  Area Leader Responsibilities*
>
>
>
> *6.5 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-dynamic-flooding-05%23section-6.5&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307013733&sdata=1XXbBG%2Fo%2Ft6zGyxqPQdbMZQLET3%2FaxrKj516zl1Ayn8%3D&reserved=0>.  Distributed Flooding Topology Calculation*
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cc-lsr-flooding-reduction-08&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307018706&sdata=zf%2FK80oG8tz90g15eVrkGeyGc5fhBym5PJezCFfSi9A%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lsr-flex-algo-07&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307023687&sdata=MkDKud9pIJUwwoN%2F7w71fnOXfwu38sk4qwkGmDspUKI%3D&reserved=0>
>
>
>
>
>
> Best Regards,
>
> Huaimo
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cisco.com%2Fc%2Fen%2Fus%2Fproducts%2Fcollateral%2Fswitches%2Fnexus-9000-series-switches%2Fwhite-paper-c11-743015.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307028662&sdata=NM0O3bq44tQ5GxZWm08rVjOh34mJjI1QsQ8DKFMgrAI%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-lsr-dynamic-flooding%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307033643&sdata=tk5GwzA0o%2Bheui0Hl3nIpNwmNXM0QW%2FEXRbDQav8y54%3D&reserved=0>
>
>
>
> Kind regards
>
>
>
> Gyan
>
>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-cc-lsr-flooding-reduction%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307038619&sdata=Rg7ZsHHsYJnJS7SpYUCLRsrDZ86Gi0iyKD2vMcjbboM%3D&reserved=0>
>
>
>
> Thanks,
> Acee
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307043598&sdata=JDfLRjkZ4PI%2BwVcV0Mm0LXqq4Pzl3wz7BWWpv0zTtq0%3D&reserved=0>
>
> --
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307048576&sdata=gHSFT4GR6ZWS2MoTOPOVT%2BtTnF3wtTfRi5r1u6nzmcI%3D&reserved=0>
>
> *Gyan
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307053548&sdata=5RCW%2FwKABspmTndYt2yddKU2cGmYRpylfBQrM44LVZ0%3D&reserved=0>Mishra*
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307058534&sdata=6kQPY2lr7kCb1D8TK8FyEcLUhEw%2BXbGo5wq25P1%2BCN8%3D&reserved=0>*Network
> Solutions Architect *
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307068486&sdata=efWfnCnZLIuib%2FkjHpXFoRTG%2FtueVoh5yTltBhLr4y4%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307073469&sdata=DU1ttb6xRduWgtpsBD6WNSWjma%2BtmtQdS%2FfOkth%2FwYc%3D&reserved=0>
>
>
>
> --
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307078448&sdata=0Oy2TQby8nTywn4XD8Zlsf8pbX34m0xOcwFcPdDl6u0%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%250D%250A%2BColumbia%2BPike%2B%250D%250A%2BSilver%250D%250A%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307083424&sdata=DDxMBzfPAQ4XWIlzTfnZSp%2Fn5Q2Q1eAqZffx%2BHM4aig%3D&reserved=0>13101
> Columbia Pike
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307083424&sdata=KSSlepfFHvtyqtOAbwIAdqkXy9RF%2FdOfo7%2FDz5RHp7k%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307088401&sdata=8N6QAF6sCbXNbIhQQDT%2B7LbdWxWK5PX5kcfqeSA8PW0%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307098359&sdata=RFI30Fh8pkVGzCIo0t%2FuhBIYcu6cFYMQnfAKH9TCXXM%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307103340&sdata=JJvVXt2V%2B4qdM6D8hsCCltvguXzAGUPqzJAF2cSurVo%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307108314&sdata=zZ9exHtpFs%2B7d%2BTLGDwewg8ogHEksDYKQ%2FlHoXfS5R4%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307123246&sdata=hspNepcNSicG01BlQPInlTrzCEDP7PrhsN5l0U9Qps4%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307128228&sdata=Zb1%2FHn2R9VxjacjDLBnZIb97XOKZvEMRn7QJS2LUN0s%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307143161&sdata=X%2FWFBYrgiaP3mP0VBmEbu9FmwKXpEBlXX%2F7N6IlbQMM%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307148138&sdata=9KuBH1b%2FrqYPVPz1x0oh6WOhHTgJwGYW4oTqijSBVns%3D&reserved=0>
> *Silver Spring, MD
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307153117&sdata=A%2F3aTskhdp8bYtLKDT9VQLCNNifuZm%2F3F2YRciVyH5E%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307168050&sdata=mixHFVEqF4qQ4i%2B6JbES5OP1g%2FSb%2FrxDgIv9Rww4jf4%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%2B%250D%250A%2BSilver%2BSpring%2C%2BMD%3Fentry%3Dgmail%26source%3Dg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4c12ec234b2a452db84408d7feb65044%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637257931307173031&sdata=zguxTuADiqiiAZ22lAVWQD8f6JNBQwU9hgD1QktRULs%3D&reserved=0>*
>
> --

*Gyan Mishra*

---

From: Huzhibo <[email-masked]>
Date: Fri, 29 May 2020 14:52:54 +0000

I support this adaption.It propose an algorithm for node to compute a flooding topology.It is useful for reduce flooding.

--------------------------------------------------
胡志波 Hu Zhibo
Mobile: +86-18618192287<tel:+86-18618192287>
Email: [email-masked]<mailto:[email-masked]>

发件人：Acee Lindem (acee) <acee=[email-masked]>
收件人：lsr <[email-masked]>
时 间：2020-05-16 03:40:29
主 题：[Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks,
Acee

---

From: "Dailongfei (Larry, IP Research)" <[email-masked]>
Date: Sat, 30 May 2020 16:17:52 +0000

I support this adoption. It is useful to reduce flooding in dense network.

Thanks
Larry
发件人: Lsr [mailto:[email-masked]] 代表 Huzhibo
发送时间: 2020年5月29日 22:53
收件人: Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; lsr <[email-masked]<mailto:[email-masked]>>
主题: Re: [Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

--------------------------------------------------
胡志波 Hu Zhibo
Mobile: +86-18618192287<tel:+86-18618192287>
Email: [email-masked]<mailto:[email-masked]>
发件人：Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>
收件人：lsr <[email-masked]<mailto:[email-masked]>>
时 间：2020-05-16 03:40:29
主 题：[Lsr] Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks,
Acee

---

From: ruoxin huang <[email-masked]>
Date: Sat, 30 May 2020 16:22:05 +0000

I support this adoption. It is useful to reduce flooding.

Thanks
ruoxin
________________________________
From: Lsr <[email-masked]> on behalf of Dailongfei (Larry, IP Research) <[email-masked]>
Sent: Sunday, May 31, 2020 12:17 AM
To: lsr <[email-masked]>
Subject: [Lsr] 答复: Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks
Larry

Thanks,
Acee

---

From: reta Yang <[email-masked]>
Date: Sat, 30 May 2020 16:26:40 +0000

I support this adoption.

Thanks
Reta
________________________________
From: Lsr <[email-masked]> on behalf of ruoxin huang <[email-masked]>
Sent: Sunday, May 31, 2020 12:22 AM
To: lsr <[email-masked]>
Subject: [Lsr] Fw: 答复: Flooding Topology Computation Algorithm - draft-cc-lsr-flooding-reduction-08 Working Group Adoption Call

Thanks
ruoxin

Thanks

Larry

时 间：2020-05-16 03:40:29

Thanks,
Acee