Subject: Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

From: Davey Song <[email-masked]>
Date: Sat, 6 Mar 2021 01:25:44 +0800

+1 support. It is a good piece of work.

Davey

*发件人：* Acee Lindem \(acee\) <acee=[email-masked]>
*发送时间：* 2021-03-03 07:27
*收件人：* [email-masked]
*主题：* [Lsr]WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for
Segment Routing based Virtual Transport Network” -
draft-xie-lsr-isis-sr-vtn-mt-03

This information draft describes how MT could be used for VTN segmentation.
The authors have asked for WG adoption.

This begins a three week LSR Working Group Adoption Poll for “Using IS-IS
Multi-Topology (MT) for Segment Routing based Virtual Transport Network” -
draft-xie-lsr-isis-sr-vtn-mt-03. I’m giving it three weeks due to the IETF
next week. Please register your support or objection on this list prior to
the end of the adoption poll on 3/24/2020.

Thanks,

Acee

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 9 Mar 2021 22:55:47 +0800

Hi, all

 This draft describes the IGP control plane mechanism with necessary extensions to build SR based VTNs. It is useful. I support the adoption of this document.

Best regards，
Cong Li
 
发件人： Acee Lindem (acee)
发送时间： 2021-03-03 07:27
收件人： [email-masked]
主题： [Lsr]WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03
This information draft describes how MT could be used for VTN segmentation. The authors have asked for WG adoption. 
 
This begins a three week LSR Working Group Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03. I’m giving it three weeks due to the IETF next week. Please register your support or objection on this list prior to the end of the adoption poll on 3/24/2020. 
 
Thanks,
Acee

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 18 Mar 2021 08:49:09 +0800

Hi, folks,
In this draft, MT-ID is resued as the control plane ID of VTN and advertise TE attrributes for different VTNs. I think it is useful for carrier network, and I support it to be adopted.

Best regards
Chen 

李  晨  Li Chen
中国电信研究院  网络规划研究创新中心
电话：010-50902891/18910853955
邮箱：[email-masked]/[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Planning Researching and Innovation Center
Email：[email-masked] /[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 30 Mar 2021 09:58:25 +0000

Hi Chongfeng,

From: Chongfeng Xie <[email-masked]>
Date: Tuesday, March 30, 2021 at 3:26 AM
To: Acee Lindem <[email-masked]>, Jie Dong <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Re: [Lsr]WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Hi, Acee,
Thank you for your comments. I agree with your consideration about using mature and deployed control plane technologies, and this document does not introduce any new IS-IS encodings. While the resource-aware segments has the same format as the legacy SR segments, the difference is in the semantics. Thus the same control plane mechanism in this draft could be used with either the legacy SR SIDs or the resource-aware SIDs. Using it with legacy SR SIDs could also help to compute SR paths in a VTN taking its topology and resources as constraints. When used with the resource-aware SIDs, it can further provide VTNs with guaranteed resources. We could add some text about this to the draft if you think this is helpful.

Yes – that would be useful.
Thanks,
Acee

Best regards
Chongfeng

发件人： Acee Lindem \(acee\)<mailto:acee=[email-masked]>
发送时间： 2021-03-30 03:32
收件人： Chongfeng Xie<mailto:[email-masked]>; Dongjie (Jimmy)<mailto:[email-masked]>; Acee Lindem (acee)<mailto:acee=[email-masked]>; [email-masked]<mailto:[email-masked]>
主题： Re: [Lsr]WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03
Hi Chongfeng,

Given that the main argument for using MT to realize VTNs in the control plane is that it is a mature and deployed technology, requiring resource-aware segments, a new and evolving technology, defeats the purpose.

Thanks,
Acee

From: Chongfeng Xie <[email-masked]>
Date: Monday, March 29, 2021 at 8:58 AM
To: Acee Lindem <[email-masked]>, "chongfeng.xie" <[email-masked]>, Jie Dong <[email-masked]>, "Acee Lindem (acee)" <acee=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Hi, Acee,
Thanks for your comments. This document can be used with resource-aware segments to provide VTNs with guaranteed resources, while I agree it may also be used with legacy SR technologies. This could be clarified in next version.

Regards
Chongfeng

发件人： Acee Lindem (acee)<mailto:[email-masked]>
发送时间： 2021-03-27 18:31
收件人： Chongfeng Xie<mailto:[email-masked]>; Dongjie (Jimmy)<mailto:[email-masked]>; Acee Lindem (acee)<mailto:acee=[email-masked]>; [email-masked]<mailto:[email-masked]>
主题： Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03
Speaking as WG member:

Hi Chongfeng,

Another thing, if one is trying to support a VTN with legacy technologies, it would be good to decouple it from the SR resource-aware segments.

Thanks,
Acee

From: Chongfeng Xie <[email-masked]>
Date: Friday, March 26, 2021 at 11:15 PM
To: Acee Lindem <[email-masked]>, Jie Dong <[email-masked]>, "chongfeng.xie" <[email-masked]>, "Acee Lindem (acee)" <acee=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Hi, Acee,

Thanks for your understanding about the deployment considerations and the value of reusing existing technologies when possible.

We have submitted the draft as draft-ietf-lsr-isis-sr-vtn-mt-00 with only the change in the title and date.  And we will expand section 5 and add references to relevant TEAS documents in next revision.

Chongfeng

发件人： Acee Lindem (acee)<mailto:[email-masked]>
发送时间： 2021-03-26 23:30
收件人： Dongjie (Jimmy)<mailto:[email-masked]>; Chongfeng Xie<mailto:[email-masked]>; Acee Lindem (acee)<mailto:acee=[email-masked]>; [email-masked]<mailto:[email-masked]>
主题： Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03
Hi Jie, Chongfeng,

I’ve read draft-ietf-teas-enhanced-vpn and I agree that the combination of MT and SR could be used to meet a given SLO. Given that I work with products and customers, I also know there can be a significant time lag for qualification and deployment of a software version. In lieu of resource-aware segments, you could even use an existing technology like VLANs with appropriate QoS guarantees. Hence, I can see the value of using existing technologies. Please go ahead and republish draft-xie-lsr-sr-vtn-mt as draft-ietf-lsr-sr-vtn-mt-00.txt.

Section 5 can be expanded in subsequent revisions with appropriate references to TEAS documents.

Thanks,
Acee

From: Lsr <[email-masked]> on behalf of Jie Dong <[email-masked]>
Date: Friday, March 26, 2021 at 10:39 AM
To: Chongfeng Xie <[email-masked]>, "Acee Lindem (acee)" <acee=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Hi Acee,

I agree with what Chongfeng said about VTN. It refers to a virtual underlay network with specific topology and resource attributes, and the topology of VTNs can be specified using multi-topology. It is important to understand the difference between a VTN and a logical network topology.

As for the deployment choice and scalability, draft-dong-teas-enhanced-vpn-vtn-scalability gives some detailed analysis. In summary, it says in different network scenarios and phases, the required number of VTNs could be different, thus several options may be provided to meet different requirements, with different cost and time to market.

Best regards,
Jie

From: Lsr [mailto:[email-masked]] On Behalf Of Chongfeng Xie
Sent: Friday, March 26, 2021 2:14 PM
To: Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
Subject: Re: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Hi，Acee，

Regarding to the issues put forward in your mail, I'd like to provide some comments as below,

Q1：I’d like to know of the WG members who supported it, would you really want to market it as a VTN solution?

[CF]：VTN is defined in draft-ietf-teas-enhanced-vpn, and also used in other documents. It is a technical term to refer to virtual underlay networks with specific topology and resource attributes. This document provides an MT based mechanism to build VTNs. If for marketing, perhaps it would be better called "network slicing":-)

Q2：Those of you who operate networks, would you actually consider deploying it?

[CF]：As an operator we will consider the scenarios and the requirements to pick the most suitable solution, IMO this is a good candidate for scenarios where the required number of VTN is not very large, and as it requires no new encodings, it could be ready for shipment soon. we plans to use this approach in some of our network deployment.

Q3：In any case, section 5 needs to be expanded on the scalability and where using MTs to support VTNs would make sense and where it wouldn’t.

[CF]：OK. The current section 5 already has some text to cover this, and it can be expanded further to clarify.

Best regards
Chongfeng

发件人： Acee Lindem \(acee\)<mailto:acee=[email-masked]>
发送时间： 2021-03-26 02:20
收件人： [email-masked]<mailto:[email-masked]>
主题： Re: [Lsr]WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03
Speaking as WG chair:

There has been considerable support for this document. However, there has also been objections to the document. The objections are either that there is nothing to standardize given that all pieces exist and that the MT isn’t a viable option for VTNs since it isn’t scalable.

Since most of the draft’s support is from “friends and family”, I’d like to know of the WG members who supported it, would you really want to market it as a VTN solution? Those of you who operate networks, would you actually consider deploying it?

In any case, section 5 needs to be expanded on the scalability and where using MTs to support VTNs would make sense and where it wouldn’t.

Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <acee=[email-masked]<mailto:acee=[email-masked]>>
Date: Tuesday, March 2, 2021 at 6:28 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Lsr] WG Adoption Poll for “Using IS-IS Multi-Topology (MT) for Segment Routing based Virtual Transport Network” - draft-xie-lsr-isis-sr-vtn-mt-03

Thanks,
Acee