Subject: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

From: Linda Dunbar <[email-masked]>
Date: Tue, 9 Mar 2021 00:40:01 +0000

Christian,

You said at LSR session today that there might be concern of network optimizing ANYCAST traffic to better balance among multiple App Layer Load Balancers.
First of all, only the Applications that need to leverage the network condition to balance among their multiple Load Balancers will get the benefit of path selection that are based on the combination of routing distance and other dynamic running status. The networks (e.g. 5G EC Local Data Networks)  only optimize the ANYCAST traffic for the registered addresses.
The network is already responsible for selecting the shortest path to one Application Load Balancer. draft-dunbar-lsr-5g-edge-compute-ospf-ext proposes to add additional weight in path selection.

ANYCAST makes it possible to dynamically load balance across server locations based on network conditions. With multiple servers having the same ANYCAST address, it eliminates the single point of failure and bottleneck at the application layer load balancer that has the shortest routing distance. Another benefit of using ANYCAST address is removing the dependency on how UEs get the IP addresses for their Applications. Some UEs (or clients) might use stale cached IP addresses for extended period.

Network service providers can even offer this as a value added service, making network information more useful to deliver services to applications.
Isn't it a win-win approach for both network service providers and the applications owners?

Linda Dunbar

---

From: Christian Hopps <[email-masked]>
Date: Mon, 8 Mar 2021 19:59:54 -0500

> On Mar 8, 2021, at 7:40 PM, Linda Dunbar <[email-masked]> wrote:
> 
> Christian,
> 
> Isn’t it a win-win approach for both network service providers and the applications owners?

As WG member,

It's not a win when their network fails.

At a high level I think the idea of a smart network is interesting. I don't have good initial feelings though about trying to achieve that by adding application load based metrics into the routing protocol. There's all sort of layer violations going on there for one, but perhaps more importantly, our routing protocols have not been tried and tested over the decades with this use in mind.

One could imagine designing a higher layer distributed load balancing application/protocol that utilized routing information though, something like that would align more closely with the layering we've been designing to all these years. It probably would not rely on anycast exclusively, but instead use anycast to talk to a server that implemented this LB protocol (something anycast is good at) which would provide a unicast address for the requested application, with the ability to adjust (reacquire a new unicast address, whatever) as conditions (either at the routing or application layer) change through notifications or polling. Just brainstorming here, but there are lots of ways one could imagine this working.

Thanks,
Chris.

---

From: Liyizhou <[email-masked]>
Date: Tue, 9 Mar 2021 04:35:45 +0000

Hi,

Sorry to chime in.

There are certainly some higher layer application/protocols to employ. At the same time, there are some advantages of network layer approaches as well in my mind.

When talking about edge computing, there are some unique characteristics. The number of edge sites could be large or huge in future in a big city. Edges are geographically scattered which could be a few, or tens of, or a hundred kilometers away from each other, and each site has limited computing resources which could be a small cluster. Application layer based approach normally would rely on one or several “server”/”broker” to be responsible for request handling all over the city. As such “servers” are unlikely available on each and every edge site, it introduces additional path stretch for data packets requiring delivery to other edge sites first. Such path stretch introduces additional (network and processing) delay which could be crucial for short live request flow. On the contrary, the network node at the edge is naturally sitting on the data path without introducing any additional cost to direct the (explicit/implicit) request somewhere else. Also routing system has been proven doing good in such distributed manner.

There is a dyncast (dynamic anycast) work ongoing. It is not exactly same as what Linda proposed here, but some relations can be seen, like trying to use anycast methodology to access an edge computing, especially computational intensive, service. The current discussions are about compellingness of the use cases, the deficiency of existing solutions, and proposed architecture, not gone very far into what specific routing protocols to use yet. A side meeting will be held on Wed 10am CET. You may check https://github.com/dyncast/ietf110 for more info.

Cheers,
Yizhou

From: Lsr [mailto:[email-masked]] On Behalf Of Christian Hopps
Sent: Tuesday, March 9, 2021 9:00 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; Christian Hopps <[email-masked]>
Subject: Re: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

On Mar 8, 2021, at 7:40 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

Christian,

As WG member,

Thanks,
Chris.

Linda Dunbar

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 9 Mar 2021 01:07:41 -0500

Linda and authors

Some thoughts regarding load balancing draft.

Anycast in my experience has been used predominantly in my experience
within operators networks with BGP overlay,  using BGP best path selection
and most cases boils down to lowest IGP metric tie breaker shortest path
for the service Anycast proximity route which you can also with unique RD
in overlay and can take advantage of iBGP multipath equal cost load
balancing over an operator vaccine or 4G/5G RAN xhaul or internet.

The nice thing about Anycast with BGP overlay you as are automatically
proximity based routing load balancing inherent to Anycast routing.

Point here is we are using BGP best path selection but it does boils down
to IGP lowest metric tie breaker but you can use iBGP multipath to further
optimize the routing for cloud computing.

We have so many tools in our operators toolbox to optimize routing SR or
Flex-Algo, SDN etc am wondering if some form of SDN or SD-WAN overlay could
provide the Dyncast type Dynamic Anycast solution.

I want to the wiki page for Dyncast.  The presentation is not available
yet.  Will check tomorrow.

Thanks

Gyan

On Mon, Mar 8, 2021 at 11:36 PM Liyizhou <[email-masked]> wrote:

> Hi,
>
>
>
> Sorry to chime in.
>
>
>
> There are certainly some higher layer application/protocols to employ. At
> the same time, there are some advantages of network layer approaches as
> well in my mind.
>
>
>
> When talking about edge computing, there are some unique characteristics.
> The number of edge sites could be large or huge in future in a big city.
> Edges are geographically scattered which could be a few, or tens of, or a
> hundred kilometers away from each other, and each site has limited
> computing resources which could be a small cluster. Application layer based
> approach normally would rely on one or several “server”/”broker” to be
> responsible for request handling all over the city. As such “servers” are
> unlikely available on each and every edge site, it introduces additional
> path stretch for data packets requiring delivery to other edge sites first.
> Such path stretch introduces additional (network and processing) delay
> which could be crucial for short live request flow. On the contrary, the
> network node at the edge is naturally sitting on the data path without
> introducing any additional cost to direct the (explicit/implicit) request
> somewhere else. Also routing system has been proven doing good in such
> distributed manner.
>
>
>
>
>
> There is a dyncast (dynamic anycast) work ongoing. It is not exactly same
> as what Linda proposed here, but some relations can be seen, like trying to
> use anycast methodology to access an edge computing, especially
> computational intensive, service. The current discussions are about
> compellingness of the use cases, the deficiency of existing solutions, and
> proposed architecture, not gone very far into what specific routing
> protocols to use yet. A side meeting will be held on Wed 10am CET. You may
> check https://github.com/dyncast/ietf110 for more info.
>
>
>
> Cheers,
>
> Yizhou
>
>
>
> *From:* Lsr [mailto:[email-masked]] *On Behalf Of *Christian Hopps
> *Sent:* Tuesday, March 9, 2021 9:00 AM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* [email-masked]; Christian Hopps <[email-masked]>
> *Subject:* Re: [Lsr] Why not leverage Network conditions to optimize
> balancing among multiple App Layer Load Balancers? as proposed by
> draft-dunbar-lsr-5g-edge-compute-ospf-ext
>
>
>
>
>
>
>
> You said at LSR session today that there might be concern of network
> optimizing ANYCAST traffic to better balance among multiple App Layer Load
> Balancers.
>
> First of all, only the Applications that need to leverage the network
> condition to balance among their multiple Load Balancers will get the
> benefit of path selection that are based on the combination of routing
> distance and other dynamic running status. The networks (e.g. 5G EC Local
> Data Networks)  only optimize the ANYCAST traffic for the registered
> addresses.
>
> The network is already responsible for selecting the shortest path to one
> Application Load Balancer. draft-dunbar-lsr-5g-edge-compute-ospf-ext
> proposes to add additional weight in path selection.
>
>
>
> ANYCAST makes it possible to dynamically load balance across server
> locations based on network conditions. With multiple servers having the
> same ANYCAST address, it eliminates the single point of failure and
> bottleneck at the application layer load balancer that has the shortest
> routing distance. Another benefit of using ANYCAST address is removing the
> dependency on how UEs get the IP addresses for their Applications. Some UEs
> (or clients) might use stale cached IP addresses for extended period.
>
>
>
> Network service providers can even offer this as a value added service,
> making network information more useful to deliver services to applications.
>
> At a high level I think the idea of a smart network is interesting. I
> don't have good initial feelings though about trying to achieve that by
> adding application load based metrics into the routing protocol. There's
> all sort of layer violations going on there for one, but perhaps more
> importantly, our routing protocols have not been tried and tested over the
> decades with this use in mind.
>
>
>
> One could imagine designing a higher layer distributed load balancing
> application/protocol that utilized routing information though, something
> like that would align more closely with the layering we've been designing
> to all these years. It probably would not rely on anycast exclusively, but
> instead use anycast to talk to a server that implemented this LB protocol
> (something anycast is good at) which would provide a unicast address for
> the requested application, with the ability to adjust (reacquire a new
> unicast address, whatever) as conditions (either at the routing or
> application layer) change through notifications or polling. Just
> brainstorming here, but there are lots of ways one could imagine this
> working.
>
>
>
> Thanks,
>
> Chris.
>
>
>
>
>
> Linda Dunbar
>
>
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 9 Mar 2021 12:46:30 +0000

Christian,

If “network fails”, the packets won’t even get into the desired App Server (or App Layer Load Balancer).
What the draft has proposed is to add a “Tie breaker” or additional weight to the “Best Path” selection by  BGP/IGP.

There is definitely interaction among the Application Function Controller (AF) and the network. The Load measurement can be advertised to the AF which can perform dynamic analysis and send back more accurate value for the “Site preference” to the routers. But they are out of the scope of this draft.

Optimizing the ANYCAST for 5G EC is a concrete use case for Dynamic ANYCAST initiative. While the Dynamic ANYCAST is for bigger network, the 5G EC optimization is for smaller 5G Local Data Network.

Linda

From: Christian Hopps <[email-masked]>
Sent: Monday, March 8, 2021 6:00 PM
To: Linda Dunbar <[email-masked]>
Cc: Christian Hopps <[email-masked]>; [email-masked]
Subject: Re: Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

Christian,

As WG member,

Thanks,
Chris.

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 10 Mar 2021 23:46:48 +0000

Gyan,

To a router, having multiple servers with the same (ANYCAST) address attached to different egress routers (A-ER) is same as having multiple paths to reach the (ANYCAST) address.

You are absolutely correct that there are many tools to influence the path section, such as the routing distance, TE metrics, policies, etc.

draft-dunbar-lsr-5g-edge-compute-ospf-ext proposes to add another component to influence the path selection: the "Site-Cost"  which is influenced by  "site-capacity + load measurement + Preference + xxx". The "site-Cost" can be raw measurements collected by the egress routers based on the instruction from a controller, or informed by the App Controller periodically.

In the past, ANYCAST has been predominantly used for multiple servers in geographically far apart locations so that routing distance alone can always nail down to one specific ANYCAST server.

3GPP TR23.748 (5G Edge Computing) is proposing to use multiple servers (or multiple App Layer Load Balancers) with the same ANYCAST address in their Local IP Data Network to avoid the single point of failure and the bottleneck at the App Layer Load Balancer for mission critical applications.

Thank you very much for your comments. I have made some changes to the text. Please see the revision: https://datatracker.ietf.org/doc/draft-dunbar-lsr-5g-edge-compute-ospf-ext/

Linda

From: Gyan Mishra <[email-masked]>
Sent: Tuesday, March 9, 2021 12:08 AM
To: Liyizhou <[email-masked]>
Cc: Christian Hopps <[email-masked]>; Linda Dunbar <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

Linda and authors

Anycast in my experience has been used predominantly in my experience within operators networks with BGP overlay,  using BGP best path selection and most cases boils down to lowest IGP metric tie breaker shortest path for the service Anycast proximity route which you can also with unique RD in overlay and can take advantage of iBGP multipath equal cost load balancing over an operator vaccine or 4G/5G RAN xhaul or internet.

The nice thing about Anycast with BGP overlay you as are automatically proximity based routing load balancing inherent to Anycast routing.

Point here is we are using BGP best path selection but it does boils down to IGP lowest metric tie breaker but you can use iBGP multipath to further optimize the routing for cloud computing.

We have so many tools in our operators toolbox to optimize routing SR or Flex-Algo, SDN etc am wondering if some form of SDN or SD-WAN overlay could provide the Dyncast type Dynamic Anycast solution.

I want to the wiki page for Dyncast.  The presentation is not available yet.  Will check tomorrow.

Thanks

Gyan

On Mon, Mar 8, 2021 at 11:36 PM Liyizhou <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Sorry to chime in.

When talking about edge computing, there are some unique characteristics. The number of edge sites could be large or huge in future in a big city. Edges are geographically scattered which could be a few, or tens of, or a hundred kilometers away from each other, and each site has limited computing resources which could be a small cluster. Application layer based approach normally would rely on one or several "server"/"broker" to be responsible for request handling all over the city. As such "servers" are unlikely available on each and every edge site, it introduces additional path stretch for data packets requiring delivery to other edge sites first. Such path stretch introduces additional (network and processing) delay which could be crucial for short live request flow. On the contrary, the network node at the edge is naturally sitting on the data path without introducing any additional cost to direct the (explicit/implicit) request somewhere else. Also routing system has been proven doing good in such distributed manner.

There is a dyncast (dynamic anycast) work ongoing. It is not exactly same as what Linda proposed here, but some relations can be seen, like trying to use anycast methodology to access an edge computing, especially computational intensive, service. The current discussions are about compellingness of the use cases, the deficiency of existing solutions, and proposed architecture, not gone very far into what specific routing protocols to use yet. A side meeting will be held on Wed 10am CET. You may check https://github.com/dyncast/ietf110<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fdyncast%2Fietf110&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779221152%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2BARHREw51PPjAyjut9I9Z5Ym%2FV%2FDYwPl2xO2luZxIag%3D&reserved=0> for more info.

Cheers,
Yizhou

From: Lsr [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Christian Hopps
Sent: Tuesday, March 9, 2021 9:00 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Christian Hopps <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

Christian,

As WG member,

Thanks,
Chris.

Linda Dunbar

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779231156%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eTZ9G6OwmE%2FHAJyIInOzMSSmQTmVcGFmXbrNm5YCMX4%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779231156%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eJ5%2ByOifw0UB7MvrjhqcBLWhvhO6n9QR3%2ByuuWKs2tk%3D&reserved=0>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 11 Mar 2021 00:48:57 -0500

Hi Linda

Comments in-line

On Wed, Mar 10, 2021 at 6:46 PM Linda Dunbar <[email-masked]>
wrote:

> Gyan,
>
>
>
> To a router, having multiple servers with the same (ANYCAST) address
> attached to different egress routers (A-ER) is same as having multiple
> paths to reach the (ANYCAST) address.
>
>
>
> You are absolutely correct that there are many tools to influence the path
> section, such as the routing distance, TE metrics, policies, etc.
>
>
>
> draft-dunbar-lsr-5g-edge-compute-ospf-ext proposes to add another
> component to influence the path selection: the “Site-Cost”  which is
> influenced by  “site-capacity + load measurement + Preference + xxx”. The
> “site-Cost” can be raw measurements collected by the egress routers based
> on the instruction from a controller, or informed by the App Controller
> periodically.
>
>
>
> In the past, ANYCAST has been predominantly used for multiple servers in
> geographically far apart locations so that routing distance alone can
> always nail down to one specific ANYCAST server.
>
>  Gyan>  The Anycast environments that I have worked with architecture have
> been server clusters in data centers geographically diverse that sit behind
> a load balancer that uses a concept called HRI host route injection that if
> the service is up the VIP is BGP advertised for the cluster to DC core and
> then services VIP host route are advertised into the core all BGP
> attributes equal so lowest IGP metric tie breaker picks best path shortest
> path across the core  as best path and of iBGP multipath is used that
> services VIPs are geographically load balanced flow based if metric is a
> tie and if IPv6 is used in the core then 5-tuple per flow load balanced
> optimized.
>

3GPP TR23.748 (5G Edge Computing) is proposing to use multiple servers (or
> multiple App Layer Load Balancers) with the same ANYCAST address in their
> Local IP Data Network to avoid the single point of failure and the
> bottleneck at the App Layer Load Balancer for mission critical
> applications.
>
>  Gyan>  With Anycast routing as I mentioned you don’t have a single point
> of failure and really have optimal redundancy which is why for any services
> such as DNS, NTP and many others Anycast is the best most redundancy and
> optimal as proximity routing is used. If your closest lowest IGP metric
> iBGP load balanced path goes down let’s say multiple DC outages you still
> have your next closest in the BGP path list pecking order to reach the
> service thus optimized redundancy as every DC would have to be down for
> service VIP to be down.  Also with Anycast as it a distributed architecture
> you are not overloading core paths or certain DC VIPs as all traffic is
> distributed geographically proximity load balanced automatically.  So there
> is a lesser chance of bottleneck as the Anycast architecture is distributed.
>

   As far as 5G you still have main components of the path from UE  user
data plane to RAN xHaul VPN within the wireless operator network then
handoff to the core to a service VIP in a closet proximity data center. So
now we are trying to further optimize the cost based on real time PM
performance metrics to calculate the best path with this draft.

This draft below is in LSR maybe interesting to you related to flex algo
bandwidth related constraints so that the TE static ERO concept of exclude
L2 links in a bundle can be accomplished based on link delay bandwidth
thresholds that use semi dynamic metrics based on PM measurements.

In that discussion thread was brought up use of the PM based metrics and if
that would cause instability.  That maybe something to consider when using
dynamic PM based metrics.

https://datatracker.ietf.org/doc/html/draft-hegde-lsr-flex-algo-bw-con-01

Kind Regards

Gyan

Thank you very much for your comments. I have made some changes to the
> text. Please see the revision:
> https://datatracker.ietf.org/doc/draft-dunbar-lsr-5g-edge-compute-ospf-ext/
>
>
>
>
>
> Linda
>
>
>
> *From:* Gyan Mishra <[email-masked]>
> *Sent:* Tuesday, March 9, 2021 12:08 AM
> *To:* Liyizhou <[email-masked]>
> *Cc:* Christian Hopps <[email-masked]>; Linda Dunbar <
> [email-masked]>; [email-masked]
> check https://github.com/dyncast/ietf110
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fdyncast%2Fietf110&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779221152%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2BARHREw51PPjAyjut9I9Z5Ym%2FV%2FDYwPl2xO2luZxIag%3D&reserved=0>
> for more info.
>
>
>
> Cheers,
>
> Yizhou
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779231156%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eTZ9G6OwmE%2FHAJyIInOzMSSmQTmVcGFmXbrNm5YCMX4%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C090a578c2711455d431808d8e2c1ad0b%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508668779231156%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eJ5%2ByOifw0UB7MvrjhqcBLWhvhO6n9QR3%2ByuuWKs2tk%3D&reserved=0>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
>
>
> *M 301 502-1347 13101 Columbia Pike
> <https://www.google.com/maps/search/13101+Columbia+Pike?entry=gmail&source=g>
> *Silver Spring, MD
>
>
>
-- 

*Gyan Mishra*

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 12 Mar 2021 20:26:13 +0000

Gyan,

You said:
 Gyan>  The Anycast environments that I have worked with architecture have been server clusters in data centers geographically diverse that sit behind a load balancer that uses a concept called HRI host route injection that if the service is up the VIP is BGP advertised for the cluster to DC core and then services VIP host route are advertised into the core all BGP attributes equal so lowest IGP metric tie breaker picks best path shortest path across the core  as best path and of iBGP multipath is used that services VIPs are geographically load balanced flow based if metric is a tie and if IPv6 is used in the core then 5-tuple per flow load balanced optimized.
The "cluster of servers" in your paragraph  is considered as ONE (address) in In draft-dunbar-lsr-5g-edge-compute-ospf-ext. Only the ADDRESS (or the VIP) of the cluster is visible to the network. How the App Load Balancer distribute the traffic to individual servers is not visit to network.

You said:
Gyan>  With Anycast routing as I mentioned you don't have a single point of failure and really have optimal redundancy which is why for any services such as DNS, NTP and many others Anycast is the best most redundancy and optimal as proximity routing is used.
[Linda] Are you saying using VIP to achieve the "Anycast routing" ?
Using a  VIP for multiple  clusters of servers requiring all those clusters of servers to be attached to a common device, such as a NAT or a GW router.  The "single point failure and bottleneck" is referring to the NAT or the GW router.
5G EC needs the multiple clusters of servers to be placed in different mini Edge-DCs.  And desire to use the same IP address for those clusters of servers attached to different egress routers.
Gyan>  If your closest lowest IGP metric iBGP load balanced path goes down let's say multiple DC outages you still have your next closest in the BGP path list pecking order to reach the service thus optimized redundancy as every DC would have to be down for service VIP to be down.  Also with Anycast as it a distributed architecture you are not overloading core paths or certain DC VIPs as all traffic is distributed geographically proximity load balanced automatically.  So there is a lesser chance of bottleneck as the Anycast architecture is distributed.
[Linda] Yes, when multiple clusters of servers are attached to different routers, the IGP metric and iBGP load balanced path can select the optimal one.

The  draft-dunbar-lsr-5g-edge-compute-ospf-ext adds another component into https://datatracker.ietf.org/doc/html/draft-hegde-lsr-flex-algo-bw-con-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>, i.e. the "Load to reach the cluster"  which is influenced by  "site-capacity + load measurement + Preference + xxx". The "Load to reach the cluster" can be the raw measurements collected by the egress routers based on the instruction from a controller, or informed by the App Controller periodically.

I don't see  any conflicts to the https://datatracker.ietf.org/doc/html/draft-hegde-lsr-flex-algo-bw-con-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>, am I missing anything?

Thanks, Linda Dunbar

From: Gyan Mishra <[email-masked]>
Sent: Wednesday, March 10, 2021 11:49 PM
To: Linda Dunbar <[email-masked]>
Cc: Christian Hopps <[email-masked]>; Liyizhou <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

Hi Linda

Comments in-line

On Wed, Mar 10, 2021 at 6:46 PM Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Gyan,

In the past, ANYCAST has been predominantly used for multiple servers in geographically far apart locations so that routing distance alone can always nail down to one specific ANYCAST server.
 Gyan>  The Anycast environments that I have worked with architecture have been server clusters in data centers geographically diverse that sit behind a load balancer that uses a concept called HRI host route injection that if the service is up the VIP is BGP advertised for the cluster to DC core and then services VIP host route are advertised into the core all BGP attributes equal so lowest IGP metric tie breaker picks best path shortest path across the core  as best path and of iBGP multipath is used that services VIPs are geographically load balanced flow based if metric is a tie and if IPv6 is used in the core then 5-tuple per flow load balanced optimized.

3GPP TR23.748 (5G Edge Computing) is proposing to use multiple servers (or multiple App Layer Load Balancers) with the same ANYCAST address in their Local IP Data Network to avoid the single point of failure and the bottleneck at the App Layer Load Balancer for mission critical applications.
 Gyan>  With Anycast routing as I mentioned you don't have a single point of failure and really have optimal redundancy which is why for any services such as DNS, NTP and many others Anycast is the best most redundancy and optimal as proximity routing is used. If your closest lowest IGP metric iBGP load balanced path goes down let's say multiple DC outages you still have your next closest in the BGP path list pecking order to reach the service thus optimized redundancy as every DC would have to be down for service VIP to be down.  Also with Anycast as it a distributed architecture you are not overloading core paths or certain DC VIPs as all traffic is distributed geographically proximity load balanced automatically.  So there is a lesser chance of bottleneck as the Anycast architecture is distributed.

   As far as 5G you still have main components of the path from UE  user data plane to RAN xHaul VPN within the wireless operator network then handoff to the core to a service VIP in a closet proximity data center. So now we are trying to further optimize the cost based on real time PM performance metrics to calculate the best path with this draft.

This draft below is in LSR maybe interesting to you related to flex algo bandwidth related constraints so that the TE static ERO concept of exclude L2 links in a bundle can be accomplished based on link delay bandwidth thresholds that use semi dynamic metrics based on PM measurements.

In that discussion thread was brought up use of the PM based metrics and if that would cause instability.  That maybe something to consider when using dynamic PM based metrics.

https://datatracker.ietf.org/doc/html/draft-hegde-lsr-flex-algo-bw-con-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>

Kind Regards

Gyan

Thank you very much for your comments. I have made some changes to the text. Please see the revision: https://datatracker.ietf.org/doc/draft-dunbar-lsr-5g-edge-compute-ospf-ext/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-lsr-5g-edge-compute-ospf-ext%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5IWGEcPWpcIIy%2FDO4mHg3%2FYiaNGmzpvk86b7c24Pgv4%3D&reserved=0>

Linda

From: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 9, 2021 12:08 AM
To: Liyizhou <[email-masked]<mailto:[email-masked]>>
Cc: Christian Hopps <[email-masked]<mailto:[email-masked]>>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Lsr] Why not leverage Network conditions to optimize balancing among multiple App Layer Load Balancers? as proposed by draft-dunbar-lsr-5g-edge-compute-ospf-ext

Linda and authors

Thanks

Gyan

Sorry to chime in.

There is a dyncast (dynamic anycast) work ongoing. It is not exactly same as what Linda proposed here, but some relations can be seen, like trying to use anycast methodology to access an edge computing, especially computational intensive, service. The current discussions are about compellingness of the use cases, the deficiency of existing solutions, and proposed architecture, not gone very far into what specific routing protocols to use yet. A side meeting will be held on Wed 10am CET. You may check https://github.com/dyncast/ietf110<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fdyncast%2Fietf110&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527226752%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SU8HUrnZjFvTUDzT8mTzKKKl9r44GNup49A5z8gC8gg%3D&reserved=0> for more info.

Cheers,
Yizhou

Christian,

As WG member,

Thanks,
Chris.

Linda Dunbar

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527226752%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=OwvE4lUfKJJA8FLPEa73f1wJZCF4uRgj4rr34MrtrS8%3D&reserved=0>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527236753%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8aKtaCwTAE0z6JUQE8JjDxHGrbkf9PGxO56Qw3gKWNw%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%3Fentry%3Dgmail%26source%3Dg&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527246741%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=PaGYGnWRVvxkxCW5R%2FYG4KIBMTLkCBFWW3zwO2X5aXU%3D&reserved=0>
Silver Spring, MD

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527246741%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Y4jR4Ke1u2DGEa0ZISE422wF2uipJcvuiJ5pnU9%2F2lM%3D&reserved=0>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 12 Mar 2021 16:16:59 -0500

Hi Linda

On Fri, Mar 12, 2021 at 3:26 PM Linda Dunbar <[email-masked]>
wrote:

> Gyan,
>
>
>
> You said:
>
> * Gyan>  The Anycast environments that I have worked with architecture
> have been server clusters in data centers geographically diverse that sit
> behind a load balancer that uses a concept called HRI host route injection
> that if the service is up the VIP is BGP advertised for the cluster to DC
> core and then services VIP host route are advertised into the core all BGP
> optimized.  *
> The “cluster of servers” in your paragraph  is considered as ONE (address)
> in In draft-dunbar-lsr-5g-edge-compute-ospf-ext. Only the ADDRESS (or the
> VIP) of the cluster is visible to the network. How the App Load Balancer
> distribute the traffic to individual servers is not visit to network.
>
>  Gyan> Yes only one address VIP is visible to the network and an
> xforwardedfor header is tacked on with the client IP when the packet is
> forwarded to the backend server.  The LB is performing a NAT like function
> but it’s just forwarding  to the attached services being monitored in a
> hash round robin fashion.  Correct the load balancing algorithm is not
> visible to the network.
>
You said:
>
> *Gyan>  With Anycast routing as I mentioned you don’t have a single point
> optimal as proximity routing is used. *
>
> [Linda] Are you saying using VIP to achieve the “Anycast routing” ?
>

    Gyan> Having the servers behind a LB provides better redundancy and as
the LB can distribute the flows using a variety of LB algorithms.

> Using a  VIP for multiple  clusters of servers requiring all those
> clusters of servers to be attached to a common device, such as a NAT or a
> GW router.  The “single point failure and bottleneck” is referring to the
> NAT or the GW router.
>
Gyan> Yes all the backend servers in the cluster would be locally routed
attached but don’t have to be on the same subnet so technically they don’t
even have to be in the same geographic location but generally are at least
within the same DC.

> 5G EC needs the multiple clusters of servers to be placed in different
> mini Edge-DCs.  And desire to use the same IP address for those clusters of
> servers attached to different egress routers.
>

Gyan> So with LB front ending the back end servers in a cluster you can
have that same setup in every edge DC with a LB device VIP front ending the
backend servers.

With non Anycast VIP just standard app VIP what’s registered in DNS if the
app is geo load balanced is a site specific name and geo load balanced name
and so the Geo DNS database based on the client source IP the Geo DNS can
serve up Name based on proximity so the app flow is optimal hits the
closest DC resources.

> *Gyan>  If your closest lowest IGP metric iBGP load balanced path goes
> down let’s say multiple DC outages you still have your next closest in the
> BGP path list pecking order to reach the service thus optimized redundancy
> as every DC would have to be down for service VIP to be down.  Also with
> Anycast as it a distributed architecture you are not overloading core paths
> or certain DC VIPs as all traffic is distributed geographically proximity
> load balanced automatically.  So there is a lesser chance of bottleneck as
> the Anycast architecture is distributed.*
>
> [Linda] Yes, when multiple clusters of servers are attached to different
> routers, the IGP metric and iBGP load balanced path can select the optimal
> one.
>
>  Gyan> Exactly.  Would this LB model work for you for the 5G edge
> computing?
>
> The  draft-dunbar-lsr-5g-edge-compute-ospf-ext adds another component into
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>,
> i.e. the “Load to reach the cluster”  which is influenced by
> “site-capacity + load measurement + Preference + xxx”. The “Load to reach
> the cluster” can be the raw measurements collected by the egress routers
> based on the instruction from a controller, or informed by the App
> Controller periodically.
>
>
>
> I don’t see  any conflicts to the
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>,
> am I missing anything?
>
>  Gyan>  Agreed no conflict.  That draft was just to show an idea similar
> to your costing based on load measurement.
>
Thanks, Linda Dunbar
> *Sent:* Wednesday, March 10, 2021 11:49 PM
> *Cc:* Christian Hopps <[email-masked]>; Liyizhou <[email-masked]>;
> [email-masked]
> In that discussion thread was brought up use of the PM based metrics and
> if that would cause instability.  That maybe something to consider when
> using dynamic PM based metrics.
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hegde-lsr-flex-algo-bw-con-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ajhSjizE8O6QiSTy1fUFe%2Bxy6%2FIHKeX3QdKomZaVByo%3D&reserved=0>
>
>
>
> Kind Regards
>
>
>
>
>
> Gyan
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-lsr-5g-edge-compute-ospf-ext%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527216760%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5IWGEcPWpcIIy%2FDO4mHg3%2FYiaNGmzpvk86b7c24Pgv4%3D&reserved=0>
>
>
>
>
>
> Linda
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fdyncast%2Fietf110&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527226752%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SU8HUrnZjFvTUDzT8mTzKKKl9r44GNup49A5z8gC8gg%3D&reserved=0>
> for more info.
>
>
>
> Cheers,
>
> Yizhou
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527226752%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=OwvE4lUfKJJA8FLPEa73f1wJZCF4uRgj4rr34MrtrS8%3D&reserved=0>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527236753%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8aKtaCwTAE0z6JUQE8JjDxHGrbkf9PGxO56Qw3gKWNw%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fmaps%2Fsearch%2F13101%2BColumbia%2BPike%3Fentry%3Dgmail%26source%3Dg&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527246741%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=PaGYGnWRVvxkxCW5R%2FYG4KIBMTLkCBFWW3zwO2X5aXU%3D&reserved=0>
> *Silver Spring, MD
>
>
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cf137baecd8394d51827908d8e451643f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637510385527246741%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Y4jR4Ke1u2DGEa0ZISE422wF2uipJcvuiJ5pnU9%2F2lM%3D&reserved=0>
>
> *Gyan Mishra*
>
-- 

*Gyan Mishra*