Subject: [Lsr] Comments on draft-dunbar-lsr-5g-edge-compute-ospf-ext-03

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 8 Mar 2021 20:12:05 +0000

Speaking as WG member:

Hi Linda and Co-authors,

My first major comment is the confusion with the usage of multiple anycast addresses for the same application. Why are you requiring multiple anycast address? It would seem the load balancing over multiple servers can be done at the data center layer. I guess a UE would use the same anycast address for an application based on the initial DNS query? It is very confusing.

My second major comment is that in section 4, you point out that an aggregated metric would solve the problem. However, the purported downside is that all the Application Egress Routers (A-ERs) would need to use the same algorithm to aggregate the various capacity measurements into a single metric. It would seem to be an even larger obstacle for all the OSPF routers in the area to support these new metrics and consistent routing based on those metrics.

Also, some minor comments:

  1.  Why do you talk about ACLs to determine the anycast addresses? Presumably, you wouldn’t even have these metrics available for other addresses.
  2.  Section 5 still references the misguided draft-wang-lsr-passive-interface-attribute draft. I believe you meant to remove this.

There are other nits as well but it doesn’t make sense to spend time on them at this stage.

Thanks,
Acee

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 9 Mar 2021 11:58:03 +0800

Hi, Acee:

From: [email-masked] <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Tuesday, March 9, 2021 4:12 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Lsr] Comments on draft-dunbar-lsr-5g-edge-compute-ospf-ext-03

Speaking as WG member:

Hi Linda and Co-authors, 

[WAJ] To transfer the raw information about the server, is the prefix address TLV right container for such information?   There may be other parameters to be associated in future, for example, the bandwidth, the delay, where will you put all these information that can influence the performances of App server?  https://datatracker.ietf.org/doc/draft-wang-lsr-prefix-unreachable-annoucement/ describes just the general container for such information.

Thanks,
Acee

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 10 Mar 2021 21:04:40 +0000

Acee,

Thank you very much for your comments.
Answers are inserted below.

Linda
From: Acee Lindem (acee) <[email-masked]>
Sent: Monday, March 8, 2021 2:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: Comments on draft-dunbar-lsr-5g-edge-compute-ospf-ext-03

Speaking as WG member:

Hi Linda and Co-authors,

[Linda] Yeh, agree with you. It is kind of confusing.  That was one of the proposed solutions  in  3GPP’s TR23.748.
With OSPF periodically advertising the reachability to the ANYCAST servers, all routers should automatically switch to an alternative location for the ANYCAST server.
 I will remove the Section 6 in the next revision.

[Linda] Agree with you. The solution is only useful for a small controlled network, for example,  the Application Function Controller could send the “aggregated cost” to the egress routers periodically.
Even though the solution description described in the Section 4 has very limited usage, I feel it is important to include it in the draft.
I change the text to the following

“If all egress routers that have direct connection to the App Servers can get periodic update of the aggregated cost to the App Servers or can be configured with a consistent algorithm to compute an aggregated cost that take into consideration the Load Measurement, Capacity value and Preference value, this aggregated cost can be considered as the Metric of the link to the App Server.
In this scenario, there is no protocol extension needed.”

  1.  Why do you talk about ACLs to determine the anycast addresses? Presumably, you wouldn’t even have these metrics available for other addresses.
[Linda]  There could be large number of addresses attached to each Egress router. The egress routers only need to measure the “Running Environment” for the addresses filtered by the ACLs.

  1.  Section 5 still references the misguided draft-wang-lsr-passive-interface-attribute draft. I believe you meant to remove this.
[Linda] AiJun has answered this question.

Thanks,
Acee