Subject: Re: [Lsr] New Version Notification for draft-wang-lsr-isis-mfi-00.txt

From: wangyali <[email-masked]>
Date: Mon, 1 Mar 2021 09:05:49 +0000

Hi Tony,

First of all, I'm sorry I misunderstood your question in previous mail. My understanding of the 'subdivide the LSDB' in your question that ' Are there separate flooding topologies but a common LSDB? Or are you trying to subdivide the LSDB?' is subdividing a single LSDB for each MFI. 

Hence in the previous mail I said that 'Because different information advertisements are categorized into different MFI, so an LSP in MFI A and another LSP in MFI B have different flooding topology, flooding parameters, and prioritization for processing LSP. Each flooding instance is associated with a MFI-specific LSDB, which is trying to subdivide the LSDB.' Hence, I'm trying to say each Update process associated with a MFI operates on a logically subdivided LSDB.

Therefore I clarify that MFIs share a common adjacencies, and a single LSDB. And each MFI can have its own flooding sub topology and its customized flooding parameters.

Best regards,
Yali

-----Original Message-----
From: wangyali 
Sent: Thursday, February 25, 2021 1:24 PM
To: Tony Li <[email-masked]>
Cc: [email-masked]; Huzhibo <[email-masked]>; Aijun Wang <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: RE: [Lsr] New Version Notification for draft-wang-lsr-isis-mfi-00.txt

Hi Tony,

Thanks for your questions and comments. Please see inline >>Yali.

Best regards,
Yali

-----Original Message-----
From: Tony Li [mailto:[email-masked]] On Behalf Of Tony Li
Sent: Wednesday, February 24, 2021 6:08 AM
To: wangyali <[email-masked]>
Cc: [email-masked]; Huzhibo <[email-masked]>; Aijun Wang <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: Re: [Lsr] New Version Notification for draft-wang-lsr-isis-mfi-00.txt

Hi,

Thank you for contributing your draft. I’m writing because I’m having trouble understanding the motivation for this work.

First off, I do NOT want to argue about carrying unnecessary information in IS-IS. IMHO, it is unmitigated evil and an attempt to destroy the viability of the protocol by creating arbitrary complexity and scale. But never mind that, I’ll stipulate for this discussion that we want to do so.

Given this, what is it that you’re trying to accomplish?  You’ve called this a ‘multi-flooding instance’, but it’s very unclear about what that means.  You say that multiple MFIs exist within a single IS-IS instance.
>>Yali: The ‘multi-flooding instance' means that multiple Update process are allowed operating within the zero IS-IS instance. Each Update process is associated with a topology and a LSDB. Flooding parameters of each Update process can be different and customized based on different information needed to be advertised in the associated Flooding Instance. 
Although each Flooding Instance has its own separate Update process, flooding topology and LSDB, these multiple flooding instances share a common adjacencies.

You obviously want data flooded. So what is the difference between an LSP in MFI A and another LSP in MFI B? Are there separate flooding topologies but a common LSDB? Or are you trying to subdivide the LSDB?
>>Yali: Because different information advertisements are categorized into different MFI, so an LSP in MFI A and another LSP in MFI B have different flooding topology, flooding parameters, and prioritization for processing LSP. 
Each flooding instance is associated with a MFI-specific LSDB, which is trying to subdivide the LSDB.

You mention that there is only a single update process in an instance. AFAICT, that’s only a model, not a requirement. There’s no prohibition that I know of against an implementation using a process per interface if iit wanted to.
>>Yali: As mentioned in draft, the each flooding instance support one update process operation on a LSDB.

What problem are you solving?
>>Yali: The problem we are trying to solve is how to isolate application information flooding from the routing information flooding through multiple flooding instance.

Regards,
Tony

> On Feb 22, 2021, at 11:10 PM, wangyali <[email-masked]> wrote:
> 
> Hi all,
> 
> In order to separate multiple flooding instances for dissemination of routing information and other types of application-specific information to minimizes the impact of non-routing information flooding on the routing convergence and stability, We submitted a new IS-IS flooding mechanism implemented in the zero IS-IS instance, named as IS-IS Multi-flooding Instances (MFIs).
> 
> An encoding format for IS-IS MFI-ID TLV and MFIs Update Process defined in this draft could be found in https://datatracker.ietf.org/doc/draft-wang-lsr-isis-mfi/ .
> 
> Any questions and comments are welcome.
> 
> Thanks,
> Yali
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, February 22, 2021 9:59 AM
> To: Aijun Wang <[email-masked]>; Tianran Zhou 
> <[email-masked]>; wangyali <[email-masked]>; Huzhibo 
> <[email-masked]>
> Subject: New Version Notification for draft-wang-lsr-isis-mfi-00.txt
> 
> 
> A new version of I-D, draft-wang-lsr-isis-mfi-00.txt has been successfully submitted by Yali Wang and posted to the IETF repository.
> 
> Name:		draft-wang-lsr-isis-mfi
> Revision:	00
> Title:		IS-IS Multi-Flooding Instances
> Document date:	2021-02-20
> Group:		Individual Submission
> Pages:		7
> URL:            https://www.ietf.org/archive/id/draft-wang-lsr-isis-mfi-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-wang-lsr-isis-mfi/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-wang-lsr-isis-mfi
> Htmlized:       https://tools.ietf.org/html/draft-wang-lsr-isis-mfi-00
> 
> 
> Abstract:
>  This document proposes a new IS-IS flooding mechanism which separates 
> multiple flooding instances for dissemination of routing information 
> and other types of application-specific information to minimizes the 
> impact of non-routing information flooding on the routing convergence 
> and stability.  Due to different flooding information has different 
> requirements on the flooding rate, these multi-flooding instances 
> should be given various priorities and flooding parameters.  An 
> encoding format for IS-IS Multi-Flooding Instance Identifier (MFI-ID) 
> TLV and Update Process are specified in this document.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: Tony Li <[email-masked]>
Date: Mon, 1 Mar 2021 10:00:55 -0800

Hi Yali,

Thank you for the clarification.  Yes, ok, that then suggests that MFI is simply a way to partition flooding.

I’m still missing out on the motivation for doing this.  What is the benefit of having some data take one flooding path and other data take another flooding path? Since all nodes are going to end up synchronized sooner or later, how is this better?

Tony

> On Mar 1, 2021, at 1:05 AM, wangyali <[email-masked]> wrote:
> 
> Hi Tony,
>

---

From: wangyali <[email-masked]>
Date: Wed, 3 Mar 2021 02:45:24 +0000

Hi Tony,

Many thanks for your reply and question.

In this version, for each MFI, it is given a MFI-specific prioritization for processing PDUs and MFI-specific flooding parameters so as to allow different MFIs to consume network-wide resources at different rates. For example, different flooding information is distributed to different queues. 

Currently, the document considers that flooding topology for each MFI can be the complete graph. But in the updated version, we will also consider the MFI-specific flooding topology, which may be a sub topology of the complete graph.

Best regards,
Yali

-----Original Message-----
From: Tony Li [mailto:[email-masked]] On Behalf Of Tony Li
Sent: Tuesday, March 2, 2021 2:01 AM
To: wangyali <[email-masked]>
Cc: [email-masked]; Huzhibo <[email-masked]>; Aijun Wang <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: Re: [Lsr] New Version Notification for draft-wang-lsr-isis-mfi-00.txt

Hi Yali,

Tony

> Cc: [email-masked]; Huzhibo <[email-masked]>; Aijun Wang 
> <[email-masked]>; Tianran Zhou <[email-masked]>
> Cc: [email-masked]; Huzhibo <[email-masked]>; Aijun Wang 
> <[email-masked]>; Tianran Zhou <[email-masked]>