Subject: [Lsr] draft-draft-peng-lsr-algorithm-related-adjacency-sid

From: <[email-masked]>
Date: Thu, 11 Mar 2021 16:51:52 +0800 (CST)

Hi Tony, 

   Thanks for your comments. The reason why this draft is proposed is that:

   Currently, the current FA draft only defines that the algorithm identifier is included as part of a  Prefix-SID advertisement,that maybe not satisfy some scenarios where multiple algorithm share the same link resource.  

    For example, an SR-TE policy may be instantiated within specific Flex-algo plane, i.e.,the SID list requires to include algorithm related SIDs.  An algorithm-unware Adjacency-SID included in the SID list can just steer the packet towards the link, but can not apply different QoS policy for different algorithm.         

     Another example is that the TI-LFA backup path computed in Flex-algo plane may also contain an algorithm-unware Adjacency-SID, which maybe also used in other SR-TE instance that carries other service.

    This document complement that the algorithm identifier can be also  included as part of an Adjacency-SID advertisement for SR-MPLS.

Best Regards,

Ran

---

From: Peter Psenak <[email-masked]>
Date: Thu, 11 Mar 2021 10:56:24 +0100

Hi Ran, Tony,

I believe the primary use case for algorithm specific adj-SID is for the 
protected Adj-SID. The backup path of such Adj-SID follows the algo 
specific constraints.

thanks,
Peter

On 11/03/2021 09:51, [email-masked] wrote:
>     Currently, the current FA draft only defines that the algorithm 
> identifier is included as part of a  Prefix-SID advertisement,that maybe 
> not satisfy some scenarios where multiple algorithm share the same link 
> resource.
> 
>      For example, an SR-TE policy may be instantiated within specific 
> Flex-algo plane, i.e.,the SID list requires to include algorithm related 
> SIDs.  An algorithm-unware Adjacency-SID included in the SID list can 
> just steer the packet towards the link, but can not apply different QoS 
> policy for different algorithm.
> 
>       Another example is that the TI-LFA backup path computed in 
> Flex-algo plane may also contain an algorithm-unware Adjacency-SID, 
> which maybe also used in other SR-TE instance that carries other service.
> 
>      This document complement that the algorithm identifier can be also 
>   included as part of an Adjacency-SID advertisement for SR-MPLS.
> 
> 
> Best Regards,
> 
> Ran
> 
>

---

From: <[email-masked]>
Date: Fri, 12 Mar 2021 10:49:23 +0800 (CST)

Hi Peter,

Agree, that is an important use case. We will add it to the next version.

Regards,

PSF

原始邮件

发件人：PeterPsenak
收件人：陈然00080434;[email-masked];
抄送人：[email-masked];
日 期 ：2021年03月11日 17:57
主 题 ：Re: [Lsr] draft-draft-peng-lsr-algorithm-related-adjacency-sid

Hi Ran, Tony,

thanks,
Peter

>   included as part of an Adjacency-SID advertisement for SR-MPLS.

_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr