Subject: Re: [Lsr] New draft on Flex-Algorithm Bandwidth Constraints

From: Aijun Wang <[email-masked]>
Date: Thu, 4 Mar 2021 22:23:14 +0800

Hi, Peter:

Whatever the interval is set, I think the measured value is “unpredictable parameter” and should not be used as the input factors for IGP SPF calculations by the network devices.
Or else, the overall behavior of the network will be uncontrollable.
For the delay aware application, we prefer to using the controller to calculate and program the network devices, to let such applications traffic follow one optimized path, to meet the application’s requirements.

Aijun Wang
China Telecom

> On Mar 4, 2021, at 21:30, Peter Psenak <ppsenak=[email-masked]> wrote:
> 
> On 04/03/2021 14:28, Robert Raszuk wrote:
>>> Is it minimum ever, is it min of the year, month, week, day ... etc
>>   https://tools.ietf.org/html/rfc8570#section-4.2
>>   Peter
>> Maybe it is just me but in section 4.2 I see NOTHING about how often that delay should be measured which was the point above.
> 
> it says it clearly - "over a configurable interval"
> 
> Peter
> 
>> Thx,
>> R.
> 
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: Peter Psenak <[email-masked]>
Date: Thu, 4 Mar 2021 16:13:29 +0100

Aijun,

> Or else, the overall behavior of the network will be uncontrollable.

let me disagree.

> For the delay aware application, we prefer to using the controller to calculate and program the network devices, to let such applications traffic follow one optimized path, to meet the application’…

I don't object your personal choice.

There is sufficient interest in distributed version of delay optimized 
forwarding in the field. There are multiple implementations of flex-algo 
with delay metric available. There are also multiple deployments of it 
in the field.

thanks,
Peter

---

From: Aijun Wang <[email-masked]>
Date: Fri, 5 Mar 2021 00:03:02 +0800

Hi, Peter:
We are also interested the distributed mode deployment. Would you like to provide more information about the deployment/implementaction and we can learn what’s the size of network scale and how often the measured value is changed. Some pointers are also help.
Thanks in advance.

Aijun Wang
China Telecom

> On Mar 4, 2021, at 23:14, Peter Psenak <[email-masked]> wrote:
> 
> Aijun,
> 
> There is sufficient interest in distributed version of delay optimized forwarding in the field. There are multiple implementations of flex-algo with delay metric available. There are also multiple deployments of it in the field.
> 
> thanks,
> Peter
> 
> 
>> Aijun Wang
>> China Telecom