Subject: [Lsr] RFC 8919 clarification

From: <[email-masked]>
Date: Thu, 3 Jun 2021 12:55:14 +0000

Hi all,

In order to (try to) avoid interop issues, I have a clarification question on RFC 8919.

"If link attributes are advertised associated with zero-length Application Identifier Bit Masks for both standard applications and user-defined applications, then any standard application and/or any user-defined application is permitted to use that set of link attributes so long as there is not another set of attributes advertised on that same link that is associated with a non-zero-length Application Identifier Bit Mask with a matching Application Identifier Bit set."
https://www.rfc-editor.org/rfc/rfc8919.html#name-application-specific-link-a

My reading is that if one ALSA "S1"  with a specific application bit set (e.g. X-Flag/FlexAlgo) advertises a set of attributes (A1, A2), then this ALSA (or the set of all ASLA occurrence with the X-Flag set) needs to advertise _all_ the attributes used by this application.

So:
- if we have another ALSA "S2" advertising zero-length Application Identifier Bit Masks for both standard applications and user-defined applications, that application (FlexAlgo) is not permitted to fall back to "S2" in order to learn a another attribute (A3). Regardless of whether S2 advertises the L-flag (legacy) or its own Link Attribute sub-sub-TLVs.
- if we don't have such S2 ASLA, that application (FlexAlgo) is not permitted to fall back to legacy attributes.

IOW, an ALSA for application X, does not advertise additional/more specific attributes for application X, but _all_ the attributes that application X is allowed to read. As a consequence, if an attribute is common to N set of applications, it needs to be advertised N times in N ASLA.

Thanks for correcting/confirming.

Thanks,
Regards,
Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Peter Psenak <[email-masked]>
Date: Thu, 3 Jun 2021 15:27:37 +0200

Hi Bruno,

On 03/06/2021 14:55, [email-masked] wrote:
> “If link attributes are advertised associated with zero-length 
> Application Identifier Bit Masks for both standard applications and 
> user-defined applications, then any standard application and/or any 
> user-defined application is permitted to use that set of link attributes 
> so long as there is not another set of attributes advertised on that 
> same link that is associated with a non-zero-length Application 
> Identifier Bit Mask with a matching Application Identifier Bit set.”
> 
> My reading is that if one ALSA “S1” with a specific application bit set 
> (e.g. X-Flag/FlexAlgo) advertises a set of attributes (A1, A2), then 
> this ALSA (or the set of all ASLA occurrence with the X-Flag set) needs 
> to advertise _/all/_ the attributes used by this application.

right.

> 
> So:
> 
> - if we have another ALSA “S2” advertising zero-length Application 
> Identifier Bit Masks for both standard applications and user-defined 
> applications, that application (FlexAlgo) is not permitted to fall back 
> to “S2” in order to learn a another attribute (A3). Regardless of 
> whether S2 advertises the L-flag (legacy) or its own Link Attribute 
> sub-sub-TLVs.

yes, that is correct.

> 
> - if we don’t have such S2 ASLA, that application (FlexAlgo) is not 
> permitted to fall back to legacy attributes.

well, if you have S1 as you mentioned above, S2 becomes irrelevant from 
the flex-algo perspective. So you are right, flex-algo is not allowed to 
use legacy advertisement in this case.

> 
> IOW, an ALSA for application X, does not advertise additional/more 
> specific attributes for application X, but _/all/_ the attributes that 
> application X is allowed to read. 

correct.

> As a consequence, if an attribute is 
> common to N set of applications, it needs to be advertised N times in N 
> ASLA.

depends. If the set of attributes that are common across N applications 
represent the full set of attributes for all these N applications, you 
simply advertise them once with SAMB/UDAMB including the bits for all N 
applications. If the set of attributes for each application is 
different, but there is one attribute that is common, you need to 
include that attribute in ASLA advertisement for every app.

thanks,
Peter

---

From: <[email-masked]>
Date: Thu, 3 Jun 2021 13:41:29 +0000

Hi Peter,

Thank you for your answer and for your crystal clear email.

As a side note, my reading of RFC 8920 is that this behaviour is different in OSPF.

“If link attributes are advertised with zero-length Application Identifier Bit Masks for both standard applications and user-defined applications, then any standard application and/or any user-defined application is permitted to use that set of link attributes. If support for a new application is introduced on any node in a network in the presence of such advertisements, these advertisements are permitted to be used by the new application. If this is not what is intended, then existing advertisements MUST be readvertised with an explicit set of applications specified before a new application is introduced.An application-specific advertisement (Application Identifier Bit Mask with a matching Application Identifier Bit set) for an attribute MUST always be preferred over the advertisement of the same attribute with the zero-length Application Identifier Bit Masks for both standard applications and user-defined applications on the same link.”

Not sure whether there was a technical reason for this difference, but it didn’t help be clarify by myself the RFC 8919 formulation.

Thank you,

--Bruno

> -----Original Message-----

> From: Peter Psenak [mailto:[email-masked]]

> Sent: Thursday, June 3, 2021 3:28 PM

> To: DECRAENE Bruno INNOV/NET <[email-masked]>; [email-masked]

> Subject: Re: [Lsr] RFC 8919 clarification

> > In order to (try to) avoid interop issues, I have a clarification

> > question on RFC 8919.

> ______________________________________________________________________

> ___________________________________________________

> > Ce message et ses pieces jointes peuvent contenir des informations

> confidentielles ou privilegiees et ne doivent donc

> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce

> message par erreur, veuillez le signaler

> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages

> electroniques etant susceptibles d'alteration,

> > Orange decline toute responsabilite si ce message a ete altere, deforme ou

> falsifie. Merci.

> > This message and its attachments may contain confidential or privileged

> information that may be protected by law;

> > If you have received this email in error, please notify the sender and delete this

> message and its attachments.

> > As emails may be altered, Orange is not liable for messages that have been

> modified, changed or falsified.

---

From: Peter Psenak <[email-masked]>
Date: Thu, 3 Jun 2021 16:04:11 +0200

Bruno,

> As a side note, my reading of RFC 8920 is that this behaviour is 

my reading is that it is consistent with the ISIS ASLA RFC.

thanks,
Peter

> 
> “If link attributes are advertised with zero-length Application 
> applications, then any standard application and/or any user-defined 
> application is permitted to use that set of link attributes. If support 
> for a new application is introduced on any node in a network in the 
> presence of such advertisements, these advertisements are permitted to 
> be used by the new application. If this is not what is intended, then 
> existing advertisements MUST be readvertised with an explicit set of 
> applications specified before a new application is introduced.An 
> application-specific advertisement (Application Identifier Bit Mask with 
> a matching Application Identifier Bit set) for an attribute MUST always 
> be preferred over the advertisement of the same attribute with the 
> zero-length Application Identifier Bit Masks for both standard 
> applications and user-defined applications on the same link.”
> 
> Not sure whether there was a technical reason for this difference, but 
> it didn’t help be clarify by myself the RFC 8919 formulation.
> 
> Thank you,
> 
> --Bruno
>

---

From: <[email-masked]>
Date: Thu, 3 Jun 2021 14:20:32 +0000

Peter,

> my reading is that it is consistent with the ISIS ASLA RFC.

Ah. Not an issue for our deployment as we are using IS-IS. But ideally I'd like to understand why we have a different reading.

RFC8920
If link attributes are advertised with zero-length Application Identifier Bit Masks for both standard applications and user-defined applications, then any standard application and/or any user-defined application is permitted to use that set of link attributes

RFC 8919
If link attributes are advertised associated with zero-length Application Identifier Bit Masks for both standard applications and user-defined applications, then any standard application and/or any user-defined application is permitted to use that set of link attributes so long as there is not another set of attributes advertised on that same link that is associated with a non-zero-length Application Identifier Bit Mask with a matching Application Identifier Bit set.

The difference that I'm seeing is that RFC 8919 seems to add an extra condition which is not present in OSPF " so long as there is not another set of attributes advertised on that same link that is associated with a non-zero-length Application Identifier Bit Mask with a matching Application Identifier Bit set."

--

RFC 8920
An application-specific advertisement (Application Identifier Bit Mask with a matching Application Identifier Bit set) for an attribute MUST always be preferred over the advertisement of the same attribute with the zero-length Application Identifier Bit Masks for both standard applications and user-defined applications on the same link.

- "for an attribute" seems to indicate that the choice is on a per attribute basis, rather than a per ASLA basis.
- "preferred over" seems to say the application (FlexAlgo) reads the attributes in both the "default" ALSA and the application specific ASLA. Just in case of duplicate, the attribute from the application specific ASLA is prefred. 

Thanks,
--Bruno