Subject: Re: [Lsr] Second Working Last Call for draft-ietf-lsr-flex-algo

From: Shraddha Hegde <[email-masked]>
Date: Mon, 5 Jul 2021 04:44:50 +0000

I support progressing this draft.

I have a minor comment on the Flags sub-TLV.

In section "ISIS Flexible Algorithm Definition Flags Sub-TLV"
And  "OSPF Flexible Algorithm Definition Flags Sub-TLV"

We should add an explicit statement that

" If any undefined flag is set and that flag is not
Understood by the node it MUST stop participating in the flex-algorithm"

While this information can be derived from previous sections, adding an explicit
Statement in the flags section will help implementors to honor that statement.
If implementations miss this, it would be difficult to deploy features that need new flags
In future.

Rgds
Shraddha

Juniper Business Use Only
From: Les Ginsberg (ginsberg) <[email-masked]>
Sent: Thursday, June 24, 2021 10:56 AM
To: Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
Cc: [email-masked]; Christian Hopps <[email-masked]>; [email-masked]
Subject: RE: Second Working Last Call for draft-ietf-lsr-flex-algo

[External Email. Be cautious of content]

I support progressing this document.
Flex-algo has already been demonstrated to be useful with a number of implementations/deployments.

   Les

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Acee Lindem (acee)
Sent: Wednesday, June 16, 2021 7:01 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Christian Hopps <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [Lsr] Second Working Last Call for draft-ietf-lsr-flex-algo

After the first successful WG last call, the authors discovered that some re-work was needed for OSPF AS External route calculation - specifically with respect to the Flex Algorithm ASBR metrics and calculation. This was fixed and there were clarifications in the IANA section (see versions -14 and -15). The draft has been stable since April and we are now ready to WG last call the updated version.

Without further ado, this begins a 2 week WG Last Call, ending on July 1st, 2021, for draft-ietf-lsr-flex-algo

  https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7x3QAu8ny$>

All authors, please indicate by sending an email to the list, whether you aware of any other IPR beyond what is already posted:

  [From https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo<https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7x8TVfDmS$>]

  https://datatracker.ietf.org/ipr/3910/<https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/3910/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7xwIee-xG$>
  https://datatracker.ietf.org/ipr/3248/<https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/3248/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7xyrFkBLf$>

Thanks,
Chris & Acee.

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 5 Jul 2021 01:33:53 -0400

I support publication of Flex Algo specification.

Flex Algo use with SR-TE policy provides added steering capabilities to SR
framework and is very useful tool to have in the operators toolbox.

Flex Algo has been implemented by multiple vendors as well as had
successfully deployed by operators.

Gyan
On Mon, Jul 5, 2021 at 12:45 AM Shraddha Hegde <shraddha=
[email-masked]> wrote:

> In section “ISIS Flexible Algorithm Definition Flags Sub-TLV”
>
> And  “OSPF Flexible Algorithm Definition Flags Sub-TLV”
>
>
>
> “ If any undefined flag is set and that flag is not
>
> Understood by the node it MUST stop participating in the flex-algorithm”
>
>
>
> *From:* Les Ginsberg (ginsberg) <[email-masked]>
> *Sent:* Thursday, June 24, 2021 10:56 AM
> *To:* Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
> *Cc:* [email-masked]; Christian Hopps <[email-masked]>;
> [email-masked]
> *Subject:* RE: Second Working Last Call for draft-ietf-lsr-flex-algo
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> *From:* Lsr <[email-masked]> *On Behalf Of *Acee Lindem (acee)
> *Sent:* Wednesday, June 16, 2021 7:01 AM
> *To:* [email-masked]
> *Cc:* [email-masked]; Christian Hopps <[email-masked]>;
> [email-masked]
> *Subject:* [Lsr] Second Working Last Call for draft-ietf-lsr-flex-algo
>
>
>
> After the first successful WG last call, the authors discovered that some
> re-work was needed for OSPF AS External route calculation – specifically
> with respect to the Flex Algorithm ASBR metrics and calculation. This was
> fixed and there were clarifications in the IANA section (see versions -14
> and -15). The draft has been stable since April and we are now ready to WG
> last call the updated version.
>
>
>
>
>
>   https://datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo/
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-lsr-flex-algo/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7x3QAu8ny$>
>
>
>
> All authors, please indicate by sending an email to the list, whether you
> aware of any other IPR beyond what is already posted:
>
>
>
>   [From
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7x8TVfDmS$>
> ]
>
>
>
>   https://datatracker.ietf.org/ipr/3910/
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/3910/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7xwIee-xG$>
>
>   https://datatracker.ietf.org/ipr/3248/
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/3248/__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7xyrFkBLf$>
>
>
>
> Thanks,
>
> Chris & Acee.
>
>
>
>
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Peter Psenak <[email-masked]>
Date: Mon, 5 Jul 2021 10:05:01 +0200

Hi Shraddha,

> Statement in the flags section will help implementors to honor that 

will add that statement in the next version.

thanks,
Peter

> *From:*Les Ginsberg (ginsberg) <[email-masked]>
> *From:*Lsr <[email-masked] <mailto:[email-masked]>> *On 
> Behalf Of *Acee Lindem (acee)
> *To:* [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; Christian Hopps 
> <[email-masked] <mailto:[email-masked]>>; 
> <mailto:[email-masked]>
> After the first successful WG last call, the authors discovered that 
> some re-work was needed for OSPF AS External route calculation – 
> specifically with respect to the Flex Algorithm ASBR metrics and 
> calculation. This was fixed and there were clarifications in the IANA 
> section (see versions -14 and -15). The draft has been stable since 
> April and we are now ready to WG last call the updated version.
> 
> All authors, please indicate by sending an email to the list, whether 
> you aware of any other IPR beyond what is already posted:
> 
>    [From 
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo__;!!NEt6yMaO-gk!S24A0VDoKfWQMUhBAT1294ruoAud7W0REDqMrKLfBu7v843mcXzJ6Eu7x8TVfDmS$>]
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 5 Jul 2021 13:46:03 +0000

The second WG last call has ended. There is considerable support for publication and a few minor comments. The most significant comments resulted in an errata to RFC 8919. I will work on the shepherd’s writeup and will request publication of the updated revision.

Thanks,
Acee

From: Acee Lindem <[email-masked]>
Date: Wednesday, June 16, 2021 at 10:00 AM
To: "[email-masked]" <[email-masked]>
Cc: Christian Hopps <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Second Working Last Call for draft-ietf-lsr-flex-algo

After the first successful WG last call, the authors discovered that some re-work was needed for OSPF AS External route calculation – specifically with respect to the Flex Algorithm ASBR metrics and calculation. This was fixed and there were clarifications in the IANA section (see versions -14 and -15). The draft has been stable since April and we are now ready to WG last call the updated version.

  [From https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-lsr-flex-algo]

Thanks,
Chris & Acee.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 5 Jul 2021 13:47:39 +0000

Hi Peter, 

On 7/5/21, 4:05 AM, "Peter Psenak" <ppsenak=[email-masked]> wrote:

    Hi Shraddha,

We will request publication on this version. 

Thanks,
Acee

    thanks,
    Peter