Subject: [Lsr] Oscillation caused by the "site-cost" associated with a Prefix (ANYCAST) in draft-dunbar-lsr-5g-edge-compute

From: Linda Dunbar <[email-masked]>
Date: Thu, 11 Nov 2021 14:33:54 +0000

Since we didn't have enough time at today's LSR session, I want to continue the discussion of draft-dunbar-lsr-5g-edge-compute on the mailing list:

  *   Shraddha pointed out that advertising the "site aggregated cost" of a Prefix (ANYCAST) might cause oscillation of traffic flow as other egress routers with the same prefix attached can advertise different metric to cause the change of the path computation.

OSPF-TE has the  same problem, does it? Link Bandwidth or condition changes advertisement can cause IGP path change?

>From each node's perspective, there has be a timer to adjust the IGP path change with newly received "site-cost" metrics.

In addition, "Site-Cost" associated with the prefix is only considered in computing the IGP path when the Flag in the FlexAlgo TLV is set to indicate the need to include the "site-cost" metrics.

  *   draft-dunbar-lsr-5g-edge-compute is using E-intra-Area-Prefix-LSA[RFC7684]  and Prefix Reachability TLV to advertise the  "Site-Cost" associated with the prefix.  At today's session, I heard that the "Stub Link" can be used as well. Want to hear WG opinion on which one is more suitable?

One more point, the "Site-Cost" associated with a prefix is not only intended as Tiebreaker. When the  Flag in the FlexAlgo TLV is set to indicate the need to include the "site-cost" metrics, the path computation will include the value in the SPF computation.

Thank you very much.
Linda

---

From: Peter Psenak <[email-masked]>
Date: Thu, 11 Nov 2021 16:16:54 +0100

Linda,

On 11/11/2021 15:33, Linda Dunbar wrote:
> Since we didn’t have enough time at today’s LSR session, I want to 
> continue the discussion of draft-dunbar-lsr-5g-edge-compute on the 
> mailing list:
> 
>   * Shraddha pointed out that advertising the “site aggregated cost” of
>     a Prefix (ANYCAST) might cause oscillation of traffic flow as other
>     egress routers with the same prefix attached can advertise different
>     metric to cause the change of the path computation. 
> 
> OSPF-TE has the  same problem, does it? Link Bandwidth or condition 
> changes advertisement can cause IGP path change?

IGPs do not use dynamic bandwidth as part of its calculation. TE is a 
different beast, it has a way to pin the traffic to a certain path.

Shraddha has a valid point - we need to be careful with any metric that 
changes often and can shift traffic suddenly. But if the metric is not 
too dynamic maybe we can make it work.

What I'm not sure about is how would you prevent all existing sessions 
to be shifted between the anycast locations if the new metric changes. I 
would think you would want to keep the existing sessions where they are 
and only use the alternate anycast location for the new sessions. If 
that is the requirement, I'm not sure how we can achieve that purely at 
the routing level as that would shift all the traffic.

> 
>  From each node’s perspective, there has be a timer to adjust the IGP 
> path change with newly received “site-cost” metrics.
> 
> In addition, “Site-Cost” associated with the prefix is only considered 
> in computing the IGP path when the Flag in the FlexAlgo TLV is set to 
> indicate the need to include the “site-cost” metrics.
> 
>   * draft-dunbar-lsr-5g-edge-compute is using
>     E-intra-Area-Prefix-LSA[RFC7684]  and Prefix Reachability TLV to
>     advertise the  “Site-Cost” associated with the prefix.  At today’s
>     session, I heard that the “Stub Link” can be used as well. Want to
>     hear WG opinion on which one is more suitable? 

stub-link in OSPF Router LSA is not extendible as it it not TLV based. 
Any new data that you want to add to the OSPF link/prefix needs be 
advertised as defined in RFC7684.

If you are referring to draft-wang-lsr-passive-interface-attribute-08, 
authors have defined the new TLV using RFC7684 (not that I agree with 
what it is meant to be used for).

> 
> One more point, the “Site-Cost” associated with a prefix is not only 
> intended as Tiebreaker. When the  Flag in the FlexAlgo TLV is set to 
> indicate the need to include the “site-cost” metrics, the path 
> computation will include the value in the SPF computation.

It's up to us to define the best behavior to address the valid use case 
we have.

thanks,
Peter