Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 2 Feb 2022 20:37:17 +0000

Speaking as Document Shepherd:

I have some editorial comments that I will pass on to the authors offline. One change I didn’t suggest since it was a big change was from “Strict-Mode for BFD” to simply “BFD Strict-Mode”. What are your thoughts on this?

We’ve had some good discussion and an updated version is coming with some updates based on that discussion. Remember that we don’t necessarily have to incorporate every suggested change but simply need to conclude the discussion.

Thanks,
Acee

From: "Acee Lindem (acee)" <acee=[email-masked]>
Date: Friday, January 28, 2022 at 7:24 AM
To: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

Speaking as WG member:

I support publication of the document. As indicated by the Albert Fu, it has been implemented by two vendors. I will provide WG Last Call comments when I prepare the Shepherd’s report.

Thanks,
Acee

From: Lsr <[email-masked]> on behalf of "Acee Lindem (acee)" <acee=[email-masked]>
Date: Thursday, January 27, 2022 at 12:09 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

LSR WG,

This begins a two week last call for the subject draft. Please indicate your support or objection on this list prior to 12:00 AM UTC on February 11th, 20222. Also, review comments are certainly welcome.
Thanks,
Acee

---

From: Ketan Talaulikar <[email-masked]>
Date: Thu, 3 Feb 2022 21:00:38 +0530

Hi Acee,

The authors had picked the term "OSPF BFD Strict-Mode" originally - please
refer to
https://datatracker.ietf.org/doc/html/draft-ketant-lsr-ospf-bfd-strict-mode-01.
However, post IETF presentation, we got feedback from WG members that the
term was misleading and gave an impression that the proposal was
introducing a "strict-mode" in BFD. What we are doing is introducing a
"strict-mode" of operation in OSPF for BFD usage.

We are open to any suggestions for change/clarity.

Thanks,
Ketan

On Thu, Feb 3, 2022 at 2:07 AM Acee Lindem (acee) <[email-masked]> wrote:

> I have some editorial comments that I will pass on to the authors offline.
> One change I didn’t suggest since it was a big change was from “Strict-Mode
> for BFD” to simply “BFD Strict-Mode”. What are your thoughts on this?
>
>
>
> We’ve had some good discussion and an updated version is coming with some
> updates based on that discussion. Remember that we don’t necessarily have
> to incorporate every suggested change but simply need to conclude the
> discussion.
>
>
>
> Thanks,
>
> Acee
>
>
>
> *From: *"Acee Lindem (acee)" <acee=[email-masked]>
> *Date: *Friday, January 28, 2022 at 7:24 AM
> *To: *Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for
> BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04
>
>
>
> Speaking as WG member:
>
>
>
> I support publication of the document. As indicated by the Albert Fu, it
> has been implemented by two vendors. I will provide WG Last Call comments
> when I prepare the Shepherd’s report.
>
>
>
> Thanks,
>
> Acee
>
>
>
> *From: *Lsr <[email-masked]> on behalf of "Acee Lindem (acee)"
> <acee=[email-masked]>
> *Date: *Thursday, January 27, 2022 at 12:09 PM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <
> [email-masked]>
> *Subject: *[Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" -
> draft-ietf-lsr-ospf-bfd-strict-mode-04
>
>
>
> LSR WG,
>
>
>
> This begins a two week last call for the subject draft. Please indicate
> your support or objection on this list prior to 12:00 AM UTC on February 11
> th, 20222. Also, review comments are certainly welcome.
>
> Thanks,
> Acee
>
>
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 3 Feb 2022 16:43:48 +0000

Hi Ketan,
Do you remember who this comment came from?  I definitely think anyone who reads the abstract of the draft wouldn’t be confused and don’t agree with the comment.

Also, this is meant to be a per-interface sub-option of the existing BFD configuration – right? There is at least one place that would lead one to believe it is pre-node.

Thanks,
Acee

From: Ketan Talaulikar <[email-masked]>
Date: Thursday, February 3, 2022 at 10:31 AM
To: Acee Lindem <[email-masked]>
Cc: "Acee Lindem (acee)" <acee=[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

Hi Acee,

The authors had picked the term "OSPF BFD Strict-Mode" originally - please refer to https://datatracker.ietf.org/doc/html/draft-ketant-lsr-ospf-bfd-strict-mode-01. However, post IETF presentation, we got feedback from WG members that the term was misleading and gave an impression that the proposal was introducing a "strict-mode" in BFD. What we are doing is introducing a "strict-mode" of operation in OSPF for BFD usage.

Thanks,
Ketan

On Thu, Feb 3, 2022 at 2:07 AM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Speaking as Document Shepherd:

Thanks,
Acee

From: "Acee Lindem (acee)" <acee=[email-masked]<mailto:[email-masked]>>
Date: Friday, January 28, 2022 at 7:24 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

Speaking as WG member:

Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <acee=[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 27, 2022 at 12:09 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

LSR WG,

---

From: Ketan Talaulikar <[email-masked]>
Date: Thu, 3 Feb 2022 23:10:43 +0530

Hi Acee,

I do not remember the persons (it was more than one) who provided this
comment.

We will make the following changes (unless there are any objections):

s/ OSPF Strict-Mode for BFD/ OSPF BFD Strict-Mode
s/ Strict-Mode for BFD / BFD Strict-Mode
similar ...

Thanks,
Ketan

On Thu, Feb 3, 2022 at 10:13 PM Acee Lindem (acee) <[email-masked]> wrote:

> Hi Ketan,
>
> Do you remember who this comment came from?  I definitely think anyone who
> reads the abstract of the draft wouldn’t be confused and don’t agree with
> the comment.
>
>
>
> Also, this is meant to be a per-interface sub-option of the existing BFD
> configuration – right? There is at least one place that would lead one to
> believe it is pre-node.
>
>
>
> Thanks,
> Acee
>
>
>
> *From: *Ketan Talaulikar <[email-masked]>
> *Date: *Thursday, February 3, 2022 at 10:31 AM
> *To: *Acee Lindem <[email-masked]>
> *Cc: *"Acee Lindem (acee)" <acee=[email-masked]>, "
> [email-masked]" <[email-masked]>, "
> [email-masked]" <
> The authors had picked the term "*OSPF BFD Strict-Mode*" originally -
> please refer to

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 3 Feb 2022 17:57:13 +0000

Hi Ketan,

Date: Thursday, February 3, 2022 at 12:41 PM

Hi Acee,

I do not remember the persons (it was more than one) who provided this comment.

I wouldn’t think there would be many of the latter. Perhaps, you could always use “OSPF BFD Strict-Mode” to avoid any confusion.

Thanks,
Ketan

On Thu, Feb 3, 2022 at 10:13 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ketan,
Do you remember who this comment came from?  I definitely think anyone who reads the abstract of the draft wouldn’t be confused and don’t agree with the comment.

Thanks,
Acee

From: Ketan Talaulikar <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 3, 2022 at 10:31 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "Acee Lindem (acee)" <acee=[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

Hi Acee,

Thanks,
Ketan

Thanks,
Acee

Speaking as WG member:

Thanks,
Acee

LSR WG,

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 3 Feb 2022 18:13:28 +0000

Searching the draft there are actually a lot of “Strict-Mode for BFD” w/o “OSPF” preceding it.

I agree w Acee’s suggestion – always use “OSPF BFD Strict-Mode”.

    Les

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Thursday, February 3, 2022 9:57 AM
To: Ketan Talaulikar <[email-masked]>
Cc: [email-masked]; [email-masked]; Acee Lindem (acee) <acee=[email-masked]>
Subject: Re: [Lsr] Working Group Last Call for "OSPF Strict-Mode for BFD" - draft-ietf-lsr-ospf-bfd-strict-mode-04

Hi Ketan,

Cc: "Acee Lindem (acee)" <acee=[email-masked]<mailto:acee=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi Acee,

Thanks,
Ketan

Thanks,
Acee

Hi Acee,

Thanks,
Ketan

Thanks,
Acee

Speaking as WG member:

Thanks,
Acee

LSR WG,

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Fri, 4 Feb 2022 16:03:35 +0530

On Thu, Feb 3, 2022 at 10:14 PM Acee Lindem (acee) <acee=
[email-masked]> wrote:

> configuration – right?

That's why I was asking whether multi-hop BFD is in scope (multi-hop BFD is
not enabled per interface). If so, then some suggestions:
https://mailarchive.ietf.org/arch/msg/lsr/wffR6A6Vq-wtKYPiLE2wuVyJDNY/

Regards,
Muthu

> There is at least one place that would lead one to believe it is pre-node.
>
>
>
> Thanks,
> Acee
>
>
>
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>