Subject: [Lsvr] WG Adoption call for draft-ymbk-lsvr-lsoe-03 (to end 17 December 2018)

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 3 Dec 2018 14:23:39 +0000

Hi All,

This begins a 2 week WG adoption call for draft-ymbk-lsvr-lsoe-03 (December 3 - December 17)
and is the procedure follow up of the IETF103 LSVR WG meeting where WG adoption was recognized.

https://datatracker.ietf.org/doc/draft-ymbk-lsvr-lsoe/

During your discussion in the WG Adoption Call, the chairs are looking for more context as only a 'yeh' or 'ney'.

Please indicate the following things:
1) Support to adopt draft " draft-ymbk-lsvr-lsoe-03" as LSVR WG document?
2) Are there any technical issues with this draft?
3) Which are current pain-points in the draft requiring additional content and technical attention?
4) What is missing from this draft?

The authors (or anybody else) of this draft should send their IPR statements in response to this email.

Kind Regards,
Gunter & Victor
LSVR WG co-chairs

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 10 Dec 2018 09:26:48 +0000

Reminder ...

G/

From: Lsvr <[email-masked]> On Behalf Of Van De Velde, Gunter (Nokia - BE/Antwerp)
Sent: Monday, December 3, 2018 15:24
To: [email-masked]
Cc: [email-masked]; Victor Kuarsingh <[email-masked]>
Subject: [Lsvr] WG Adoption call for draft-ymbk-lsvr-lsoe-03 (to end 17 December 2018)

Hi All,

This begins a 2 week WG adoption call for draft-ymbk-lsvr-lsoe-03 (December 3 - December 17)
and is the procedure follow up of the IETF103 LSVR WG meeting where WG adoption was recognized..

Kind Regards,
Gunter & Victor
LSVR WG co-chairs

---

From: Neeraj Malhotra <[email-masked]>
Date: Mon, 10 Dec 2018 09:08:38 -0800

Hi,

Support. 

This is a really important draft and plays a key role in simplifying neighbor discovery, eliminating operational complexities associated with legacy link level learning protocols.

Thanks,
Neeraj

> On Dec 10, 2018, at 1:26 AM, Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> Reminder …
>  
> G/
>  
> This begins a 2 week WG adoption call for draft-ymbk-lsvr-lsoe-03 (December 3 – December 17)
> and is the procedure follow up of the IETF103 LSVR WG meeting where WG adoption was recognized...   
>  
> _______________________________________________
> Lsvr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsvr

---

From: Jacob Uecker <[email-masked]>
Date: Tue, 11 Dec 2018 05:42:05 -0800

1) Yes, I support it
2 - 4) No issues, pain points or missing items. As noted, there are some items that could warrant additional discussion and flushing out but nothing that would stop this document form moving forward.

Thank you

Jacob 

> On Dec 3, 2018, at 6:23 AM, Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> Hi All,
>

---

From: Paul Congdon <[email-masked]>
Date: Fri, 14 Dec 2018 06:55:14 -0800

> 1) Support to adopt draft " draft-ymbk-lsvr-lsoe-03" as LSVR WG document?

I do not support the adoption of this draft as is.  I still believe there
are technical issues which I describe below, but they can be fixed in a
future draft.

One other significant issue is the name of this protocol.  It is not a link
state protocol over ethernet and that can lead to confusion.  There is
already a standard 'link state' protocol over Ethernet called SPB (shortest
path bridging) in 802.1Q.

This is really a peer discovery and liveness protocol.  Better names would
be any of the following:

BGP Peer Discover Protocol over Ethenet, or just
Peer Discovery over Ethernet
Encapsulation Discovery over Ethernet

I still do not believe the ACK mechanism works without some sort of packet
number or identifier for what it is ACKing.  It is possible for an
unambiguous ACK to pass in flight with a retransmission can cause a
duplication at the receiver.

> 3) Which are current pain-points in the draft requiring additional content

Given that this protocol sends 'Hello' messages, I think the strict policy
of dropping packets that don't match the version number will create extra
chatter on the network when a subsequent version of this is rolled out.  It
would be a good idea to attempt to be forward/backward compatible if
possible.  Examples of this have been documented in 802.1.

> 4) What is missing from this draft?
As stated above

As a side note and FYI, I have requested time to present a consideration
for an LLDPv2 proposal within 802.1.   There is a universal need to extend
LLDP's ability to transfer TLVs beyond what can fit a single PDU and
several of us with 802.1 have created an initial proposal to be presented
at an upcoming conference call or F2F meeting.  This is not an intention to
challenge the contribution or need for this draft, rather to address a
current unmet need of a widely deployed protocol.

Regards,
Paul

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 24 Dec 2018 09:27:30 +0000

Hi LSVR WG, draft-ymbk-lsvr-lsoe authors,

The LSoE WG adoption call has been completed. Adoption call feedback indicated that while the current version of LSoE may have room for improvement, that there is sufficient interrest to proceed the draft as LSVR WG document.

Authors, may i ask to re-submit the draft as LSVR WG draft.

The LSVR WG co-chairs together with the responsible AD are already in process to send a liaison to IEEE 802.1 WG to inform on this adjacent technology development at IETF.

Brgds,
Gunter & Victor
LSVR co-chairs

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>
Sent: Monday, December 3, 2018 3:23 PM
To: [email-masked]
Cc: Victor Kuarsingh; [email-masked]
Subject: WG Adoption call for draft-ymbk-lsvr-lsoe-03 (to end 17 December 2018)

Hi All,

1) Support to adopt draft "draft-ymbk-lsvr-lsoe-03" as LSVR WG document?

Kind Regards,
Gunter & Victor
LSVR WG co-chairs