Subject: [Lsvr] "Shortest Path Routing Extensions for BGP Protocol" - draft-ietf-lsvr-bgp-spf-10 Implementation Status

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 3 Aug 2020 17:49:33 +0000

Hi Alvaro,
You had asked about implementation status in the subject draft. Why couldn’t we simply add an informative reference to https://datatracker.ietf.org/doc/draft-psarkar-lsvr-bgp-spf-impl/ ?
Thanks,
Acee

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 3 Aug 2020 14:20:28 -0500

Acee:

Hi!

I was asking for an rfc7942-style section…but an informative reference to
the implementation report draft is ok with me.

Note that I don’t think it is necessary to publish the implementation
report draft as a RFC.

Thanks!

Alvaro.

On August 3, 2020 at 1:49:43 PM, Acee Lindem (acee) (
acee=[email-masked]) wrote:

Hi Alvaro,

You had asked about implementation status in the subject draft. Why
couldn’t we simply add an informative reference to
https://datatracker.ietf.org/doc/draft-psarkar-lsvr-bgp-spf-impl/ ?

Thanks,
Acee

_______________________________________________
Lsvr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsvr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 3 Aug 2020 20:42:48 +0000

Hi Alvaro,

From: Lsvr <[email-masked]> on behalf of Alvaro Retana <[email-masked]>
Date: Monday, August 3, 2020 at 3:20 PM
To: "Acee Lindem (acee)" <acee=[email-masked]>
Cc: Keyur Patel <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsvr] "Shortest Path Routing Extensions for BGP Protocol" - draft-ietf-lsvr-bgp-spf-10 Implementation Status

Acee:

Hi!

I was asking for an rfc7942-style section…but an informative reference to the implementation report draft is ok with me.

Given that the work has already been done in a separate draft, I’d rather not copy it into the BGP SPF draft (especially since it will eventually be removed as per RFC 7942).

Note that I don’t think it is necessary to publish the implementation report draft as a RFC.

Speaking as a working group chair of another WG, I’m generally so pleased when people do this type of work and do it well that I prefer to publish it as an informational draft.

Thanks,
Acee

Thanks!

Alvaro.

On August 3, 2020 at 1:49:43 PM, Acee Lindem (acee) (acee=[email-masked]<mailto:acee=[email-masked]>) wrote:
Hi Alvaro,
You had asked about implementation status in the subject draft. Why couldn’t we simply add an informative reference to https://datatracker.ietf.org/doc/draft-psarkar-lsvr-bgp-spf-impl/ ?
Thanks,
Acee

_______________________________________________
Lsvr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf..org/mailman/listinfo/lsvr<https://www.ietf.org/mailman/listinfo/lsvr>

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 4 Aug 2020 08:25:39 -0500

On August 3, 2020 at 4:42:51 PM, Acee Lindem wrote:

Acee:

Hi!

...
> Speaking as a working group chair of another WG, I’m generally so pleased
> when people do this type of work and do it well that I prefer to publish
> it as an informational draft.

I'm not sure if you meant publication as an Informational RFC, or for
the document to remain in the repository as a draft.

While the content of implementation reports can be useful at the time,
the information quickly becomes stale because it was a view of a
moment in time.  Archiving such information (as an RFC) makes it hard
to update and keep the community up to date, vs leaving the document
in draft form or use the Wiki (as idr does, for example).  Personally
I think that the value of publishing that type of information as an
RFC is lost with publication.

Having said that, if the WG wants to freeze the implementation
information in time, I would prefer it to be included in an appendix
of the specification.  If there is consensus to publish a separate
RFC, then I will insist with it being progressed with the main
specification.  I'll let the Chairs guide any discussion in the WG.

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 4 Aug 2020 13:51:17 +0000

Hi Alvaro, 

On 8/4/20, 9:25 AM, "Alvaro Retana" <[email-masked]> wrote:

    Acee:

    Hi!

    ...

I did mean Informational RFC.

True but since RFCs have a publication date, it is pretty obvious that it represents a snapshot and not necessarily the current implementation status. 

Ok - sounds good. 

Thanks,
Acee

    Thanks!

    Alvaro.

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 4 Aug 2020 13:52:44 +0000

As a chair it is pleasing to see detailed implementation details in a document, particular if the technology involved is state-of-the-art new protocol.
A fixed dedicated document however introduce that the implementation information may be perceived frozen in time, and non-trivial to quickly update.

When we look over the WG fence, and see the satisfying implementation tracking at IDR WG, then LSVR could adopt something similar for longer term and for pragmatic usability.

The implementation information for LSVR should be easy accessible, and not require an abundance of recursive lookups in a set of sites and documents.
I am not a big fan of detailed implementation detail inside a proposed standards document, as that deviate away from the normative language. An exec summary is sufficient for me so that it becomes clear its not just paperware, but a real product.

Hence, not sure that crafting such info with an RFC number in mind is desirable. Having a wiki with details for easy future update seems future proof and has proven track record.
During the IESG evaluation a nice write-up with implementation details will help the LSVR spec through the IETF machinery.

I believe everybody is in sync, not?

G/

-----Original Message-----
From: Lsvr <[email-masked]> On Behalf Of Alvaro Retana
Sent: Tuesday, August 4, 2020 15:26
To: Acee Lindem (acee) <[email-masked]>; Acee Lindem (acee) <acee=[email-masked]>
Cc: Keyur Patel <[email-masked]>; [email-masked]
Subject: Re: [Lsvr] "Shortest Path Routing Extensions for BGP Protocol" - draft-ietf-lsvr-bgp-spf-10 Implementation Status

Acee:

Hi!

...
> Speaking as a working group chair of another WG, I’m generally so 
> pleased when people do this type of work and do it well that I prefer 
> to publish it as an informational draft.

I'm not sure if you meant publication as an Informational RFC, or for the document to remain in the repository as a draft.

While the content of implementation reports can be useful at the time, the information quickly becomes stale because it was a view of a moment in time.  Archiving such information (as an RFC) makes it hard to update and keep the community up to date, vs leaving the document in draft form or use the Wiki (as idr does, for example).  Personally I think that the value of publishing that type of information as an RFC is lost with publication.

Having said that, if the WG wants to freeze the implementation information in time, I would prefer it to be included in an appendix of the specification.  If there is consensus to publish a separate RFC, then I will insist with it being progressed with the main specification.  I'll let the Chairs guide any discussion in the WG.

Thanks!

Alvaro.