Subject: [Ltru] Matching: Ranges vs. range lists

From: Martin Duerst <[email-masked]>
Date: Wed, 16 Nov 2005 18:49:46 +0900

[This mail is somewhat related to my mail entitled
Matching: Filtering and Lookup: What's the fundamental difference.]

I think the current draft is not careful enough to distinguish
between single ranges and lists of ranges.

I think that each specific matching section (e.g. basic range
lookup, and so on) should first define whether a given range matches
against a given tag (the result ideally being binary), and then
go on and talk about the cases of having more than one tag
and/or more than one range, in a well organized fashion.

Regards,   Martin. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 16 Nov 2005 17:16:11 -0800

I think I agree with Harald, although I also agree that we should mention (as the text in draft-06 currently does) what one might do with the default content. Please propose changes to that text!

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: 2005年11月16日 16:34
> To: Mark Davis; Addison Phillips
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Matching: Ranges vs. range lists
> 
> 
> 
> --On 16. november 2005 08:56 -0800 Mark Davis <[email-masked]>
> wrote:
> 
> > One of the key issues is making sure that lookup allows for correct
> > handling of the default fallback. This is important because different
> > systems do it differently. Lookup on a single language tag progressively
> > truncates. It switches to the default language before going to root (the
> > last resort). So suppose that the default language is ja-JP (Japanese in
> > Japan). We would search as follows:
> > en_US_California
> > en_US
> > en
> > ja_JP
> > ja
> > ROOT
> 
> I don't think I agree. My interpretation is that "default language" is a
> per-application decision, not a part of the language matching rule, and
> treating it as part of the langauge matching rule will just add confusion.
> 
> But I have to read the matching draft carefully before I'm sure what I
> disagree with, or how to express it.