Subject: [Ltru] Matching: make sure subtags are explained

From: Martin Duerst <[email-masked]>
Date: Fri, 18 Nov 2005 17:11:04 +0900

[chair hat off]

(Re)Reading the matching draft, I find myself unsure
about what each tag or subtag in an example means.

A typical example is the following, from 3.2.3:

    ... For example, depending on the domain, an implemenation
    might give a small distance to the difference between the language
    subtag 'no' and the closely related language subtags 'nb' or 'nn'; or
    between the script subtags 'Kata' and 'Hira'; or between the region
    subtags 'US' and 'UM'.
<<<<

By chance, I know all the above subtags except 'UM'.
Reading the draft, I have no intention to look these
up. My guess is that maybe except for 'US', many readers
easily won't know any of these tags. It seems that the
text would be a lot more readable (because the examples
are a lot more self-explaining) if we change this
to something like

    ... For example, depending on the domain, an implemenation
    might give a small distance to the difference between the language
    subtag 'no' (Norvegian) and the closely related language subtags
    'nb' (Norvegian, Bookmal) or 'nn' (Norvegian, Newnorsk); or
    between the script subtags 'Kata' (Katakana) and 'Hira' (Hiragana);
    or between the region subtags 'US' (USA) and 'UM' (???).
<<<<

Do we have a general policy for how to handle such cases?
For example, there may be examples that are really just
only about the mechanics of the tags, and others (like
above) where the meaning of the tag is quite relevant to
understand the example.

Regards,    Martin.

[I'm not sure we have done this persistently in the
registry draft, but for that it is too late now, anyway.] 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 18 Nov 2005 21:33:54 +0100

>     or between the region subtags 'US' (USA) and 'UM' (???).

UM = US Minor Outlying Islands, if I remember right.

BTW, Norwegian's spelled with a W in English, and the variants should be 
"Bokmal" and "Nynorsk" (transliterated from "Bokmål"), or "Book language" 
and "New Norwegian" if you want to translate.