Subject: RE: [Ltru] Matching draft: terminology: application

From: "Addison Phillips" <[email-masked]>
Date: Sun, 13 Nov 2005 08:44:17 -0800

I don't quite agree. 

I believe the word application does *include* other standards, such as HTTP or CSS. But it also includes the traditional meaning of the word 'application'. For example, here is the first instance of the word application:

--
The suitability of a particular mechanism to a particular application depends on the needs of that application.
--

It seems clear to me that the intended audience is anyone needing to select a matching scheme for their application (be it a standard or a specific implementation).

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: 2005年11月13日 4:09
> To: LTRU Working Group
> Subject: [Ltru] Matching draft: terminology: application
> 
> The term 'application' shows up many times in the document,
> but it's not very clear what that means. My understanding
> is that it means other standards such as HTTP, CSS, and so
> on, not individual end-user applications on a PC.
> 
> If this is so, we should make this clear, preferably in
> an introductory section about terminology. If this is
> different, we should also make it clear.
> 
> Regards,   Martin.
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Erik van der Poel <[email-masked]>
Date: Mon, 14 Nov 2005 09:04:38 -0800

RFCs often use the word "application" in this confusing way. If you're 
used to RFCs and Internet Drafts, you know what "application" means. But 
if you're coming from a different background, such as PC software 
development, the word "application" has a more specific meaning.

The matching draft does sometimes make it quite clear. In one place it 
raises HTTP as an example of an application. In other places it talks 
about "application or protocol". And in one place it even has 
"application protocol". I don't know whether we need to define 
"application" in this spec, but maybe some more of the occurences of the 
word "application" could be replaced with "application or protocol".

Erik

Addison Phillips wrote:
>>------------------------------------------------------------------------
>>

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 14 Nov 2005 18:57:04 +0100

Erik van der Poel wrote:

> I don't know whether we need to define "application" in this
> spec

Let's stick to RfC 1983 / FYI 18:

| application
|   A program that performs a function directly for a user.
|   FTP, mail and Telnet clients are examples of network
|   applications.

It also explains "protocol", "application layer", and "API".

Pretty old, some (now) obscure terms, but still better than
reinventing the wheel.
                       Bye, Frank

---

From: Martin Duerst <[email-masked]>
Date: Tue, 15 Nov 2005 12:02:52 +0900

Hello Addison, others,

[co-chair hat on]
I think we have to split this discussion into two issues:

1) What do we want to say, and
2) How do we say it

So let's figure out 1) first, and let's look at 2)
once we have figured out 1). I think we have two options:
a) Apply to protocols (and other standards) only
b) Apply to everything including what I'd like to call here
    'end user applications'

It looks to me like Erik is saying that the current draft
says a), whereas Frank seems to say that the current draft
says b) (at least where it doesn't mention protocols).
Addison seems to say the current draft says b).
[co-chair hat off]

I personally think I could live both with a) and with b),
given that it was clear what we ment. I favorize b) because
the matching stuff can indeed be used by 'end user applications'.
However, I have one concern with b): I'd like end user
applications that implement a protocol (or other standard)
to follow that standard first and foremost, and the
advice in our draft after that. I'd also like protocol
specs and other standards to clearly choose which matching
algorithm they use in case they do matching. If there is
a good way to make this clear, I think b) is clearly
the better option.

Regards,   Martin.

At 01:44 05/11/14, Addison Phillips wrote:
 >I don't quite agree.
 >
 >I believe the word application does *include* other standards, such as HTTP
 >or CSS. But it also includes the traditional meaning of the word
 >'application'. For example, here is the first instance of the word application:
 >
 >--
 >The suitability of a particular mechanism to a particular application
 >depends on the needs of that application.
 >--
 >
 >It seems clear to me that the intended audience is anyone needing to select
 >a matching scheme for their application (be it a standard or a specific
 >implementation).
 >
 >Addison
 >
 >Addison P. Phillips

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 15 Nov 2005 10:07:45 +0100

Martin Duerst wrote:

> Frank seems to say that the current draft says b)

Okay, but actually I wanted to say something different:

 If we need some kind of "definition" for "application"
 and / or "protocol" let's reference RfC 1983 (FYI 18).
<http://tools.ietf.org/html/1983#page-5>
<http://tools.ietf.org/html/1983#page-45>

                       Bye, Frank

---

From: Marion Gunn <[email-masked]>
Date: Tue, 15 Nov 2005 10:24:17 +0000

Much better. Use the terminology formula: 'application: as defined in
RfC 1983 / FYI 18' and ideally follow that with the full quotation, as
given by Frank below (to save people having to buy yet another standard
to get one stray definition).
mg

Scríobh Frank Ellermann:
> ...

-- 

Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an 
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Tue, 15 Nov 2005 07:38:13 -0500

> From: Marion Gunn [mailto:[email-masked]] 
> Sent: Tuesday, November 15, 2005 5:24 AM
> To: Frank Ellermann
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: Matching draft: terminology: application
> 

IETF standards are free (as in beer).  There is no cost to obtain copies
beyond whatever it costs you to download and save a copy of a text document.

It is generally better to cite a definition found in another document
without quoting it.  Quoting puts that definition in two places.  If one of
them changes in the future, which one remains the authoritative definition?

-Scott-

---

From: Marion Gunn <[email-masked]>
Date: Tue, 15 Nov 2005 16:01:19 +0000

> beyond whatever it costs you to download and save a copy of a text document.

Good point. ISO Standards generally are not.

> them changes in the future, which one remains the authoritative definition?

I'd say quoting it makes it the authoritative definition in in the doc.
wherein quoted, but I'd also say it would be enough to enclose a
copy/link to original in the daughter doc. Either way, if it costs
nothing to get the second one, giving it in reference is probably
enough, though still a bit annoying to users not having both readily to hand.
mg

--