Subject: RE: [Ltru] Need more interesting distance metric (?) (was:Matching:choice of schemes)

From: "Addison Phillips" <[email-masked]>
Date: Fri, 18 Nov 2005 09:09:41 -0800

> If we have a good idea of what 'distance metric' is useful for,
> we should clearly indicate that.

I quote draft-06, Section 3.1:

--
# Scored Filtering (Distance Metric Filtering) produces an ordered set of content using either basic or extended language ranges. It should be used when the quality of the match within a specific language range is important, as when presenting a list of documents resulting from a search.
--

And then Section 3.2.3:

--
Both basic and extended language range filtering produce simple boolean matches. Sometimes it may be beneficial to provide an array of results with different levels of matching, for example, sorting results based on the overall "quality" of the match. Distance metric filtering provides a way to generate these quality values.
--

I think that pretty clearly indicates what a distance metric is useful for.

> If we can explain what the
> specific values are good for, we should also explain that,
> because it will help implementers choose other values if
> they need something different.

I agree. I note that multiplying the scores by "q" (quality) weights can produce interleaved lists when working with a language priority list (like Accept-Language).

> But if this thing gets too complicated, or too imprecise,
> we should also seriously consider dropping it.

Perhaps, although we could go the route of being less specific about the weights and just describing the scheme generally. I tend to favor what we've done, though. I'll see if I have time to finish off my little implementation today and put a demo on my website. That should help us make better decisions.

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: 2005年11月18日 0:14
> To: Addison Phillips; Frank Ellermann; [email-masked]
> Subject: RE: [Ltru] Need more interesting distance metric (?)
> (was:Matching:choice of schemes)
> 
> [chair hat off]
> 
> If we have a good idea of what 'distance metric' is useful for,
> we should clearly indicate that. If we can explain what the
> specific values are good for, we should also explain that,
> because it will help implementers choose other values if
> they need something different.
> 
> But if this thing gets too complicated, or too imprecise,
> we should also seriously consider dropping it.
> 
> Regards,    Martin.
> 
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 19 Nov 2005 20:33:00 +0100

Addison Phillips wrote:

> I note that multiplying the scores by "q" (quality) weights
> can produce interleaved lists when working with a language
> priority list (like Accept-Language).

That's okay, but please stick to the original "scoring" idea.
Maybe we should use the term "scoring" instead of "distance
metric", the latter is somewhat unclear, there's no clear limit
for the number of variants.  For extensions we have at least
a theoretical limit 25.

Multiple variants and extensions are messy.  I don't see the
point of splitting it into _five_ dimensions.  The original
four dimensions language + script + region + "whatever" were
already difficult.

>From my POV the region is just a special case of "whatever",
like variants and extensions.  Either it's important, I want
en-US and no other en-* (or en-GB-oed and no other en-*), or
it's irrelevant.

It's the job of the scoring to help me with this, the only
case I really care about is "I don't want it if it's no Latin".

> Perhaps, although we could go the route of being less
> specific about the weights and just describing the scheme
> generally. I tend to favor what we've done, though.

I'm not convinced.  If I get de-DE-1996 as Braille I'm lost.

The *-Brai q=0.0 approach could allow me to say so, with any
scoring, so why not simply use 10-5-1-1-1 if you insist on
five dimensions ?
                           Bye, Frank