Subject: [Ltru] Matching draft: 2.4 Meaning of language tags...

From: Martin Duerst <[email-masked]>
Date: Mon, 14 Nov 2005 19:13:30 +0900

I'm somewhat surprised we have a paragraph on meaning
of language tags in the matching document; shouldn't that
have been in the registry document?

I agree some of the material makes sense here, but I don't
see the point of the bulletet list at the end, which is
a (modulo minor changes, I didn't check for that) verbatim
copy of Section 4.2 of draft-ietf-ltru-registry-14.txt
and isn't, in my view, very matching-specific.

The first paragraph says that a language tag 'defines'
a language; we successfully elimitated this usage; if
we still need this paragraph, please use 'indicate' or
whatever.

The paragraph starting "This relationship is not guaranteed..."
doesn't make sense to me. "This relationship" refers to
"narrower"/"more specific", but the paragraph then gives
"NOT guaranteed to be mutually intellegible". Mutual
intellegibility is something different from narrower
or wider. In theory, there could be a prefix for
Indo-European, and then some narrower stuff, and we
all know Indo-European is too wide to be mutually
intellegible.

Another (minor) problem is that "intellegible" is used
both in the general (spoken and written) sense as well
as just for writing (in the az example).

Regarding 'mutually intellegible', it would be good to
point out that this is a subjective concept; the text
somehow alludes to that in the az example paragraph,
but doesn't really explicitly say so.

For the end, back to the title of the section: it
should be changed so that it's clear we don't define
the meaning of language tags here. Also, we should say
something about ranges, or leave it out of the title.

Regards,   Martin. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Marion Gunn <[email-masked]>
Date: Mon, 14 Nov 2005 10:50:51 +0000

I understand that the purpose of a language tag is to 'identify' a
language, that the word 'langtag' is  only short for language
identifier. Using words such as 'defines' or 'indicates' could be
confusing. What is the advantage in avoiding the words 'identify' or 'identifier"?
mg

Scríobh Martin Duerst:
> ...
> whatever...

-- 

Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an 
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *