Subject: RE: [Ltru] Re: New ISO 639 language identifier approved: SwissGerman; Alemanic

From: "Addison Phillips" <[email-masked]>
Date: Mon, 7 Nov 2005 11:26:28 -0800

According to the ietf-languages list discussion, 'gsw' and "de-CH" are not the same language, despite their English names. As such, "gsw-*" and "de-*-CH-*" don't match.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Misha Wolf
> Sent: 2005年11月7日 11:23
> To: LTRU Working Group
> Subject: RE: [Ltru] Re: New ISO 639 language identifier approved:
> SwissGerman;Alemanic
> 
> Ouch.  Good catch.  What will happen to the matching
> of "de" or "de-CH" against "gsw"?
> 
> Misha
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Erik van der Poel
> Sent: 07 November 2005 18:21
> To: Doug Ewell
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Re: New ISO 639 language identifier approved: Swiss
> German;Alemanic
> 
> I'm wondering whether it might be better to delay the addition of "gsw"
> until after the 2 IDs currently at the IESG stage get published as RFCs.
> 
> It just seems like "gsw" has a number of issues hanging off of it, and
> that any "rushed" addition might miss something or cause an error. I may
> 
> be overreacting -- if so, please let me know, I'm new here.
> 
> Now for the issues themselves. There are already a couple of "redundant"
> 
> tags for Swiss German: de-CH-1901 and de-CH-1996. However, if we add
> "gsw" and it becomes the preferred subtag for Swiss German, then those
> de-CH tags are no longer "redundant" in the normal sense of that word.
> Should we then add a Preferred-Value (or a See-Also) to those
> "redundant" entries? Rules 8 and 10 in Section 3.4 of the registry ID
> appear to talk specifically about language subtags, but I didn't
> immediately notice any discussion of language-COUNTRY combos like de-CH.
> 
> I'm probably missing something -- let me know.
> 
> If it is true that Switzerland's orthography years were the same as
> Germany's (1901 and 1996), then should the entry for the "variant" with
> the subtag "1901" also have the prefix "gsw" (and likewise for 1996)?
> 
> If German has a Suppress-Script of Latn, shouldn't "gsw" also have that?
> 
> On the other hand, if this "gsw" case raises a number of issues in the
> IDs, we may want to delay them to fix them (for new rules that would
> cover this sort of case). Not that I want to be the person blamed for
> the delay of these RFCs!
> 
> Erik
> 
> 
> To find out more about Reuters visit www.about.reuters.com
> 
> Any views expressed in this message are those of the individual sender,
> except where the sender specifically states them to be the views of
> Reuters Ltd.
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 07 Nov 2005 20:47:36 +0100

Addison Phillips wrote:

> According to the ietf-languages list discussion, 'gsw' and
> "de-CH" are not the same language, despite their English
> names. As such, "gsw-*" and "de-*-CH-*" don't match.

Yes.  And we probably don't need 1901/1996 for gsw, nds, etc.,
the "official spelling" is only relevant for de as written
in schools or laws.  For related languages without "official
spelling" it's irrelevant.
                           Bye, Frank