Subject: [Ltru] en-UM and the like (was: Re: Matching: make sure subtags are explained)

From: "Doug Ewell" <[email-masked]>
Date: Sat, 19 Nov 2005 19:54:50 -0800

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> UM, by the way, is "United States Minor Outlying Islands"
>> region.
>
> Most of them uninhabited, unusable for laguage tags.  Even if
> en-UM as spoken on Midway is different from en-US, then what
> about en-UM as spoken on Wake Island ?

Please, I beg, let's not go down this dusty road again.

Yes, of course you are right from a practical standpoint.  It is absurd 
to talk about "language X as spoken in" an uninhabited region, and for 
regions populated by military or scientific personnel, the language 
variant(s) is/are completely determined by wherever the itinerant 
population comes from.  "English as spoken in Australia" is en-US on an 
American research base, en-AU on an Australian base, and so forth. 
en-BV is preposterous.

But we have made a commitment to stay compatible with all language tags 
that were valid under RFC 1766 and 3066, and that means allowing any ISO 
3166-1 code element valid since 1995 as a region subtag, no matter how 
preposterous the language-region combination.  To do otherwise would be 
to claim authority and responsibility for determining "what is a 
country," which we have decided not to do for both practical and 
scriptural reasons.

Region subtagging can be too precise, not precise enough, or maybe even 
both at the same time.  Let's accept that and turn the page.

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/ 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 20 Nov 2005 12:32:05 +0100

> Please, I beg, let's not go down this dusty road again.

As a dusty road it isn't suited for an example in a part
of BCP 47.  We also replaced en-boont by better examples.

The whole concept of region codes derived from 3166-1 is
dubious, we only kept it for backward compatibility.  The
region codes in language tags are in no way more important
than variants or future extensions, it's a waste of time
to invent complex scoring schemes where the region code is
always more relevant than variant(s) or extension(s):

Left-to-right automatically does this.  Something simple
like 32-16-8-3-1 is good enough to reflect left-to-right
numerically for almost all practical cases.

An "interesting" scoring example would allow to overrule
the left-to-right effect, e.g. 8-4-1-1-1.

It could even rearrange the left-to-right order, just use
4-8-1-1-1 for some "script first" effect. or 8-4-0-1-1 for
"ignore region".

> It is absurd to talk about "language X as spoken in" an
> uninhabited region, and for regions populated by military
> or scientific personnel, the language variant(s) is/are
> completely determined by wherever the itinerant population
> comes from.

Yes, and by absuing en-UM as example that point is obscured,
and next you see is a strange debate about ga-GB vs. "ga-UK",
where my main question would be whether ga is different from
ga-IE, and if yes whether ga-GB is actually ga-IE.

The region codes in language tags aren't for the geographical
position of the speaker or author, en-UM is "valid" but bogus.

> en-BV is preposterous.

ACK.  There are more than enough relevant examples like en-JA.

                          Bye, Frank

---

From: Martin Duerst <[email-masked]>
Date: Mon, 21 Nov 2005 18:11:43 +0900

>Yes, and by absuing en-UM as example that point is obscured,

My understanding was that in that specific instance, en-UM
was taken as an example of a case where there wouldn't be
any difference to en-US. For that, the example seemed to
make sense.

Regards,    Martin.