Subject: RE: [Ltru] Matching: make sure subtags are explained

From: "Addison Phillips" <[email-masked]>
Date: Fri, 18 Nov 2005 08:39:37 -0800

I agree and will make the modifications to the matching draft. UM, by the way, is "United States Minor Outlying Islands" region.

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: 2005年11月18日 0:11
> To: LTRU Working Group
> Subject: [Ltru] Matching: make sure subtags are explained
> 
> [chair hat off]
> 
> (Re)Reading the matching draft, I find myself unsure
> about what each tag or subtag in an example means.
> 
> A typical example is the following, from 3.2.3:
> 
>  >>>>
>     ... For example, depending on the domain, an implemenation
>     might give a small distance to the difference between the language
>     subtag 'no' and the closely related language subtags 'nb' or 'nn'; or
>     between the script subtags 'Kata' and 'Hira'; or between the region
>     subtags 'US' and 'UM'.
> <<<<
> 
> By chance, I know all the above subtags except 'UM'.
> Reading the draft, I have no intention to look these
> up. My guess is that maybe except for 'US', many readers
> easily won't know any of these tags. It seems that the
> text would be a lot more readable (because the examples
> are a lot more self-explaining) if we change this
> to something like
> 
>  >>>>
>     ... For example, depending on the domain, an implemenation
>     might give a small distance to the difference between the language
>     subtag 'no' (Norvegian) and the closely related language subtags
>     'nb' (Norvegian, Bookmal) or 'nn' (Norvegian, Newnorsk); or
>     between the script subtags 'Kata' (Katakana) and 'Hira' (Hiragana);
>     or between the region subtags 'US' (USA) and 'UM' (???).
> <<<<
> 
> Do we have a general policy for how to handle such cases?
> For example, there may be examples that are really just
> only about the mechanics of the tags, and others (like
> above) where the meaning of the tag is quite relevant to
> understand the example.
> 
> Regards,    Martin.
> 
> [I'm not sure we have done this persistently in the
> registry draft, but for that it is too late now, anyway.]
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 19 Nov 2005 21:01:46 +0100

Addison Phillips wrote:

> UM, by the way, is "United States Minor Outlying Islands"
> region.

Most of them uninhabited, unusable for laguage tags.  Even if
en-UM as spoken on Midway is different from en-US, then what
about en-UM as spoken on Wake Island ?

Baker      0 http://www.cia.gov/cia/publications/factbook/print/fq.html
Howland    0 http://www.cia.gov/cia/publications/factbook/print/hq.html
Johnston 361 http://www.cia.gov/cia/publications/factbook/print/jq.html
Kingman    0 http://www.cia.gov/cia/publications/factbook/print/kq.html
Midway    40 http://www.cia.gov/cia/publications/factbook/print/mq.html
Navassa    0 http://www.cia.gov/cia/publications/factbook/print/bq.html
Palmyra   12 http://www.cia.gov/cia/publications/factbook/print/lq.html
Wake     200 http://www.cia.gov/cia/publications/factbook/print/wq.html
         613
                            Bye, Frank