Subject: [Ltru] RE: Matching draft, section 8

From: "Addison Phillips" <[email-masked]>
Date: Tue, 29 Nov 2005 11:11:50 -0800

Good catch. I changed this section to say:

<t>Language tags permit only
the characters A-Z, a-z, 0-9, and HYPHEN-MINUS (%x2D). Language ranges also use the character ASTERISK (%x2A).  These characters are present in 
most character sets, so presentation or exchange of language tags or ranges should not present any 
character set issues.</t>

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]]
> Sent: 2005年11月28日 15:49
> To: Addison Phillips
> Cc: [email-masked]
> Subject: Matching draft, section 8
> 
> 
> <quote>
> 8. Character Set Considerations
> 
> The syntax of language tags and language ranges permit only the characters
> A-Z, a-z, 0-9, and HYPHEN-MINUS (%x2D). These characters are present in
> most character sets, so presentation of language tags should not present
> any character set issues.
> </quote>
> 
> Correction: The asterisk ('*') is also allowed in language ranges.  This
> is also present in most character sets, so there still should be no
> problem, but you need to mention this for completeness.
> 
> --
> Doug Ewell
> Opinions and views expressed in this text are not those of my employer.
> No affiliation with Bio-Rad Laboratories, Inc. is expressed or implied.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 29 Nov 2005 11:23:29 -0800

Hi Addison,

Presentation should not present?  How about changing to:

"These characters are present in most character sets, so 
presentation or exchange of language tags or ranges should 
not be constrained by character set issues."

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

---

From: "Addison Phillips" <[email-masked]>
Date: Tue, 29 Nov 2005 11:40:06 -0800

Sadly, that is one bit of the text I didn't change from draft-registry. Your version reads better and I'm making the change (unless someone objects).

Addison

Addison P. Phillips

> From: McDonald, Ira [mailto:[email-masked]]
> Sent: 2005年11月29日 11:23
> To: Addison Phillips; LTRU Working Group
> Cc: [email-masked]
> Subject: RE: [Ltru] RE: Matching draft, section 8
> 
> Hi Addison,
>