Subject: RE: [Ltru] Need more interesting distance metric (?) (was: Matching:choice of schemes)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 17 Nov 2005 08:44:58 -0800

There were (he says, racking his brains to remember) a couple of reasons for increasing the distances in the metric:

1. It allows for better custom tailoring (by creating the possibility for half-scores and the like). The theorized use of "q" weights in a language priority list to multiply the values works better with larger gaps between the values, at least on paper.

2. It helps deal with the fact that variants can have more than one subtag. You need four matching variant subtags to equal one region subtag.

But otherwise I don't really recall why the numbers were increased. My implementation isn't done, so I haven't had a chance to play with it much in depth.

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Frank Ellermann
> Sent: 2005年11月17日 5:25
> To: [email-masked]
> Subject: [Ltru] Need more interesting distance metric (?) (was:
> Matching:choice of schemes)
> 
> Harald Tveit Alvestrand wrote:
> 
> > I'll comment on -06 after publication.
> 
> Something with the "distance metric" is odd.  It was 8-4-2-1.
> That was the minimal metric having precisely the same effect
> as LTR (letf-to-right).
> 
> Now it's 256-128-32-4-1.  Beats me where that could be
> different from 16-8-4-2-1, which would be again the same as
> LTR, only over 5 positions.
> 
> For some interesting effect - plus a still missing example to
> explain it - we need w1-w2-w3-w4-w5 with a pair w(i)-w(i+1)
> where w(i) < 2*w(i+1).  With 2*w(i+1) <= w(i) everywhere it's
> always the same as LTR matching, or do I miss something ?
> 
>                        Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Fri, 18 Nov 2005 17:14:03 +0900

[chair hat off]

If we have a good idea of what 'distance metric' is useful for,
we should clearly indicate that. If we can explain what the
specific values are good for, we should also explain that,
because it will help implementers choose other values if
they need something different.

But if this thing gets too complicated, or too imprecise,
we should also seriously consider dropping it.

Regards,    Martin.

At 01:44 05/11/18, Addison Phillips wrote:
 >Content-class: urn:content-classes:message
 >Content-Type: text/plain;charset="UTF-8"
 >
 >There were (he says, racking his brains to remember) a couple of reasons
 >for increasing the distances in the metric:
 >
 >1. It allows for better custom tailoring (by creating the possibility for
 >half-scores and the like). The theorized use of "q" weights in a language
 >priority list to multiply the values works better with larger gaps between
 >the values, at least on paper.
 >
 >2. It helps deal with the fact that variants can have more than one subtag.
 >You need four matching variant subtags to equal one region subtag.
 >
 >But otherwise I don't really recall why the numbers were increased. My
 >implementation isn't done, so I haven't had a chance to play with it much
 >in depth.
 >
 >Addison
 >
 >Addison P. Phillips
 >> Sent: 2005$Bj;%((B11$Bk|/(B7$Bkw!&(B 5:25
 >> To: [email-masked]