Subject: RE: [Ltru] Re: New ISO 639 language identifier approved: SwissGerman; Alemanic

From: "Addison Phillips" <[email-masked]>
Date: Mon, 7 Nov 2005 15:26:25 -0800

We'd be better off with a long "Comments" field than with an unusual "Description". And, in my opinion, the "Comments" would properly belong on the 'gsw' subtag. 

Interestingly, the registration process allows for individuals to propose additions of this nature, if someone feels them necessary. A long-ish comment might even be justified to prevent future confusion. For example:

%%
Type: language
Subtag: gsw
Description: Alemanic
Description: Swiss German
Description: Schwyzerd&#xFC;tsch
Added: 2005-10-16
Suppress-Script: Latn
Comments: Although the description 'Swiss German' is suggestive,
  this language is not the same thing as tags of the form 
  "de-CH" and this subtag should not be used to indicate
  that particular regional variation of Standard German.
%%

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Erik van der Poel
> Sent: 2005年11月7日 14:15
> To: [email-masked]
> Cc: Misha Wolf; LTRU Working Group
> Subject: Re: [Ltru] Re: New ISO 639 language identifier approved:
> SwissGerman; Alemanic
> 
> I'm sorry that I brought up an old issue! I just joined ietf-languages.
> I agree with Karen that it would be a good idea to use the multiple
> description feature to point out the subtleties. Perhaps gsw should be
> mentioned in the entries for de, CH, de-CH-1901 and de-CH-1996. Or maybe
> a pointer (URI) to a document that briefly explains this stuff. E.g.
> 
> %%
> Type: language
> Subtag: de
> Description: German
> Description: see also
> http://www.iana.org/assignments/lang-tag-docs/swiss-german
> Added: 2005-10-16
> Suppress-Script: Latn
> %%
> 
> (and the same for CH, de-CH-1901, de-CH-1996 and gsw)
> 
> Erik
> 
> [email-masked] wrote:
> > There was discussion on the list that forced my registration of gsw. I
> > previously thought de-CH and de-AT applied to these Swiss and Austrian
> > dialects as well, and I'm sure this is not an uncommon belief.  It was
> > made clear that these tags applied to German and Austrian variants of
> > standard German, often combined with the tagging for the spelling
> > reforms, and did not apply to the primarily spoken dialects I was trying
> > to identify.
> >
> > I guess this case shows both the advantages and potential pitfalls of
> > RFC 3066bis and how tagging building blocks defined by RFC 3066bis could
> > be combined in an inaccurate ways by those who are unfamiliar with such
> > subtleties . Perhaps the multiple description feature in the registry
> > will help resolve some of these ambiguities -- it's not particularly
> > unreasonable to assume that de-CH defines "Swiss German."  If this tag
> > is added to the registry, I would also include the description
> > "Schwyzerdütsch." This is also the name used for this language in 639-3.
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: [email-masked]
Date: Mon, 7 Nov 2005 15:39:52 -0800

+1

If I have additional suggestions for comments such as these, I will submit 
them. (None come to mind at present, but I'll give it some thought based 
on what I've seen in my analysis of real-world application of these tags.) 
 I think the comments field is critical for exactly such cases. - Karen

"Addison Phillips" <[email-masked]>
11/07/2005 03:26 PM

        To:     "Erik van der Poel" <[email-masked]>, <[email-masked]>
        cc:     "Misha Wolf" <[email-masked]>, "LTRU Working Group" 
<[email-masked]>
        Subject:        RE: [Ltru] Re: New ISO 639 language identifier approved: SwissGerman; 
Alemanic

We'd be better off with a long "Comments" field than with an unusual 
"Description". And, in my opinion, the "Comments" would properly belong on 
the 'gsw' subtag. 

Interestingly, the registration process allows for individuals to propose 
additions of this nature, if someone feels them necessary. A long-ish 
comment might even be justified to prevent future confusion. For example:

%%
Type: language
Subtag: gsw
Description: Alemanic

Best Regards,

Addison

Addison P. Phillips