Subject: [Ltru] scored filtering demo...

From: "Addison Phillips" <[email-masked]>
Date: Fri, 18 Nov 2005 16:22:13 -0800

There is a demo page for scored filtering on my website based on my little Java implementation of the Scored Filtering in draft-06.

http://www.inter-locale.com/langtags/index.jsp

The demo has one quirk: grandfathered tags are not parsed properly, so "en-boont" produces funny scores (it doesn't match the range 'en', for example).

There is a canned list of language tags that the range you enter is compared to. There may be bugs as yet.

Based on some light experimentation, we may wish to change aspects of the algorithm (especially expansion of fields in either ranges or tags to the wildcard). 

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 20 Nov 2005 15:18:49 +0100

--On fredag, november 18, 2005 16:22:13 -0800 Addison Phillips 
<[email-masked]> wrote:

> There is a demo page for scored filtering on my website based on my
> little Java implementation of the Scored Filtering in draft-06.
>
> The demo has one quirk: grandfathered tags are not parsed properly, so
> "en-boont" produces funny scores (it doesn't match the range 'en', for
> example).
>
> Based on some light experimentation, we may wish to change aspects of the
> algorithm (especially expansion of fields in either ranges or tags to the
> wildcard).

hmm... very interesting!

de-CH gives zero distance to de, de-CH and de-Latn in the first variant, 
zero distance to de-CH and de-Latn-CH-1901 in the second variant, and de-CH 
only in the third variant.

It wasn't clear to me what the difference between the 3 variants was...