Subject: RE: [Ltru] Too many ABNF issues (was: Proposal for -matching: "sc oredfiltering" > "scoring")

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 22 Feb 2006 08:24:33 -0800

Hi Addison,

With respect, 'extlang' is there as an attempt at future-proofing
that we're not yet using.  In a protocol spec, it would have been
summarily removed during 'last call'.

It should now be obvious that RFC3066ter will take _years_ to
wander through the smelly swamp of the "fast" IETF process.

I maintain that 'extlang' was and is a mistake, at present.

One ounce of effort in matching algorithms for 'extlang' is too
much.

Please remove "Scoring" entirely - some hardy soul with a very
thick skin can write it up some future RFC.

We _really_ need closure, so that RFC3066bis can be published
one of these years - mere mortals don't get fast turnaround in
the RFC Editor queue these days.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 11:14 AM
> To: 'McDonald, Ira'; 'John Cowan'
> Cc: 'Frank Ellermann'; [email-masked]
> Subject: RE: [Ltru] Too many ABNF issues (was: Proposal for -matching:
> "scoredfiltering" > "scoring")
> 
> 
> > (2) Delete 'extlang' - it's a fuzzy-minded mistake that 
> keeps breaking
> >     matching approaches.
> 
> We can't delete 'extlang'. It is inherent in 3066bis. 
> Currently no subtags
> are permitted in tags, but there is a strong idea that this 
> is where certain
> subtags will go in the future.
> 
> Matching doesn't have, strictly speaking, to deal with it now, but any
> syntax we write for matching should take the full structure 
> of language tags
> into account.
> 
> I actually am thinking that some of us may have been wrong in 
> yesterday's
> thread: extlangs should stay "attached" to their primary 
> language subtag (I
> suspect that "zh-cmn" and "zh-cms" will be atomic units 
> rather than two
> separate things). If so, the original scoring quintuple 
> breakdown would be
> correct and some simplicity could be achieved (it's why we 
> did that in the
> first place I think). 
> 
> Oh, and extlangs do not break basic or extended filtering 
> where they exist
> as mere subtags. Try it and see.
> 
> > (3) Please do NOT introduce ANY negation anywhere.
> 
> Negation is necessary for a syntax in which every field must 
> be filled with
> some value: the wildcard star is greedy and sucks up the tags 
> the user does
> not want. My "fix" for extended filtering avoids this by 
> avoiding negation
> (and matching rather more tags than it might otherwise 
> match), but scoring
> cannot avoid it.
> 
> Addison
> 
> Addison Phillips
> Internationalization Architect - Yahoo! Inc.
> 
> Internationalization is an architecture.
> It is not a feature. 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 22 Feb 2006 11:50:07 -0500

> wander through the smelly swamp of the "fast" IETF process.

Perhaps so, but I think a lot of that time was spent mastering
process issues, and there are now enough people who understand them.
3066bis was the really big change; ter is a patch.

> One ounce of effort in matching algorithms for 'extlang' is too

+1

> thick skin can write it up some future RFC.

+1

> the RFC Editor queue these days.

+15

-- 
Barry gules and argent of seven and six,        John Cowan
on a canton azure fifty molets of the second.   [email-masked]
        --blazoning the U.S. flag               http://www.ccil.org/~cowan

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 22 Feb 2006 09:43:02 -0800

I removed scoring in my draft-10-var1 copy yesterday. If the chairs decide
that there is consensus on the removal of scoring, that version of the
matching draft can go forward. I personally favor that path forward. I take
it you concur?!?

> summarily removed during 'last call'.

With respect, you're all wet :-). While 3066ter might never happen, the
grammar of language tags is set in stone as of 3066bis. Reasonable limits
were set there on extended language subtags. Although some might that it
would have been better to limit them to just *one* such subtag (and a
3066ter might make such a limit), the fact is we did NOT do so. Matching
schemes must take extlangs into account if they are affected by them (basic
and extended filtering, as we've written them currently, are not affected;
lookup might conceivably be if extlangs are "atomic" with their primary
language tags; scoring or expression-based syntaxes are deeply affected and
this morning might be on the scrap heap as a result).

Protocols often reserve space for future extension or expansion. 3066bis is
no different. What was done was done responsibly and it is my hope that
3066ter will go more smoothly as a (relatively) simple addition of some
subtags and cleanup. Heck, it might only take a couple of years.

> I maintain that 'extlang' was and is a mistake, at present.

At some point rough consensus carries the day and we live and learn. Overall
I'm happy with 3066bis (I have one or another regret, but I'll be damned if
I'm going to bring them up now) and I'm darned tired of rehashing what we
might have done. We did what we did. Can we work on matching now? :-)
> One ounce of effort in matching algorithms for 'extlang' is too

If matching algorithms break when extlangs are introduced, we will have
served the community ill. Since, for the most part, we don't have any such
problem (with scoring removed) we can move along.

> the RFC Editor queue these days.

The RFC Editor queue is a moot point--we are in the 3066bis era *now*--but I
agree that it would be *very* nice to get the document published
once-and-for-all (ease of reference, if nothing else). OTOH, it is my
observation that we "go faster" when we concentrate on doing the right thing
in favor of supporting whatever text happens to be in the current draft.
Fewer sour grapes that way too.

Addison

Addison Phillips

---

From: Mark Davis <[email-masked]>
Date: Wed, 22 Feb 2006 11:21:01 -0800

It seems like we are in rough consensus on removing scored filtering.

I disagree on extlang, and it's too late now anyway. So let's not deep 
end on that.

Mark