Subject: RE: [Ltru] Too many ABNF issues (was: Proposal for -matching: "sc oredfiltering" > "scoring")

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 23 Feb 2006 08:30:26 -0800

Hi Felix,

Actually, the "BCP47" reference is no help at all.  The RFC
Editor publishes the 'bcp-index.txt' file which is simply
a list of RFCs in each BCP.  Until RFC3066bis is published
as an RFC, it's dead as a reference for many/most other
responsible public standards organizations.

The regular extreme delay in the RFC queue and IANA issues
for publishing an RFC is becoming a very serious problem
for standards organizations that want to reference IETF
standards or best practices documents.

Cheers,
- Ira

PS - And Frank Ellerman is right to observe that the m-to-n
mapping from RFC to BCP is flaky, because even the number
of documents keeps changing for some BCPs.

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Felix Sasaki [mailto:[email-masked]]
> Sent: Thursday, February 23, 2006 1:13 AM
> To: McDonald, Ira
> Cc: 'Addison Phillips'; 'John Cowan'; 'Frank Ellermann';
> [email-masked]
> Subject: Re: [Ltru] Too many ABNF issues (was: Proposal for -matching:
> "sc oredfiltering" > "scoring")
> 
> 
> McDonald, Ira wrote:
> >> -----Original Message-----
> >> From: Addison Phillips [mailto:[email-masked]]
> >>
> >> (snip)
> >>
> >>> We _really_ need closure, so that RFC3066bis can be published
> >>> one of these years - mere mortals don't get fast turnaround in
> >>> the RFC Editor queue these days.
> >> The RFC Editor queue is a moot point--we are in the 3066bis 
> >> era *now*--but I
> >> agree that it would be *very* nice to get the document published
> >> once-and-for-all (ease of reference, if nothing else). 
> OTOH, it is my
> >> observation that we "go faster" when we concentrate on doing 
> >> the right thing
> >> in favor of supporting whatever text happens to be in the 
> >> current draft.
> >> Fewer sour grapes that way too.
> > 
> > No, we are NOT in the RFC3066bis era now, even if the IANA Subtag
> > Registry was apparently functioning.  
> > 
> > I can't speak for W3C policies and procedures.
> 
> I am working in the W3C Internationalization Activity, where we have
> recommended in the past to other working groups the usage of
> formulations like "RFC 3066 or its successor", if they want to cite an
> RFC for language tags. Based on Addisons input we have 
> started proposing
> [BCP 47] instead, to avoid the reference to the "3066" number. (With
> [BCP 47], no specs have to be updated.)
> Unfortunately, the willingness to follow the new proposal 
> depends on the
> working group we are approaching. It will be *much easier* as the
> matching draft is done ...
> 
> Regards,
> 
> Feli
> 
> > 
> > But I can authoritatively say that FSG (Free Standards Group)
> > and IEEE-ISTO PWG (Printer Working Groups) standards CANNOT
> > normatively reference unpublished RFCs, even if IESG-approved.
> > I know this from repeated personal experience in those bodies.
> > 
> > We need this RFC to published.
> > 
> > Cheers,
> > - Ira
> > 
> > Ira McDonald (Musician / Software Architect)
> > Blue Roof Music / High North Inc
> > PO Box 221  Grand Marais, MI  49839
> > phone: +1-906-494-2434
> > email: [email-masked]
> > 
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 23 Feb 2006 12:32:05 -0500

> responsible public standards organizations.

True, but at least without a baked-in RFC number the reference
will eventually be updated.  I know of at least one widely
used specification which still references RFC 1766.

> standards or best practices documents.

+1

-- 
Not to perambulate                 John Cowan <[email-masked]>    
    the corridors                  http://www.ap.org
during the hours of repose         http://www.ccil.org/~cowan
    in the boots of ascension.       --Sign in Austrian ski-resort hotel