Subject: RE: [Ltru] Re: non-terminal names

From: "Kent Karlsson" <[email-masked]>
Date: Thu, 9 Feb 2006 22:35:20 +0100 (CET)

Addison Phillips wrote:
> I dislike the basic assertion that we should use different
> non-terminals. I
> think it is *more* confusing to have a production for a tag

Surely not. Would you have said the same if the two had been
in the same document, rather than in two documents?

> and then, when
> choosing my range to select that tag, a differently named
> sub-entity. Adding
> "-pat" doesn't add anything in my opinion.

It's a systematic name change.

> When selecting an extended language range to do some matching
> operation, I
> think it is useful to know that the "language" production selects the
> "language" part of a language tag and the "script" production
> select the
> script part (und so weite). Admittedly, this is a
> preferential thing, and it
> seems I'm in the minority on this.

You are welcome to change your mind!

> > I think that the current (v. -09) -matching production
> >
> > extension = singleton *("-" (2*8alphanum)) [ "-*" ]
> >
> > is wrong. It allows a singleton *alone* (no dash and second
> > component at all), which I don't think was intended. See the
> > last productions below for a correction.
>
> You have a good point. More later.
>
> > extlang-pat   = *2("-" 3ALPHA) "-*"    ; reserved for future use
> >                                        ; wildcard can only appear
> >                                        ;   at the end
>
> Nope.

Nope on that nope. It should be as I wrote. See below.

> This production would require a trailing -* and disallows the
> (remotely possible) 3-subtag extlang sequence. The current
> (more correct
> IMO) production is:
>
> extlang       = *2("-" 3ALPHA) ("-" ( 3ALPHA / "*"))
>                                        ; reserved for future use
>                                        ; wildcard can only appear
>                                        ;   at the end

The case you want to cover here is covered by the production:
language-pat  = language
(which was in the message I sent).

> As noted in previous threads, there is a bit of subtlety
> (which may be lost
> on readers) here. If you choose to include an extlang
> sequence at all, it
> will contain at least one subtag (... or you will have
> omitted the extlang
> sequence). The back half of the production covers this. The
> front half of
> the production (*2 etc.) covers any additional subtags as needed.
>
> > extension-pat = singleton 1*("-" (2*8alphanum))
> >               / singleton *("-" (2*8alphanum)) "-*"
>
> You're correct about the meaning of the current ABNF, but I
> think we need to

"think" -> "don't think"?

> be quite as redundant. I would suggest:
>
>    extension = singleton *("-" ext-subtag) ("-" (ext-subtag / "*"))
>    ext-subtag = 2*8alphanum

Matter of taste. I like Frank's rewrite better.

> This uses the same subtlety as the extlang, allowing us to
> explain it in the
> text only once and keeping the number of different issues to
> a minimum. In
> particular, I would suggest adding this text immediately
> following the ABNF:
>
> ---
> Some subtag types, such as extlang, variant, privateuse, and
> extension,
> allow more than one subtag when forming a language tag.
> Extended language
> ranges permit the wildcard subtag "-*" only at the end of
> such a sequence in
> order to simplify matching implementations. Thus, if "EXA"
> and "EXB" were
> extended language subtags, the range "qx-EXA-EXB-*" would be
> legal, while
> the range "qx-EXA-*-EXB" would not be. This is a subtlety in
> the ABNF which
> might not be immediately obvious.
> ---

I don't think that text is needed.

	/kent k

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 9 Feb 2006 21:29:07 -0800

Martin Duerst <duerst at it dot aoyama dot ac dot jp> wrote:

> Others, please state your preferences so that we can move
> forward on this point.

I explicitly state no opinion as to the names.

The final ABNF must (a) pass all relevant validators and (b) exactly 
reflect the intent of the prose.  If it meets those requirements, I am 
fine with it.

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/

---

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 10 Feb 2006 10:09:52 -0800

+1

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Martin Duerst
> Sent: Thursday, February 09, 2006 10:02 PM
> To: Harald Tveit Alvestrand; Addison Phillips; 'Kent Karlsson';
> [email-masked]
> Subject: RE: [Ltru] Re: non-terminal names
> 
> 
> At 04:52 06/02/10, Harald Tveit Alvestrand wrote:
>  >
>  >
>  >--On 9. februar 2006 10:34 -0800 Addison Phillips 
> <[email-masked]> wrote:
>  >
>  >> I dislike the basic assertion that we should use 
> different non-terminals.
>  >> I think it is *more* confusing to have a production for a 
> tag and then,
>  >> when choosing my range to select that tag, a differently named
>  >> sub-entity. Adding "-pat" doesn't add anything in my opinion.
>  >
>  >I prefer the "-pat" pattern; using one production for "the 
> thing" and 
> another production for "either the thing or a wildcard" seems 
> like a clean 
> way to name things for me.
> 
> I have to say that I agree with Harald (and Kent) here.
> 
> Regards,     Martin.