Subject: [Ltru] RE: [newsml-2] japanese scripts (was: person/name given and family elements)

From: Misha Wolf <[email-masked]>
Date: Fri, 10 Feb 2006 19:05:02 +0000

Unfortunately, this page:
    http://www.iana.org/numbers.html#L
says:
    "No further registrations in this registry."
in relation to the RFC 3066 language tags registry.
 
I suppose that if the IETF takes much longer to move RFC 3066 bis to RFC status, we may have to lobby for the RFC 3066 registry to be re-opened.  We're now stuck between one system which has closed and another which has not yet opened.
 
Misha

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rob Warner
Sent: 10 February 2006 18:53
To: [email-masked]
Subject: Re: [newsml-2] japanese scripts (was: person/name given and family elements)

It's worth noting that the XML 1.0 specification does explicitly allow for values in a form defined by RFC 3066's successor to be used in xml:lang attributes: http://www.w3.org/TR/2004/REC-xml-20040204/#sec-lang-tag

The danger of course is that existing consumers may not fully understand the new syntax.  Since there are really no NewsML 2 consumers yet, that's probably not an issue for us. 

If RFC 3066 bis is too far in the future, we might look at registering jp-Hani & friends, the same way zh-Hans & zh-Hant were done.

cheers,

Rob

On 10/02/06, Misha Wolf <[email-masked]> wrote: 

	Yes.  I imagine that the new RFC will be approved before NewsML 2 is finalised.
	 
	Misha

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Laurent Le Meur
	Sent: 10 February 2006 17:37
	To: [email-masked]
	Cc: [email-masked] 
	
	Subject: RE: [newsml-2] japanese scripts (was: person/name given and family elements)

	Therefore your proposal is to explicitly and provisionally allow for xml:lang="jp-Hani", isn't it? 

	Laurent 

________________________________

	De : [email-masked] [mailto: [email-masked] <mailto:[email-masked]> ] De la part de Misha Wolf
	Envoyé : vendredi 10 février 2006 18:21
	À : [email-masked]
	Cc : [email-masked]
	Objet : RE: [newsml-2] japanese scripts (was: person/name given and family elements)

	It would be a bad idea to introduce a "script" attribute now, just before draft-ietf-ltru-registry [1] becomes an RFC, replacing RFC 3066.

	[1] http://ietfreport.isoc.org/idref/draft-ietf-ltru-registry/ 

	Misha

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Laurent Le Meur
	Sent: 10 February 2006 11:33
	To: [email-masked]
	Subject: RE: [newsml-2] japanese scripts (was: person/name given and family elements)

	Takahiro, 

	The xml:lang attribute can take values indicating a script: it is the case for zh-Hans and zh-Hant (Traditional vs. Simplified Chinese), isn't it?

	I see that it is not currently used for Japanese scripts (kanji, katagana, hiragana).

	I spotted:

	http://www.w3.org/International/articles/language-tags/ 

	" There is a need, sometimes, to distinguish the script used, in addition to the language. For example, Mongolian might be written in Mongolian script or Cyrillic; Croatian might be written in Latin or Cyrillic; ..."

	Then http://www.inter-locale.com/ID/draft-ietf-ltru-registry-13.html#script 

	"Script subtags are used to indicate the script or writing system variations that distinguish the written forms of a language or its dialects. The following rules apply to the script subtags: "

	Then http://www.unicode.org/iso15924/iso15924-codes.html 

	And found the tokens found in HR-ML samples 

	- Hani (for Kanji)

	- Kana (Katakana)

	- Hrkt (alias for Hiragana + Katakana)

	My question: Can't we already express script with xml:lang="jp-Hani" ?

	(I imagine that it would not be RFC3066 compliant any more).

	If not, should we then create a specific attribute, as a sibling of xml:lang, in all elements supporting strings, that will be deprecated when the replacement of RFC3066 is standardized? If so, why are we the only group looking at this problem?

	Laurent 

________________________________

	De : [email-masked] [mailto: [email-masked] <mailto:[email-masked]> ] De la part de Takahiro FUJIWARA
	Envoyé : lundi 16 janvier 2006 01:20
	À : [email-masked]
	Objet : Re: [newsml-2] FW: person/name given and family elements

	I would explain from the view of Japanese people.

	> With Japanese comes another factor: two scripts for one language.

	Yes! this is the thing what I want to say.

	   We always need two scripts in the application form such as resident registration, curriculum vitae(résumé), application form when the online shopping...

	   One is for the formal printable name.  The other one is for the pronunciation.  There is many ways to write a pronunciation such as Hiragana, Katakana, multiple-romanisations.  But there is needed only one pronunciation in one application form because we can convert to another.  This pronunciation is also used for the name list with order by pronunciation.  Japanese people do not use order by Alphabetical nor order by Kanji.

	Takahiro Fujiwara

________________________________

	-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 

	This e-mail, and any file transmitted with it, is confidential and intended solely for the use of the individ ual or entity to whom it is addressed. If you have received this email in error, please contact the sende r and delete the email from your system. If you are not the named addressee you should not disseminate, distr ibute or copy this email. 
	
	For more information on Agence France-Presse, please visit our web site at http://www.afp.com 

	-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 

	
	To find out more about Reuters visit www.about.reuters.com
	
	Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

	-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 

	This e-mail, and any file transmitted with it, is confidential and intended solely for the use of the individ ual or entity to whom it is addressed. If you have received this email in error, please contact the sende r and delete the email from your system. If you are not the named addressee you should not disseminate, distr ibute or copy this email. 
	
	For more information on Agence France-Presse, please visit our web site at http://www.afp.com 
	
	-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 

	
	To find out more about Reuters visit www.about.reuters.com
	
	Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

	SPONSORED LINKS 
Computer security <http://groups.yahoo.com/gads?t=ms&k=Computer+security&w1=Computer+security&w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=NXlGxZwPdSovwYGB_QxPfg>  	Large format <http://groups.yahoo.com/gads?t=ms&k=Large+format&w1=Computer+security&w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=Xgv39LCLBufY68C7Cn591Q>  	Computer training <http://groups.yahoo.com/gads?t=ms&k=Computer+training&w1=Computer+security&w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=AITXDmxE-xPOb2PMRGopaA>  	
Cover letter formats <http://groups.yahoo.com/gads?t=ms&k=Cover+letter+formats&w1=Computer+security&w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=hdKoTXIuKmdrxQCTebJkRA>  	

________________________________

	YAHOO! GROUPS LINKS 

	*	 Visit your group "newsml-2 <http://groups.yahoo.com/group/newsml-2> " on the web.
		  
	*	 To unsubscribe from this group, send an email to:
		  [email-masked] <mailto:[email-masked]?subject=Unsubscribe> 
		  
	*	 Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service <http://docs.yahoo.com/info/terms/>  . 

________________________________

SPONSORED LINKS 
Computer training <http://groups.yahoo.com/gads?t=ms&k=Computer+training&w1=Computer+training&w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=wNk3N1pL6jKj7rQtAo6_Bg>  	Computer security <http://groups.yahoo.com/gads?t=ms&k=Computer+security&w1=Computer+training&w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=P4cBpLcQ_APNQBncv4s5Kw>  	Large format <http://groups.yahoo.com/gads?t=ms&k=Large+format&w1=Computer+training&w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=qTXrDc3eP0NoTfnkNtPBHQ>  	
Cover letter formats <http://groups.yahoo.com/gads?t=ms&k=Cover+letter+formats&w1=Computer+training&w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=9SdRM48GwBoPiwisRRoRAg>  	

________________________________

YAHOO! GROUPS LINKS 

*	 Visit your group "newsml-2 <http://groups.yahoo.com/group/newsml-2> " on the web.
	  
*	 To unsubscribe from this group, send an email to:
	 [email-masked] <mailto:[email-masked]?subject=Unsubscribe> 
	  
*	 Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service <http://docs.yahoo.com/info/terms/> . 

________________________________

To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Fri, 10 Feb 2006 11:17:56 -0800

Just because 3066bis is not published with an RFC number yet doesn’t mean
that it isn’t BCP 47, does it? That isn’t how the process was presented to
me. I’ve been told repeatedly that once the RFC-to-be has passed through the
process to IESG approval, we’re done. (And the appearance of the new
registry is evidence of this.) If you need a subtag, submit a 3066bis
request and let’s testdrive the system…

Addison

Addison Phillips
Internationalization Architect - Yahoo! Inc.

Internationalization is an architecture.
It is not a feature. 

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Misha Wolf
Sent: Friday, February 10, 2006 11:05 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ltru] RE: [newsml-2] japanese scripts (was: person/name given and
family elements)

says:

I suppose that if the IETF takes much longer to move RFC 3066 bis to RFC
status, we may have to lobby for the RFC 3066 registry to be re-opened.
We're now stuck between one system which has closed and another which has
not yet opened.

Misha

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rob Warner
Sent: 10 February 2006 18:53
To: [email-masked]
Subject: Re: [newsml-2] japanese scripts (was: person/name given and family
elements)

It's worth noting that the XML 1.0 specification does explicitly allow for
values in a form defined by RFC 3066's successor to be used in xml:lang
attributes: http://www.w3.org/TR/2004/REC-xml-20040204/#sec-lang-tag

The danger of course is that existing consumers may not fully understand the
new syntax.  Since there are really no NewsML 2 consumers yet, that's
probably not an issue for us. 

If RFC 3066 bis is too far in the future, we might look at registering
jp-Hani & friends, the same way zh-Hans & zh-Hant were done.

cheers,

Rob

Yes.  I imagine that the new RFC will be approved before NewsML 2 is
finalised.

Misha

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Laurent Le Meur
Sent: 10 February 2006 17:37
To: [email-masked]
Cc: [email-masked] 

Subject: RE: [newsml-2] japanese scripts (was: person/name given and family
elements)

Therefore your proposal is to explicitly and provisionally allow for
xml:lang="jp-Hani", isn't it? 

Laurent 

  _____  

De : [email-masked] [mailto: <mailto:[email-masked]>
[email-masked]] De la part de Misha Wolf
Envoyé : vendredi 10 février 2006 18:21
À : [email-masked]
Cc : [email-masked]
Objet : RE: [newsml-2] japanese scripts (was: person/name given and family
elements)

It would be a bad idea to introduce a "script" attribute now, just before
draft-ietf-ltru-registry [1] becomes an RFC, replacing RFC 3066.

Misha

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Laurent Le Meur
Sent: 10 February 2006 11:33
To: [email-masked]
Subject: RE: [newsml-2] japanese scripts (was: person/name given and family
elements)

Takahiro, 

The xml:lang attribute can take values indicating a script: it is the case
for zh-Hans and zh-Hant (Traditional vs. Simplified Chinese), isn't it?

I see that it is not currently used for Japanese scripts (kanji, katagana,
hiragana).

I spotted:

" There is a need, sometimes, to distinguish the script used, in addition to
the language. For example, Mongolian might be written in Mongolian script or
Cyrillic; Croatian might be written in Latin or Cyrillic; ..."

"Script subtags are used to indicate the script or writing system variations
that distinguish the written forms of a language or its dialects. The
following rules apply to the script subtags: "

- Hani (for Kanji)

- Kana (Katakana)

If not, should we then create a specific attribute, as a sibling of
xml:lang, in all elements supporting strings, that will be deprecated when
the replacement of RFC3066 is standardized? If so, why are we the only group
looking at this problem?

Laurent 

  _____  

De : [email-masked] [mailto: [email-masked]
<mailto:[email-masked]> ] De la part de Takahiro FUJIWARA
Envoyé : lundi 16 janvier 2006 01:20
À : [email-masked]
Objet : Re: [newsml-2] FW: person/name given and family elements

   We always need two scripts in the application form such as resident
registration, curriculum vitae(résumé), application form when the online
shopping...

   One is for the formal printable name.  The other one is for the
pronunciation.  There is many ways to write a pronunciation such as
Hiragana, Katakana, multiple-romanisations.  But there is needed only one
pronunciation in one application form because we can convert to another.
This pronunciation is also used for the name list with order by
pronunciation.  Japanese people do not use order by Alphabetical nor order
by Kanji.

Takahiro Fujiwara

  _____  

This e-mail, and any file transmitted with it, is confidential and intended
solely for the use of the individ ual or entity to whom it is addressed. If
you have received this email in error, please contact the sende r and delete
the email from your system. If you are not the named addressee you should
not disseminate, distr ibute or copy this email. 

For more information on Agence France-Presse, please visit our web site at
http://www.afp.com 

Any views expressed in this message are those of the individual sender,
except where the sender specifically states them to be the views of Reuters
Ltd.

This e-mail, and any file transmitted with it, is confidential and intended
solely for the use of the individ ual or entity to whom it is addressed. If
you have received this email in error, please contact the sende r and delete
the email from your system. If you are not the named addressee you should
not disseminate, distr ibute or copy this email. 

For more information on Agence France-Presse, please visit our web site at
http://www.afp.com 

Any views expressed in this message are those of the individual sender,
except where the sender specifically states them to be the views of Reuters
Ltd.

SPONSORED LINKS 

Computer security
<http://groups.yahoo.com/gads?t=ms&k=Computer+security&w1=Computer+security&
w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=N
XlGxZwPdSovwYGB_QxPfg>  

Large format
<http://groups.yahoo.com/gads?t=ms&k=Large+format&w1=Computer+security&w2=La
rge+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=Xgv39L
CLBufY68C7Cn591Q>  

Computer training
<http://groups.yahoo.com/gads?t=ms&k=Computer+training&w1=Computer+security&
w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.sig=A
ITXDmxE-xPOb2PMRGopaA>  

Cover letter formats
<http://groups.yahoo.com/gads?t=ms&k=Cover+letter+formats&w1=Computer+securi
ty&w2=Large+format&w3=Computer+training&w4=Cover+letter+formats&c=4&s=90&.si
g=hdKoTXIuKmdrxQCTebJkRA>  

  _____  

YAHOO! GROUPS LINKS 

*	 Visit your group "newsml-2 <http://groups.yahoo.com/group/newsml-2>
" on the web.
  
*	 To unsubscribe from this group, send an email to:
  [email-masked]
<mailto:[email-masked]?subject=Unsubscribe> 
  
*	 Your use of Yahoo! Groups is subject to the Yahoo! Terms
<http://docs.yahoo.com/info/terms/>  of Service . 

  _____  

SPONSORED LINKS 

Computer
<http://groups.yahoo.com/gads?t=ms&k=Computer+training&w1=Computer+training&
w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=w
Nk3N1pL6jKj7rQtAo6_Bg>  training 

Computer
<http://groups.yahoo.com/gads?t=ms&k=Computer+security&w1=Computer+training&
w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=P
4cBpLcQ_APNQBncv4s5Kw>  security 

Large
<http://groups.yahoo.com/gads?t=ms&k=Large+format&w1=Computer+training&w2=Co
mputer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.sig=qTXrDc
3eP0NoTfnkNtPBHQ>  format 

Cover
<http://groups.yahoo.com/gads?t=ms&k=Cover+letter+formats&w1=Computer+traini
ng&w2=Computer+security&w3=Large+format&w4=Cover+letter+formats&c=4&s=90&.si
g=9SdRM48GwBoPiwisRRoRAg>  letter formats 

  _____  

YAHOO! GROUPS LINKS 

*	 Visit your group "newsml-2 <http://groups.yahoo.com/group/newsml-2>
" on the web.
  
*	 To unsubscribe from this group, send an email to:
 [email-masked]
<mailto:[email-masked]?subject=Unsubscribe> 
  
*	 Your use of Yahoo! Groups is subject to the Yahoo!
<http://docs.yahoo.com/info/terms/>  Terms of Service. 

  _____  

Any views expressed in this message are those of the individual sender,
except where the sender specifically states them to be the views of Reuters
Ltd.