Subject: RE: [Ltru] Too many ABNF issues (was: Proposal for -matching: "sc oredfiltering" > "scoring")

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 22 Feb 2006 07:16:50 -0800

Hi,

OK - my two cents:

(1) Delete "Scoring" entirely - it may never be ready for prime time,
    but it's sure not now.

(2) Delete 'extlang' - it's a fuzzy-minded mistake that keeps breaking
    matching approaches.

(3) Please do NOT introduce ANY negation anywhere.

Cheers,
- Ira

PS - I know 'extlang' is in the Registry draft, but I don't care - it's
just a lousy idea.

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 12:16 AM
> To: 'John Cowan'
> Cc: 'Frank Ellermann'; [email-masked]
> Subject: RE: [Ltru] Too many ABNF issues (was: Proposal for -matching:
> "scoredfiltering" > "scoring")
> 
> 
> Yes, the !s are grotesque. But once you open the world to 
> negation of any
> kind you're stuck with (some form of) them. Interior 
> wildcards introduce all
> manner of problem if we don't consider them and extlangs make 
> a mess of an
> otherwise neatly ordered world.
> 
> I think it wise to not document algorithms we don't actually 
> need. It would
> be nice to include text inviting individual contributions as 
> necessary. In
> the meantime, consider the "-var1" text.
> 
> Addison
> 
> Addison Phillips
> Internationalization Architect - Yahoo! Inc.
> 
> Internationalization is an architecture.
> It is not a feature. 
> > -----Original Message-----
> > From: John Cowan [mailto:[email-masked]]
> > Sent: Tuesday, February 21, 2006 8:53 PM
> > To: Addison Phillips
> > Cc: 'Frank Ellermann'; [email-masked]
> > Subject: Re: [Ltru] Too many ABNF issues (was: Proposal for 
> -matching:
> > "scoredfiltering" > "scoring")
> > 
> > Addison Phillips scripsit:
> > 
> > > Only scoring depends to any great depth on well-formed 
> ranges. Perhaps I
> > am
> > > trying to do too much with the scoring algorithm, tho'.
> > 
> > I think these !s are grotesque, and I agree with Frank that 
> in order to
> > handle extlang subtags properly, you need to do things like 
> ar-!-!-! to
> > specify just ar with no extlang subtags.  Which is bletcherous.
> > 
> > Let's call the whole thing off.
> > 
> > --
> > Kill Gorgûn!  Kill orc-folk!            John Cowan
> > No other words please Wild Men.         [email-masked]
> > Drive away bad air and darkness         http://www.ap.org
> > with brig ht iron!  --Ghân-buri-Ghân    http://www.ccil.org/~cowan
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 22 Feb 2006 08:14:16 -0800

> (2) Delete 'extlang' - it's a fuzzy-minded mistake that keeps breaking

We can't delete 'extlang'. It is inherent in 3066bis. Currently no subtags
are permitted in tags, but there is a strong idea that this is where certain
subtags will go in the future.

Matching doesn't have, strictly speaking, to deal with it now, but any
syntax we write for matching should take the full structure of language tags
into account.

I actually am thinking that some of us may have been wrong in yesterday's
thread: extlangs should stay "attached" to their primary language subtag (I
suspect that "zh-cmn" and "zh-cms" will be atomic units rather than two
separate things). If so, the original scoring quintuple breakdown would be
correct and some simplicity could be achieved (it's why we did that in the
first place I think). 

Oh, and extlangs do not break basic or extended filtering where they exist
as mere subtags. Try it and see.

> (3) Please do NOT introduce ANY negation anywhere.

Negation is necessary for a syntax in which every field must be filled with
some value: the wildcard star is greedy and sucks up the tags the user does
not want. My "fix" for extended filtering avoids this by avoiding negation
(and matching rather more tags than it might otherwise match), but scoring
cannot avoid it.

Addison

Addison Phillips

---

From: John Cowan <[email-masked]>
Date: Wed, 22 Feb 2006 11:45:06 -0500

> (1) Delete "Scoring" entirely - it may never be ready for prime time,

+1

> (2) Delete 'extlang' - it's a fuzzy-minded mistake that keeps breaking

-1

> (3) Please do NOT introduce ANY negation anywhere.

+1

-- 
Go, and never darken my towels again!           John Cowan
        --Rufus T. Firefly                      www.ccil.org/~cowan

---

From: John Cowan <[email-masked]>
Date: Wed, 22 Feb 2006 11:47:39 -0500

Addison Phillips scripsit:

> separate things). 

True, and fair enough, but "zh" and "zh-cmn" will also be treated as distinct.
But if scoring dies in the arse, as it deserves to, then there is no
further issue.

-- 
John Cowan      [email-masked]        http://www.ap.org
        "Not to know The Smiths is not to know K.X.U."  --K.X.U.

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 22 Feb 2006 19:46:42 +0100

Addison Phillips wrote:
 
> We can't delete 'extlang'. It is inherent in 3066bis.

ACK, unfortunately complicating parts of the matching.

The draft should note that "straight forward solutions"
are difficult with these beasts.

> I actually am thinking that some of us may have been
> wrong in yesterday's thread: extlangs should stay 
> "attached" to their primary language subtag (I suspect
> that "zh-cmn" and "zh-cms" will be atomic units rather
> than two separate things).

True, but one of your design goals was "it works without
knowing the registry".  We have no syntactical indication
that zh never comes alone, or that zh-cmn is complete, no
unspecified second extlang.
                           Bye, Frank

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 22 Feb 2006 11:07:02 -0800

> unspecified second extlang.

Each matching scheme should have the potential of separate design goals. The
goal of not having registry knowledge is a good one that can be abandoned if
the scheme requires it, but that isn't the case for any of the remaining
three algorithms.

The filtering schemes are just fine. For lookup, the difference would be in
how subtags are removed during fallback. That is "zh-cmn-xxx-yyy" might be
removed all at once (no registry knowledge is necessary to do this, only
subtag size/position is needed to spot the extlangs), falling immediately
back to "root" instead of removing each extlang in turn. 

We should decide now if that's the right course (although it borders on
making decisions about what extlangs are).

As a bonus, if scoring or patterns were to make a return and extlangs were
made "atomic with the primary language", that would restore the quintuple
structure and save us one level of potential negation fun.

Addison

Addison Phillips

> From: Frank Ellermann [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 10:47 AM
> To: [email-masked]
> Subject: [Ltru] Re: Too many ABNF issues
> 
> Addison Phillips wrote:
>