Subject: [Ltru] Re: Matching Text

From: "Doug Ewell" <[email-masked]>
Date: Fri, 12 Oct 2007 00:38:35 -0700

Mark Davis <mark dot davis at icu dash project dot org> wrote:

> We've been talking about two different models for dealing with 
> macrolanguages: extlang and no-extlang. In our telephone 
> conversations, a third has come up: partial-extlang.
>
> The partial-extlang model is where we only make X a secondary language 
> for Y when it can reliably be assumed that someone who understands X 
> will also understand Y. That would be the case if all of the 
> microlanguages of Y are mutually intelligible, or if Y is generally 
> identified with a "prestige" variant. With this model we wouldn't make 
> all the microlanguages be secondary, just certain ones like those 
> having ar and zh as macrolanguages. An example might be zh-yue.

Would we have to make this decision on a case-by-case basis for each of 
several hundred encompassed languages?

--
Doug Ewell * Fullerton, California, USA * RFC 4645 * UTN #14
http://users.adelphia.net/~dewell/
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 12 Oct 2007 10:13:46 -0400

> several hundred encompassed languages?

No, just for the macrolanguages.  But I agree that it's contentious.

-- 
The man that wanders far                        [email-masked]
from the walking tree                           http://www.ccil.org/~cowan
        --first line of a non-existent poem by:         John Cowan

---

From: Martin Duerst <[email-masked]>
Date: Sat, 13 Oct 2007 13:17:07 +0900

At 16:38 07/10/12, Doug Ewell wrote:
>> We've been talking about two different models for dealing with macrolanguages: extlang and no-extlang. In our telephone conversations, a third has come up: partial-extlang.
>>
>> The partial-extlang model is where we only make X a secondary language for Y when it can reliably be assumed that someone who understands X will also understand Y. That would be the case if all of the microlanguages of Y are mutually intelligible, or if Y is generally identified with a "prestige" variant. With this model we wouldn't make all the microlanguages be secondary, just certain ones like those having ar and zh as macrolanguages. An example might be zh-yue.
>
>Would we have to make this decision on a case-by-case basis for each of several hundred encompassed languages?

I think if we have to do this for each encompased language
(e.g. zh-yue it is, but min, not zh-min, or some such), then
that will be quite a bit of work. If we can restrict it to
be done once per macrolanguage, I think the overhead would
be very manageable. Which one seems more appropriate?

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]