Subject: [Ltru] Astur-Leonese: a macrolanguage case study

From: Peter Constable <[email-masked]>
Date: Mon, 29 Oct 2007 22:36:30 -0700

Here's a what-if based on a realistic scenario: "ast" is currently treated in ISO 639 as an individual-language entry with names "Asturian; Asturleonese; Bable; Leonese". What if ISO 639 changed the scope of "ast" to macrolanguage, and added two new encompassed individual-language entries: "Asturian; Bable" and "Leonese"?

While I haven't yet seen really clear evidence, there are some people claiming that Leonese is a distinct language from Asturian and requesting a distinct ISO 639 ID. Suppose a sufficient case is made: since "ast" currently denotes both the Asturian and Leonese varieties, we cannot simply narrow "ast" to denote only Asturian and add something new for Leonese. One possible outcome is the one I describe above: "ast" becomes a macrolanguage. (A possible variation is that Mirandese, "mwl", is included in the macrolanguage.)

What would the impact be in a 4646bis world with / without extlang subtags?

I suppose that depends on various details of the scenario. (Per above, this discussion assumes it is already determined that Asturian and Leonese are distinct.)

Possible scenario A: There's a bunch of existing "ast" content, virtually all of which is Asturian, not Leonese.

(Note: in principle, the mirror scenario, with Leonese predominant, is hypothetically possible, but not in practice: "Asturian" is recognized in Spanish law and is actively being developed; if Leonese is functionally distinct, it does not have comparable status and attention at present.)

Possible scenario B: There's a bunch of existing "ast" content, but neither Asturian or Leonese has a significantly greater proportion that the other.

Possible scenario C: There isn't much existing "ast" content.

(In terms of general macrolanguage cases, scenario A would be similar to the Mandarin versus Cantonese contrast, except that there's nowhere near as much "ast" content as there is "zh" content; scenario C would be similar to cases like Bikol, Cree, Hmong, Zapotec or several others. Scenario B is probably somewhat akin to "Serbo-Croatian" (hbs), Norwegian (nor) and "Persian" (fas). For general macrolanguages, there's probably a fourth scenario type: two or more distinct undeveloped varieties exist, and a "standard" developed variety emerges that is either distinct from the former, or is designed to be more or less neutral relative to the others - a possible characterization for the Arabic case, and potentially applicable to how some groups such as Dinka or Fulah may evolve.)

Peter

Microsoft has an open Program Management position working on international text and fonts. For details, go to:
http://members.microsoft.com/careers/search/details.aspx?JobID=69CF50EA-5FB5-47C8-9083-FCE0EF9CF547

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Tue, 30 Oct 2007 10:46:09 -0400

> What would the impact be in a 4646bis world with / without extlang subtags?

Without extlang subtags, of course, nothing happens.

Once a primary language subtag, always a primary language subtag, so
both camps agree that 'mwl' remains unchanged.  I'd argue for adding the
new code elements as extlang subtags, but I could live with restricting
extlangs to the set as of Date C.

In either case the "Macrolanguage:" header gets inserted into the records
for the new subtags.

-- 
I could dance with you till the cows            John Cowan
come home.  On second thought, I'd              http://www.ccil.org/~cowan
rather dance with the cows when you             [email-masked]
came home.  --Rufus T. Firefly

---

From: Peter Constable <[email-masked]>
Date: Tue, 30 Oct 2007 09:18:06 -0700

> From: John Cowan [mailto:[email-masked]]

> > What would the impact be in a 4646bis world with / without extlang

> subtags?

> Without extlang subtags, of course, nothing happens.

Nothing happens to tags; that doesn't mean there isn't any impact for data, tagging recommendations and matching behaviour / implementations.

Peter

---

From: GerardM <[email-masked]>
Date: Tue, 30 Oct 2007 17:24:54 +0100

Hoi,
When there is a language continuum, there can be a distinction between one
and the other without there being a reason for separate language codes. A
language code only makes sense when the languages are mutually exclusive.
The ISO-639-3 does not cater well for this. The ISO-639-6 will provide the
hierarchical structure needed to deal properly with these issues.

ISO-639-3 only allows for yes/no different and there are reasons why you
want to make a distinction without pronouncing it a language. The same is
true for Montenegrin. Technically is is not a different language. You do
however want to be able to indicate it being Montenegrin.

So from my perspective, are these part of a language continuum or are they
mutually exclusive ?

Thanks,
    Gerard

On 10/30/07, Peter Constable <[email-masked]> wrote:
>
>  Here's a what-if based on a realistic scenario: "ast" is currently
> treated in ISO 639 as an individual-language entry with names "Asturian;
> Asturleonese; Bable; Leonese". What if ISO 639 changed the scope of "ast" to
> macrolanguage, and added two new encompassed individual-language entries:
> "Asturian; Bable" and "Leonese"?
>
>
>
> While I haven't yet seen really clear evidence, there are some people
> claiming that Leonese is a distinct language from Asturian and requesting a
> distinct ISO 639 ID. Suppose a sufficient case is made: since "ast"
> currently denotes both the Asturian and Leonese varieties, we cannot simply
> narrow "ast" to denote only Asturian and add something new for Leonese. One
> possible outcome is the one I describe above: "ast" becomes a macrolanguage.
> (A possible variation is that Mirandese, "mwl", is included in the
> macrolanguage.)
>
>
>
> I suppose that depends on various details of the scenario. (Per above,
> this discussion assumes it is already determined that Asturian and Leonese
> are distinct.)
>
>
>
> (Note: in principle, the mirror scenario, with Leonese predominant, is
> hypothetically possible, but not in practice: "Asturian" is recognized in
> Spanish law and is actively being developed; if Leonese is functionally
> distinct, it does not have comparable status and attention at present.)
>
>
>
> Possible scenario B: There's a bunch of existing "ast" content, but
> neither Asturian or Leonese has a significantly greater proportion that the
> other.
>
>
>
> (In terms of general macrolanguage cases, scenario A would be similar to
> the Mandarin versus Cantonese contrast, except that there's nowhere near as
> much "ast" content as there is "zh" content; scenario C would be similar to
> cases like Bikol, Cree, Hmong, Zapotec or several others. Scenario B is
> probably somewhat akin to "Serbo-Croatian" (hbs), Norwegian (nor) and
> "Persian" (fas). For general macrolanguages, there's probably a fourth
> scenario type: two or more distinct undeveloped varieties exist, and a
> "standard" developed variety emerges that is either distinct from the
> former, or is designed to be more or less neutral relative to the others – a
> possible characterization for the Arabic case, and potentially applicable to
> how some groups such as Dinka or Fulah may evolve.)
>
>
>
>
>
> Peter
>
>
>

---

From: Peter Constable <[email-masked]>
Date: Tue, 30 Oct 2007 10:40:50 -0700

Re hierarchical structure, I don’t know of a need for tags to reflect hierarchical structure in general.

ISO 639-3 does not require mutual exclusivity in the case of macrolanguages. It does limit the degree of specificity to distinctions between individual languages, and does so by design. BCP47 allows for greater specificity, be design, and so the two are complementary. One might say that 639-6 has a benefit in that it has all levels of specificity, though in so doing it simply disregards the language/dialect issue; that may not always be a benefit since it provides no conventions as to how content should usefully be tagged (i.e. at what levels of specificity) thereby hindering interoperability. (Interop can be restored only by applications carrying large data tables.)

I do not know if Asturian and Leonese should be considered distinct / mutually exclusive. Suppose they are not: it’s not clear if there’d be a need to have distinct tags. If there is a need in some scenarios, though, BCP47 provides the means.

Peter

From: GerardM [mailto:[email-masked]]
Sent: Tuesday, October 30, 2007 9:25 AM
To: Peter Constable
Cc: [email-masked]
Subject: Re: [Ltru] Astur-Leonese: a macrolanguage case study

Hoi,
When there is a language continuum, there can be a distinction between one and the other without there being a reason for separate language codes. A language code only makes sense when the languages are mutually exclusive. The ISO-639-3 does not cater well for this. The ISO-639-6 will provide the hierarchical structure needed to deal properly with these issues.

ISO-639-3 only allows for yes/no different and there are reasons why you want to make a distinction without pronouncing it a language. The same is true for Montenegrin. Technically is is not a different language. You do however want to be able to indicate it being Montenegrin.

So from my perspective, are these part of a language continuum or are they mutually exclusive ?

Thanks,
    Gerard
On 10/30/07, Peter Constable <[email-masked]<mailto:[email-masked]>> wrote:

(In terms of general macrolanguage cases, scenario A would be similar to the Mandarin versus Cantonese contrast, except that there's nowhere near as much "ast" content as there is "zh" content; scenario C would be similar to cases like Bikol, Cree, Hmong, Zapotec or several others. Scenario B is probably somewhat akin to "Serbo-Croatian" (hbs), Norwegian (nor) and "Persian" (fas). For general macrolanguages, there's probably a fourth scenario type: two or more distinct undeveloped varieties exist, and a "standard" developed variety emerges that is either distinct from the former, or is designed to be more or less neutral relative to the others – a possible characterization for the Arabic case, and potentially applicable to how some groups such as Dinka or Fulah may evolve.)

Peter

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www1.ietf.org/mailman/listinfo/ltru