Subject: [Ltru] Fragmentary notes from telecon

From: "Mark Davis" <[email-masked]>
Date: Wed, 21 Nov 2007 15:10:28 -0800

http://docs.google.com/Doc?id=dfqr8rd5_43dnw36c

-- 
Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 22 Nov 2007 15:01:13 +0100

On Wed, Nov 21, 2007 at 03:10:28PM -0800,
 Mark Davis <[email-masked]> wrote 

> http://docs.google.com/Doc?id=dfqr8rd5_43dnw36c

IMHO, the IETF rules for mailing lists do not mix well with "outside"
documents, which may not be available in the future, when someone will
read the archive. So, I take the liberty to copy it here:

LTRU Telecon Notes
Felix, Randy, Martin, John, Addison, Mark

Fragmentary notes (see end)

Mark:
We could look over the suggested changes in http://docs.google.com/Doc?id=dfqr8rd5_42gzc36s to see how this would be/change depending on the choices we make.

Addison:
Mostly in agreement about difficulties with macrolanguages.
Disagreement:
 extlang is a useful mechanism, gives better results
 extlang is not a useful mechanism, gives worse results

(Someone): Conflation of macrolanguage and majority language is a mistake.

John: with extlang, should deviate from truncate from right in lookup

Mark: sole reason for extlang is for not changing the algorithm

Others: reason is to avoid need to look at registry

Mark: doesn't matter -- no big deal to look at registry. Not proposing that it be required, just optional. And practically, software can update every so often to get the cases it cares about. Not a lot of data. Even for limited-memory environments, like cellphones, can

Addision: people would be recommended to use the languages they can handle: eg zh, yue

John: have registered tags encoded with extlang style

Mark: those are not productive in tags

Addision: those were in good faith, but can deprecate and remap; have done in other cases.

Addision: lookup with extlang would look like:

zh-yue-Hant-TW
zh-yue-Hant
zh-yue
zh-hant-tw
zh-hant
zh
(default)

...
(many interesting points made, but was too involved in the conversation to keep up with the notes)
...

Martin: Why not have extlang (question about google)

Mark: Concerned with more than just Google: impacts Unicode (CLDR), ICU, Java, ... Concern is that better results overall are returned if we don't have extlang; we're inventing a mechanism and complications that we don't need. Example, zh/yue -- we got along without extlang for the analogous case of de/gsw. ... (Q about filtering). For filtering, in other cases, we specify the languages we want; if I want de and gsw, I list them. Similar for yue and zh.
...

At the end.

    * Will have weekly meeting.
    * We talked about assigning a scribe, or having people note what they just said -- either way, set up something before we start next time.
    * Addison will set up a collaboration tool for next time, and notify us ahead of time.

Google Docs -- Web word processing, presentations and spreadsheets.

---

From: Martin Duerst <[email-masked]>
Date: Tue, 27 Nov 2007 11:51:49 +0900

>read the archive. So, I take the liberty to copy it here:

Yes indeed. In the future, please send a copy of such notes, not
just a pointer. This also makes it much easier for people to
comment inline.

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]