Subject: [Ltru] action item: "other" collections in 639

From: Peter Constable <[email-masked]>
Date: Wed, 28 Nov 2007 15:57:11 -0800

In our teleconf, I took an action to push the ISO 639 JAC for action on getting rid of "other" collections.

Last status was that I raised the issue within the JAC back in April. There was a bit of discussion, but I had also raised the "mis" issue at the same time, and that got all the attention. There were just a couple of comments wrt "other": someone from LOC mentioned that "other" was still meaningful for those using 639-2 and not 639-3 (implying a desire not to change). I suggested that that was an issue to be handled by applications of a 639 standard. Another member replied that, in the context of 639 as a whole, there can be applications using different subsets, and so "other" would need to be defined in the context of the particular subset.

Also relevant here is that the code table in ISO/FDIS 639-5 does not include "other" in *any* of the entries (which are a superset of the collections in 639-2). That itself suggests to me that getting rid of "other" is very likely to happen and that it's just a matter of how long it takes for that to get reflected in data tables provided by either LOC or SIL.

At any rate, I have restarted discussion on this within the JAC and will try to push for quick action.

Peter

Microsoft has an open Program Management position working on international text and fonts. For details, go to:
http://members.microsoft.com/careers/search/details.aspx?JobID=69CF50EA-5FB5-47C8-9083-FCE0EF9CF547

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 28 Nov 2007 16:05:02 -0800

That'd be great. Thanks, Peter.

On Nov 28, 2007 3:57 PM, Peter Constable <[email-masked]> wrote:

> Last status was that I raised the issue within the JAC back in April.
> There was a bit of discussion, but I had also raised the "mis" issue at the
> same time, and that got all the attention. There were just a couple of
> comments wrt "other": someone from LOC mentioned that "other" was still
> meaningful for those using 639-2 and not 639-3 (implying a desire not to
> change). I suggested that that was an issue to be handled by applications of
> a 639 standard. Another member replied that, in the context of 639 as a
> whole, there can be applications using different subsets, and so "other"
> would need to be defined in the context of the particular subset.
>
>
>
> Also relevant here is that the code table in ISO/FDIS 639-5 does not
> include "other" in **any** of the entries (which are a superset of the
> collections in 639-2). That itself suggests to me that getting rid of
> "other" is very likely to happen and that it's just a matter of how long it
> takes for that to get reflected in data tables provided by either LOC or
> SIL.
>
>
>

-- 
Mark

---

From: "Don Osborn" <[email-masked]>
Date: Thu, 29 Nov 2007 12:39:00 -0500

Not sure about where is most appropriate to bring this up so will bring it up on both ltru and ietf-languages (with apologies for the crossposting). 

I've been in discussions about a project to facilitate writing of locales for African languages, and in that discussion I have suggested that the effort keep notes on the categories of language headings available in ISO 639 for this purpose.

I feel this is a unique opportunity to gather information on application of these tags in specific work relating to use of a number of African languages in ICT. I don't expect anything dramatic, but hope this helps get discussions past the few examples generally circulated (including ones that some readers may be tired of seeing from me).

It may possibly lead to some suggestions re new codes. It might also lead to other observations re use of existing codes. 

Two requests:
1) thoughts or guidelines on the above, what specifics to look for, etc.
2) ideal follow-up with the RFC process and its post 464* iterations if/as indicated; I understand of course about the processes for applying for new ISO 639 codes, which the event they are necessary (at the very least I would expect one for Runyakitara) would probably be initiated by country-level partners

Don Osborn
Bisharat.net
PanAfriL10n.org

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 29 Nov 2007 10:59:39 -0800

Hi Don -

Information regarding the situation with languages in addition
to the ones that have already received intensive discussion would
be most welcome.  I think that some of the follow-ups to your
message will belong on [email-masked], and others
on [email-masked].

Here's how I'd recommend dispatching them:

   - data that would help the extlang / macrolanguage discussion
     should go to [email-masked]

   - discussion of registration process, or the types of information
     that should be included with registration requests or recorded
     in the registry, should go to [email-masked]

   - discussion of guidelines to be documented belongs on [email-masked]

   - requests at add a new code or to modify information associated
     with some specific subtag should go to [email-masked]

I hope this will help minimize the need for cross-posting.

Randy
ltru co-chair

----- Original Message ----- 
From: "Don Osborn" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, November 29, 2007 9:39 AM
Subject: ISO 639, RFC 464* & African languages

Not sure about where is most appropriate to bring this up so will bring it up on both ltru and ietf-languages (with apologies for
the crossposting).

I've been in discussions about a project to facilitate writing of locales for African languages, and in that discussion I have
suggested that the effort keep notes on the categories of language headings available in ISO 639 for this purpose.

I feel this is a unique opportunity to gather information on application of these tags in specific work relating to use of a number
of African languages in ICT. I don't expect anything dramatic, but hope this helps get discussions past the few examples generally
circulated (including ones that some readers may be tired of seeing from me).

Two requests:
1) thoughts or guidelines on the above, what specifics to look for, etc.
2) ideal follow-up with the RFC process and its post 464* iterations if/as indicated; I understand of course about the processes for
applying for new ISO 639 codes, which the event they are necessary (at the very least I would expect one for Runyakitara) would
probably be initiated by country-level partners

Don Osborn
Bisharat.net
PanAfriL10n.org

_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages