Subject: [Ltru] Re: action item: "other" collections in 639

From: "Doug Ewell" <[email-masked]>
Date: Wed, 28 Nov 2007 22:55:45 -0800

Peter Constable <petercon at microsoft dot com> wrote:

> In our teleconf, I took an action to push the ISO 639 JAC for action 
> on getting rid of "other" collections.

By "getting rid of" I take it you mean "withdrawing" them.  That would 
have the effect of allowing us to deprecate them in the Registry, but of 
course they could not actually be deleted from the Registry; we've 
promised never to do that.

Of course, if we're ready to add the exceptionally reserved 3166 codes, 
it wouldn't be that much of a stretch to make another change to 4646bis 
to deprecate all language subtags based on codes not in 639-3, which 
basically means all the collection codes.  That way we wouldn't have to 
wait for the JAC, just as we've chosen not to wait for 3166/MA.

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://home.roadrunner.com/~dewell
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Wed, 28 Nov 2007 23:02:33 -0800

> From: Doug Ewell [mailto:[email-masked]]

> By "getting rid of" I take it you mean "withdrawing" them.

Oh, my! No! I didn't express that very clearly: I mean deleting "(Other)" from language names so that all collections in ISO 639 are nominally inclusive (though any application, particular those using a subset of all 639 entities, can treat certain collections as exclusive, "remainder only" groups).

> wait for the JAC, just as we've chosen not to wait for 3166/MA.

I've suggested in the past that removing collection IDs from BCP47 might not be a bad idea, but on several occasions people have indicated that they wish to have the collections kept.

Peter

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 29 Nov 2007 16:25:58 +0100

Peter Constable wrote:
 
> I've suggested in the past that removing collection IDs from
> BCP47 might not be a bad idea, but on several occasions people
> have indicated that they wish to have the collections kept.

"Removing" can't fly.  Do you mean "not add new" (in the 4645bis
bulk update), "deprecate old", or both ?  

 Frank

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 29 Nov 2007 07:52:30 -0800

Nobody is calling for removing. Peter's action was to take "(Other)" out of
the names, that's all.

Mark

-- 
Mark

---

From: Peter Constable <[email-masked]>
Date: Thu, 29 Nov 2007 08:04:54 -0800

> From: Frank Ellermann [mailto:[email-masked]]

> bulk update), "deprecate old", or both ?

Deprecate, and not add new.

Peter

---

From: Peter Constable <[email-masked]>
Date: Thu, 29 Nov 2007 08:12:51 -0800

Let me clarify this sub-thread: I have questioned in the past whether language collection ID of any kind are useful in IETF language tags. Whenever I made that suggestion, there were others here insisting that they wanted them kept.

I am not proposing any change in this regard at this time. This only came up because I had poorly worded my statement about getting rid of “(Other)” from language-collection names, and Doug thought I was suggesting that ISO 639 “withdraw” those entries – I was not suggesting that.

Let me clarify what change I am pursuing: I am asking the JAC to remove “(Other)” from the names of language-collection entries that currently contain that string. That is *all* this thread was intended to be about.

Peter

From: Mark Davis [mailto:[email-masked]]
Sent: Thursday, November 29, 2007 7:53 AM
To: Frank Ellermann
Cc: [email-masked]
Subject: Re: [Ltru] Re: action item: "other" collections in 639

Nobody is calling for removing. Peter's action was to take "(Other)" out of the names, that's all.

Mark
On Nov 29, 2007 7:25 AM, Frank Ellermann < [email-masked]<mailto:[email-masked]>> wrote:

 Frank

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www1.ietf.org/mailman/listinfo/ltru