Subject: [Ltru] some issues

From: Peter Constable <[email-masked]>
Date: Wed, 28 Nov 2007 14:14:03 -0800

I was replying to mail yesterday from someone at my company raising concerns with language-identification issues. His understanding was not at all up to date, so I was trying to fill him in on some things. I tried to think of a cross-section of issues we (mainly MS) are facing with representative cases and though of the following off the top of my head. Just thought I'd share it:

1.       We have to distinguish between different written forms for a language (script or orthography differences - e.g. Serbian in Cyrillic versus Latin script; English with US versus UK spelling).

2.       We have to support dialect distinctions in some cases (e.g. Brazilian vs. Iberian Portuguese).

3.       We have to recognize language differences that for years have been glossed over (e.g. "Chinese" really encompasses multiple, distinct languages, including Mandarin versus Cantonese).

4.       We occasionally have to support quasi-dialectal variations - resources tailored to cover multiple markets but not really corresponding to a particular dialect (e.g. Latin American Spanish)

5.       We are starting to support some neo-development languages in cases where there's a chain of closely related languages but we have to identify a particular language in our product, yet history is yet to unfold as to which varieties will become more developed than the others (e.g. Quechua).

6.       Changing geo-politics that sometimes carry language-identity issues (but with dubious linguistic bases for differentiation, at least at present) in their wake (e.g. "Montenegrin")

Peter

Microsoft has an open Program Management position working on international text and fonts. For details, go to:
http://members.microsoft.com/careers/search/details.aspx?JobID=69CF50EA-5FB5-47C8-9083-FCE0EF9CF547

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 28 Nov 2007 22:49:34 -0000

Hi Peter
 
As you know many of these will be facilitated by ISO 639-6 which will be
submitted for FDIS vote before end of December 2007.  There is scope to
discuss the inclusion of ISO 639-6 within RFC4646bis according to the
charter.
 
I don't see any harm in having a discussion on this but as far as inclusion
within RFC4646bis is concerned I think publication as IS will be too late;
in any case, I know people here don't want to hold up the inclusion of ISO
639-3.
 
IMHO, the WG should be rechartered after publication of RFC4646bis to
include ISO 639-6 once published.
 
Best regards
 
Debbie

  _____  

From: Peter Constable [mailto:[email-masked]] 
Sent: 28 November 2007 22:14
To: [email-masked]
Subject: [Ltru] some issues

I was replying to mail yesterday from someone at my company raising concerns
with language-identification issues. His understanding was not at all up to
date, so I was trying to fill him in on some things. I tried to think of a
cross-section of issues we (mainly MS) are facing with representative cases
and though of the following off the top of my head. Just thought I'd share
it:

1.       We have to distinguish between different written forms for a
language (script or orthography differences - e.g. Serbian in Cyrillic
versus Latin script; English with US versus UK spelling).

2.       We have to support dialect distinctions in some cases (e.g.
Brazilian vs. Iberian Portuguese).

3.       We have to recognize language differences that for years have been
glossed over (e.g. "Chinese" really encompasses multiple, distinct
languages, including Mandarin versus Cantonese).

4.       We occasionally have to support quasi-dialectal variations -
resources tailored to cover multiple markets but not really corresponding to
a particular dialect (e.g. Latin American Spanish)

5.       We are starting to support some neo-development languages in cases
where there's a chain of closely related languages but we have to identify a
particular language in our product, yet history is yet to unfold as to which
varieties will become more developed than the others (e.g. Quechua).

6.       Changing geo-politics that sometimes carry language-identity issues
(but with dubious linguistic bases for differentiation, at least at present)
in their wake (e.g. "Montenegrin")

Peter

Microsoft has an open Program Management position working on international
text and fonts. For details, go to:

<http://members.microsoft.com/careers/search/details.aspx?JobID=69CF50EA-5FB
5-47C8-9083-FCE0EF9CF547>
http://members.microsoft.com/careers/search/details.aspx?JobID=69CF50EA-5FB5
-47C8-9083-FCE0EF9CF547

---

From: Peter Constable <[email-masked]>
Date: Wed, 28 Nov 2007 15:45:56 -0800

It's not at all obvious to me how ISO 639-6 of itself can facilitate solutions to issues 4, 5 or 6.

Peter.

From: Debbie Garside [mailto:[email-masked]]
Sent: Wednesday, November 28, 2007 2:50 PM
To: Peter Constable; [email-masked]
Subject: RE: [Ltru] some issues

Hi Peter

As you know many of these will be facilitated by ISO 639-6 which will be submitted for FDIS vote before end of December 2007.  There is scope to discuss the inclusion of ISO 639-6 within RFC4646bis according to the charter.

I don't see any harm in having a discussion on this but as far as inclusion within RFC4646bis is concerned I think publication as IS will be too late; in any case, I know people here don't want to hold up the inclusion of ISO 639-3.

IMHO, the WG should be rechartered after publication of RFC4646bis to include ISO 639-6 once published.

Best regards

Debbie

________________________________

Peter