Subject: [Ltru] Charter

From: "Debbie Garside" <[email-masked]>
Date: Fri, 9 May 2008 00:28:19 +0100

Hi

The Charter states:

---

The working group will also consider how the draft work on
ISO 639-6 may relate to the future development of language tags.

---

I think with the current highlighted problems surrounding the tagging of
spoken and written variations that now would be a good time to introduce
this topic.

For those of you that do not already know, the model for ISO FDIS 639-6 is
hierarchical and incorporates the following:

Alpha4 code, ParentAlpha4 Code, Reference Name

The basic gist of the standard is as follows:

Hierarchical Upper Language Levels (Using ISO FDIS 639-5 where available)
Language (Using 639-3 where available which is mapped to ISO 639-1/2B/2T)
Language Written
Language Written Script1
Language Written Script2 (etc. where required)
Language Spoken
Language Spoken Variants (etc.)

This work is currently going out for a 2 month FDIS vote and the data is
scheduled for completion in two months.

I do not want to hold up the publication of this RFC and do not envisage any
discussion resulting in the inclusion of ISO 639-6 data within the RFC but
please, at least, consider how this work can help.

Best regards

Debbie Garside
Editor ISO FDIS 639-6

CEO/Managing Director
The World Language Documentation Centre and GeoLang Ltd
Corner House
Barn Street
Haverfordwest
Pembrokeshire SA61 1BW
Wales UK

Tel: 0044 1437 766441
Fax: 0044 1437 766173

Web: http://www.thewldc.org
Web: http://www.geolang.com

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: [email-masked]
Date: Thu, 8 May 2008 16:34:05 -0700

I agree that this may have some impact on the discussion of extlang, etc. 
Was this considered in the conference calls at all? 

As the reference ISO 639 standards get increasingly more specific, we may 
have more and more of a need to create hierarchical tagging structures 
that go from least specific tag to most specific. The ISO 639-6 work does 
seem to contain the spoken/written distinctions I need, and the hierarchy 
of languages is useful for reasons mentioned over the last week's 
discussions. Even if we manage to flatten the relationship between ISO 
639-2 and ISO 639-3, will this tactic work for future ISO 639-6? Is this a 
factor?

Best regards,

Karen Broome

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 9 May 2008 12:02:18 +0100

Herewith the draft data from ISO FDIS 639-6 for Mandarin:
(I have added some extra notes to assist in column 4)

mycx	 zho	 Mandarin Yue Complex	  	
micr	 mycx	 Mandarin Cluster	  	
cmn	 micr 	 Mandarin Chinese	  	
cmnw	 cmn	 Mandarin Chinese Written	  	
cmnc	 cmnw	 Mandarin Chinese Written Chinese Script	  	
cmns	 cmn	 Mandarin Chinese Spoken	  	
bjgh	 cmn	 Bei-Jing-Hua	 Beijing Dialect	
bjgk	 bjgh	 Bei-Jing-Hua Spoken	  	
bjjg	 bjgk	 Beijing 	Modern Beijing Dialect 	
goyu	 bjgk	 Guo-Yu	 Taiwan Standard Mandarin Chinese	
gyut	 goyu	 Guo-Yu Written	  	
gwcb	 gyut	 Guo-Yu Written Bai-Hua  Chinese  Script	  	
gpml	 gyut	 Guo-Yu Written Pre-Communist Sino-Latin Script	  	
gcyp	 gyut	 Guo-Yu Written Chu-Yin Phonetic Script  	  	
sgoy	 goyu	 Guo-Yu Spoken	  	
huyu	 bjgk	 Hua-Yu	 Singapore Standard Mandarin Chinese	
whuy	 huyu	 Hua-Yu Written	  	
chuy	 whuy	 Hua-Yu Written Chinese Script	  	
shuy	 huyu	 Hua-Yu Spoken	  	
cosc	 bjgk	 Putonghua	 Standard Mandarin Chinese based on original
Beijing dialect	
cscw	 cosc	 Putonghua Written	  	
ccwc	 cscw	 Putonghua Written Chinese Script 	 Putonghua Popular
Literary Model	
ccwl	 cscw	 Putonghua Written Sino-Latin Script	  	
scoy	 cosc	 Putonghua Spoken	  	
jghi	 bjgk	 Jing-Shi	  	
heng	 bjgk	 Huai-Cheng	  	
cofg	 bjgk	 Chao-Feng	  	
dbiu	 cmn	 Dong-Bei-Hua	  	
dhut	 dbiu	 Dong-Bei-Hua Written	  	
dewc	 dhut	 Dong-Bei-Hua Written Chinese Script	  	
dbhn	 dbiu	 Dong-Bei-Hua Spoken	  	
cgji	 dbhn	 Chang-Jin	  	
zafu	 dbhn	 Zhao-Fu	  	
tgxi	 dbhn	 Tong-Xi	  	
ynji	 dbhn	 Yan-Ji	  	
jini	 dbhn	 Jiao-Ning	  	
jifu	 dbhn	 Jia-Fu	  	
nnke	 dbhn	 Nen-Ke	  	
znhu	 dbhn	 Zhan-Hua	  	
jliu	 cmn	 Jiao-Liao-Hua	  	
jiuk	 jliu	 Jiao-Liao-Hua Spoken	  	
qnzu	 jiuk	 Qing-Zhou	  	
dezu	 jiuk	 Deng-Zhou	  	
gihu	 jiuk	 Gai-Huan	  	
jlua	 cmn	 Ji-Lu-Hua	  	
jhak	 jlua	 Ji-Lu-Hua Spoken	  	
flog	 jhak	 Fu-Long	  	
lcag	 jhak	 Luan-Chang	  	
jizn	 jhak	 Ji-Zun	  	
tjin	 jhak	 Tian-Jin	  	
digb	 jhak	 Ding-Ba	  	
laif	 jhak	 Lai-Fu	  	
hnle	 jhak	 Huang-Le	  	
ynsu	 jhak	 Yang-Shou	  	
zaua	 jhak	 Zhang-Huan	  	
juzo	 jhak	 Ju-Zhao	  	
zohe	 jhak	 Zhao-Shen	  	
xieg	 jhak	 Xing-Heng	  	
loti	 jhak	 Liao-Tai	  	
zgyu	 cmn	 Zhong-Yuan-Hua	  	
zyuk	 zgyu	 Zhong-Yuan-Hua Spoken	  	
zyjl	 zyuk	 Zhongyuan-Jilu	  	
cine	 zyuk	 Cailu-NE 	  	
zcao	 zyuk	 Zheng-Cao-N	  	
zcoe	 zyuk	 Zheng-Cao-E	  	
zgcc	 zyuk	 Zheng-Cao-C	  	
zgco	 zyuk	 Zheng-Cao-W	  	
xinb	 zyuk	 Xin-Beng	  	
ccal	 zyuk	 Cailu-SW	  	
lxue	 zyuk	 Luoxu-E	  	
lxuc	 zyuk	 Luoxu-C	  	
loxu	 zyuk	 Luoxu-W 	  	
hazu	 zyuk	 Hai-Zhou 	  	
piya	 zyuk	 Ping-Yang	  	
jigz	 zyuk	 Jiang-Zhou	  	
guzg	 zyuk	 Guan-Zhong	  	
qlon	 zyuk	 Qin-Long	  	
lozg	 zyuk	 Long-Zhong	  	
njig	 zyuk	 Nan-Jiang	  	
zgyt	 zyuk	 Zhong-Yuan-'Settlers'-S	  	
lyiu	 cmn	 Lan-Yin-Hua	  	
liue	 lyiu	 Lan-Yin-Hua Spoken	  	
yiwu	 liue	 Yin-Wu	  	
jicg	 liue	 Jin-Cheng	  	
hhxi	 liue	 He-Xi	  	
biin	 liue	 Bei-Jiang-N	  	
xghu	 cmn	 Xinan-Guan-Hua	  	
xuuk	 xghu	 Xinan-Guan-Hua Spoken	  	
wuia	 xuuk	 Wu-Tian	  	
ebbi	 xuuk	 E-Bei	  	
cahe	 xuuk	 Chang-He	  	
cyuc	 xuuk	 Chengyu-C	  	
cyse	 xuuk	 Chengyu-SE	  	
mjic	 xuuk	 Minjiang-C	  	
mjgn	 xuuk	 Minjiang-N 	  	
mige	 xuuk	 Minjiang-E 	  	
miji	 xuuk	 Minjiang-SW 	  	
rfne	 xuuk	 Renfu-NE	  	
refu	 xuuk	 Renfu-S	  	
rnfu	 xuuk	 Renfu-W	  	
yami	 xuuk	 Ya-Mian	  	
liha	 xuuk	 Li-Chuan	  	
bolu	 xuuk	 Bao-Lu	  	
yoli	 xuuk	 Yao-Li	  	
kngu	 xuuk	 Kun-Gui 	  	
qibe	 xuuk	 Qian-Bei	  	
qnan	 xuuk	 Qian-Nan	  	
cnji	 xuuk	 Cen-Jiang	  	
gili	 xuuk	 Gui-Liu	  	
xgnn	 xuuk	 Xiang-Nan	  	
juai	 cmn	 Jiang-Huai	  	
jgik	 juai	 Jiang-Huai Spoken	  	
hxao	 jgik	 Huang-Xiao-W 	  	
haxi	 jgik	 Huang-Xiao-NE	  	
hagx	 jgik	 Huang-Xiao-SE 	  	
hnco	 jgik	 Hong-Chao-N	  	
hogh	 jgik	 Hong-Chao-S	  	
taru	 jgik	 Tairu	  	

Best regards
 
Debbie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: 09 May 2008 00:34
> To: [email-masked]
> Subject: Re: [Ltru] Charter
>
> As the reference ISO 639 standards get increasingly more
> specific, we may have more and more of a need to create
> hierarchical tagging structures that go from least specific
> tag to most specific. The ISO 639-6 work does seem to contain
> the spoken/written distinctions I need, and the hierarchy of
> languages is useful for reasons mentioned over the last
> week's discussions. Even if we manage to flatten the
> relationship between ISO
> 639-2 and ISO 639-3, will this tactic work for future ISO
> 639-6? Is this a factor?
>
> Best regards,
>
> Karen Broome
>
> ISO 639-6
> > may relate to the future development of language tags.
> >
> > ---
> >
> > I think with the current highlighted problems surrounding
> the tagging
> > of spoken and written variations that now would be a good time to
> > introduce this topic.
> >
> > For those of you that do not already know, the model for ISO FDIS
> > 639-6
> is
> > Language Written Script2 (etc. where required) Language Spoken
> > This work is currently going out for a 2 month FDIS vote
> and the data
> > is scheduled for completion in two months.
> >
> > I do not want to hold up the publication of this RFC and do not
> > envisage
> any
> > discussion resulting in the inclusion of ISO 639-6 data
> within the RFC
> but
> > Barn Street Haverfordwest Pembrokeshire SA61 1BW Wales UK
> >
> > Tel: 0044 1437 766441
> > Fax: 0044 1437 766173
> >

---

From: Leif Halvard Silli <[email-masked]>
Date: Fri, 09 May 2008 16:00:16 +0200

> gpml	 gyut	 Guo-Yu Written Pre-Communist Sino-Latin Script

I would like to suggest that that draft should say "pre People Republic 
of China" or "pre PRC" instad of "Pre-Communist.

This stems from my observeration that in Russia it is preferred to say 
"Soviet period" instead of "communist period".

It is even more precise to say "Soviet" and "PRC" instead of "communist".

-- 
leif halvard silli