Subject: [Ltru] default for q-values in Accept-Language and elsewhere

From: Martin Duerst <[email-masked]>
Date: Wed, 07 May 2008 16:07:46 +0900

Dear HTTP WG,

This was brought up in the LTRU WG by Mark Davis:

>Unfortunately, the specs are ill-defined regarding the q values. Take the >following example:
>
>a, b;q=0.7, c, d;q=0.5, e, f;q=0.9, g
>
>The specs do not distinguish between at least two different possible >reasonable interpretations of what the q values of c, e, and g are: 
    * >   c;q=1.0, e;q=1.0, g;q=1 // always 1 
    * >   c;q=0.7, e;q=0.5, g;q=0.9 // always same as previous 
> Our guess is that the user meant #2, but it is only a guess.

I read RFC 2616, and indeed didn't find any specification of
the defaults for q values in the case of Accept-Language.

Looking at other subsections of Section 14, there is an explicit
default of q=1 for Accept and Accept-Charset, but I also didn't
find a default for Accept-Encoding.

Please add this issue to your issue list unless you already
have it listed.

Regards,   Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Julian Reschke <[email-masked]>
Date: Wed, 07 May 2008 13:49:21 +0200

Adrien de Croy wrote:
> also the whole concept of q values only makes any sense if the default 
> value is 1.
> ...

I'd recommend that we state the default just once in the section that 
introduces qvalues 
(<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p3-payload-latest.html#rfc.section.3.4>) 
and remove the description everywhere else.

BR, Julian

---

From: Martin Duerst <[email-masked]>
Date: Wed, 07 May 2008 19:36:06 +0900

Dear HTTP WG,

Please accept my appology for the double confusion:
- Sending out the same change request just a few hours after Mark.
- Not being able to find the text about the default value
  despite reading that subsection several times.

Regards,    Martin.

At 16:07 08/05/07, Martin Duerst wrote:
>>Unfortunately, the specs are ill-defined regarding the q values. Take the 
>>following example:
>>
>>The specs do not distinguish between at least two different possible 
>>reasonable interpretations of what the q values of c, e, and g are: