Subject: [Ltru] extlang and stability of macrolanguage

From: Nicolas Krebs <[email-masked]>
Date: Fri, 23 May 2008 00:27:27 +0200

Hello, 

The meaning of rm has changed in january 2007
http://www.alvestrand.no/pipermail/ietf-languages/2007-January/005615.html

http://tools.ietf.org/html/draft-ietf-ltru-initial-06#page-24  
Type: language
Subtag: rm
Description: Raeto-Romance
Added: 2005-10-16

http://tools.ietf.org/html/draft-ietf-ltru-4645bis-05#page-27 
Type: language
Subtag: rm
Description: Romansh
Added: 2005-10-16

I would had prefer that the maining of rm had not been changed, 
or at least with a change notification in the registry, but this is another 
subject wich has been discuted previously 
( http://www.ietf.org/mail-archive/web/ltru/current/msg06987.html ). 

Lets suppose that later is added a new language code abc for 
Rhaeto-Romance, added as Macrolanguage: for Rhaeto-Romance 
languages. 

The rm ISO 639 language tag would become 
Type: language
Subtag: rm
Description: Romansh
Macrolanguage: abc 

Without extlang ( urn:ietf:id:draft-ietf-ltru-4646bis-14 
http://tools.ietf.org/html/draft-ietf-ltru-4646bis-14#section-2.2.2 )
the bcp 47 ietf language tags would become 

rm Romansh; macrolanguage abc 
lld Ladin; macrolanguage abc 
fur Friulian; macrolanguage abc 
abc Rhaeto-Romance

With extlang only ( urn:ietf:id:draft-ietf-ltru-4646bis-09 
http://tools.ietf.org/html/draft-ietf-ltru-4646bis-09#section-2.2.2 )
the bcp 47 ietf language tags would become 

rm Romansh; deprecated, use abc-roh
lld Ladin; deprecated, use abc-lld
fur Friulian; deprecated, use abc-fur
abc Rhaeto-Romance
abc-roh Romansh; macrolanguage abc 
abc-lld Ladin; macrolanguage abc 
abc-fur Friulian; macrolanguage abc 

With and without extlang (both allowed, 
http://www.ietf.org/mail-archive/web/ltru/current/msg10366.html )
the bcp 47 ietf language tags would become 

rm Romansh; macrolanguage abc 
lld Ladin; macrolanguage abc 
fur Friulian; macrolanguage abc 
abc Rhaeto-Romance
abc-roh Romansh; macrolanguage abc
abc-lld Ladin; macrolanguage abc
abc-fur Friulian; macrolanguage abc

Other example: Current situation for "Comorian" in 
urn:ietf:id:draft-ietf-ltru-4645bis-05 : 
swb Comorian
wlc Mwali Comorian
wni Ndzwani Comorian
zdj Ngazidja Comorian

Lets suppose that later swb Comorian change to 
macrolanguage of other "Comorian" 
( http://www.ietf.org/mail-archive/web/ltru/current/msg06987.html ). 

Without extlang ( urn:ietf:id:draft-ietf-ltru-4646bis-14 
http://tools.ietf.org/html/draft-ietf-ltru-4646bis-14#section-2.2.2 )
the bcp 47 ietf language tags would become 

swb Comorian
wlc Mwali Comorian; macrolanguage swb
wni Ndzwani Comorian; macrolanguage swb
zdj Ngazidja Comorian; macrolanguage swb

With extlang only ( urn:ietf:id:draft-ietf-ltru-4646bis-09 
http://tools.ietf.org/html/draft-ietf-ltru-4646bis-09#section-2.2.2 )
the bcp 47 ietf language tags would become 

swb Comorian
wlc Mwali Comorian; deprecated, use swb-wlc 
wni Ndzwani Comorian; deprecated, use swb-wni 
zdj Ngazidja Comorian; deprecated, use swb-zdj 
swb-wlc Mwali Comorian; macrolanguage swb
swb-wni Ndzwani Comorian; macrolanguage swb
swb-zdj Ngazidja Comorian; macrolanguage swb

It seem there would be more stability of language code (less change) 
without extlang in such case. Of course extlang have the advantage of 
easier fall back into macrolanguage, by only delete-from-right, instead 
of looking in database if there is a macrolanguage for. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 22 May 2008 19:22:36 -0700

Hi -

As a technical contributor...

> From: "Nicolas Krebs" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, May 22, 2008 3:27 PM
> Subject: [Ltru] extlang and stability of macrolanguage
...
> http://tools.ietf.org/html/draft-ietf-ltru-4645bis-05#page-27 
...

The descriptions taken by themselves make this look like a narrowing
of the category.  Was this the intent?

Randy

---

From: Peter Constable <[email-masked]>
Date: Thu, 22 May 2008 19:47:08 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Randy Presuhn

> of the category.  Was this the intent?

The change in the LSTR matched changes made by the ISO 639 JAC. As part of evaluating ISO/FDIS 639-3 and considering how rm/roh should relate to entries in Ethnologue, while the MARC language code list did indicate that roh was used as a collective for Ladin and Romansh, it was clear that there were many other uses of rm that were specifically Romansh, and the JAC representatives from LOC and other libraries indicated they considered it appropriate in ISO 639 to clarify the denotation as Romansh.

Keep in mind: prior to publication of ISO 639-3, the denotation of IDs in ISO 639 was documented only in terms of certain names, which in general are not alone an adequate means of documentation. Part of the change with ISO 639-3 was to begin to document denotations in terms of a larger body of information of a more encyclopedic nature, something that was unavoidable in determining how the existing entries should relate to the large collection of new entries that would be added to the code. This was simply one of many decisions regarding more specific determination of denotation for existing entries that were explicitly or tacitly made.

Btw, this change was made before ISO 639-3 was approved; IMO, it is not a case of a macrolanguage being added.

Peter

---

From: Martin Duerst <[email-masked]>
Date: Fri, 23 May 2008 19:05:14 +0900

I'm somewhat confused. Romans(c)h and Rhaeto-Romance are simply
alternate names for one and the same language. So I'm not sure
why there is talking about a narrowing or change.

Regards,    Martin.

At 11:47 08/05/23, Peter Constable wrote:
>The change in the LSTR matched changes made by the ISO 639 JAC. As part of 
>evaluating ISO/FDIS 639-3 and considering how rm/roh should relate to 
>entries in Ethnologue, while the MARC language code list did indicate that 
>roh was used as a collective for Ladin and Romansh, it was clear that there 
>were many other uses of rm that were specifically Romansh, and the JAC 
>representatives from LOC and other libraries indicated they considered it 
>appropriate in ISO 639 to clarify the denotation as Romansh.
>
>Keep in mind: prior to publication of ISO 639-3, the denotation of IDs in 
>ISO 639 was documented only in terms of certain names, which in general are 
>not alone an adequate means of documentation. Part of the change with ISO 
>639-3 was to begin to document denotations in terms of a larger body of 
>information of a more encyclopedic nature, something that was unavoidable 
>in determining how the existing entries should relate to the large 
>collection of new entries that would be added to the code. This was simply 
>one of many decisions regarding more specific determination of denotation 
>for existing entries that were explicitly or tacitly made.
>

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: John Cowan <[email-masked]>
Date: Sat, 24 May 2008 14:15:23 -0400

> why there is talking about a narrowing or change.

The term "Rhaeto-Romance" has two senses: one in which it is synonymous
with "Rumansch", the other in which it names the subfamily containing
Rumansch, Friulian, and Ladin.  The 639-2/RA was clarifying that it
intended the first sense.  The second sense is very common in English,
as googling for "the Rhaeto-Romance languages" will quickly show.

-- 
By Elbereth and Luthien the Fair, you shall     [email-masked]
have neither the Ring nor me!  --Frodo          http://www.ccil.org/~cowan
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Sat, 24 May 2008 14:25:46 -0700

> From: Martin Duerst [mailto:[email-masked]]

> why there is talking about a narrowing or change.

Indeed, there isn't. There was potential to consider it a narrowing based on how MARC had used roh, but the JAC decided that the denotation was simply Romansh; the name change itself was driven by the fact that the Swiss government uses "Romansh" as the English-language name for that language.

Peter