Subject: Re: [Ltru] I'm really confused by chinese in 3066bis

From: [email-masked]
Date: Fri, 2 May 2008 20:13:50 -0700

I don't think the average developer will understand the distinction you've made below. We should have a clear recommendation for languages and dialects formerly encompassed by "zh".

I need a tag for spoken Taiwanese Mandarin. I mention that it's spoken only because I won't consider using any tag with a script in it. I do not believe the members of this list will agree on what the best tag for this content is. If this list can't agree on the preferred tag, I fear we've done something wrong.

Regards,

Karen Broome

[email-masked] wrote: -----

>To: [email-masked]
>From: "Mark Davis" <[email-masked]>
>Sent by: [email-masked]
>Date: 05/02/2008 07:47PM
>cc: "LTRU Working Group" <[email-masked]>
>Subject: Re: [Ltru] I'm really confused by chinese in 3066bis
>
>I'm obviously not making myself clear, because you are leaping to
>conclusions that are not founded in what I'm saying.
>
>
>I am NOT saying that zh is the same as cmn.
> I'm not changing the semantics of 'zh' at all*.
>
>
>What I'm saying is:
>although they are semantically distinct,
> my advice to most users would be that in practice for backwards
>compatibility in programs they are best off treated as synonyms.
>
>
>Maybe it would be clearer with another example. I might say, for
>practical purposes on input in a particular program the value
>$99.999999 is best handled as though it were synonymous with $100 (eg
>rounding). That doesn't mean I think that these two numbers are
>synonyms -- far from it!
>
>
>
>Mark
>
>
>* (Although, frankly, the few words of identification given in ISO
>639-1
>and -2 are often very fuzzy, as we've seen time and time again. Many
>people, for example, consider Swiss German a kind of German. And
>"German" was all it said for 'de' in ISO 639-1. So it would be
>perfectly natural for people to think that Swiss German would be
>de-CH, just like Austrian German is de-AT. )
>
>
>
>
>On Fri, May 2, 2008 at 6:26 PM,  <
>[email-masked]
>> wrote:
>
>
>As much as we'd like to rewrite history, it's a semantic change.
> There is
>
>
>a whole list of grandfathered tags such as zh-min, zh-yue, zh-hakka,
>and
>
>
>others that will make no sense after this new semantic goes into
>effect
>
>
>with RFC 4646bis.  You've not only changed the semantic of "zh",
> you've
>
>
>made all of those tags senseless as well.  The very existence of
>those
>
>
>tags that identify other Chinese languages indicates to me that the
>
>
>registrants of those tags, myself included, did NOT interpret "zh" to
>mean
>
>
>Mandarin.
>
>
>
>
>When I look at this page, I can see that John Cowan, Clay Compton,
>Kai-hus
>
>
>Tai, and I all registered tags that assume a more generic definition
>of
>
>
>"zh". This seems to contradict your statement that "zh" has always
>meant
>
>
>Mandarin in practice. Do you assume that these tag registrants
>registered
>
>
>these tags and then never put them to use?
>
>
>
>
>
>http://www.iana.org/assignments/language-tags
>
>
>
>
>Looking at the registrations you made, it appears possible that you
>were
>
>
>operating under this assumption, but I'm not so sure this is the case
>with
>
>
>every user.
>
>
>
>
>Regards,
>
>
>
>
>Karen Broome
>
>
>
>
>
>
>[email-masked]
> wrote on 05/02/2008 03:19:31 PM:
>
>
>
>
>>
>
>
>
>
>> On Fri, May 2, 2008 at 2:15 PM, <
>[email-masked]
>> wrote:
>
>
>> Comments.
>
>
>>
>
>
>>
>[email-masked]
> wrote on 05/02/2008 01:27:15 PM:
>
>
>>
>
>
>> > I see it a bit differently:
>
>
>> > cmn means specifically Mandarin Chinese, spoken or written (eg
>cmn-HK)
>
>
>> > yue means specifically Cantonese Chinese, spoken or written (eg
>
>
>yue-HK)
>
>
>> > zh means any Chinese, spoken or written, thus encompassing
>Mandarin,
>
>
>> > Cantonese, and others. It thus is formally correct to tag either
>
>
>> > Mandarin Chinese content or Cantonese content with 'zh'. (eg
>zh-HK).
>
>
>
>
>> So far, so good.
>
>
>>
>
>
>> > However, because of the de facto predominance of Mandarin, 'zh'
>has
>
>
>> > long been used to mean Mandarin only.
>
>
>
>
>> Disagree. It was simply the most specific tag one could use for the
>
>
>> Mandarin at the time. That doesn't mean the tag ever meant
>"Mandarin" to
>
>
>> anyone. We might as well say zh-TW means Traditional Mandarin as
>this
>
>
>tag
>
>
>> has been used more often than zh-Hant.
>
>
>>
>
>
>> I stand by what I said: it has long been used to mean just
>Mandarin.
>
>
>> If you make a request using 'zh' to products from Google,
>Microsoft,
>
>
>> Apple, Sun, and so on, in practice that does not mean:
>
>
>
>
>> Give me some kind of Chinese, I don't care whether it is Mandarin
>or
>
>
>> Cantonese or Hakka.
>
>
>
>
>> Instead, in practice, it means:
>
>
>
>
>> Give me Mandarin.
>
>
>>
>
>
>>
>
>
>> > In practice, 'zh' and 'cmn' are best treated as synonyms
>
>
>
>
>> OK, so you're changing the semantics of the tag in practice. I
>don't
>
>
>think
>
>
>> there can be any other interpretation of that statement. I think
>this
>
>
>> subtlety will be utterly lost on anyone who did not participate in
>this
>
>
>> working group. Where else do we give users a choice as far as which
>
>
>> language subtag to use? How am I going to tell people they can't
>use
>
>
>"eng"
>
>
>> but that they have a choice of "zh" or "cmn" when it comes to
>Mandarin?
>
>
>>
>
>
>> > Where backwards compatibility is important, 'zh' is preferred
>over
>
>
>> 'cmn'.
>
>
>> > Content that is not Mandarin (eg Cantonese) should not be tagged
>with
>
>
>> 'zh'
>
>
>
>
>>
>
>
>> Your average developer just gets a language requirement and wants
>to
>
>
>match
>
>
>> it to a code. They may not be interested in assessing their need
>for
>
>
>> backwards compatibility and multiple language modes as part of this
>
>
>task.
>
>
>> This wasn't something that needed to be considered in the past.
> Forcing
>
>
>> the user to use conditional logic to figure out which tag to use is
>not
>
>
>> likely to result in any sort of consistency of tagging and could
>even
>
>
>> prevent the adoption and utility of this work.
>
>
>>
>
>
>>
>
>
>> Personally, if someone in my company came to me and said "what
>
>
>> should I use", I would unconditionally say "zh". If someone were to
>
>
>> hand us 'cmn-CN', I'd say, map that first thing to "zh-CN".
>Backward
>
>
>> compatibility dominates.
>
>
>>
>
>
>> The important thing for us is to get the *new* capability offered
>by
>
>
>> "yue", etc., not to make a distinction between 'zh' and 'cmn' that
>
>
>> would be extremely painful to implement and return no extra value
>
>
>> for our users.
>
>
>>
>
>
>> If you are in an isolated, new environment where you didn't have
>any
>
>
>> backwards compatibility issues, it'd be fine to make a distinction
>
>
>> between 'zh' and 'cmn'. Those environments are going to probably be
>
>
>> rather rare.
>
>
>>
>
>
>>
>
>
>>
>
>
>> Regards,
>
>
>>
>
>
>> Karen Broome
>
>
>>
>
>
>>
>
>
>>
>
>
>> > On Fri, May 2, 2008 at 12:25 PM, <
>[email-masked]
>> wrote:
>
>
>> > It seems like we're suggesting the following:
>
>
>> >
>
>
>> > 1) The shortest tag for written Mandarin is "zh".
>
>
>> > 2) The shortest tag for spoken Mandarin is "cmn" unless of course
>you
>
>
>> feel
>
>
>> > like using "zh" (which, psst, might be a good idea because that's
>how
>
>
>> it's
>
>
>> > been used even if that isn't exactly what it means) and by the
>way,
>
>
>you
>
>
>> > can also use "zh-cmn" or "zh-guoyu."
>
>
>> >
>
>
>> > I think that the shortest tag for Mandarin in each case -- if
>extlang
>
>
>is
>
>
>> > removed and we do not want to change the tag semantics -- should
>be
>
>
>> "cmn."
>
>
>> > If it's not "cmn," you've changed the semantic of the "zh" tag to
>
>
>> > disinclude "yue."  With extlang, you have "zh-cmn" and "zh-yue"
>and
>
>
>the
>
>
>> > semantics of "zh" remain consistent. The argument that an
>overwhelming
>
>
>> > number of documents tagged with "zh" are Mandarin does not sway
>me. I
>
>
>> have
>
>
>> > Cantonese subtitles.
>
>
>> >
>
>
>> > There are differences of opinion on how I should accurately tag
>my
>
>
>> > Taiwanese Mandarin -- this seems to indicate that there is
>something
>
>
>in
>
>
>> > the draft that is ambiguous.
>
>
>> >
>
>
>> > In written form, it seems like the variants of what ISO calls
>Chinese
>
>
>> are
>
>
>> > mutually intelligible (dialects). In spoken form, they are
>languages.
>
>
>> This
>
>
>> > seems to create some odd scenarios and no clear recommendation on
>the
>
>
>> best
>
>
>> > tag to use for these languages. I agree with Shawn that there is
>
>
>> something
>
>
>> > wrong here. I just wish I could better express my reservations.
>
>
>> >
>
>
>> > Regards,
>
>
>> >
>
>
>> > Karen Broome
>
>
>> >
>
>
>> >
>
>
>> >
>
>
>> >
>[email-masked]
> wrote on 05/02/2008 12:03:59 PM:
>
>
>> >
>
>
>> > > Shawn Steele scripsit:
>
>
>> > >
>
>
>> > > > I'm confused by the text surrounding Chinese.  I've been out
>for a
>
>
>> few
>
>
>> > > > weeks so I may have missed some of the discussion.  The draft
>
>
>seems
>
>
>> > > > contradictory, but with the draft as my only guide, my
>
>
>> interpretation
>
>
>> > > > of what I'm reading now for Chinese is:
>
>
>> > >
>
>
>> > > I assume that when you say "3066bis" you actually mean
>"4646bis",
>
>
>and
>
>
>> > are
>
>
>> > > asking about the meaning of the new draft rather than of the
>
>
>existing
>
>
>> > RFC.
>
>
>> > >
>
>
>> > > > * zh should be pretty much assumed to be Mandarin.
>
>
>> > > > * yue should be used if you want Cantonese.
>
>
>> > >
>
>
>> > > Yes.
>
>
>> > >
>
>
>> > > > * zh-cmn should be used if you want to say "don't just assume
>this
>
>
>> is
>
>
>> > > > Mandarin, it really is Mandarin."
>
>
>> > >
>
>
>> > > Rather, the appropriate tag for that meaning in new material
>will be
>
>
>> > > "cmn".  "zh-cmn" becomes a grandfathered form equivalent to
>"cmn".
>
>
>> > >
>
>
>> > > > I get this from the end of 4.1 (choice)
>
>
>> > > >
>
>
>>
>http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-13.html#choice
>:
>
>
>> > > >
>
>
>> > > >   "In general, use the most specific subtag to form the
>language
>
>
>> > > >   tag. However, where the macrolanguage tag has been
>historically
>
>
>> > > >   used to denote a dominant encompassed language, it SHOULD
>be
>
>
>used
>
>
>> > > >   in place of the subtag specific to that encompassed
>language
>
>
>> unless
>
>
>> > > >   it is necessary to clearly distinguish the macrolanguage as
>a
>
>
>> whole
>
>
>> > > >   from that enclosed dominant language variety."
>
>
>> > > >
>
>
>> > > > So this sounds like I'm supposed to use "zh" instead of "cmn"
>
>
>> "unless
>
>
>> > > > it is necessary"
>
>
>> > >
>
>
>> > > Yes, provided that "pretty much assumed" does not mean "must be
>used
>
>
>> > for".
>
>
>> > > There are occasional reasons not to use it.
>
>
>> > >
>
>
>> > > > Earlier in 2. of 4.1 it says:
>
>
>> > > >
>
>
>> > > >   "When labeling content that is unwritten (such as a
>recording of
>
>
>> > human
>
>
>> > > >   speech), the script subtag should not be used, even if the
>
>
>> language
>
>
>> > > >   is customarily written in several scripts. Thus the
>subtitles to
>
>
>a
>
>
>> > > >   movie might use the tag "zh-cmn-Hant" (Chinese, Mandarin,
>
>
>> > Traditional
>
>
>> > > >   script), but the audio track for the same language would be
>
>
>tagged
>
>
>> > > >   "zh-cmn". "
>
>
>> > >
>
>
>> > > Oops, that should be fixed to remove the "zh-" part.
>
>
>> > >
>
>
>> > > Addison, can you make this fix quickly and look for other
>places
>
>
>where
>
>
>> > > zh- or ar- might appear and see if they are now correct?
>
>
>> > >
>
>
>> > > > So apparently it is "necessary" to use a tag for Mandarin in
>some
>
>
>> > > > cases.  This example uses an irregular grandfathered tag
>though,
>
>
>> > > > I don't get that.  This section is "choice", presumably I
>
>
>shouldn't
>
>
>> > > > choose a grandfathered tag.
>
>
>> > >
>
>
>> > > Right.
>
>
>> > >
>
>
>> > > > Later we have:
>
>
>> > > >
>
>
>> > > >   "In particular, the Chinese family of languages call for
>special
>
>
>> > > >   consideration. Because the written form is very similar for
>most
>
>
>> > > >   languages having 'zh' (Chinese) as a macrolanguage (and
>because
>
>
>> > > >   historically subtags for the various encompassed languages
>were
>
>
>> not
>
>
>> > > >   available), languages such as 'yue' (Cantonese) have
>
>
>historically
>
>
>> > > >   used either 'zh' or a tag (now grandfathered) beginning
>with
>
>
>> > > >   'zh'. This means that macrolanguage information can be
>usefully
>
>
>> > > >   applied when searching for content or when providing
>fallbacks
>
>
>in
>
>
>> > > >   language negotiation. For example, the information that
>'yue'
>
>
>has
>
>
>> > > >   a macrolangauge of 'zh' could be used in the Lookup
>algorithm to
>
>
>> > > >   fallback from a request for "yue-Hans-CN" to "zh-Hans-CN"
>
>
>without
>
>
>> > > >   losing the script and region information (even though the
>user
>
>
>did
>
>
>> > > >   not specify "zh-Hans-CN" in their request). "
>
>
>> > > >
>
>
>> > > > This is very different from the Mandarin description in 4.1
>(2.)
>
>
>> > >
>
>
>> > > Not really.  The core idea is that the "zh" tag is
>vague/inclusive
>
>
>and
>
>
>> > can
>
>
>> > > be used for any variety of Chinese.  However, most spoken
>Chinese is
>
>
>> in
>
>
>> > fact
>
>
>> > > Mandarin, and almost all written Chinese is in fact Mandarin,
>so
>
>
>there
>
>
>> > is
>
>
>> > > a tendency to assume that "zh" simply means Mandarin.  In order
>to
>
>
>> > benefit
>
>
>> > > people who must distinguish, the tag "cmn" is introduced to
>mean
>
>
>> > "specifically
>
>
>> > > Mandarin, excluding all non-Mandarin varieties".
>
>
>> > >
>
>
>> > > > So from the text of the draft I'm not entirely certain what
>is
>
>
>> > expected.
>
>
>> > > > As mentioned, I was out, so this may have been discussed and
>I
>
>
>> missed
>
>
>> > > > it, but if I only have the draft as context I would have to
>
>
>assume:
>
>
>> > > >
>
>
>> > > > * zh == cmn == zh-cmn and I need to do lookup for each of
>those
>
>
>> > > > * yue is explicitly Cantonese, but I may need to look at zh
>during
>
>
>> > lookup.
>
>
>> > >
>
>
>> > > Most Mandarin is tagged zh, but some may be cmn == zh-cmn
>instead.
>
>
>> > > Cantonese might be any of zh, zh-yue, or yue.
>
>
>> > >
>
>
>> > > > Can someone clarify what the expectation is?  I would guess
>that
>
>
>by
>
>
>> > > > the table and the macrolanguage SHOULD be used statement
>that:
>
>
>> > > > * Only zh should be used to represent Mandarin, and that
>
>
>> > >
>
>
>> > > Not so.  "zh" should be used unless there is a compelling
>reason to
>
>
>> use
>
>
>> > > "cmn".
>
>
>> > >
>
>
>> > > > * only yue should be used to represent Cantonese, which
>optional
>
>
>> > > fallback lookup to zh if desired.
>
>
>> > >
>
>
>> > > Yes.
>
>
>> > >
>
>
>> > > --
>
>
>> > > Real FORTRAN programmers can program FORTRAN    John Cowan
>
>
>> > > in any language.  --Allen Brown
>[email-masked]
>
>
>> > > _______________________________________________
>
>
>> > > Ltru mailing list
>
>
>> > >
>[email-masked]
>
>
>> > >
>https://www.ietf.org/mailman/listinfo/ltru
>
>
>> > >
>
>
>> >
>
>
>> >
>
>
>> > _______________________________________________
>
>
>> > Ltru mailing list
>
>
>> >
>[email-masked]
>
>
>> >
>https://www.ietf.org/mailman/listinfo/ltru
>
>
>> >
>
>
>> >
>
>
>> >
>
>
>> > --
>
>
>> > Mark
>
>
>
>
>>
>
>
>>
>
>
>>
>
>
>> --
>
>
>> Mark _______________________________________________
>
>
>> Ltru mailing list
>
>
>>
>[email-masked]
>
>
>>
>https://www.ietf.org/mailman/listinfo/ltru
>
>
>
>
>
>
>
>
>
>--
>
>Mark
>

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Edmon Chung" <[email-masked]>
Date: Sat, 3 May 2008 11:45:30 +0800

Your use of "Taiwanese" is a bit confusing.

If you are saying Mandarin spoken in Taiwan.  In that case, I would tag it:

cmn-TW

"Taiwanese" is also a dialect and you can use "min".  Taiwanese Mandarin
would somewhat mean a mixture of Taiwanese and Mandarin?  In that case I
think the tag should be (multiple langauges):

min,cmn

Is it possible to do cmn-min?  It would seem a bit strange but I can
appreciate the possibility, i.e. that the content is a mixture of Taiwanese
and Mandarin.  It is quite common in Taiwan I understand.  I mean mixing it
within sentences and not just some content with distinct portions of
Taiwanese and Mandarin.

Overall, I feel the description for Chinese in the document is acceptable.
The example of "zh-cmn" and "zh-cmn-hant" should be updated to "cmn" and
"cmn-hant" I feel.  I however have a different question which I apologize
might create even more confusion (and potentially a stupid question)... but
nevertheless, how would I tag Pinyin content (a written form of Chinese
using English or Latin alphabets)?  Should it be: en-cmn or latn-cmn or
should it be cmn-en or cmn-latn?  If people feel it is the latter case, then
defintely zh-cmn should always be cmn.  However, if en-cmn or latn-cmn makes
sense, then perhaps there is value for zh-cmn to distinguish between it and
en-cmn.

Edmon

 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Saturday, May 03, 2008 11:14 AM
To: Mark Davis
Cc: [email-masked]; LTRU Working Group
Subject: Re: [Ltru] I'm really confused by chinese in 3066bis

I don't think the average developer will understand the distinction you've
made below. We should have a clear recommendation for languages and dialects
formerly encompassed by "zh".  

I need a tag for spoken Taiwanese Mandarin. I mention that it's spoken only
because I won't consider using any tag with a script in it. I do not believe
the members of this list will agree on what the best tag for this content
is. If this list can't agree on the preferred tag, I fear we've done
something wrong.

Regards,

Karen Broome

[email-masked] wrote: -----

>> > I see it a bit differently:
>
>
>> > yue means specifically Cantonese Chinese, spoken or written (eg
>
>
>yue-HK)
>
>
>> > Cantonese, and others. It thus is formally correct to tag either
>
>
>> > long been used to mean Mandarin only.
>
>
>
>
>> > In practice, 'zh' and 'cmn' are best treated as synonyms
>
>
>
>
>> > On Fri, May 2, 2008 at 12:25 PM, <
>> > It seems like we're suggesting the following:
>
>
>> >
>
>
>> > 1) The shortest tag for written Mandarin is "zh".
>
>
>> > can also use "zh-cmn" or "zh-guoyu."
>
>
>> >
>
>
>> > If it's not "cmn," you've changed the semantic of the "zh" tag to
>
>
>> > Cantonese subtitles.
>> > the draft that is ambiguous.
>
>
>> >
>
>
>> > tag to use for these languages. I agree with Shawn that there is
>
>
>> something
>
>
>> > wrong here. I just wish I could better express my reservations.
>
>
>> >
>
>
>> > Regards,
>
>
>> >
>
>
>> > Karen Broome
>
>
>> >
>
>
>> >
>
>
>> >
>
>
>> > 
>[email-masked]
>> > > Shawn Steele scripsit:
>> > > > weeks so I may have missed some of the discussion.  The draft
>
>
>seems
>
>
>> > > > contradictory, but with the draft as my only guide, my
>
>
>> interpretation
>
>
>> > > > of what I'm reading now for Chinese is:
>
>
>> > >
>
>
>> > > asking about the meaning of the new draft rather than of the
>
>
>existing
>
>
>> > RFC.
>
>
>> > >
>
>
>> > > > * zh should be pretty much assumed to be Mandarin.
>
>
>> > > > * yue should be used if you want Cantonese.
>
>
>> > >
>
>
>> > > Yes.
>
>
>> > >
>
>
>> > > > Mandarin, it really is Mandarin."
>
>
>> > >
>
>
>> > > > I get this from the end of 4.1 (choice)
>
>
>> > > >
>
>
>> 
>> > > >   from that enclosed dominant language variety."
>
>
>> > > >
>
>
>> > > > So this sounds like I'm supposed to use "zh" instead of "cmn"
>
>
>> "unless
>
>
>> > > > it is necessary"
>
>
>> > >
>
>
>> > for".
>> > > There are occasional reasons not to use it.
>
>
>> > >
>
>
>> > > > Earlier in 2. of 4.1 it says:
>
>
>> > > >
>
>
>> > human
>> > > >   speech), the script subtag should not be used, even if the
>
>
>> language
>
>
>> > > >   movie might use the tag "zh-cmn-Hant" (Chinese, Mandarin,
>
>
>> > Traditional
>
>
>> > > >   script), but the audio track for the same language would be
>
>
>tagged
>
>
>> > > >   "zh-cmn". "
>
>
>> > >
>
>
>> > > Oops, that should be fixed to remove the "zh-" part.
>
>
>> > >
>
>
>> > > zh- or ar- might appear and see if they are now correct?
>
>
>> > >
>
>
>> > > > I don't get that.  This section is "choice", presumably I
>
>
>shouldn't
>
>
>> > > > choose a grandfathered tag.
>
>
>> > >
>
>
>> > > Right.
>
>
>> > >
>
>
>> > > > Later we have:
>
>
>> > > >
>
>
>> > > >   available), languages such as 'yue' (Cantonese) have
>
>
>historically
>
>
>> > > >   fallback from a request for "yue-Hans-CN" to "zh-Hans-CN"
>
>
>without
>
>
>> > > >   not specify "zh-Hans-CN" in their request). "
>
>
>> > > >
>
>
>> > can
>> > fact
>> > benefit
>> > "specifically
>> > > Mandarin, excluding all non-Mandarin varieties".
>
>
>> > >
>
>
>> > expected.
>> > > > it, but if I only have the draft as context I would have to
>
>
>assume:
>
>
>> > > >
>
>
>> > lookup.
>> > > Cantonese might be any of zh, zh-yue, or yue.
>
>
>> > >
>
>
>> > > > * Only zh should be used to represent Mandarin, and that
>
>
>> > >
>
>
>> > > fallback lookup to zh if desired.
>
>
>> > >
>
>
>> > > Yes.
>
>
>> > >
>
>
>> > > --
>
>
>> > > Real FORTRAN programmers can program FORTRAN    John Cowan
>
>
>> > > in any language.  --Allen Brown                 
>[email-masked]
>
>

---

From: John Cowan <[email-masked]>
Date: Sat, 3 May 2008 14:29:28 -0400

[email-masked] scripsit:

> I need a tag for spoken Taiwanese Mandarin. I mention that it's spoken
> only because I won't consider using any tag with a script in it. I do
> not believe the members of this list will agree on what the best tag
> for this content is.  If this list can't agree on the preferred tag,
> I fear we've done something wrong.

I said zh-TW was appropriate for that function, particularly when the
context eliminates the possibility that zh-TW is being used to represent
written language.  No one has contradicted me yet.

-- 
Not to perambulate                 John Cowan <[email-masked]>
    the corridors                  http://www.ccil.org/~cowan
during the hours of repose
    in the boots of ascension.       --Sign in Austrian ski-resort hotel
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Sat, 3 May 2008 21:31:03 -0700

No, you cannot use "min" to refer to a Chinese language: "min" is a Philippine language, Minangkabau. The appropriate ID would be "nan".

It is not possible to create a tag "cmn-min" or "cmn-nan". You could, perhaps, tag content with two (or more) tags, application allowing: cmn; nan.

The tag "zh-Latn" would mean "Chinese written in Latin script", and could be used for Chinese written in Pinyin. Similarly, "cmn-Latn" could be used to indicate Mandarin written in Pinyin.

The tag "zh-cmn" is a valid, grandfathered tag, but with the publication of 4646bis "cmn" would also be valid and would have equivalent meaning; at that point, "zh-cmn" should be deprecated in favour of "cmn". The difficult question is whether authors should henceforth be recommended to use "cmn" for Mandarin content or continue to tag Chinese content (which usually is Mandarin) as "zh".

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Edmon Chung
Sent: Friday, May 02, 2008 8:46 PM
To: [email-masked]; 'Mark Davis'
Cc: 'LTRU Working Group'
Subject: Re: [Ltru] I'm really confused by chinese in 3066bis

cmn-TW

"Taiwanese" is also a dialect and you can use "min".  Taiwanese Mandarin would somewhat mean a mixture of Taiwanese and Mandarin?  In that case I think the tag should be (multiple langauges):

min,cmn

Is it possible to do cmn-min?  It would seem a bit strange but I can appreciate the possibility, i.e. that the content is a mixture of Taiwanese and Mandarin.  It is quite common in Taiwan I understand.  I mean mixing it within sentences and not just some content with distinct portions of Taiwanese and Mandarin.

Overall, I feel the description for Chinese in the document is acceptable.  The example of "zh-cmn" and "zh-cmn-hant" should be updated to "cmn" and "cmn-hant" I feel.  I however have a different question which I apologize might create even more confusion (and potentially a stupid question)... but nevertheless, how would I tag Pinyin content (a written form of Chinese using English or Latin alphabets)?  Should it be: en-cmn or latn-cmn or should it be cmn-en or cmn-latn?  If people feel it is the latter case, then defintely zh-cmn should always be cmn.  However, if en-cmn or latn-cmn makes sense, then perhaps there is value for zh-cmn to distinguish between it and en-cmn.

Edmon

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, May 03, 2008 11:14 AM
To: Mark Davis
Cc: [email-masked]; LTRU Working Group
Subject: Re: [Ltru] I'm really confused by chinese in 3066bis

Regards,

Karen Broome

---

From: Peter Constable <[email-masked]>
Date: Sat, 3 May 2008 21:38:22 -0700

For Karen's particular application, I wouldn't be surprised (of course, she can clarify) if she needed to distinguish "Mandarin as spoken in Taiwan" from "Min Nan as spoken in Taiwan" or "Hakka as spoken in Taiwan". If so, then "zh-TW" would not really be adequate for the first.

Peter

> -----Original Message-----
> John Cowan
> Sent: Saturday, May 03, 2008 11:29 AM
> Cc: LTRU Working Group

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 4 May 2008 23:36:54 +0200

On Sat, May 03, 2008 at 09:31:03PM -0700,
 Peter Constable <[email-masked]> wrote 
 a message of 2989 lines which said:

> The tag "zh-Latn" would mean "Chinese written in Latin script", and
> could be used for Chinese written in Pinyin.

I'm not sure. There are other transliteration systems in Latin. Until
very recently, chinese names in french books and newspapers were
transcribed with another system. 

You can use Arabic as an example: there is no "pinyin", no standard
transliteration so ar-Latn is not specific enough.

---

From: "Mark Davis" <[email-masked]>
Date: Sun, 4 May 2008 15:44:36 -0700

Chinese written in Pinyin can be tagged "zh-Latn", so it is true as Peter
says that it "could be used for Chinese written in Pinyin".

It is also true that that is not sufficient to tell between Pinyin and (say)
WG; we need to register some additional variant tags for different
transliteration methods.

Mark

---

From: Peter Constable <[email-masked]>
Date: Mon, 5 May 2008 18:03:13 -0700

I recognize that there are alternate transliteration systems. That is precisely why I said *could* be used rather than *should* be used.

Peter

> From: Stephane Bortzmeyer [mailto:[email-masked]]
> Sent: Sunday, May 04, 2008 2:37 PM
> To: Peter Constable
> Cc: 'LTRU Working Group'
> Subject: Pinyin in language tags (Was: I'm really confused by chinese
> in 3066bis
>