Subject: Re: [Ltru] I'm really confused by chinese in 3066bis

From: "Doug Ewell" <[email-masked]>
Date: Wed, 7 May 2008 20:32:21 -0600

Mark Davis <mark dot davis at icu dash project dot org> wrote:

> Nothing better to start with than the Cantonese Wikipedia article on 
> Cantonese: 
> <http://zh-yue.wikipedia.org/wiki/??<http://zh-yue.wikipedia.org/wiki/%E7%B2%B5%E8%AA%9E>>.
> Similarly, 
> <http://zh-yue.wikipedia.org/wiki/??<http://zh-yue.wikipedia.org/wiki/%E9%A6%99%E6%B8%AF>>,
> <http://zh-yue.wikipedia.org/wiki/Unicode>, and pretty much everything 
> else in the Cantonese Wikipedia.

It's really a shame, isn't it, that Wikipedia adopted the "zh-yue" 
extlang convention for naming their subdomains.  They're not the only 
ones who will need to be re-educated.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Shawn Steele <[email-masked]>
Date: Wed, 7 May 2008 20:15:02 -0700

> ones who will need to be re-educated.

I don't know what else they could've chosen.  At the time they only had 4646 to look at, which would easily lead one to believe that zh-yue might be the better long-term option.

- Shawn

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 7 May 2008 20:26:19 -0700

Zh-yue is valid... and the only thing available until we finish our work. Doug's right it's a shame. But it is also our fault in many ways :-).

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Shawn Steele
> Sent: Wednesday, May 07, 2008 8:15 PM
> To: Doug Ewell; LTRU Working Group
> Subject: Re: [Ltru] I'm really confused by chinese in 3066bis
> Importance: Low
>
> > > <http://zh-yue.wikipedia.org/wiki/??<http://zh-
> yue.wikipedia.org/wiki/%E7%B2%B5%E8%AA%9E>>.
> > > Similarly,
> > > <http://zh-yue.wikipedia.org/wiki/??<http://zh-
> yue.wikipedia.org/wiki/%E9%A6%99%E6%B8%AF>>,
> I don't know what else they could've chosen.  At the time they only had
> 4646 to look at, which would easily lead one to believe that zh-yue
> might be the better long-term option.
>
> - Shawn

---

From: John Cowan <[email-masked]>
Date: Thu, 8 May 2008 00:54:34 -0400

> ones who will need to be re-educated.

It's valid, it remains valid.

-- 
Schlingt dreifach einen Kreis vom dies!    John Cowan <[email-masked]>
Schliesst euer Aug vor heiliger Schau,     http://www.ccil.org/~cowan
Denn er genoss vom Honig-Tau,
Und trank die Milch vom Paradies.            -- Coleridge (tr. Politzer)
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 8 May 2008 08:04:47 +0100

Doug wrote:

> extlang convention for naming their subdomains.  They're not
> the only ones who will need to be re-educated.

It is hardly surprising that wikipedia adopted extlang as the "noise" coming
out of this WG for the past few years has been that the syntax was
absolutely stable!

Best

Debbie

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 08 May 2008 03:32
> To: LTRU Working Group
> <http://zh-yue.wikipedia.org/wiki/Unicode>, and
> > pretty much everything else in the Cantonese Wikipedia.
>
> extlang convention for naming their subdomains.  They're not
> the only ones who will need to be re-educated.
>
> --
> http://www.alvestrand.no/mailman/listinfo/ietf-languages  ^
>

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 8 May 2008 08:46:15 -0700

Um.. they adopted a registered (grandfathered) tag from the 3066 era.

Addison

Addison Phillips

> Debbie Garside
> Sent: Thursday, May 08, 2008 12:05 AM
> To: 'Doug Ewell'; 'LTRU Working Group'

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 8 May 2008 17:01:12 +0100

> Um.. they adopted a registered (grandfathered) tag from the 3066 era.

/blush/ :-) I didn't know that!

But it doesn't change the fact that the syntax that was supposed to be
completely stable and which would have kept the tag "current" has, in
effect, been scuppered!  or do I have that wrong too?

Best
Debbie

> From: Phillips, Addison [mailto:[email-masked]]
> Sent: 08 May 2008 16:46
> To: [email-masked]; 'Doug Ewell'; 'LTRU Working Group'
> Subject: RE: [Ltru] I'm really confused by chinese in 3066bis
>
> > From: [email-masked] [mailto:[email-masked]]
> On Behalf
> > Of Debbie Garside
> > > extlang convention for naming their subdomains.  They're not the
> > > only ones who will need to be re-educated.
> >
> > It is hardly surprising that wikipedia adopted extlang as
> the "noise"
> > coming
> > > From: [email-masked]
> [mailto:[email-masked]] On Behalf
> > > Of Doug Ewell
> > > Sent: 08 May 2008 03:32
> > > To: LTRU Working Group
> > > > Nothing better to start with than the Cantonese
> Wikipedia article
> > on
> > > > Cantonese:
> > > >
> > > extlang convention for naming their subdomains.  They're not the
> > > only ones who will need to be re-educated.
> > >
> > > --

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 8 May 2008 09:08:05 -0700

Registered tags are valid forever, regardless of the choices we make now (or later). Their choice might be deprecated or be assigned a preferred value, but it will always be valid. For that matter, "no-nyn" is a valid tag for "nn". It's also been deprecated for years.

Addison

Addison Phillips

> From: Debbie Garside [mailto:[email-masked]]
> Sent: Thursday, May 08, 2008 9:01 AM
> To: Phillips, Addison; 'Doug Ewell'; 'LTRU Working Group'

---

From: John Cowan <[email-masked]>
Date: Thu, 8 May 2008 12:31:47 -0400

> effect, been scuppered!  or do I have that wrong too?

No, we just decided not to extend the valid (as opposed to well-formed)
syntax in a certain direction that we expected to, leaving zh-yue 
still well-formed and valid and grandfathered, rather than redundant.

-- 
All Norstrilians knew what laughter was:        John Cowan
it was "pleasurable corrigible malfunction".    [email-masked]
        --Cordwainer Smith, Norstrilia
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 8 May 2008 17:45:33 +0100

John wrote:

> No, we just decided not to extend the valid (as opposed to
> well-formed) syntax in a certain direction that we expected
> to, leaving zh-yue still well-formed and valid and
> grandfathered, rather than redundant.

I fear we are quibbling here! :-)

In essence, Wikipedia may have devised an entire system based around the
syntax **(*)-*** based on their adoption of zh-yue and the supporting
information from RFC4646 that this syntax was valid, current and stable.  I
am not saying that they have but we don't know that a number of
organizations haven't.

best

Debbie

> From: John Cowan [mailto:[email-masked]]
> Sent: 08 May 2008 17:32
> To: Debbie Garside
> Cc: 'Phillips, Addison'; 'Doug Ewell'; 'LTRU Working Group'
> No, we just decided not to extend the valid (as opposed to
> well-formed) syntax in a certain direction that we expected
> to, leaving zh-yue still well-formed and valid and
> grandfathered, rather than redundant.
>
> --

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 8 May 2008 22:11:17 -0600

Addison Phillips <addison at amazon dot com> wrote:

>> It is hardly surprising that wikipedia adopted extlang as the "noise" 
>> coming out of this WG for the past few years has been that the syntax 
>> was absolutely stable!
>

They also used "roa-rup" for Aromanian (should be just "rup"), as well 
as some other tags with extlang that are incorrect for other reasons:

"cbk-zam" for Zamboanga Chavacano
(should be just "cbk"; "zam" is Miahuatlán Zapotec in 639-3)

"bat-smg" for Samogitian
(no tag; dialect of Lithuanian; "smg" is Simbali in 639-3)

"map-bms" for Banyumasan
(no tag; dialect of Javanese; "bms" is Bilma Kanuri in 639-3)

"fiu-vro" for Võro
(dialect of Estonian or independent language? could be "fiu" or "est"; 
"vro" is unassigned even in 639-3)

Guys, STOP making up your own three-letter language tags!  Perhaps this 
is a greater risk to the success of language tagging than some others we 
have been laboring over.

There are other examples among the Wikipedias of non-well-formed tags 
("zh-classical"), well-formed but invalid tags ("simple" for the loosely 
defined "Simple English"), and valid but misapplied tags ("als" for 
Alemannic).  Deserving of special mention is "nrm" for Norman (which has 
no tag in 639-*; "nrm" is Narom is 639-3), which not only is used as the 
domain for the Norman WP, but is also claimed by the English WP as the 
639-3 code for Norman!

Admittedly there are fewer examples of extlangs in localized Wikipedias 
than I had anticipated.