Subject: [Ltru] rfc4646bis-18 section 3.1.2 "at least one"

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 2 Nov 2008 02:33:29 -0700

Hi -

As a technical contributor...

In section 3.1.2 on Page 24:
   Each record MUST contain at least one of each of the following
   fields:

It seems that the first few (Type, and Subtag or Tag) should
occur exactly once, right?

This is not a showstopper, but I'm sure we'll hear about it
from whoever our next reviewer is.

Randy

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Sun, 2 Nov 2008 16:18:33 -0800

(editor hat OFF)

Why? It is a true statement. Perhaps it is not a complete statement to require at least one (and then later restrict some to exactly one). How would you address it? Should I make one block of exactly-ones and then include the one "at least one" case in a separate blocking following?

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Sunday, November 02, 2008 1:33 AM
> To: LTRU Working Group
> Subject: [Ltru] rfc4646bis-18 section 3.1.2 "at least one"
> 
> Hi -
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 2 Nov 2008 18:58:02 -0800

Hi -

> From: "Phillips, Addison" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Sunday, November 02, 2008 4:18 PM
> Subject: RE: [Ltru] rfc4646bis-18 section 3.1.2 "at least one"
>
> (editor hat OFF)
> 
> Why? It is a true statement. Perhaps it is not a complete statement
> to require at least one (and then later restrict some to exactly one).
> How would you address it? Should I make one block of exactly-ones
> and then include the one "at least one" case in a separate blocking following?
...

This seems very reasonable to me.  As I said before, it's not a showstopper,
but I'm sure other reviewers would have a similar reaction.

Randy

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 4 Nov 2008 13:55:08 -0800

+0 (I don't care either way).
Mark