Subject: Re: [Ltru] Issue #9: record ordering instructions

From: CE Whitehead <[email-masked]>
Date: Wed, 11 Feb 2009 10:30:39 -0500

Hi, all.  I am sorry I could not do a better job of revising this sentence.  But I'll try one more time.
 
> From: "Randy Presuhn" <randy_presuhn at mindspring.com> 
> To: <ltru at ietf.org> 
> Date: Tue, 10 Feb 2009 16:36:13 -0800 
>> From: "Phillips, Addison" <addison at amazon.com>>> To: "Randy Presuhn" <randy_presuhn at mindspring.com>; <ltru at ietf.org>>> Sent: Tuesday, February 10, 2009 3:50 PM>> Subject: RE: [Ltru] Issue #9: record ordering instructions...>> If we really must make such a minor edit, I would propose:>> -->> IANA will extract the record from the form and place the inserted or modified record into the appropriate section of the languagesubtag registry, grouping the records by their 'Type' field. Inserted records can be placed anywhere within the appropriate section;there is no guarantee that the registry's records are in any particular order other than their being grouped together by 'Type'.Modified records overwrite the record they replace.> -->>> This would make clear that it is the registry's overall records (not just the >>inserted records) are meant; that there is noguarantee about ordering; and that the Type groupings is what was meant by "appropriate section".>
Addison this is very clear; however you are right; 'correct English grammar' tends to be a bit Latinate (& that is exactly what the use of the gerund "grouping" is here).  I do agree with Randy that there is a need for a fix.   Addison's rewrite is more informative, but Randy's rewrite gave me an idea about what to do with "grouping." 
 
What about the following text (I dispensed with the gerund & used a simple passive verb)?:
 
"IANA will extract the record from the form and place the inserted or modified record into the appropriate section of the languagesubtag registry, grouping the records by their 'Type' field. Inserted records can be placed anywhere within the appropriate section;there is no guarantee that the registry's records will be placed in any particular order except that they will always be grouped by 'Type.'Modified records overwrite the record they replace."

{The above is wordy but explicit; I don't normally go for the passive but it's o.k. sometimes; here it's not being used to get around to say who is doing something, but rather to place the focus on the records--which is o.k. One more alternative that is a bit shorter:
 
IANA will extract the record from the form and place the inserted or modified record into the appropriate section of the languagesubtag registry, grouping the records by their 'Type' field.  Otherwise the records will not be arranged in any particular order:  inserted records can be placed anywhere within the appropriate section (that is with other records of the same 'Type').Modified records overwrite the record they replace."
}

--C. E. Whitehead
[email-masked] 
 
>> I still propose that we not make this edit, since it really isn't necessary....> Addison's proposed text is also ok with me.  Although I understand thegrammatical problem with the existing text, I, too, am not fullyconvinced that there is a *need* for a fix.  This is the kind ofproblem that most native speakers would probably not even noticein spoken English, and would catch in written material only uponvery careful examination.  My reason for posting was to make surethat Edith's original comment was addressed, and not just myside-remark.Randy

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 11 Feb 2009 18:26:24 -0700

CE Whitehead <cewcathar at hotmail dot com> wrote:

>> IANA will extract the record from the form and place the inserted or 
>> modified record into the appropriate section of the language subtag 
>> registry, grouping the records by their 'Type' field. Inserted 
>> records can be placed anywhere within the appropriate section; there 
>> is no guarantee that the registry's records are in any particular 
>> order other than their being grouped together by 'Type'. Modified 
>> records overwrite the record they replace.
>
> "IANA will extract the record from the form and place the inserted or 
> modified record into the appropriate section of the language subtag 
> registry, grouping the records by their 'Type' field. Inserted records 
> can be placed anywhere within the appropriate section; there is no 
> guarantee that the registry's records will be placed in any particular 
> order except that they will always be grouped by 'Type.' Modified 
> records overwrite the record they replace."

I like this change; "except that" flows better than "other than."

> IANA will extract the record from the form and place the inserted or 
> modified record into the appropriate section of the language subtag 
> registry, grouping the records by their 'Type' field.  Otherwise the 
> records will not be arranged in any particular order:  inserted 
> records can be placed anywhere within the appropriate section (that is 
> with other records of the same 'Type'). Modified records overwrite the 
> record they replace."

This is too much of a rewording, and the parenthetical phrase slowed me 
down, negating the benefit of fewer words.  Best to stick with the first 
rewording, if any.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ