Subject: [Ltru] Edith Whitehead's proposed editorial changes to 4646bis i-d (was Re: Editor's copy of draft-4646bis updated...)

From: CE Whitehead <[email-masked]>
Date: Sat, 7 Feb 2009 10:57:00 -0500

Hi, sorry for posting these at this date (this draft has lengthened substantially because I was involved some in the 2008 editing at ietf??)
 
(I had the idea from a previous message of Randy's that I could still post my editorial comments although they might not all be considered.)
 
On the "different to"/"different from"/"different than" issue (4.1, par 3) sorry for not noticing that "different to" is British English (obviously I don't speak that & saw this usage as an error); however "different from" is safest according to:
http://www.bartleby.com/68/37/1837.html
 
You do absolutely need to change 4.1 paragraph 6 item 1 second bullet though & that's one reason I decided to send these.
 
(I also disagree with Randy's editing in one case; I do think you need to change 5.1, paragraph 4, sentence 2; because grammatically "grouping" needs a subject antecedent here and does not have one.  However readers may figure out what is meant here because this is a common grammatical error.)

. . . 
> As a technical contributor...>> From: "Edith Whitehead" <quaiouestenglish at yahoo.com>>> Sent: Friday, February 06, 2009 9:31 AM> ! 4.1   par 3>> { ORIGINAL TEXT }>> "   Standards, protocols, and applications that reference this document>    normatively but apply different rules to the ones given in this>    section MUST specify how language tag selection varies from the>    guidelines given here.">> { ! CORRECTION:  CHANGE:  "different rules to the . . . " > "rules different than those . . . ">  you can say :  "rules different than,"  "rules different from,"  or "different rules than,"> but where do you get "different rules to"?  It's not English.> Nor is "different rules than".  If folks feel a need for a change,> "rules different from" would be more acceptible.
"different from" is fine; "different to" turns out to be British English (my mistake here).  "Different from" is safe in all usages apparently....>>  ?? Also, CHANGE: "apply" to "adhere to" or simply "follow"  (I like "adhere to" better;>> "apply" might be a word you use with applications and rules but I do not use it with anything but formatting,>> "formatting is applied . . ."> Disagree.  I see no need for this change.O.k....>>  ? Also, CHANGE:  "the ones" to "those" (I think the the text is more cohesive with 'those'>> because it refers back to 'the rules'--this is an idea that Halliday has about cohesion too) }> Disagree.  I see no need for this change.O.k.> "Standards, protocols, and applications that reference this document>   normatively but adhere to rules different than those given in this section . . . "> This proposed usage of "than" is simply wrong, and I cannot support it....>> ! 4.1 par 6 item 1 second bullet>>>> {ORIGINAL TEXT }>> " Note that some subtag sequences might not represent the>>           language a casual user might expect, especially if when>>           relying on the subtag's description in the registry. ">>>> {! CORRECTION:  delete either "if" or "when" as "if when" seems a bit redundant, right? }> Yup.  However, the entire phrase "especially...registry" is not helpful> to the sense of the paragraph in question.  Consequently, I think> that if a change is to be made, it would be better to delete> everything from the comma to the word "registry".
Fine.  You've got to make a change here.> ...> ! 4.3 Par 1 Bullet 1 last sentence>> {ORIGINAL TEXT}>    "o  A language priority list [RFC4647] describing a user's language>        preferences.  This is a (possibly weighted) list of potentially->       unrelated varieties, expressing a preference, rather than as a>       declaration about actual content."> ...> "This is a (possibly weighted) list of potentially unrelated varieties,>  expressing a preference, rather than a declaration of actual content."> Yup.  However, this sentence is entirely redundant, so if there is going> to be a change, I'd rather just delete it.Unsure.>> ! 5.1, par 4, sentence 2>>>> { ORIGINAL TEXT }>>>> " Inserted records can be placed anywhere in the appropriate section; there is>>   no guarantee of the order of the records beyond grouping them together by 'Type'.">> ...>> "Inserted records can be placed anywhere in the appropriate section; there>> is no guarantee of their order beyond their being grouped together by 'Type'.">Ok.  This "can" probably should be a MAY, but it's not a big deal and it's not>worth changing.The problem is I don't know here who is "grouping" the records; there is no subject antecendent for the word "grouping" and it needs one.
Anyway . . . it's not grammatically correct as it is now but readers may figure it out....>> ! 4.4.2 Par 1, last sentence>>>> { ORIGINAL TEXT }>>>> "  Such truncation MUST NOT>>    permit a subtag to be chopped off in the middle or the formation of>>    invalid tags (for example, one ending with the "-" character)."...>> "Such truncation MUST NOT permit the formation of invalid tags-->> either by chopping a subtag off in the middle, or by leaving a singleton without any subtag."> Disagree.  The original text is gramamtically and technically correct.> The proposed text changes the meaning in a subtly  incompatible way.> Consider the case where chopping a subtag in the middle does *not*> result in an invalid tag, but instead produces a tag containing a subtag> not present in the original.
Hmm? O.k. > ....> ? 3.5  "Registration Procedure for Subtags" Par 4, 2nd sentence>> { ORIGINAL TEXT }>> " Note that each response is not limited in>    size so that the request can adequately describe the registration.">> {COMMENTS: the word "response" is not clear here, and this sentence> is awkward and unclear as a whole.I think the sentence is abundantly clear in context, and see no need for change....> ? 3.7 par 4 & 5...> {COMMENT:  the two maintaining authorities, IANA, and the individual> authority, might be confused by readers here??...> Given the topic of the section, I find it difficult to imagine such confusion> taking place.O.k. I suggested this change because people read these fast and want things to be ultra-clear but fine at this date; no need to clean it up further at this date . . .The rest of my changes were not changes I considered that important & I do see your point in many case.

Thanks.
 
--C. E. Whitehead
[email-masked]

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 7 Feb 2009 10:53:14 -0800

Hi -

As co-chair...

> From: "CE Whitehead" <[email-masked]>
> To: <[email-masked]>
> Sent: Saturday, February 07, 2009 7:57 AM
> Subject: [Ltru] Edith Whitehead's proposed editorial changes to 4646bis i-d (was Re: Editor's copy of draft-4646bis updated...)
...
> (I had the idea from a previous message of Randy's that I could still
> post my editorial comments although they might not all be considered.)
...

A reasonable (and correct) surmise.

Randy

---

From: CE Whitehead <[email-masked]>
Date: Sat, 7 Feb 2009 16:58:08 -0500

Hi.> Hi -

>> From: "CE Whitehead" <cewcathar at hotmail.com>
>> To: <ltru at ietf.org>

>Randy
Thanks very much for letting me comment.I do hope the real grammatical errors can be corrected4.1 par 6 item 1 second bullet4.3 par 1 bullet 1 last sentence (remove "as")
(I wish you'd consider 5.1 par 4 sentence 2; it's up to Randy of course; also 4.1 par 3  ["different rules to" > "rules different from"] if we want to make the usage country neutral.
(it seems that the 13th hour last call for this took place in November:
http://www.ietf.org/mail-archive/web/ltru/current/msg11859.htmlI made comments right after that--a bit late--& was told at that time that only typos, spelling errors, obvious errors in grammar could be considered at that point;
I had not read the draft in full carefully at that point (I had to print a copy).
I should have submitted my major changes as soon as I did but somehow was expecting a new ietf last call this year
& finally asked permission to submit these; my mistake).
 --C. E. Whitehead
[email-masked]

From: [email-masked]: [email-masked]: [Ltru] Edith Whitehead's proposed editorial changes to 4646bis i-d (was Re: [Ltru] Editor's copy of draft-4646bis updated...)Date: Sat, 7 Feb 2009 10:57:00 -0500

Hi, sorry for posting these at this date (this draft has lengthened substantially because I was involved some in the 2008 editing at ietf??) (I had the idea from a previous message of Randy's that I could still post my editorial comments although they might not all be considered.) On the "different to"/"different from"/"different than" issue (4.1, par 3) sorry for not noticing that "different to" is British English (obviously I don't speak that & saw this usage as an error); however "different from" is safest according to:http://www.bartleby.com/68/37/1837.html You do absolutely need to change 4.1 paragraph 6 item 1 second bullet though & that's one reason I decided to send these. (I also disagree with Randy's editing in one case; I do think you need to change 5.1, paragraph 4, sentence 2; because grammatically "grouping" needs a subject antecedent here and does not have one.  However readers may figure out what is meant here because this is a common grammatical error.)   . . . > As a technical contributor...>> From: "Edith Whitehead" <quaiouestenglish at yahoo.com>>> Sent: Friday, February 06, 2009 9:31 AM> ! 4.1   par 3>> { ORIGINAL TEXT }>> "   Standards, protocols, and applications that reference this document>    normatively but apply different rules to the ones given in this>    section MUST specify how language tag selection varies from the>    guidelines given here.">> { ! CORRECTION:  CHANGE:  "different rules to the . . . " > "rules different than those . . . ">  you can say :  "rules different than,"  "rules different from,"  or "different rules than,"> but where do you get "different rules to"?  It's not English.> Nor is "different rules than".  If folks feel a need for a change,> "rules different from" would be more acceptible."different from" is fine; "different to" turns out to be British English (my mistake here).  "Different from" is safe in all usages apparently....>>  ?? Also, CHANGE: "apply" to "adhere to" or simply "follow"  (I like "adhere to" better;>> "apply" might be a word you use with applications and rules but I do not use it with anything but formatting,>> "formatting is applied . . ."> Disagree.  I see no need for this change.O.k....>>  ? Also, CHANGE:  "the ones" to "those" (I think the the text is more cohesive with 'those'>> because it refers back to 'the rules'--this is an idea that Halliday has about cohesion too) }> Disagree.  I see no need for this change.O.k.> "Standards, protocols, and applications that reference this document>   normatively but adhere to rules different than those given in this section . . . "> This proposed usage of "than" is simply wrong, and I cannot support it....>> ! 4.1 par 6 item 1 second bullet>>>> {ORIGINAL TEXT }>> " Note that some subtag sequences might not represent the>>           language a casual user might expect, especially if when>>           relying on the subtag's description in the registry. ">>>> {! CORRECTION:  delete either "if" or "when" as "if when" seems a bit redundant, right? }> Yup.  However, the entire phrase "especially...registry" is not helpful> to the sense of the paragraph in question.  Consequently, I think> that if a change is to be made, it would be better to delete> everything from the comma to the word "registry".Fine.  You've got to make a change here.> ...> ! 4.3 Par 1 Bullet 1 last sentence>> {ORIGINAL TEXT}>    "o  A language priority list [RFC4647] describing a user's language>        preferences.  This is a (possibly weighted) list of potentially->       unrelated varieties, expressing a preference, rather than as a>       declaration about actual content."> ...> "This is a (possibly weighted) list of potentially unrelated varieties,>  expressing a preference, rather than a declaration of actual content."> Yup.  However, this sentence is entirely redundant, so if there is going> to be a change, I'd rather just delete it.Unsure.>> ! 5.1, par 4, sentence 2>>>> { ORIGINAL TEXT }>>>> " Inserted records can be placed anywhere in the appropriate section; there is>>   no guarantee of the order of the records beyond grouping them together by 'Type'.">> ...>> "Inserted records can be placed anywhere in the appropriate section; there>> is no guarantee of their order beyond their being grouped together by 'Type'.">Ok.  This "can" probably should be a MAY, but it's not a big deal and it's not>worth changing.The problem is I don't know here who is "grouping" the records; there is no subject antecendent for the word "grouping" and it needs one.Anyway . . . it's not grammatically correct as it is now but readers may figure it out....>> ! 4.4.2 Par 1, last sentence>>>> { ORIGINAL TEXT }>>>> "  Such truncation MUST NOT>>    permit a subtag to be chopped off in the middle or the formation of>>    invalid tags (for example, one ending with the "-" character)."...>> "Such truncation MUST NOT permit the formation of invalid tags-->> either by chopping a subtag off in the middle, or by leaving a singleton without any subtag."> Disagree.  The original text is gramamtically and technically correct.> The proposed text changes the meaning in a subtly  incompatible way.> Consider the case where chopping a subtag in the middle does *not*> result in an invalid tag, but instead produces a tag containing a subtag> not present in the original.Hmm? O.k. > ....> ? 3.5  "Registration Procedure for Subtags" Par 4, 2nd sentence>> { ORIGINAL TEXT }>> " Note that each response is not limited in>    size so that the request can adequately describe the registration.">> {COMMENTS: the word "response" is not clear here, and this sentence> is awkward and unclear as a whole.I think the sentence is abundantly clear in context, and see no need for change....> ? 3.7 par 4 & 5...> {COMMENT:  the two maintaining authorities, IANA, and the individual> authority, might be confused by readers here??...> Given the topic of the section, I find it difficult to imagine such confusion> taking place.O.k. I suggested this change because people read these fast and want things to be ultra-clear but fine at this date; no need to clean it up further at this date . . .The rest of my changes were not changes I considered that important & I do see your point in many case.  Thanks. --C. E. [email-masked]