Subject: Re: [Ltru] Preferred-Value for YU?

From: CE Whitehead <[email-masked]>
Date: Thu, 5 Feb 2009 12:46:13 -0500

Hi, all!
 
I too have a problem with words like 'will' (in the selection Addison has cited here). Since we have keywords like 'must,' 'should,' and 'may,' I think we should stick to them here for clarity.
 For consistency we should stick with 'must' or 'should' in both sentences I think (it seems to be either a 'must' or a 'should'.   
 
Now, regarding the 'may' sentence, and Addison's proposed change to it:
 
"Changes to one subtag MAY affect other subtags as well"
Addison suggested:
 
> The problem isn't that is says "MAY"... But to have something say "MAY" enclose an example that says "MUST" makes no sense. It isn't "MAY" if you're required to do it. 
However, I do not see a problem or conflict here.  The sentences with may and those with 'will' or 'must' are referring to different concepts--the first refers to what 'may' or 'can' or 'might' happen; the second to what users/ietf 'will' or 'must' do (because of changes that 'may' or 'can' happen).  
 
But, I'm not sure if a keyword should be used here at all, because yes, having the keyword 'may' here might cause confusion  (if 'may' is used as a keyword for what users are or ietf is permitted to do, and if 'should' or 'must' is used other times when there is a recommendation or a requirement that users/ietf do something--then we interpret the words 'may,' 'should,' and 'must' as being in opposition and they are not in opposition here).
 
I am not sure if this is what is meant by the keyword 'may'--if the keyword 'may' is not meant to say what 'may' or 'can' happen (rather than what users 'may do' if they want to, that is, to indicate permission), then this 'may,' at least in my opinion, should be changed to 'can' here to avoid confusion.
 
(NOTE:  Regarding 'will,' 'may,' and 'can:'  maybe it's the influence of a primary school grammar teacher, but to me, 'can' the verb is used when "someone is able to do something or is capable of doing something;" 'can' says nothing about anyone's having permission to do something; just about his/her/its having an underlying ability to do something.)
 
(QUESTION:  By the way, is this the last call for editorial changes and corrections?  Please let me know.)
 
Thanks.
 
--C. E. Whitehead 
[email-masked]
From: "Phillips, Addison" <addison at amazon.com> Date: Thu, 5 Feb 2009 07:15:02 -0800 >> >
>> > The problem isn't that is says "MAY"...
>> > But to have something say "MAY" enclose an example
>> > that says "MUST" makes no sense. It isn't "MAY" if
>> > you're required to do it.
>> 
>> There currently is no "MUST" there.  Do you mean we should
>> replace the existing "will" with "MUST"?

> The "MUST" is in the example:

--
> Changes to one subtag MAY affect other subtags as well: when proposing changes to the registry, the Language Subtag Reviewer will review the registry for such effects and propose the necessary changes using the process in Section 3.5 (Registration Procedure for Subtags), although anyone MAY request such changes. For example:

>    Suppose that subtag 'XX' has a Preferred-Value of 'YY'. If 'YY' later changes to have a Preferred-Value of 'ZZ', then the Preferred-Value for 'XX' MUST also change to be 'ZZ'.
--
>> 
>> As a co-chair...
>> 
>> Because if we start making these sorts of trivial adjustments
>> at this point, all sorts of other non-changes will come out
>> of the woodwork.  I've seen late-stage "editorial cleanup"
>> introduce bugs too many times to be comfortable with that,
>> and I'm extremely reluctant to ask people to read yet another
>> version. At this stage my strong preference is to make
>> changes only if something is demonstrably broken.  Not
>> merely ugly, but broken as in "it cannot possibly work"
>> or "it does something the Internet cannot survive."
>> But perhaps co-chair Martin might be persuaded...
>> 

> I'm also fine with not changing it. It isn't that important.

> Addison

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 5 Feb 2009 12:38:47 -0800

Hi -

As a co-chair:

> From: "CE Whitehead" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, February 05, 2009 9:46 AM
> Subject: Re: [Ltru] Preferred-Value for YU?
...
> (QUESTION:  By the way, is this the last call for editorial changes and corrections?  Please let me know.)
...

The LAST CALL was issued on February 8, 2008.
Note the year.
Anything arriving now is really, really, really, really overdue.

As should be clear from my recent remarks, though you
MAY post your comments to this list, I will oppose making
any changes that are not justified in terms of technical
correctness, implementation of WG consensus, interoperability,
or operational experience.  Co-chair Martin might be more
(or even less) inclined to allow these, but you should know where
I stand.  Of course, the editors are free to apply purely editorial
fixes at their own convenience when it is necessary to update
the drafts for other reasons, but I would expect them to be
judicious in this matter, and to keep in mind that the RFC editor
will also be going through the material when publication time
arrives.

Randy