Subject: Re: [Ltru] [LTRU]Preferred-Value for YU

From: CE Whitehead <[email-masked]>
Date: Wed, 11 Feb 2009 20:25:06 -0500

Hi!Just a quick question; I did not see an issue number assigned for "[LTRU]Preferred-Value for YU?" (Addison & some others were concerned about whether the keyword "MAY" made sense in this particular usage??)  Is this issue then resolved?  Or is it subsumbed under: 
[Ltru] Issue #19: SHALL NOT vs. MUST NOT ?
 
Thanks.
 
(Hope this question makes sense at this time.  I guess this use of "MAY" versus "can" could involve a "normative" and not just a strictly "editorial" change; however Randy logged just about everything else with an issue number . . . ??)
 
--C. E. Whitehead
[email-masked]
From: "Doug Ewell" <doug at ewellic.org> 
 
Date: Sat, 7 Feb 2009 09:24:26 -0700 Re:  > Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

>>> While I don't insist on changing any of this text at this phenomenally late date, the fact remains that "MAY" in the sense of "is allowed or permitted to" is not the same as "may" in the sense of "could happen, or could possibly result in." 
>> True, but the statement that a change is permitted to impact others is 
>> nonetheless true. 
> Who's doing the permitting?
> In any case, as I said, I don't think it's something for which we need to hold up
> the IETF Last Call. I don't see any reason to hold up the IETF Last Call, since the
>  IETF is surely aware that the IPR boilerplate may have to be changed before
>  publication anyway, but I suppose this group will find a reason to continue
> dragging its feet.

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 11 Feb 2009 18:00:47 -0800

Hi -

> From: "CE Whitehead" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, February 11, 2009 5:25 PM
> Subject: Re: [Ltru] [LTRU]Preferred-Value for YU
>

> Hi!Just a quick question; I did not see an issue number assigned for
> "[LTRU]Preferred-Value for YU?" (Addison & some others were concerned
> about whether the keyword "MAY" made sense in this particular usage??)
>  Is this issue then resolved?  Or is it subsumbed under: 
...

As co-chair...

There were two issues in that thread.

One was whether it made sense to change the content of
a particular registry entry.  I believe the consensus was
that that was more properly left to [email-masked]
Consequently I see no need to enter that in the issue tracker
at this time.

The second was whether there was a need to change the use of 2119
keywords in this passage:
   Changes to one subtag MAY affect other subtags as well: when
   proposing changes to the registry, the Language Subtag Reviewer
   will review the registry for such effects and propose the necessary
   changes using the process in Section 3.5 (Registration Procedure
   for Subtags), although anyone MAY request such changes. For example:

   Suppose that subtag 'XX' has a Preferred-Value of 'YY'. If 'YY' later
   changes to have a Preferred-Value of 'ZZ', then the Preferred-Value
   for 'XX' MUST also change to be 'ZZ'.

I've created ticket #20 for this.  Re-scanning the thread didn't provide
me with obvious replacement text, (some have trouble with the MAY,
some have trouble with the MUST,  I think the text is tolerable as-is)
so someone who thinks there is a real problem here should supply
a specific proposal.

Randy

---

From: Mark Davis <[email-masked]>
Date: Thu, 12 Feb 2009 06:35:47 -0800

I propose the following (I think basically what Addison had in mind)

  Changes to one subtag MAY affect other subtags as well: when
  proposing changes to the registry, the Language Subtag Reviewer
  will review the registry for such effects and propose the necessary
  changes using the process in Section 3.5 (Registration Procedure
  for Subtags), although anyone MAY request such changes. For example:
=>
  Changes to one subtag can affect other subtags as well: when
 // MAY => can
  proposing changes to the registry, the Language Subtag Reviewer
  MUST review the registry for such effects and propose the necessary
// will => MUST
  changes using the process in Section 3.5 (Registration Procedure
  for Subtags), although anyone MAY request such changes. For example:

Mark

On Wed, Feb 11, 2009 at 18:00, Randy Presuhn
<[email-masked]>wrote:

> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 12 Feb 2009 11:50:22 -0800

Hi -

> From: "Mark Davis" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "LTRU Working Group" <[email-masked]>
> Sent: Thursday, February 12, 2009 6:35 AM
> Subject: Re: [Ltru] Issue 20: 3.1.7 consequence 2119 language (Was Preferred-Value for YU)
>
...

As a technical contributor:
I could live with this.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 Feb 2009 11:28:16 -0800

Hi -

As co-chair - it looks like we're ok with the proposal to

>   for Subtags), although anyone MAY request such changes. For example:

So, I'm marking this one "closed".

Randy

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 13 Feb 2009 11:31:50 -0800

(DONE)

Modified text reads:

<t>Changes to one subtag can affect other subtags as well: when proposing changes to the registry, the Language Subtag Reviewer MUST review the registry for such effects and propose the necessary changes using the process in <xref target="registrationProc"></xref>, although anyone MAY request such changes. For example:<list>

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Friday, February 13, 2009 11:28 AM
> To: LTRU Working Group
> Subject: Re: [Ltru] Issue 20: 3.1.7 consequence 2119 language
> (WasPreferred-Value for YU)
> 
> Hi -
>