Subject: [Ltru] rechartering to handle 639-6 (was FW: Anomaly in upcoming registry)

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 13 Jul 2009 08:26:14 -0700

Randy posted to the ietf-languages thread (below) that most of you are probably aware of, the following message. I'm cross-posting it so that I can respond.

I oppose rechartering LTRU at this time. We've completed the essential work of incorporating ISO 639-3 and our work has brought a few other enhancements. I think we've allowed sufficient room for the registration process to do its magic and handle most of the language identification community's needs. I would like to see the new document in use for awhile before we go to tinkering with it.

If ISO 639-6 were ready (as it is not), then LTRU could be reconstituted to look into whether or not to incorporate it (and if so, how). I suspect it might be a couple of years before that is upon us. In the meantime, we could use some experience with rfc-to-be-4646bis. Constant rewriting will not improve matters.

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn
Sent: Sunday, July 12, 2009 11:51 PM
To: [email-masked]
Subject: Re: Anomaly in upcoming registry

Hi -

Discussion of re-chartering the ltru working group belongs on
the [email-masked] mailing list, not here.  This is the time
for such discussions.

Randy
----- Original Message ----- 
From: "Gerard Meijssen" <[email-masked]>
To: "Doug Ewell" <[email-masked]>
Cc: <[email-masked]>
Sent: Sunday, July 12, 2009 11:28 PM
Subject: Re: Anomaly in upcoming registry

Hoi,
With all due respect for the diligence of the process but when you consider
the length of time it took, the ISO-639-6 will make this same process
impossible because of the amount of data involved. When this process only
starts when the publication is imminent, it will take maybe at least a
decade based on the number of new entries that ISO 639-6 will bring. That
means imho that for ISO-639-6 we will have to rethink the process. We do
have room before the publication of the new standard.. it could be seen as
pre-emptive involvement because of the huge amount of data involved.
Thanks,
       Gerard

2009/7/13 Doug Ewell <[email-masked]>

> Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:
>
> > There's no way that I'd be willing to start another round of ltru
> > revsions to make the handling of such a hypothetical any clearer.  At
> > some point folks need to realize that the BCP is not an algorithm for
> > execution by finite state automata.  It gives guidelines to humans
> > who, one would hope, are capable of exercising a bit of common sense.
>
> I would hope it's blindingly obvious to Randy and everyone else that I
> agree with this statement.  I would not want to start another round of
> LTRU revisions for almost any reason.
>
> Every so often we talk about adding ISO 639-6 support, which would be a
> good enough reason, but only if (a) the draft and data were fully
> available for WG review, (b) ISO publication appeared imminent, and (c)
> the WG had some hope of agreeing where to put the subtags
> architecturally.
>
> --
> Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
> http://www.ewellic.org
> http://www1.ietf.org/html.charters/ltru-charter.html
> http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ
>
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
>

--------------------------------------------------------------------------------

> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
>

_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages

---

From: Peter Constable <[email-masked]>
Date: Mon, 13 Jul 2009 08:46:57 -0700

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Phillips, Addison
Sent: Monday, July 13, 2009 8:26 AM
To: LTRU Working Group
Subject: [Ltru] rechartering to handle 639-6 (was FW: Anomaly in upcoming registry)

Addison Phillips

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn
Sent: Sunday, July 12, 2009 11:51 PM
To: [email-masked]
Subject: Re: Anomaly in upcoming registry

Hi -

Randy
----- Original Message ----- 
From: "Gerard Meijssen" <[email-masked]>
To: "Doug Ewell" <[email-masked]>
Cc: <[email-masked]>
Sent: Sunday, July 12, 2009 11:28 PM
Subject: Re: Anomaly in upcoming registry

Hoi,

Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 13 Jul 2009 10:36:10 -0700

Hi -

As a technical contributor...

I, too, oppose re-chartering ltru at this time.
The additions made by the documents recently approved
take us well past the point of diminishing returns
in terms of language coverage.

What that might convince me that re-chartering was needed
would be the appearance large quantities of data in large
numbers of languages in use by substantial speech communities
not covered by the recent updates, and not adequately handled
by the registration procedures.  I don't think that's going to
happen anytime in the foreseeable future.

Randy

---

From: Mark Davis ⌛ <[email-masked]>
Date: Mon, 13 Jul 2009 12:47:11 -0700

I agree.

Mark

---

From: Mark Davis ⌛ <[email-masked]>
Date: Mon, 13 Jul 2009 12:47:57 -0700

Actually, I agree on not rechartering for ISO 639-6. As to other matters, I
think we need to let the dust settle a bit.

Mark

On Mon, Jul 13, 2009 at 12:47, Mark Davis ⌛ <[email-masked]> wrote:

> I agree.
>
> Mark
>
>
>
> On Mon, Jul 13, 2009 at 10:36, Randy Presuhn <[email-masked]
> > wrote:
>
>> Hi -
>>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 14 Jul 2009 14:33:44 +0900

For the record, and hats off, I can't currently see any purpose in 
rechartering. The tags being added by RFC4645bis and the ongoing 
registry process via ISO and via ietf-languages cover the greatest 
majority of language tagging needs (at least something like four or five 
nines). Also, while the current text isn't perfect, it's not good use of 
our time to spend another year or two on further tweaking. In addition, 
I cannot think of any other topics or issues that are currently unsolved 
and would need a WG.

Regards,   Martin.

On 2009/07/14 0:26, Phillips, Addison wrote:
> From: "Gerard Meijssen"<[email-masked]>
> To: "Doug Ewell"<[email-masked]>
> Cc:<[email-masked]>
> 2009/7/13 Doug Ewell<[email-masked]>
>
>> Randy Presuhn<randy underscore presuhn at mindspring dot com>  wrote:
>>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: "Debbie Garside" <[email-masked]>
Date: Tue, 14 Jul 2009 11:52:25 +0100

Whilst I can see that the process for including ISO 639-3 and updating
RFC4646 has been long and arduous and people are pretty tired, I believe
there will be a need for inclusion of ISO 639-6 data at some point in the
future - particularly when end users request a language tag on
IETF-Languages that is facilitated within the ISO 639-6 code once published.
This begs the question, who is ultimately going to make the decision to
ignore an ISO 639 standard?

The ISO 639-6 data is hierarchical in nature, goes to a level of granularity
that will facilitate virtually any requirement and also differentiates
between written and spoken language variations - something that will be
extremely useful for metadata registries within archive industries as well
as tagging for the visually impaired, deaf and hard of hearing.

That said, I don't believe now is the correct time to re-charter for the
purposes of including ISO 639-6 data. I don't think I am ready for this - I
may be in 6-12 months. 

I do, however, think it would be a good idea to keep this list open for
general discussions and if this proves the case I will inform the list as
and when I consider ISO 639-6 data sufficiently ready for incorporation.
Whether you decide to re-charter at that point (or at any other time) is up
to you.

Best regards

Debbie Garside
Editor ISO FDIS 639-6

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Randy Presuhn
Sent: 13 July 2009 18:36
To: LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6

Hi -

Randy  

Internal Virus Database is out-of-date.
Checked by AVG. 
Version: 7.5.560 / Virus Database: 270.12.26/2116 - Release Date: 15/05/2009
06:16

Internal Virus Database is out-of-date.
Checked by AVG. 
Version: 7.5.560 / Virus Database: 270.12.26/2116 - Release Date: 15/05/2009
06:16

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 15 Jul 2009 13:25:54 +0900

On 2009/07/14 19:52, Debbie Garside wrote:

> general discussions

This is the plan. This happens with most if not all IETF WG list once 
the WG is done.

Regards,    Martin.

> and if this proves the case I will inform the list as