Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomaly in upcoming registry)

From: "Doug Ewell" <[email-masked]>
Date: Mon, 13 Jul 2009 22:54:13 -0600

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> As a technical contributor...
> (1) I'm not sure how a "language tag registry update" WG could be 
> chartered that wouldn't involve tweaking existing text.  Unless 
> operational experience had demonstrated that text to be seriously 
> broken, I'd see no point in re-opening it.

Of course any "real" updating activity would entail necessary changes to 
the existing text.  I'm not talking about that when I say "tweaking." 
I'm talking about the endless lily-gilding, adding more and more caveats 
and examples for existing edge cases and inserting new sections to cover 
the most extreme corner cases, almost as if, as you put it, the BCP were 
to be implemented by automatons instead of breathing humans.

> As co-chair...
> (2) Is there any purpose for which you could conceive of a 
> rechartering of the WG that you *would* support?

I wouldn't mind seeing supporters of ISO 639-6 put together a serious 
proposal that maintains compatibility with BCP 47 matching logic, keeps 
duplicate-tag redundancy to a minimum, AND adds value.  I'm not sure it 
can be done, and I won't support adding 639-6 if it can't be, but I 
think it deserves a chance in the marketplace of ideas.  So far we 
haven't seen any proposal that accomplishes all three goals.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

---

From: "Debbie Garside" <[email-masked]>
Date: Tue, 14 Jul 2009 17:47:25 +0100

Doug wrote:

> I wouldn't mind seeing supporters of ISO 639-6 put together a
> serious proposal that maintains compatibility with BCP 47
> matching logic, keeps duplicate-tag redundancy to a minimum,
> AND adds value.  I'm not sure it can be done, and I won't
> support adding 639-6 if it can't be, but I think it deserves
> a chance in the marketplace of ideas.  So far we haven't seen
> any proposal that accomplishes all three goals.

I think we pretty much worked this out a few years ago... See
http://www.ietf.org/mail-archive/web/ltru/current/msg06482.html
But as I said in my previous message, I am not quite ready yet as it will
involve some flagging of the data.

Best

Debbie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 14 July 2009 05:54
> To: LTRU Working Group
> Subject: Re: [Ltru] rechartering to handle 639-6 (was FW:
> Anomaly inupcoming registry)
>
> Of course any "real" updating activity would entail necessary
> changes to the existing text.  I'm not talking about that
> when I say "tweaking."
> I'm talking about the endless lily-gilding, adding more and
> more caveats and examples for existing edge cases and
> inserting new sections to cover the most extreme corner
> cases, almost as if, as you put it, the BCP were to be
> implemented by automatons instead of breathing humans.
>
> > As co-chair...
> I wouldn't mind seeing supporters of ISO 639-6 put together a
> serious proposal that maintains compatibility with BCP 47
> matching logic, keeps duplicate-tag redundancy to a minimum,
> AND adds value.  I'm not sure it can be done, and I won't
> support adding 639-6 if it can't be, but I think it deserves
> a chance in the marketplace of ideas.  So far we haven't seen
> any proposal that accomplishes all three goals.
>
> --
> Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN
> #14 http://www.ewellic.org
> http://www.alvestrand.no/mailman/listinfo/ietf-languages  ^
>
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 14 Jul 2009 10:37:34 -0700

Hi -

> From: "Debbie Garside" <[email-masked]>
> To: "'Doug Ewell'" <[email-masked]>; "'LTRU Working Group'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, July 14, 2009 9:47 AM
> Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomaly inupcomingregistry)
...
> involve some flagging of the data.
...

How much content (as a percentage of internet traffic, or as a percentage
of on-line library holdings, for example) would be covered by 639-6 (when
it's done) that would not (or could not) be covered by the registry updates
recently approved and the normal operation of [email-masked]?
What languages does it cover that cannot be addressed under the current
regime?

I'd really like to know the what language tagging problem would be fixed by
digging into 639-6, what the payoff (in terms of users served or content tagged)
would be, and why a working group would be necessary to cope with it.

Randy

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 14 Jul 2009 20:24:10 -0600

Debbie Garside <debbie at ictmarketing dot co dot uk> wrote:

>> So far we haven't seen any proposal that accomplishes all three 
>> goals.
>
> But as I said in my previous message, I am not quite ready yet as it 
> will involve some flagging of the data.

I think there are still some basic concepts to be worked out since that 
post 2½ years ago.  For example, John Cowan has since suggested using 
5-character variant subtags starting with "6" to hold ISO 639-6 code 
elements, instead of using the 4-letter language subtags reserved for 
(shhhh) this purpose.  That wasn't mentioned in the November 2006 post, 
but it's something we would have to decide upon.

Randy Presuhn <randy underscore presuhn at mindspring dot com> replied:

> I'd really like to know the what language tagging problem would be 
> fixed by digging into 639-6, what the payoff (in terms of users served 
> or content tagged) would be, and why a working group would be 
> necessary to cope with it.

Well, that's exactly what I said before: we need to know.  We don't need 
to recharter the WG to find out these facts if we can have the 
discussion now.  Of course, having the text of the standard and the data 
available would help immensely, but that's not available now, so we're 
left to do some guessing and projecting.

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 08:10:31 +0100

Doug wrote:

> I think there are still some basic concepts to be worked out
> since that post 2½ years ago.  For example, John Cowan has
> since suggested using 5-character variant subtags starting
> with "6" to hold ISO 639-6 code elements, instead of using
> the 4-letter language subtags reserved for
> (shhhh) this purpose.  That wasn't mentioned in the November
> 2006 post, but it's something we would have to decide upon.

Actually Peter constable suggested 5 characters some 6/7 years ago when I
first joined the list.

I really don't  have the time at present to enter into in-depth discussions
on the inclusion/benefits/problems of incorporating ISO 639-6 especially as
it would appear to be an uphill battle.  I would rather wait until the
standard is published and somebody comes along and states their need.

Best regards

Debbie

> Sent: 15 July 2009 03:24
> Anomaly inupcomingregistry)
>
> I think there are still some basic concepts to be worked out
> since that post 2½ years ago.  For example, John Cowan has
> since suggested using 5-character variant subtags starting
> with "6" to hold ISO 639-6 code elements, instead of using
> the 4-letter language subtags reserved for
> (shhhh) this purpose.  That wasn't mentioned in the November
> 2006 post, but it's something we would have to decide upon.
>
> Well, that's exactly what I said before: we need to know.  We
> don't need to recharter the WG to find out these facts if we
> can have the discussion now.  Of course, having the text of
> the standard and the data available would help immensely, but
> that's not available now, so we're left to do some guessing
> and projecting.
>
> --

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 08:00:33 +0100

Well for starters, there are separate codes for Catalan and Valencian :-)

And, I rather like the way ISO 639-6 deals with variants of Chinese.

Perhaps you would like to tell me how many of the 7000+ codes of ISO 639-3
will be used.  My guess is approximately 2-300 at present but over time more
and more.  The answer is the same for ISO 639-6.

Essentially, all the reasons for including ISO 639-6 are the same as for
including ISO 639-3.  Unless of course, you think that ISO 639-3 is perfect
and defines all languages distinctly and that anything else cannot, is not,
and definitely is not a language.  Then of course you have to decide that
BCP 47 will only deal with languages and not dialects.  Then, and only then,
may you exclude ISO 639-6.

Debbie

> Behalf Of Randy Presuhn
> Sent: 14 July 2009 18:38
> Anomalyinupcomingregistry)
>
> Hi -
>
> How much content (as a percentage of internet traffic, or as
> a percentage of on-line library holdings, for example) would
> be covered by 639-6 (when it's done) that would not (or could
> not) be covered by the registry updates recently approved and
> the normal operation of [email-masked]?
> What languages does it cover that cannot be addressed under
> the current regime?
>
> I'd really like to know the what language tagging problem
> would be fixed by digging into 639-6, what the payoff (in
> terms of users served or content tagged) would be, and why a
> working group would be necessary to cope with it.
>
> Randy
>

---

From: Kent Karlsson <[email-masked]>
Date: Wed, 15 Jul 2009 15:27:50 +0200

> Well for starters, there are separate codes for Catalan and Valencian :-)

So does BCP 47 (well, nearly):
    ca
    ca-valencia

There is nothing in principle hindering a registration of a variant subtag
specifically for "true" Catalan (no value judgement implied).

> And, I rather like the way ISO 639-6 deals with variants of Chinese.

639-3 also deals with "variants" of Chinese (separate languages, really).
How does 639-6 do it differently (apart from using 4-letter codes instead of
3-letter codes)?

> BCP 47 will only deal with languages and not dialects.

BCP 47 does deal with dialects, using variant subtags. However, it is very
very far from systematic or comprehensive. It requires individual
registration of each variant. I would venture to guess that that process
will never result in a systematic or (in some sense) comprehensive set
of variant subtags for dialects. On the other hand, the call for tagging
dialects separately, currently seems fairly small amongst the consumers of
BCP 47, IMHO.

    /kent k

> Then, and only then,

---

From: Gerard Meijssen <[email-masked]>
Date: Wed, 15 Jul 2009 15:47:26 +0200

Hoi,
The "best practice" is limited to a subset what these codes can be used for.
Imho defending a practice that will never inherently provide a systematic or
comprehensive approach is hard when a replacement with a more systematic and
comprehensive approach becomes available.
Thanks,
      GerardM

2009/7/15 Kent Karlsson <[email-masked]>

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Jul 2009 08:25:10 -0700

SIL certainly has projects involving way more than 2-300. For them, 2000 is not unrealistic.

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Debbie Garside
Sent: Wednesday, July 15, 2009 12:01 AM
To: 'Randy Presuhn'; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

Debbie

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Jul 2009 08:33:43 -0700

> may you exclude ISO 639-6.

Your qualifications notwithstanding, I disagree. While the boundaries of languages and dialects may be debatable generally and in many cases, I think it is the case that there are a good number of cases for which there is current practice and convention in terms of recognizing languages, that this number well exceeds what was covered in 639-1/-2 and is largely encompassed within 639-3. There will remain a relatively small number of cases in which conventionally-recognized language entities are not covered, and those may be covered in 639-6, but if there is conventional acceptance that they should be deemed languages then they are probably candidates for part 3; it would not be worth supporting all of 639-6 just for this particular tail, IMO.

Rather, I think if there is potential benefit from 639-6 it will be in relation to sub-language variations. 

Peter

---

From: "Broome, Karen" <[email-masked]>
Date: Wed, 15 Jul 2009 08:37:06 -0700

For what it's worth, the film and television world does have a pretty heavy requirement for dialect distinctions. We also have a need to identify spoken and written variants. ISO 639-6 also provides a fixed-length tag, which can be advantageous in some situations. While I tend to see ISO 639-6 as an interesting alternative to xml:lang and not necessarily something I'd use within xml:lang, I wanted to correct the assumption that dialect tagging is obscure and the distinction between spoken and written variants is not useful.

Regards,

Karen Broome

-----Original Message-----
From: [email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

---

From: Mark Davis ⌛ <[email-masked]>
Date: Wed, 15 Jul 2009 10:31:15 -0700

I think the difference among dialects is important, but 639-6 doesn't work
for incorporation into BCP47. The advantage of the BCP47 structure is that
it allows reasonable behavior for applications that don't recognize the
dialectical distinctions. That is, if we have:

en-US-southern
en-US-newengla
en-US-philly (pronouncing "huge" as /judʒ/)
en-US-general
en-GB-scots
...
(cf http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language)

Then applications that don't recognize the variants can fall back to en-US
and en-GB. If these all had different atomic primary language codes, then
applications would be forced to keep all the relationship data for all the
codes hanging around - which, frankly, they are not going to do.

Mark

On Wed, Jul 15, 2009 at 08:37, Broome, Karen <[email-masked]>wrote:

>  For what it's worth, the film and television world does have a pretty
> heavy requirement for dialect distinctions. We also have a need to identify
> spoken and written variants. ISO 639-6 also provides a fixed-length tag,
> which can be advantageous in some situations. While I tend to see ISO 639-6
> as an interesting alternative to xml:lang and not necessarily something I'd
> use within xml:lang, I wanted to correct the assumption that dialect tagging
> is obscure and the distinction between spoken and written variants is not
> useful.
>
> Regards,
>
> Karen Broome
>
>

---

From: Kent Karlsson <[email-masked]>
Date: Wed, 15 Jul 2009 20:26:56 +0200

I never intended to give the impression that I assumed that dialect tagging
was obscure, nor that having a distinction between spoken and written
variants would not be useful. I just noted that the number of registrations
for dialect variants in the Language Subtag Registry is miniscule covering
only a handful of dialects of even fewer languages. And that after several
years of having a Language (Sub)Tag Registry with registration possibility.

    /kent k

Den 2009-07-15 17.37, skrev "Broome, Karen" <[email-masked]>:

> For what it's worth, the film and television world does have a pretty heavy
> requirement for dialect distinctions. We also have a need to identify spoken
> and written variants. ISO 639-6 also provides a fixed-length tag, which can be
> advantageous in some situations. While I tend to see ISO 639-6 as an
> interesting alternative to xml:lang and not necessarily something I'd use
> within xml:lang, I wanted to correct the assumption that dialect tagging is
> obscure and the distinction between spoken and written variants is not useful.
> 
> Regards,
> 
> Karen Broome
> 
>

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Jul 2009 13:27:44 -0700

Karen: do you want a list of (order of magnitude) 10,000 language variants for users in the film & television industry to choose from, or just those that they need?

What we have now _should_ be able to deliver what they need.

One thing that an atomic, fixed-length tag does *not* do well: provide individual facets of the total information denoted -- the language, the region, the script - except by relying on carrying tables of data in which those can be looked up.

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Broome, Karen
Sent: Wednesday, July 15, 2009 8:37 AM
To: Kent Karlsson; [email-masked]; LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

Regards,

Karen Broome

-----Original Message-----
From: [email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Jul 2009 13:40:16 -0700

From: Debbie Garside [mailto:[email-masked]] 

> It is quite possible to design a structure within BCP
> 47 for end users to be able to lookup the code within ISO 639-6 and register
> this code within the LSR as a variant of an ISO 639-3/2/1/5 based primary
> language subtag.

That might not be unreasonable. Of course, we wouldn't need a change in BCP 47 to effect that; it might be sufficient just to have a working procedure within ietf-languages that, if a variant registration comes along, then we always look into the possibility of registering the 639-6 ID, adapted as needed. The most important reason to revise BCP 47 would be to formalize requirements on how the ID should be adapted (e.g. requiring "6" + alpha4 -- or whatever).

> As previously stated, I will come back when ISO 639-6 is published and the
> data complete and we can decide then whether this WG should be re-chartered.

Makes sense.

Peter

---

From: Mark Davis ⌛ <[email-masked]>
Date: Wed, 15 Jul 2009 14:15:24 -0700

A good example. Here's what I suggest you do:

The following are all expressible in BCP47, and need to be tossed out:

   1. All those already with language codes (ang, enm).
   2. All of the written vs non-written differences
   3. All "written in <script>" variants

Most of the rest are associated with geographic designations. Rather than
have a hit&miss approach to those that seem important to the designers of
639-6, we'd be better off having some variant convention like the following.

   - unlXXXXX is a UN/LOCODE minus the country designator (see for this
   case, http://www.unece.org/cefact/locode/gb.htm)
   - isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by CLDR).
   See for this case, http://en.wikipedia.org/wiki/ISO_3166-2:GB,

So toss out all those that could be expressed in this way (using case just
to make the derivation clear):

en-GB-unlHMA for Helmsdale
en-GB-unlNCS for Newcastle
en-GB-isoSCT for Scots
en-GB-isoZET for Shetlandic
...

Then what you have left would be useful to review.

Mark

On Wed, Jul 15, 2009 at 13:40, Debbie Garside <[email-masked]>wrote:

>  Mark wrote:
>
> >> (cf
> http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language)
>
> A more in-depth version of en-GB dialects... representing the draft data
> for ISO 639-6   And... I personally have to take full responsibility for
> this particular piece of research so corrections/suggestions etc. are most
> welcome!
>
>     gmcw grmc Germanic West nsea gmcw North Sea angl nsea Anglic ango angl Anglo
> Saxon meng ango Middle English enen meng Early Northern Middle English
> emsc enen Early Scots Northern Middle English msco emsc Middle Scots sco
> engc Scots scow sco Scots Written scol scow Scots Written  Latin Script
> scos sco Scots Spoken sctl sco Scots-L sctw sctl Scots-L Written sotl sctw Scots-L
> Written Latin Script llan sco Lallans llaw llan Lallans Written llnl llaw Lallans
> Written Latin Script budo sco Buchan-Doric wbud budo Buchan-Doric Written
> lbud wbud Buchan-Doric Written Latin Script stld scos Shetlandic orcd scos
> Orcadian cthn scos Caithness helm scos Helmsdale bkil scos Black-Isle nirn
> scos Nairn mray scos Moray bchn scos Buchan abrd scos Aberdonian munh scos
> Mounth csct scos Central-Scots glca scos Glesca swst scos Southwest-Scots
> brsc scos Border-Scots ulla llan Ullans wull ulla Ullans Written ulll wull Ullans
> Written Latin Script sull ulla Ullans Spoken dngl sull Donegal drya sull
> Derry-Antrim cntd sull County-Down mlde scos Madeleine-Scots otgo scos
> Otago-Scots nubn sco Northumbrian  nrbn nubn Northumbrian Spoken nond nrbn
> Northumberland grdi nrbn Geordie wrde nrbn Wearside teed nrbn Tees-Side
> dumc nrbn Durham-County swwe nrbn Swaledale-Wensleydale yrkm nrbn
> Yorkshire-Moors hmbn nrbn Humberside-N lxyn nrbn Lyne crle nrbn Carlisle
> vled nrbn Vale-Of-Eden lkln nrbn Lakeland-N lknd nrbn Lakeland-S esse meng Early
> Southern And South Western Middle English emse meng Early Midland And
> South Eastern Middle English emen emse Early Modern English aeng eng
> Anglo-English waen aeng Anglo-English Written laen waen Anglo-English
> Written Latin Script seng aeng Anglo-English Spoken aenn seng Anglo-English
> North Cluster naen aenn Northern Anglo-English nann naen Northern
> Anglo-English Northeast newc nann Newcastle sdld nann Sunderland ddbh nann
> Middlesborough tyne nann Tyneside naln naen Northern Anglo-English Lower
> North nalc naln Northern Anglo-English Lower North Central clsl nalc
> Carlisle shff nalc Sheffield cumb nalc Cumbria angy nalc Yorkshire wngy
> angy Yorkshire Western hlfx wngy Halifax hddf wngy Huddersfield brdd wngy
> Bradford lddd wngy Leeds yrkk wngy York lanc nalc Lancashire lacc lanc Lancashire
> Central hmbe lanc Humberside huuu nalc Hull gmby nalc Grimsby cang seng Anglo-English
> Central Cluster aenc cang Anglo-English West Central Cluster scou aenc
> Scouse nwme aenc North West Midlands English mctr nwme Manchester chsr
> nwme Cheshire shpn nwme Shropshire North drby nwme Derbyshire stff nwme
> Staffordshire pttr nwme Potteries wmen cang West Midlands English brmm
> wmen Birmingham blco wmen Black Country ecen cang East Central English
> cece ecen Central Midlands English nnle cece Northern
> Nottinghamshire-Leicester nttm cece Nottingham leic cece Leicester neme
> ecen North-East Midlands English lncn neme Lincoln eden ecen East Midlands
> English nttt eden Nottinghamshire-S slcn eden Lincolnshire-S snrt eden
> Northamptonshire-S cmbn eden Cambridgeshire-N grnk cmbr Grantham-Newark
> pbom cmbr Peterborough-Oakham crby cmbr Corby bnor cmbr Northamptonshire
> Borders saen seng Anglo-English South Cluster swen saen Anglo-English
> South Southwest uswe swen Upper Southwest English hrfd uswe Herefordshire
> shrp uswe Shropshire gloc uswe Gloucestershire wrrc uswe Worcestershire
> gowp uswe Gower Peninsula spem uswe South Pembrokeshire cswe swen Central
> Southwest English glct cswe Gloucestershire bucc cswe Buckinghamshire-S
> ofrd cswe Oxfordshire brke cswe Berkshire-S hmpe cswe Hampshire-S wilt
> cswe Wiltshire avnn cswe Avon sstt cswe Somerset brst cswe Bristol lswe
> swen Lower Southwest English dvon lswe Devon lswc lswe Cornwall eacr lswc East
> Cornwall wecr lswc West Cornwall anec seng Anglo-English East Cluster smen
> anec South Midlands English nthh smen Northamptonshire bedd smen
> Bedfordshire camb smen Cambridgeshire buck smen Buckinghamshire-NW eaan
> anec East Anglia sufn eaan Suffolk-NE nflk eaan Norfolk nfol nflk Norfolk
> Northern nnoe nflk Norfolk Eastern fenn eaan Fens snea eaan Southern-East
> Anglia hcen anec Home Counties English cckn hcen Cockney lndn hcen London
> Counties hant hcen Hampshire nrks hcen Berkshire bckk hcen Buckinghamshire
>
>
> Best regards
>
> Debbie
>
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mark Davis ?
> *Sent:* 15 July 2009 18:31
> *To:* Broome, Karen
> *Cc:* Kent Karlsson; [email-masked]; LTRU Working Group
> *Subject:* Re: [Ltru] rechartering to handle 639-6 (was FW:
>>  Den 2009-07-15 09.00, skrev "Debbie Garside" <[email-masked]
>> >:
>>

---

From: "Broome, Karen" <[email-masked]>
Date: Wed, 15 Jul 2009 14:30:25 -0700

One example:

What would you suggest for an international file-naming standard that is composed of concatenated fixed-length components (much like BCP 47) where the file name needs to indicate the language of the subtitled or dubbed asset? 

There are other examples, but this one should be well-understood by this group. What would we do in RFC 4646 if we had a source tag set with this much variability in code length? Though BCP 47 seems to work well in many situations and addresses the language lists I've seen, there have been times that I have run up against a fixed-length tag limitation.

Regards,

Karen Broome

-----Original Message-----
From: Peter Constable [mailto:[email-masked]]
Sent: Wed 7/15/2009 1:27 PM
To: Broome, Karen; Kent Karlsson; [email-masked]; LTRU Working Group
Subject: RE: [Ltru] rechartering to handle 639-6 (was FW:Anomalyinupcomingregistry)

Peter

Regards,

Karen Broome

-----Original Message-----
From: [email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 20:59:31 +0100

Peter wrote:

> Your qualifications notwithstanding, I disagree.

Not qualified yet! ;-)

> While the
> boundaries of languages and dialects may be debatable
> generally and in many cases, I think it is the case that
> there are a good number of cases for which there is current
> practice and convention in terms of recognizing languages,
> that this number well exceeds what was covered in 639-1/-2
> and is largely encompassed within 639-3. There will remain a
> relatively small number of cases in which
> conventionally-recognized language entities are not covered,
> and those may be covered in 639-6, but if there is
> conventional acceptance that they should be deemed languages
> then they are probably candidates for part 3;

I agree...

> it would not be
> worth supporting all of 639-6 just for this particular tail, IMO.

I agree, in part...

I really am trying not to get into deliberations about ISO 639-6 and its
inclusion within BCP47 at this present time due to other more pressing
commitments.  Nevertheless...

What I can say, and this also responds to Mark's points in relation to
fallback, is that if a structure for ISO 639-6 data was incorporated within
BCP 47 said structure does not necessarily need to take the form of a
primary language subtag nor does the full set of data need to be included
within the registry.  It is quite possible to design a structure within BCP
47 for end users to be able to lookup the code within ISO 639-6 and register
this code within the LSR as a variant of an ISO 639-3/2/1/5 based primary
language subtag.  If this route was chosen there are various ways, already
discussed, of doing this syntactically with either preceding letters or
numbers in order to differentiate between an ISO 639-6 variant subtag and a
script subtag.  (In fact doing it this way will save me having to flag the
entities for inclusion).

All this has been chewed over many years ago and with all due respect the
level of opposition to including ISO 639-6 at this present time and also the
fact that the standard is still at FDIS stage makes me unwilling to spend
much or any time discussing it further.  I, like all of you, am rather tired
of BCP 47 at this present time and think it would do us all good to let the
new BCP bed in before starting discussions anew.

Best regards

Debbie

> Sent: 15 July 2009 16:34
> To: [email-masked]; 'Randy Presuhn'; 'LTRU Working Group'
> Behalf Of Debbie Garside
> > Essentially, all the reasons for including ISO 639-6 are
> the same as
> > for including ISO 639-3.  Unless of course, you think that
> ISO 639-3
> > is perfect and defines all languages distinctly and that
> anything else
> > cannot, is not, and definitely is not a language.  Then of
> course you
> > have to decide that BCP 47 will only deal with languages and not
> > dialects.  Then, and only then, may you exclude ISO 639-6.
>
> Your qualifications notwithstanding, I disagree. While the
> boundaries of languages and dialects may be debatable
> generally and in many cases, I think it is the case that
> there are a good number of cases for which there is current
> practice and convention in terms of recognizing languages,
> that this number well exceeds what was covered in 639-1/-2
> and is largely encompassed within 639-3. There will remain a
> relatively small number of cases in which
> conventionally-recognized language entities are not covered,
> and those may be covered in 639-6, but if there is
> conventional acceptance that they should be deemed languages
> then they are probably candidates for part 3; it would not be
> worth supporting all of 639-6 just for this particular tail, IMO.
>
> Rather, I think if there is potential benefit from 639-6 it
> will be in relation to sub-language variations.
>
>
>
> Peter
>
>
>

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 21:40:25 +0100

Mark wrote:
 
>> (cf  <http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language> http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language)
 
A more in-depth version of en-GB dialects... representing the draft data for ISO 639-6   And... I personally have to take full responsibility for this particular piece of research so corrections/suggestions etc. are most welcome!  
 
gmcw	 grmc	 Germanic West	
nsea	 gmcw	 North Sea	
angl	 nsea	 Anglic	
ango	 angl	 Anglo Saxon	
meng	 ango	 Middle English	
enen	 meng	 Early Northern Middle English	
emsc	 enen	 Early Scots Northern Middle English	
msco	 emsc	 Middle Scots	
sco	 engc	 Scots	
scow	 sco	 Scots Written	
scol	 scow	 Scots Written  Latin Script	
scos	 sco	 Scots Spoken	
sctl	 sco	 Scots-L	
sctw	 sctl	 Scots-L Written	
sotl	 sctw	 Scots-L Written Latin Script	
llan	 sco	 Lallans	
llaw	 llan	 Lallans Written	
llnl	 llaw	 Lallans Written Latin Script	
budo	 sco	 Buchan-Doric	
wbud	 budo	 Buchan-Doric Written	
lbud	 wbud	 Buchan-Doric Written Latin Script	
stld	 scos	 Shetlandic	
orcd	 scos	 Orcadian	
cthn	 scos	 Caithness	
helm	 scos	 Helmsdale	
bkil	 scos	 Black-Isle	
nirn	 scos	 Nairn	
mray	 scos	 Moray	
bchn	 scos	 Buchan	
abrd	 scos	 Aberdonian	
munh	 scos	 Mounth	
csct	 scos	 Central-Scots	
glca	 scos	 Glesca	
swst	 scos	 Southwest-Scots	
brsc	 scos	 Border-Scots	
ulla	 llan	 Ullans	
wull	 ulla	 Ullans Written	
ulll	 wull	 Ullans Written Latin Script	
sull	 ulla	 Ullans Spoken	
dngl	 sull	 Donegal	
drya	 sull	 Derry-Antrim	
cntd	 sull	 County-Down	
mlde	 scos	 Madeleine-Scots	
otgo	 scos	 Otago-Scots	
nubn	 sco	 Northumbrian 	
nrbn	 nubn	 Northumbrian Spoken	
nond	 nrbn	 Northumberland	
grdi	 nrbn	 Geordie	
wrde	 nrbn	 Wearside	
teed	 nrbn	 Tees-Side	
dumc	 nrbn	 Durham-County	
swwe	 nrbn	 Swaledale-Wensleydale	
yrkm	 nrbn	 Yorkshire-Moors	
hmbn	 nrbn	 Humberside-N	
lxyn	 nrbn	 Lyne	
crle	 nrbn	 Carlisle	
vled	 nrbn	 Vale-Of-Eden	
lkln	 nrbn	 Lakeland-N	
lknd	 nrbn	 Lakeland-S	
esse	 meng	 Early Southern And South Western Middle English	
emse	 meng	 Early Midland And South Eastern Middle English	
emen	 emse	 Early Modern English	
aeng	 eng	 Anglo-English	
waen	 aeng	 Anglo-English Written	
laen	 waen	 Anglo-English Written Latin Script	
seng	 aeng	 Anglo-English Spoken	
aenn	 seng	 Anglo-English North Cluster	
naen	 aenn	 Northern Anglo-English	
nann	 naen	 Northern Anglo-English Northeast	
newc	 nann	 Newcastle	
sdld	 nann	 Sunderland	
ddbh	 nann	 Middlesborough	
tyne	 nann	 Tyneside	
naln	 naen	 Northern Anglo-English Lower North	
nalc	 naln	 Northern Anglo-English Lower North Central	
clsl	 nalc	 Carlisle	
shff	 nalc	 Sheffield	
cumb	 nalc	 Cumbria	
angy	 nalc	 Yorkshire	
wngy	 angy	 Yorkshire Western	
hlfx	 wngy	 Halifax	
hddf	 wngy	 Huddersfield	
brdd	 wngy	 Bradford	
lddd	 wngy	 Leeds	
yrkk	 wngy	 York	
lanc	 nalc	 Lancashire	
lacc	 lanc	 Lancashire Central	
hmbe	 lanc	 Humberside	
huuu	 nalc	 Hull	
gmby	 nalc	 Grimsby	
cang	 seng	 Anglo-English Central Cluster	
aenc	 cang	 Anglo-English West Central Cluster	
scou	 aenc	 Scouse	
nwme	 aenc	 North West Midlands English	
mctr	 nwme	 Manchester	
chsr	 nwme	 Cheshire	
shpn	 nwme	 Shropshire North	
drby	 nwme	 Derbyshire	
stff	 nwme	 Staffordshire	
pttr	 nwme	 Potteries	
wmen	 cang	 West Midlands English	
brmm	 wmen	 Birmingham	
blco	 wmen	 Black Country	
ecen	 cang	 East Central English 	
cece	 ecen	 Central Midlands English	
nnle	 cece	 Northern Nottinghamshire-Leicester	
nttm	 cece	 Nottingham	
leic	 cece	 Leicester	
neme	 ecen	 North-East Midlands English	
lncn	 neme	 Lincoln	
eden	 ecen	 East Midlands English	
nttt	 eden	 Nottinghamshire-S	
slcn	 eden	 Lincolnshire-S	
snrt	 eden	 Northamptonshire-S	
cmbn	 eden	 Cambridgeshire-N	
grnk	 cmbr	 Grantham-Newark	
pbom	 cmbr	 Peterborough-Oakham	
crby	 cmbr	 Corby	
bnor	 cmbr	 Northamptonshire Borders	
saen	 seng	 Anglo-English South Cluster	
swen	 saen	 Anglo-English South Southwest	
uswe	 swen	 Upper Southwest English	
hrfd	 uswe	 Herefordshire	
shrp	 uswe	 Shropshire	
gloc	 uswe	 Gloucestershire	
wrrc	 uswe	 Worcestershire	
gowp	 uswe	 Gower Peninsula	
spem	 uswe	 South Pembrokeshire	
cswe	 swen	 Central Southwest English	
glct	 cswe	 Gloucestershire	
bucc	 cswe	 Buckinghamshire-S	
ofrd	 cswe	 Oxfordshire	
brke	 cswe	 Berkshire-S	
hmpe	 cswe	 Hampshire-S	
wilt	 cswe	 Wiltshire	
avnn	 cswe	 Avon	
sstt	 cswe	 Somerset	
brst	 cswe	 Bristol	
lswe	 swen	 Lower Southwest English	
dvon	 lswe	 Devon	
lswc	 lswe	 Cornwall	
eacr	 lswc	 East Cornwall	
wecr	 lswc	 West Cornwall	
anec	 seng	 Anglo-English East Cluster	
smen	 anec	 South Midlands English	
nthh	 smen	 Northamptonshire	
bedd	 smen	 Bedfordshire	
camb	 smen	 Cambridgeshire	
buck	 smen	 Buckinghamshire-NW	
eaan	 anec	 East Anglia	
sufn	 eaan	 Suffolk-NE	
nflk	 eaan	 Norfolk	
nfol	 nflk	 Norfolk Northern	
nnoe	 nflk	 Norfolk Eastern	
fenn	 eaan	 Fens	
snea	 eaan	 Southern-East Anglia	
hcen	 anec	 Home Counties English	
cckn	 hcen	 Cockney	
lndn	 hcen	 London Counties	
hant	 hcen	 Hampshire	
nrks	 hcen	 Berkshire	
bckk	 hcen	 Buckinghamshire	

Best regards
 
Debbie

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis ?
Sent: 15 July 2009 18:31
To: Broome, Karen
Cc: Kent Karlsson; [email-masked]; LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

I think the difference among dialects is important, but 639-6 doesn't work for incorporation into BCP47. The advantage of the BCP47 structure is that it allows reasonable behavior for applications that don't recognize the dialectical distinctions. That is, if we have:

en-US-southern
en-US-newengla

Then applications that don't recognize the variants can fall back to en-US and en-GB. If these all had different atomic primary language codes, then applications would be forced to keep all the relationship data for all the codes hanging around - which, frankly, they are not going to do.

Mark

On Wed, Jul 15, 2009 at 08:37, Broome, Karen <[email-masked]> wrote:

Regards,

Karen Broome 

-----Original Message-----
From: [email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 15 Jul 2009 15:09:42 -0700

Hi -

> From: "Broome, Karen" <[email-masked]>
> To: "Peter Constable" <[email-masked]>; "Kent Karlsson" <[email-masked]>; <[email-masked]>; "LTRU
Working Group" <[email-masked]>
> Sent: Wednesday, July 15, 2009 2:30 PM
> Subject: Re: [Ltru] rechartering to handle 639-6 (wasFW:Anomalyinupcomingregistry)
...
> What would you suggest for an international file-naming standard that is
> composed of concatenated fixed-length components (much like BCP 47)
> where the file name needs to indicate the language of the subtitled or dubbed asset?

Such a design is inherently incompatible with the design of BCP 47.  One
might kluge around it by picking some maximum length for the language
tag portion, and right-filling the unused bits with, say, "~" or some other
bit pattern that could not be confused with a language tag.  But that would
be a hideously ugly kluge, and just shine a spotlight on the design incompatibility.

I'm wary of designs built around fixed-length components.  We were stuck
with them when we inherited the language tag work in ltru, and no realistic choice
bu to build on them. Fixed-length fields remind me too much of FORTRAN-IV
Hollerith fields, and should have gone the way of the IBM 029 keypunch's
control card.

Randy

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 21:51:03 +0100

Peter wrote:

> That might not be unreasonable. Of course, we wouldn't need a
> change in BCP 47 to effect that; it might be sufficient just
> to have a working procedure within ietf-languages that, if a
> variant registration comes along, then we always look into
> the possibility of registering the 639-6 ID, adapted as
> needed. The most important reason to revise BCP 47 would be
> to formalize requirements on how the ID should be adapted
> (e.g. requiring "6" + alpha4 -- or whatever).

Exactly! :-)

Debbie

> Sent: 15 July 2009 21:40
> > 47 for end users to be able to lookup the code within ISO 639-6 and
> > register this code within the LSR as a variant of an ISO
> 639-3/2/1/5
> > based primary language subtag.
>
> That might not be unreasonable. Of course, we wouldn't need a
> change in BCP 47 to effect that; it might be sufficient just
> to have a working procedure within ietf-languages that, if a
> variant registration comes along, then we always look into
> the possibility of registering the 639-6 ID, adapted as
> needed. The most important reason to revise BCP 47 would be
> to formalize requirements on how the ID should be adapted
> (e.g. requiring "6" + alpha4 -- or whatever).
>
>
> > As previously stated, I will come back when ISO 639-6 is
> published and
> > the data complete and we can decide then whether this WG
> should be re-chartered.
>
> Makes sense.
>
>
>
> Peter
>
>
>
>

---

From: Mark Davis ⌛ <[email-masked]>
Date: Wed, 15 Jul 2009 16:03:35 -0700

Mark

On Wed, Jul 15, 2009 at 15:26, Debbie Garside <[email-masked]>wrote:

>  Mark wrote:
>
> > A good example.
>
> *Thank you!*
>
> > Here's what I suggest you do:
>
> *These are all ISO 639-2/3/5 codes used within the hierarchical system of
> ISO 639-6 in order to relate the languages, so they are already within the
> LSR.  It is a simple procedure to remove them.*
> **
> *Why?  *

Because that distinction is already expressible in BCP47, as I said.

> **
> *As previously discussed, those that are expressible within BCP 47, yes,
> the others, of which there are many, no.*
>
> > Most of the rest are associated with geographic designations.
>
> *Language does tend to be linked to where people live... I will agree with
> that... but...*
>
> >  Rather than have a hit&miss approach to those that seem important to the
> designers of 639-6, we'd be better off having some variant convention like
> the following.
>
>    - isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by
>    CLDR). See for this case, http://en.wikipedia.org/wiki/ISO_3166-2:GB,
>
> > So toss out all those that could be expressed in this way (using case
> just to make the derivation clear):
>
> *I don't think so... and here's why... , let us look at the Staffordshire
> dialect as a case in point...*
> **
> *The staffordshire dialect area, as designated within ISO 639-6,  includes
> the whole of Staffordshire itself plus most of Cheshire, northern
> Shropshire, and parts of Southern Derbyshire, northwestern Warwickshire and
> northeastern Worcestershire.  it could be said that the "Potteries" dialect
> is within this dialect but I believe it is a distinct variant.  There is no
> way of defining the "potteries" via ISO or UN/LOCODE or the Staffordshire
> dialect area for that matter - it would be a complete mess.    The following
> example shows some distinctions within this dialects vowel sounds:*
> **
> *bait is pronounced like beat*
> *beat is pronounced like bait*
> **
> *In fact, I believe that in this dialect the words "It seems the same" are
> pronounced "It sames the seem"!  Quite distinct and very apt to my comments,
> I think you will agree.*
> **
> *Similarly, the Lincolnshire dialect area consists only of central
> Lincolnshire, while the Leicestershire area includes most of Leicestershire
> (other than a bit linked to the Nottinghamshire dialect) plus part of south
> Nottinghamshire and parts of western Lincolnshire.*
> **
> *I think you get my drift...*
>

It doesn't matter. The use of a region code in BCP 47 means that the variant
is associated with that region. That does not mean that the region includes
all instances, nor that the entire region only uses that variant. And no
matter how you "define" a region (eg "*whole of Staffordshire itself plus
most of Cheshire, northern Shropshire, and parts of Southern Derbyshire,
northwestern Warwickshire and northeastern Worcestershire*", that will be
the case.

**
> **
> *Best regards*
> **
> *Debbie*
> *Sent:* 15 July 2009 22:15
> *To:* [email-masked]
> *Cc:* Broome, Karen; Kent Karlsson; LTRU Working Group
>    - isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by
>    CLDR). See for this case, http://en.wikipedia.org/wiki/ISO_3166-2:GB,
>
>>     gmcw grmc Germanic West nsea gmcw North Sea angl nsea Anglic ango
>> angl Anglo Saxon meng ango Middle English enen meng Early Northern Middle
>> English emsc enen Early Scots Northern Middle English msco emsc Middle
>> Scots sco engc Scots scow sco Scots Written scol scow Scots Written  Latin
>> Script scos sco Scots Spoken sctl sco Scots-L sctw sctl Scots-L Written
>> sotl sctw Scots-L Written Latin Script llan sco Lallans llaw llan Lallans
>> Written llnl llaw Lallans Written Latin Script budo sco Buchan-Doric wbud
>> budo Buchan-Doric Written lbud wbud Buchan-Doric Written Latin Script
>> stld scos Shetlandic orcd scos Orcadian cthn scos Caithness helm scos
>> Helmsdale bkil scos Black-Isle nirn scos Nairn mray scos Moray bchn scos
>> Buchan abrd scos Aberdonian munh scos Mounth csct scos Central-Scots glca
>> scos Glesca swst scos Southwest-Scots brsc scos Border-Scots ulla llan
>> Ullans wull ulla Ullans Written ulll wull Ullans Written Latin Script
>> sull ulla Ullans Spoken dngl sull Donegal drya sull Derry-Antrim cntd
>> sull County-Down mlde scos Madeleine-Scots otgo scos Otago-Scots nubn sco
>> Northumbrian  nrbn nubn Northumbrian Spoken nond nrbn Northumberland grdi
>> nrbn Geordie wrde nrbn Wearside teed nrbn Tees-Side dumc nrbn
>> Durham-County swwe nrbn Swaledale-Wensleydale yrkm nrbn Yorkshire-Moors
>> hmbn nrbn Humberside-N lxyn nrbn Lyne crle nrbn Carlisle vled nrbn
>> Vale-Of-Eden lkln nrbn Lakeland-N lknd nrbn Lakeland-S esse meng Early
>> Anglo-English Northeast newc nann Newcastle sdld nann Sunderland ddbh
>> nann Middlesborough tyne nann Tyneside naln naen Northern Anglo-English
>> Lower North nalc naln Northern Anglo-English Lower North Central clsl
>> nalc Carlisle shff nalc Sheffield cumb nalc Cumbria angy nalc Yorkshire
>> wngy angy Yorkshire Western hlfx wngy Halifax hddf wngy Huddersfield brdd
>> wngy Bradford lddd wngy Leeds yrkk wngy York lanc nalc Lancashire lacc
>> lanc Lancashire Central hmbe lanc Humberside huuu nalc Hull gmby nalc
>> Grimsby cang seng Anglo-English Central Cluster aenc cang Anglo-English
>> West Central Cluster scou aenc Scouse nwme aenc North West Midlands
>> English mctr nwme Manchester chsr nwme Cheshire shpn nwme Shropshire
>> North drby nwme Derbyshire stff nwme Staffordshire pttr nwme Potteries
>> wmen cang West Midlands English brmm wmen Birmingham blco wmen Black
>> Country ecen cang East Central English  cece ecen Central Midlands
>> English nnle cece Northern Nottinghamshire-Leicester nttm cece Nottingham
>> leic cece Leicester neme ecen North-East Midlands English lncn neme
>> Lincoln eden ecen East Midlands English nttt eden Nottinghamshire-S slcn
>> eden Lincolnshire-S snrt eden Northamptonshire-S cmbn eden
>> Cambridgeshire-N grnk cmbr Grantham-Newark pbom cmbr Peterborough-Oakham
>> crby cmbr Corby bnor cmbr Northamptonshire Borders saen seng Anglo-English
>> South Cluster swen saen Anglo-English South Southwest uswe swen Upper
>> Southwest English hrfd uswe Herefordshire shrp uswe Shropshire gloc uswe
>> Gloucestershire wrrc uswe Worcestershire gowp uswe Gower Peninsula spem
>> uswe South Pembrokeshire cswe swen Central Southwest English glct cswe
>> Gloucestershire bucc cswe Buckinghamshire-S ofrd cswe Oxfordshire brke
>> cswe Berkshire-S hmpe cswe Hampshire-S wilt cswe Wiltshire avnn cswe Avon
>> sstt cswe Somerset brst cswe Bristol lswe swen Lower Southwest English
>> dvon lswe Devon lswc lswe Cornwall eacr lswc East Cornwall wecr lswc West
>> Cornwall anec seng Anglo-English East Cluster smen anec South Midlands
>> English nthh smen Northamptonshire bedd smen Bedfordshire camb smen
>> Cambridgeshire buck smen Buckinghamshire-NW eaan anec East Anglia sufn
>> eaan Suffolk-NE nflk eaan Norfolk nfol nflk Norfolk Northern nnoe nflk Norfolk
>> Eastern fenn eaan Fens snea eaan Southern-East Anglia hcen anec Home
>> Counties English cckn hcen Cockney lndn hcen London Counties hant hcen
>> Hampshire nrks hcen Berkshire bckk hcen Buckinghamshire
>>
>>
>> Best regards
>>
>> Debbie
>>
>> *From:* [email-masked] [mailto:[email-masked]]
>> *On Behalf Of *Mark Davis ?

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 15 Jul 2009 23:26:58 +0100

> A good example.
 
Thank you!

These are all ISO 639-2/3/5 codes used within the hierarchical system of ISO 639-6 in order to relate the languages, so they are already within the LSR.  It is a simple procedure to remove them.
 
> 2.  All of the written vs non-written differences

Why?  
 
> 3.  All "written in <script>" variants
 
As previously discussed, those that are expressible within BCP 47, yes, the others, of which there are many, no.
 
> Most of the rest are associated with geographic designations. 
 
Language does tend to be linked to where people live... I will agree with that... but...
 
>  Rather than have a hit&miss approach to those that seem important to the designers of 639-6, we'd be better off having some variant convention like the following.

*	unlXXXXX is a UN/LOCODE minus the country designator (see for this case, http://www.unece.org/cefact/locode/gb.htm) 

*	isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by CLDR). See for this case, http://en.wikipedia.org/wiki/ISO_3166-2:GB, 

> So toss out all those that could be expressed in this way (using case just to make the derivation clear):

I don't think so... and here's why... , let us look at the Staffordshire dialect as a case in point...
 
The staffordshire dialect area, as designated within ISO 639-6,  includes the whole of Staffordshire itself plus most of Cheshire, northern Shropshire, and parts of Southern Derbyshire, northwestern Warwickshire and northeastern Worcestershire.  it could be said that the "Potteries" dialect is within this dialect but I believe it is a distinct variant.  There is no way of defining the "potteries" via ISO or UN/LOCODE or the Staffordshire dialect area for that matter - it would be a complete mess.    The following example shows some distinctions within this dialects vowel sounds:
 
bait is pronounced like beat
beat is pronounced like bait
 
In fact, I believe that in this dialect the words "It seems the same" are pronounced "It sames the seem"!  Quite distinct and very apt to my comments, I think you will agree.
 
Similarly, the Lincolnshire dialect area consists only of central Lincolnshire, while the Leicestershire area includes most of Leicestershire (other than a bit linked to the Nottinghamshire dialect) plus part of south Nottinghamshire and parts of western Lincolnshire.
 
I think you get my drift...
 
Best regards
 
Debbie

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis ?
Sent: 15 July 2009 22:15
To: [email-masked]
Cc: Broome, Karen; Kent Karlsson; LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

Most of the rest are associated with geographic designations. Rather than have a hit&miss approach to those that seem important to the designers of 639-6, we'd be better off having some variant convention like the following.

*	unlXXXXX is a UN/LOCODE minus the country designator (see for this case, http://www.unece.org/cefact/locode/gb.htm) 

*	isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by CLDR). See for this case, http://en.wikipedia.org/wiki/ISO_3166-2:GB, 

So toss out all those that could be expressed in this way (using case just to make the derivation clear):

Mark

On Wed, Jul 15, 2009 at 13:40, Debbie Garside <[email-masked]> wrote:

 

gmcw	 grmc	 Germanic West	
nsea	 gmcw	 North Sea	
angl	 nsea	 Anglic	
ango	 angl	 Anglo Saxon	
meng	 ango	 Middle English	

Best regards
 
Debbie

  _____  

en-US-southern
en-US-newengla

Mark

Regards,

Karen Broome 

-----Original Message-----
From: [email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 15 Jul 2009 14:52:50 -0700

Hi -

As co-chair...

The thread "[Ltru] rechartering to handle 639-6 (was FW:Anomalyinupcomingregistry)"
seems to have reached rough consensus that it does not make sense to recharter
at this time in order to cope with ISO's upcoming 639-6.

Does anyone see any other potential good reasons to recharter the ltru working
group at this time?  I don't care about theoretical possibilities.
I'm only interested in work that:

  (1) working group participants feel is important;

  (2) to which working group participants would commit resources; 

  (3) should commence in the near future; and

  (4) could not be accomplished through the normal operation of
      [email-masked] and the registry

In other words, if you don't personally see it as important, or you are
not personally willing to spend time writing / reviewing I-Ds on the
issue, or if you think it can reasonably be handled under a 4646bis regime,
or if you think it should be started 18 months or so from now, then I don't
want to hear about it.

Randy

---

From: John Cowan <[email-masked]>
Date: Wed, 15 Jul 2009 21:36:53 -0400

> recently approved and the normal operation of [email-masked]?

As is hopefully clear by now, ISO 639-6 increases the depth, not the
breadth, of coverage.  Its code elements are a superset of those in 639-3
and 639-5 (represented by the same 3-letter codes), but also include
elements for genetic language collections not in 639-5 and variants
which are more fine-grained than those in 639-3, both represented by
4-letter codes.

Of the latter class, some can be identified with particular BCP 47 tags,
but the bulk cannot due to the lack of corresponding registered variants.
In addition, there are concepts like "Written X" that have no BCP 47
equivalent at present; we can represent "X written in script Y" but not
the concept of "X written in any script."

IMO, adding collection tags based on 639-6 would be a straightforward
extension of the process used to add 639-5 ones; however, doing so
would require activating the currently unused 4-alpha primary language
subtags.  Adding 639-6 variant tags involves identifying those which
cannot be represented by language-script-region triplets and mapping
them syntactically to variant subtags (I have suggested prepending "6"
for this purpose).

-- 
You know, you haven't stopped talking           John Cowan
since I came here. You must have been           http://www.ccil.org/~cowan
vaccinated with a phonograph needle.            [email-masked]
        --Rufus T. Firefly

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Jul 2009 18:55:38 -0700

I believe I wrote several years back that it is not a good idea to try to define language entities in terms of their boundaries – or, by implication, by their extents (geographical or otherwise). Rather, they should be defined in terms of prototypes – the representative centers. (Cf http://www.sil.org/silewp/abstract.asp?ref=2002-003, p. 12ff.)

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Debbie Garside
Sent: Wednesday, July 15, 2009 3:27 PM
To: 'Mark Davis ⌛'
Cc: 'LTRU Working Group'; 'Broome, Karen'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

Thank you!

Why?

Best regards

Debbie
________________________________

Mark

On Wed, Jul 15, 2009 at 13:40, Debbie Garside <[email-masked]<mailto:[email-masked]>> wrote:

gmcw

grmc

Germanic West

nsea

gmcw

North Sea

angl

nsea

Anglic

ango

angl

Anglo Saxon

meng

ango

Middle English

enen

meng

Early Northern Middle English

emsc

enen

Early Scots Northern Middle English

msco

emsc

Middle Scots

sco

engc

Scots

scow

sco

Scots Written

scol

scow

Scots Written  Latin Script

scos

sco

Scots Spoken

sctl

sco

Scots-L

sctw

sctl

Scots-L Written

sotl

sctw

Scots-L Written Latin Script

llan

sco

Lallans

llaw

llan

Lallans Written

llnl

llaw

Lallans Written Latin Script

budo

sco

Buchan-Doric

wbud

budo

Buchan-Doric Written

lbud

wbud

Buchan-Doric Written Latin Script

stld

scos

Shetlandic

orcd

scos

Orcadian

cthn

scos

Caithness

helm

scos

Helmsdale

bkil

scos

Black-Isle

nirn

scos

Nairn

mray

scos

Moray

bchn

scos

Buchan

abrd

scos

Aberdonian

munh

scos

Mounth

csct

scos

Central-Scots

glca

scos

Glesca

swst

scos

Southwest-Scots

brsc

scos

Border-Scots

ulla

llan

Ullans

wull

ulla

Ullans Written

ulll

wull

Ullans Written Latin Script

sull

ulla

Ullans Spoken

dngl

sull

Donegal

drya

sull

Derry-Antrim

cntd

sull

County-Down

mlde

scos

Madeleine-Scots

otgo

scos

Otago-Scots

nubn

sco

Northumbrian

nrbn

nubn

Northumbrian Spoken

nond

nrbn

Northumberland

grdi

nrbn

Geordie

wrde

nrbn

Wearside

teed

nrbn

Tees-Side

dumc

nrbn

Durham-County

swwe

nrbn

Swaledale-Wensleydale

yrkm

nrbn

Yorkshire-Moors

hmbn

nrbn

Humberside-N

lxyn

nrbn

Lyne

crle

nrbn

Carlisle

vled

nrbn

Vale-Of-Eden

lkln

nrbn

Lakeland-N

lknd

nrbn

Lakeland-S

esse

meng

Early Southern And South Western Middle English

emse

meng

Early Midland And South Eastern Middle English

emen

emse

Early Modern English

aeng

eng

Anglo-English

waen

aeng

Anglo-English Written

laen

waen

Anglo-English Written Latin Script

seng

aeng

Anglo-English Spoken

aenn

seng

Anglo-English North Cluster

naen

aenn

Northern Anglo-English

nann

naen

Northern Anglo-English Northeast

newc

nann

Newcastle

sdld

nann

Sunderland

ddbh

nann

Middlesborough

tyne

nann

Tyneside

naln

naen

Northern Anglo-English Lower North

nalc

naln

Northern Anglo-English Lower North Central

clsl

nalc

Carlisle

shff

nalc

Sheffield

cumb

nalc

Cumbria

angy

nalc

Yorkshire

wngy

angy

Yorkshire Western

hlfx

wngy

Halifax

hddf

wngy

Huddersfield

brdd

wngy

Bradford

lddd

wngy

Leeds

yrkk

wngy

York

lanc

nalc

Lancashire

lacc

lanc

Lancashire Central

hmbe

lanc

Humberside

huuu

nalc

Hull

gmby

nalc

Grimsby

cang

seng

Anglo-English Central Cluster

aenc

cang

Anglo-English West Central Cluster

scou

aenc

Scouse

nwme

aenc

North West Midlands English

mctr

nwme

Manchester

chsr

nwme

Cheshire

shpn

nwme

Shropshire North

drby

nwme

Derbyshire

stff

nwme

Staffordshire

pttr

nwme

Potteries

wmen

cang

West Midlands English

brmm

wmen

Birmingham

blco

wmen

Black Country

ecen

cang

East Central English

cece

ecen

Central Midlands English

nnle

cece

Northern Nottinghamshire-Leicester

nttm

cece

Nottingham

leic

cece

Leicester

neme

ecen

North-East Midlands English

lncn

neme

Lincoln

eden

ecen

East Midlands English

nttt

eden

Nottinghamshire-S

slcn

eden

Lincolnshire-S

snrt

eden

Northamptonshire-S

cmbn

eden

Cambridgeshire-N

grnk

cmbr

Grantham-Newark

pbom

cmbr

Peterborough-Oakham

crby

cmbr

Corby

bnor

cmbr

Northamptonshire Borders

saen

seng

Anglo-English South Cluster

swen

saen

Anglo-English South Southwest

uswe

swen

Upper Southwest English

hrfd

uswe

Herefordshire

shrp

uswe

Shropshire

gloc

uswe

Gloucestershire

wrrc

uswe

Worcestershire

gowp

uswe

Gower Peninsula

spem

uswe

South Pembrokeshire

cswe

swen

Central Southwest English

glct

cswe

Gloucestershire

bucc

cswe

Buckinghamshire-S

ofrd

cswe

Oxfordshire

brke

cswe

Berkshire-S

hmpe

cswe

Hampshire-S

wilt

cswe

Wiltshire

avnn

cswe

Avon

sstt

cswe

Somerset

brst

cswe

Bristol

lswe

swen

Lower Southwest English

dvon

lswe

Devon

lswc

lswe

Cornwall

eacr

lswc

East Cornwall

wecr

lswc

West Cornwall

anec

seng

Anglo-English East Cluster

smen

anec

South Midlands English

nthh

smen

Northamptonshire

bedd

smen

Bedfordshire

camb

smen

Cambridgeshire

buck

smen

Buckinghamshire-NW

eaan

anec

East Anglia

sufn

eaan

Suffolk-NE

nflk

eaan

Norfolk

nfol

nflk

Norfolk Northern

nnoe

nflk

Norfolk Eastern

fenn

eaan

Fens

snea

eaan

Southern-East Anglia

hcen

anec

Home Counties English

cckn

hcen

Cockney

lndn

hcen

London Counties

hant

hcen

Hampshire

nrks

hcen

Berkshire

bckk

hcen

Buckinghamshire

Best regards

Debbie

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Davis ?
Sent: 15 July 2009 18:31
To: Broome, Karen
Cc: Kent Karlsson; [email-masked]<mailto:[email-masked]>; LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)
I think the difference among dialects is important, but 639-6 doesn't work for incorporation into BCP47. The advantage of the BCP47 structure is that it allows reasonable behavior for applications that don't recognize the dialectical distinctions. That is, if we have:

en-US-southern
en-US-newengla

Mark

On Wed, Jul 15, 2009 at 08:37, Broome, Karen <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Karen Broome

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: [email-masked]<mailto:[email-masked]>; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 16 Jul 2009 13:48:46 +0100

Peter wrote:

> prototypes – the representative centers

Prototype could also be defined as the primary stimulus within a category.  

> HYPERLINK "http://www.sil.org/silewp/abstract.asp?ref=2002-003"http://www.sil.org/silewp/abstract.asp?ref=2002-003, p. 12ff.)

Good paper!

Debbie 

   _____  

From: Peter Constable [mailto:[email-masked]] 
Sent: 16 July 2009 02:56
To: [email-masked]; 'Mark Davis ⌛'
Cc: 'LTRU Working Group'; 'Broome, Karen'
Subject: RE: [Ltru] rechartering to handle 639-6 (was FW:Anomalyinupcomingregistry)

I believe I wrote several years back that it is not a good idea to try to define language entities in terms of their boundaries – or, by implication, by their extents (geographical or otherwise). Rather, they should be defined in terms of prototypes – the representative centers. (Cf HYPERLINK "http://www.sil.org/silewp/abstract.asp?ref=2002-003"http://www.sil.org/silewp/abstract.asp?ref=2002-003, p. 12ff.)

Peter

Thank you!

Why?  

>  Rather than have a hit&miss approach to those that seem important to the designers of 639-6, we'd be better off having some variant convention like the following.

*	unlXXXXX is a UN/LOCODE minus the country designator (see for this case, HYPERLINK "http://www.unece.org/cefact/locode/gb.htm"http://www.unece.org/cefact/locode/gb.htm) 
*	isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by CLDR). See for this case, HYPERLINK "http://en.wikipedia.org/wiki/ISO_3166-2:GB"http://en.wikipedia.org/wiki/ISO_3166-2:GB, 

 

Best regards

Debbie

   _____  

*	unlXXXXX is a UN/LOCODE minus the country designator (see for this case, HYPERLINK "http://www.unece.org/cefact/locode/gb.htm"http://www.unece.org/cefact/locode/gb.htm) 
*	isoXXXXX is an ISO 3166-2 code (as regularized and stabilized by CLDR). See for this case, HYPERLINK "http://en.wikipedia.org/wiki/ISO_3166-2:GB"http://en.wikipedia.org/wiki/ISO_3166-2:GB, 

Mark

On Wed, Jul 15, 2009 at 13:40, Debbie Garside <HYPERLINK "mailto:[email-masked]"[email-masked]> wrote:

Mark wrote:

>> (cf HYPERLINK "http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language" \nhttp://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language)

gmcw

grmc

Germanic West

nsea

gmcw

North Sea

angl

nsea

Anglic

ango

angl

Anglo Saxon

meng

ango

Middle English

enen

meng

emsc

enen

msco

emsc

Middle Scots

sco

engc

Scots

scow

sco

Scots Written

scol

scow

scos

sco

Scots Spoken

sctl

sco

Scots-L

sctw

sctl

Scots-L Written

sotl

sctw

llan

sco

Lallans

llaw

llan

Lallans Written

llnl

llaw

budo

sco

Buchan-Doric

wbud

budo

Buchan-Doric Written

lbud

wbud

stld

scos

Shetlandic

orcd

scos

Orcadian

cthn

scos

Caithness

helm

scos

Helmsdale

bkil

scos

Black-Isle

nirn

scos

Nairn

mray

scos

Moray

bchn

scos

Buchan

abrd

scos

Aberdonian

munh

scos

Mounth

csct

scos

Central-Scots

glca

scos

Glesca

swst

scos

Southwest-Scots

brsc

scos

Border-Scots

ulla

llan

Ullans

wull

ulla

Ullans Written

ulll

wull

sull

ulla

Ullans Spoken

dngl

sull

Donegal

drya

sull

Derry-Antrim

cntd

sull

County-Down

mlde

scos

Madeleine-Scots

otgo

scos

Otago-Scots

nubn

sco

Northumbrian 

nrbn

nubn

Northumbrian Spoken

nond

nrbn

Northumberland

grdi

nrbn

Geordie

wrde

nrbn

Wearside

teed

nrbn

Tees-Side

dumc

nrbn

Durham-County

swwe

nrbn

Swaledale-Wensleydale

yrkm

nrbn

Yorkshire-Moors

hmbn

nrbn

Humberside-N

lxyn

nrbn

Lyne

crle

nrbn

Carlisle

vled

nrbn

Vale-Of-Eden

lkln

nrbn

Lakeland-N

lknd

nrbn

Lakeland-S

esse

meng

emse

meng

emen

emse

Early Modern English

aeng

eng

Anglo-English

waen

aeng

Anglo-English Written

laen

waen

seng

aeng

Anglo-English Spoken

aenn

seng

naen

aenn

Northern Anglo-English

nann

naen

newc

nann

Newcastle

sdld

nann

Sunderland

ddbh

nann

Middlesborough

tyne

nann

Tyneside

naln

naen

nalc

naln

clsl

nalc

Carlisle

shff

nalc

Sheffield

cumb

nalc

Cumbria

angy

nalc

Yorkshire

wngy

angy

Yorkshire Western

hlfx

wngy

Halifax

hddf

wngy

Huddersfield

brdd

wngy

Bradford

lddd

wngy

Leeds

yrkk

wngy

York

lanc

nalc

Lancashire

lacc

lanc

Lancashire Central

hmbe

lanc

Humberside

huuu

nalc

Hull

gmby

nalc

Grimsby

cang

seng

aenc

cang

scou

aenc

Scouse

nwme

aenc

mctr

nwme

Manchester

chsr

nwme

Cheshire

shpn

nwme

Shropshire North

drby

nwme

Derbyshire

stff

nwme

Staffordshire

pttr

nwme

Potteries

wmen

cang

West Midlands English

brmm

wmen

Birmingham

blco

wmen

Black Country

ecen

cang

East Central English 

cece

ecen

Central Midlands English

nnle

cece

nttm

cece

Nottingham

leic

cece

Leicester

neme

ecen

lncn

neme

Lincoln

eden

ecen

East Midlands English

nttt

eden

Nottinghamshire-S

slcn

eden

Lincolnshire-S

snrt

eden

Northamptonshire-S

cmbn

eden

Cambridgeshire-N

grnk

cmbr

Grantham-Newark

pbom

cmbr

Peterborough-Oakham

crby

cmbr

Corby

bnor

cmbr

Northamptonshire Borders

saen

seng

swen

saen

uswe

swen

Upper Southwest English

hrfd

uswe

Herefordshire

shrp

uswe

Shropshire

gloc

uswe

Gloucestershire

wrrc

uswe

Worcestershire

gowp

uswe

Gower Peninsula

spem

uswe

South Pembrokeshire

cswe

swen

glct

cswe

Gloucestershire

bucc

cswe

Buckinghamshire-S

ofrd

cswe

Oxfordshire

brke

cswe

Berkshire-S

hmpe

cswe

Hampshire-S

wilt

cswe

Wiltshire

avnn

cswe

Avon

sstt

cswe

Somerset

brst

cswe

Bristol

lswe

swen

Lower Southwest English

dvon

lswe

Devon

lswc

lswe

Cornwall

eacr

lswc

East Cornwall

wecr

lswc

West Cornwall

anec

seng

smen

anec

South Midlands English

nthh

smen

Northamptonshire

bedd

smen

Bedfordshire

camb

smen

Cambridgeshire

buck

smen

Buckinghamshire-NW

eaan

anec

East Anglia

sufn

eaan

Suffolk-NE

nflk

eaan

Norfolk

nfol

nflk

Norfolk Northern

nnoe

nflk

Norfolk Eastern

fenn

eaan

Fens

snea

eaan

Southern-East Anglia

hcen

anec

Home Counties English

cckn

hcen

Cockney

lndn

hcen

London Counties

hant

hcen

Hampshire

nrks

hcen

Berkshire

bckk

hcen

Buckinghamshire

Best regards

Debbie

   _____  

From: HYPERLINK "mailto:[email-masked]" \[email-masked] [mailto:HYPERLINK "mailto:[email-masked]" \[email-masked]] On Behalf Of Mark Davis ?
Sent: 15 July 2009 18:31
To: Broome, Karen
Cc: Kent Karlsson; HYPERLINK "mailto:[email-masked]" \[email-masked]; LTRU Working Group
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

en-US-southern
en-US-newengla
en-US-philly (pronouncing "huge" as /judʒ/)
en-US-general
en-GB-scots
...
(cf HYPERLINK "http://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language" \nhttp://en.wikipedia.org/wiki/List_of_dialects_of_the_English_language)

Mark

On Wed, Jul 15, 2009 at 08:37, Broome, Karen <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

Regards,

Karen Broome 

-----Original Message-----
From: HYPERLINK "mailto:[email-masked]" \[email-masked] on behalf of Kent Karlsson
Sent: Wed 7/15/2009 6:27 AM
To: HYPERLINK "mailto:[email-masked]" \[email-masked]; 'LTRU Working Group'
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomalyinupcomingregistry)

    /kent k

_______________________________________________
Ltru mailing list
HYPERLINK "mailto:[email-masked]" \[email-masked]
HYPERLINK "https://www.ietf.org/mailman/listinfo/ltru" \nhttps://www.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
HYPERLINK "mailto:[email-masked]" \[email-masked]
HYPERLINK "https://www.ietf.org/mailman/listinfo/ltru" \nhttps://www.ietf.org/mailman/listinfo/ltru

Internal Virus Database is out-of-date.
Checked by AVG.
Version: 7.5.560 / Virus Database: 270.12.26/2116 - Release Date: 15/05/2009 06:16

Internal Virus Database is out-of-date.
Checked by AVG. 
Version: 7.5.560 / Virus Database: 270.12.26/2116 - Release Date: 15/05/2009 06:16