Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomaly inupcomingregistry)

From: CE Whitehead <[email-masked]>
Date: Wed, 15 Jul 2009 18:43:53 -0400

Hi. 

I tend to agree with Mark Davis that the structure of tags that we have enables parsing when a variant is not known.  But I like what Peter and Debbie have worked out:  

From: "Debbie Garside" <debbie at ictmarketing.co.uk> 

Date: Wed, 15 Jul 2009 21:51:03 +0100 
>Peter wrote:

>> That might not be unreasonable. Of course, we wouldn't need a
>> change in BCP 47 to effect that; it might be sufficient just
>> to have a working procedure within ietf-languages that, if a
>> variant registration comes along, then we always look into
> the possibility of registering the 639-6 ID, adapted as
>> needed. The most important reason to revise BCP 47 would be
>> to formalize requirements on how the ID should be adapted
>> (e.g. requiring "6" + alpha4 -- or whatever).

> Exactly! :-)

> Debbie

My personal feeling is that the geographic codes are generally well-suited for handling regional variation -- so we should definitely only take regional variants of languages that have ISO 639-6 codes on a case-by-case basis because I cannot see a long list of subtags with all this overlapping.
 
I am not familiar with ISO 639-6 but appreciate Debbie's list of English dialects (I need to go over these sometime). 
 
How is it decided in ISO 639-6 what is a language and what is a dialect???  Are there any rules since apparently ISO 639-6 deals more with dialects?
 
Also, will adopting the ISO 639-6 code elements mean deprecating a number of codes and many variant subtags (such as "Valencian")???  Or is that still up for discussion??

Thanks.
 
--C. E. Whitehead
[email-masked] 

From: "Debbie Garside" <debbie at ictmarketing.co.uk> 
Date: Wed, 15 Jul 2009 08:10:31 +0100 
> Doug wrote:

>> I think there are still some basic concepts to be worked out
>> since that post 2½ years ago.  For example, John Cowan has
>> since suggested using 5-character variant subtags starting
>> with "6" to hold ISO 639-6 code elements, instead of using
>> the 4-letter language subtags reserved for
>> (shhhh) this purpose.  That wasn't mentioned in the November
>> 2006 post, but it's something we would have to decide upon.

> Actually Peter constable suggested 5 characters some 6/7 years ago when I
> first joined the list.

> I really don't  have the time at present to enter into in-depth discussions
> on the inclusion/benefits/problems of incorporating ISO 639-6 especially as
> it would appear to be an uphill battle.  I would rather wait until the
> standard is published and somebody comes along and states their need.

> Best regards

> Debbie

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 16 Jul 2009 00:06:12 +0100

You wrote:
 
> How is it decided in ISO 639-6 what is a language and what is a dialect???
Are there any rules since apparently ISO 639-6 deals more with dialects?

As far as I am concerned, ISO 639-6 deals with linguistic entities and does
not classify these as either language or dialect.  I do have my own
classification system for private use but it does not form part of the
standard.  The following forms the basis of my own private system as mapped
to ISO 639-6:
 
Phylum

Branch

Sub-Branch

Group

Sub-Group

Complex

Cluster

Sub-Cluster

Language

Written Umbrella

Written

Written Component

Spoken Umbrella

Spoken

Dialect

Variant

Sub-variant

This enables me to query the data, for instance, I can extract all languages
that are written.
 
Best regards
 
Debbie

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of CE
Whitehead
Sent: 15 July 2009 23:44
To: [email-masked]
Subject: Re: [Ltru] rechartering to handle 639-6 (was FW: Anomaly
inupcomingregistry)

Hi. 

I tend to agree with Mark Davis that the structure of tags that we have
enables parsing when a variant is not known.  But I like what Peter and
Debbie have worked out:  
From: "Debbie Garside" <debbie at  <mailto:[email-masked]>
ictmarketing.co.uk> 
Date: Wed, 15 Jul 2009 21:51:03 +0100 

> Debbie
 
My personal feeling is that the geographic codes are generally well-suited
for handling regional variation -- so we should definitely only take
regional variants of languages that have ISO 639-6 codes on a case-by-case
basis because I cannot see a long list of subtags with all this overlapping.
 
I am not familiar with ISO 639-6 but appreciate Debbie's list of English
dialects (I need to go over these sometime). 
 
How is it decided in ISO 639-6 what is a language and what is a dialect???
Are there any rules since apparently ISO 639-6 deals more with dialects?
 
Also, will adopting the ISO 639-6 code elements mean deprecating a number of
codes and many variant subtags (such as "Valencian")???  Or is that still up
for discussion??

Thanks.
 
--C. E. Whitehead
[email-masked] 

From: "Debbie Garside" <debbie at  <mailto:[email-masked]>
ictmarketing.co.uk> 
Date: Wed, 15 Jul 2009 08:10:31 +0100