Subject: [Lwip] I-D Action: draft-ietf-lwig-terminology-02.txt

From: [email-masked]
Date: Thu, 28 Mar 2013 09:39:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Light-Weight Implementation Guidance Working Group of the IETF.

	Title           : Terminology for Constrained Node Networks
	Author(s)       : Carsten Bormann
                          Mehmet Ersue
	Filename        : draft-ietf-lwig-terminology-02.txt
	Pages           : 13
	Date            : 2013-03-28

Abstract:
   The Internet Protocol Suite is increasingly used on small devices
   with severe constraints, creating constrained node networks.  This
   document provides a number of basic terms that have turned out to be
   useful in the standardization work for constrained environments.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lwig-terminology

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-lwig-terminology-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-terminology-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 28 Mar 2013 17:47:33 +0100

As we discussed in Orlando, a small design team charged ahead and wrote down some power terminology, creating a new section 4 in the terminology draft.  Thanks Ari, Dominique, Peter.
And thanks Jari for letting us borrow some text out of lwig-cellular.

> http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-terminology-02

In Orlando, we said we wanted to time-box this into March, so:

-- Is this the section that we wanted?
-- Does this need major surgery, or can we do a couple small fixes and then go for WGLC?

Grüße, Carsten

---

From: "Cao Zhen \(CZ\)" <[email-masked]>
Date: Sun, 31 Mar 2013 16:00:13 +0800

Hi Carsten, 

Personally I believe the power efficiency section is good enough for the
terminology, and this is a good basis for future discussions. 

To All, please review and express your opinions. Thanks in advance. 

Best regards,
zhen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Carsten Bormann
> Sent: Friday, March 29, 2013 12:48 AM
> To: [email-masked]
> Subject: [Lwip] lwig-terminology-02, now with power terminology
> 
> As we discussed in Orlando, a small design team charged ahead and wrote
down some power
> terminology, creating a new section 4 in the terminology draft.  Thanks
Ari, Dominique, Peter.
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://w

---

From: Charles Palmer <[email-masked]>
Date: Sun, 31 Mar 2013 11:34:00 +0100

Dear Carsten and others

I've read the new draft and offer some suggestions, mostly editorial, 
but there are a couple of other constraints that I think might merit 
mentioning (particularly regularory), and a couple of questions I have 
embedded in the text. The edited version is here:

https://dl.dropbox.com/u/472780/draft-ietf-lwig-terminology-02_CGP.txt

and the changes may be found with diff.

Hope this may be of some use.

Regards - Charles

On 28/03/2013 16:47, Carsten Bormann wrote:
> https://www.ietf.org/mailman/listinfo/lwip
>

-- 
Regards - Charles Palmer
Project Hydra Project Manager - Acute Technology Limited
Woodthorpe, Calver Road, Baslow, Derbyshire, DE45 1RR, United Kingdom
Mob: +44 (0)7977 577 627    Skype: Acutetech
Email: [email-masked] Web: http://projecthydra.info

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 31 Mar 2013 14:54:53 +0200

On Mar 31, 2013, at 12:34, Charles Palmer <[email-masked]> wrote:

> I've read the new draft and offer some suggestions, mostly editorial, but there are a couple of other constraints that I think might merit mentioning (particularly regularory), and a couple of questions I have embedded in the text. The edited version is here:

Thanks, those suggestions did allow me to improve the text.  
I've left out the specific reference to EN 300 220-1 (assuming that was what you meant), but did add a bit of reference to regulatory issues (since we aren't defining terminology for them, a little reminder of them is all that is needed).
I already had changed all the lists that summarize the class numbers into tables; I was wondering whether examples in those tables help or give the impression the examples are the definition.  In the end I did add the examples to the Ex table.

I'm not sure we want to give too many examples for how the various classes go together; this would be ratholing quickly, and I trust readers will have enough phantasy to do this on their own.

So this makes the -03, just submitted:

Htmlized:        http://tools.ietf.org/html/draft-ietf-lwig-terminology-03
Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-terminology-03

In separate news, I've also added Ari Keränen as a co-author, who has supplied and edited some of the power text.

Grüße, Carsten

---

From: Charles Palmer <[email-masked]>
Date: Sun, 31 Mar 2013 14:28:27 +0100

Hi Carsten

The new text on regulatory constraints reads fine: it is enough to 
remind readers that there are legal as well as technical constraints. I 
had not intended to suggest that EN300 220-1 should be included in the 
text. I'll add more on this in a new thread.

Regards - Charles