Subject: [Lwip] efficient implementation of network protocol

From: Omprakash Gnawali <[email-masked]>
Date: Tue, 19 Mar 2013 20:44:56 -0500

I wrote a draft collecting hints for efficient implementation and
operation of RPL. My understanding is this WG wants to think beyond
CoRE in which case it makes sense to consider implementation and
operational issues at the network layer as well. Here is a link to the
draft:
http://tools.ietf.org/html/draft-gnawali-roll-rpl-recommendations-05

I will appreciate your comments and discussions.

Very interested in hearing your experiences that are not in the draft
or if your experiences contradict what is in the draft.

Thanks.

- om_p

---

From: "Cao Zhen \(CZ\)" <[email-masked]>
Date: Thu, 21 Mar 2013 10:08:06 +0800

Hi Omprakash,

Thanks for letting us know the work. When the group was chartered, we did plan to gain some RPL implementation guidance, but failed due to lack of participation from rpl people. Did you present it in the roll, and what was the feedback?

Thanks,
zhen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Omprakash Gnawali
> Sent: Wednesday, March 20, 2013 9:45 AM
> To: [email-masked]
> Subject: [Lwip] efficient implementation of network protocol
> 
> I wrote a draft collecting hints for efficient implementation and operation of RPL. My
> understanding is this WG wants to think beyond CoRE in which case it makes sense to consider
> implementation and operational issues at the network layer as well. Here is a link to the
> draft:
> Very interested in hearing your experiences that are not in the draft or if your experiences
> contradict what is in the draft.
> 
> Thanks.
> 
> - om_p
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://w

---

From: Omprakash Gnawali <[email-masked]>
Date: Thu, 21 Mar 2013 10:05:30 -0700

The feedback from ROLL was it is good to document those lessons and
hints in a document but recently ROLL has not been interested in this
document. This is not a ROLL WG document. It is a personal draft and
if we want to expand the scope of this WG to network protocols, I am
happy to move this document to this WG. This document seems aligned
with the goals of this WG and the only reason I did not mention this
draft here is because I didn't know about this WG.

- om_p

---

From: "Cao Zhen \(CZ\)" <[email-masked]>
Date: Sun, 31 Mar 2013 16:06:22 +0800

> The feedback from ROLL was it is good to document those lessons and hints
in a document but
> recently ROLL has not been interested in this document. This is not a ROLL
WG document. It is
> a personal draft and if we want to expand the scope of this WG to network
protocols, I am happy
> to move this document to this WG. 

It's in the lwig scope now, so welcome to present and share in this group.
Thanks. 

What I worry about is that roll experts seldom run into lwig group, so the
review work is not optimistic, but good thing is that audience would benefit
from your work and experience. 

Best regards,
zhen

This document seems aligned with the goals of this WG and the
> only reason I did not mention this draft here is because I didn't know
about this WG.
> > Thanks for letting us know the work. When the group was chartered, we
did plan to gain some RPL
> implementation guidance, but failed due to lack of participation from rpl
people. Did you present
> it in the roll, and what was the feedback?
> >
> > Thanks,
> > zhen
> >