Subject: Re: [Lwip] draft-ietf-lwig-terminology

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Mar 2013 22:15:14 -0400

We will have some 20 minutes tomorrow morning to discuss the LWIG terminology draft.

If you want, you can peek at my slides for that:

http://www.ietf.org/proceedings/86/slides/slides-86-lwig-5.pdf

(The pointer isn't on the agenda page yet:
https://datatracker.ietf.org/meeting/86/agenda/lwig/ )

Grüße, Carsten

---

From: <[email-masked]>
Date: Thu, 14 Mar 2013 03:10:23 +0000

Hi Carsten, all,

Thanks for the pointer. Your slides contain many valid questions.
I think that, at this point, we need to ask ourselves what the goal of the terminology draft is.
If I'm not mistaken, its goal is to help us humans read other drafts and understand them. Not to specify algorithms that machines will execute to make hard decisions (such as RFC6551). Therefore, we don't need to be overly strict in our definitions.

I think some taxonomy related to energy is useful in the terminology draft. For this, the 3 boolean variables you mention on slide 6 seem appropriate to me.
I don't think we are able to define a vector of Classes of devices as simple as EnergyClass0, EnergyClass1, etc.
I view the energy problem as at least bi-dimensional: initial energy value, and average energy regeneration rate. Maybe even tri-dimensional: currently stored energy amount, long-term average regeneration rate (based on device characteristics), short-term predicted regeneration rate (based on external conditions), where long-term and short-term may be understood differently depending on the application.
However, are we going to be able to use a 3-dimensional classification? What for? Are we going to write "for a device of EnergyClass(1,3,7) do this, for EnergyClass(2,2,1) do that"?
If the community thinks it's useful, I'm willing to give a stab at such a classification with Peter's help.
I'd first like to hear who is going to use it, and what for.
The alternative being some vocabulary like the 3 boolean variables you mentioned, complemented with some SI unit values as appropriate in the forthcoming draft that this group will produce.

Opinions?

Dominique

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Carsten Bormann
Envoyé : mercredi 13 mars 2013 22:15
À : [email-masked]
Objet : Re: [Lwip] draft-ietf-lwig-terminology

Grüße, Carsten

_______________________________________________
Lwip mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lwip

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.