Subject: [magma] Proxy querier uses 0.0.0.0 ip address

From: Koen Vermeulen <[email-masked]>
Date: Mon, 26 Jan 2004 13:57:59 +0100

Hello all,

I have again a question concerning the 'IGMP snooping recommendations' 
document.

In part 2.2.1. (IGMP Forwarding Rules) 1), is stated the the multicast 
router list can be constructed via any combination of 3 ways. However, I 
have a problem in understanding way b):

'The arrival port for IGMP Queries (sent by multicast routers) where the 
source address is not 0.0.0.0.'

I am unable to understand why we wouldn't use this type of queries to 
build our list of multicast routers. 0.0.0.0 means that we are dealing 
with a 'proxy querier'. In my opinion, this type of switch is very much 
interested in receiving reports. How else is this proxy able to build an 
internal membership database?

Suppose following network:

   +------------------+
   | multicast router |
   +------------------+
            |
    +--------------+
    |IGMP proxy (A)|
    +--------------+
       |         \
       |          \
 +-----+-----+     \
 |     |     |      \
host1 host2 host3    \
                      \
                  +-------------------+
                  | IGMP snooping (B) |
                  +-------------------+
                       |         |
                     host4     host5

where A is performing 'proxy' functionality (is regularly sending 
queries downstream to hosts 1-3 and snooping device B)
  and B is a 'regular non-proxy snooping' switch.

If B is not taking the upstream interface towards A into account 
(because of the fact that A is sending its queries with ip address 
0.0.0.0), how can A build its membership database allowing multicast 
traffic to be flooded towards hosts 4 and 5?

Or am I missing something here?

Thanks in advance,
Koen

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "girishkg" <[email-masked]>
Date: Thu, 29 Jan 2004 12:28:40 +0530

Hello All,

I was reading the drafts -- draft-ietf-magma-snoop-10.txt and
draft-ietf-magma-igmp-proxy-04.txt and i need following clarifications -

1.IGMP snooping switch which doesn't perform proxy function --

Do we need to forward the IGMP queries received on router ports to other
ports??? If yes,
a)Do we need to modify the source IP address to 0.0.0.0 ?
b)DO we need to forward queries on router ports too?

2.IGMP snooping switch which performs proxy-reporting also --

For performing proxy function, according to draft proxy-04.txt, we must have
only one upstream interface and it works only in tree topology.
a) Does this imply, we cannot implement proxy function in a IGMP snooping
switch when there are more than one router ports? But the draft snoop-10.txt
section 2.1.1  statement 2), states that IGMP snooping switches may also
implement proxy function.

Thanks in advance.

Regards
Girish.

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: "girishkg" <[email-masked]>
Date: Thu, 29 Jan 2004 12:28:40 +0530

Hello All,

Thanks in advance.

Regards
Girish.